Jump to content
Sign in to follow this  
ygagnon

Need UPS shipping module - which is recommended?

Recommended Posts

I need to set up a new OsCommerce store for a client (meaning that I intend to download and install the latest version of OsCommerce) .. and I need to install and configure some kind of UPS shipping module/contribution to calculate shipping costs based on the following:

 

1) The zip code of the customer's ship-to address

2) The overall weight of the order that was placed

 

Which UPS shipping module is best recommended for this?

 

Ideally, the module installation should require only minimal -- if any -- source code modifications.

 

I'd be interested in hearing about modules that bothdo and do not require a UPS account.

 

Also -- it's ok if the UPS shipping module is a commercial product that needs to be purchased.

 

I'm also ok with paying someone to install and configure the UPS shipping module.

 

Any suggestions or recommendations would be greatly appreciated.

 

Thanks!

- Yvan

Share this post


Link to post
Share on other sites

Have you received any replies to this question? We are setting up v2.2 RC2 and want to use UPS also. Thanks.

MitchKR

Edited by MitchKR

Share this post


Link to post
Share on other sites

The UPS XML module is probably the best, but it requires you to get an access code from UPS. This is easy to do if you have a UPS account. If you don't want to do that, the UPS Choice module worked well the last time I looked at it.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

The UPS XML module is probably the best, but it requires you to get an access code from UPS. This is easy to do if you have a UPS account. If you don't want to do that, the UPS Choice module worked well the last time I looked at it.

 

Regards

Jim

 

I am having trouble with the UPS XML module. We are running php 5.2.11, and this bit of code is causing issues:

// Incorporate the XML conversion library 
 if (PHP_VERSION >= '5.0.0') { // PHP 5 does not need to use call-time pass by reference
   require_once (DIR_WS_CLASSES . 'xml_5.php');
 } else {
   require_once (DIR_WS_CLASSES . 'xml.php');
 }

This is one of the errors in the module control panel

Warning: include(/home1/myserver/public_html/mydomain/store/includes/languages/english/modules/shipping/upsxml.php) [function.include]: failed to open stream: No such file or directory in /home1/myserver/public_html/mydomain/store/some-admin-folder/modules.php on line 136

If I comment it out I get all sorts of issues at checkout, so I am guessing it is necessary? :'( What can I do about this?

Thanks

Rusty

Edited by rusty105

Share this post


Link to post
Share on other sites

I am having trouble with the UPS XML module. We are running php 5.2.11, and this bit of code is causing issues:

// Incorporate the XML conversion library 
 if (PHP_VERSION >= '5.0.0') { // PHP 5 does not need to use call-time pass by reference
   require_once (DIR_WS_CLASSES . 'xml_5.php');
 } else {
   require_once (DIR_WS_CLASSES . 'xml.php');
 }

This is one of the errors in the module control panel

 

If I comment it out I get all sorts of issues at checkout, so I am guessing it is necessary? :'( What can I do about this?

Thanks

Rusty

Do you have the files \store\includes\classes\xml___.php?


Community Bootstrap Edition, Edge

 

Avoid the most asked question. See How to Secure My Site and How do I...?

Share this post


Link to post
Share on other sites

The error message is saying that /store/includes/languages/english/modules/shipping/upsxml.php is missing. That's included in the distribution package, as are the class files.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Those files are in the latest version (1.3.7) of the UPS XML distribution package. You should probably upgrade if you're using an older version.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×