Jump to content
Sign in to follow this  
Amazon Payments Team

Checkout by Amazon for osCommerce Support Thread

Recommended Posts

Hi All,

 

The latest versions of the CBA for osCommerce 2.2 and 2.3.1. will be posted into the Contribution section soon.

 

All the very best,

Vadym


Holbi Group (a trading name of DataLink UK Ltd)

Share this post


Link to post
Share on other sites

Just a quick note from a non-coder. I was unable to see this module in my payments area due to there being several files in which the admin directory is hardcoded as 'admin'. My admin directory is called something else.

The files in question are

/admin/orders.php

/checkout_by_amazon\checkout_by_amazon_account_dao.php

/checkout_by_amazon\checkout_by_amazon_util_dao.php

/modules/payment/checkout_by_amazon.php

 

Changing these files fixed it for me. Used Windows GREP to search the files for any containing admin/

 

Hope this helps someone.

Share this post


Link to post
Share on other sites

Hi, We are part of Amazon Associates. We want to sell books from Amazon.com on our oscommerce store on our site. We found your plugin 'Checkout by Amazon' and we're wondering if this would work with Amazon Associates?

 

Thanks

Share this post


Link to post
Share on other sites

Hey guys,

 

Are any of you receiving the email by Amazon regarding their code change? Whats different? It seems as though the one I currently have is up to date? Can any one help?

Share this post


Link to post
Share on other sites

Whenever I add the "Checkout_By_Amazon.php" to Includes/Modules/Payments my admin panel goes blank...

 

Any suggestions or recommendations?

Share this post


Link to post
Share on other sites

Thanks for the plug in. Just installed AmazonPayments on our site Direct Depot and most everything is working. I only have two issues.

 

(1) The pop up thank you page is not working. It is install on our default home page index.php

(2) The orders show up fine in our admin area but when you click the "confirm shipment" button we get the "The website cannot display the page" http 500 error.

 

Traced the error to the module checkout_by_amazon_order_processor.php. Bombing when the following line is executed:

 

$result = $this->merchantAtClient->postDocument($messageType, $orderFulfillment);

 

Any suggestions with be appreciated.

 

Thanks....

Share this post


Link to post
Share on other sites

@@Amazon Payments Team @@datalink - Is there a checkout success page with "Pay with Amazon"? A lot of my customers are complaining that they are not directed to a checkout - success page... anything on this guys? Have I installed it incorrectly?

 

If someone can help me out, I would really appreciate it.

Share this post


Link to post
Share on other sites

Hello

 

I need your help please,

I have installed the checkout by amazon module for oscommerce provided on the link below:

http://addons.oscommerce.com/info/6591

 

All things work fine for me, thanks for your contribution, but i faces some issues here.

When i make an order and then view it in the seller account the field "Your Merchant Order Id" has a value of "none saved" . Can you please confirm that where can I set this value. Please its urgent .

 

Thanks

Share this post


Link to post
Share on other sites

Good morning,

 

I am running 2.3.3.4. I have just installed the latest contribution for check out by amazon. Can someone please tell me - is this compatible with my version of osc. I have the following errors at the top of my admin page that lists the payment modules available for install:

 

Deprecated
: Assigning the return value of new by reference is deprecated in
/public_html/shop/checkout_by_amazon/library/HTTP-1.4.3/HTTP/Request.php
on line
402

 

Deprecated
: Assigning the return value of new by reference is deprecated in
/public_html/shop/checkout_by_amazon/library/merchantAtAPIs/lib/amazon/amazon_merchant_at_soap_client.php
on line
142

 

Deprecated
: Assigning the return value of new by reference is deprecated in
/public_html/shop/checkout_by_amazon/library/XML_Parser-1.3.1/XML/Parser.php
on line
616

 

Also, the coa module listed is: Checkout by Amazon 2.3 for 2.2rc2

 

Have I installed the correct download. The readme file states it is for osc 2.3 - although all of the instructions referred to 2.2rc.

 

Thanks so much for any help!

 

JoAnne


JoAnne

Share this post


Link to post
Share on other sites

Hi all,

 

I have resolved the above problem by replacing the US addon with the UK/DE cba addon. Those of you with osc 2.3.3, this was virtually an effortless install.

 

I need help with one last challenge. Because this is a UK/DE addon, it points to the UK amazon gateway server. Can anyone help me change this to the US gateway server?

 

Thanks so much for any help,

JoAnne


JoAnne

Share this post


Link to post
Share on other sites

Still progressing - I have now made the changes to be directed to the us amazon gateway server (thanks so much to Matt!). It appears I have one remaining change, which is to eliminate the VAT requirement - amazon uk requires the value added tax to be added to all orders, or it won't process them.

 

Can anyone help? Unfortunately, I only know html and css so far, so the php coding is still a mystery.

 

Let me know if anyone would like the changes I have made thus far.

 

JoAnne


JoAnne

Share this post


Link to post
Share on other sites
am using osCommerce 2.2-MS2 for this Checkout by amazon plugin "CBA_OSCommerce "

Plugin works fine

But 

in site we have  Coupon option in payment page 

and the coupon reduced amount are shows to till end of conform page 

when click to conform it url moves to amazon site 

here it comes to coupon what i added to oscommerce it doesn't apply to the site amazon 

 

 

EX : my order is 100$ i apply coupon 10$ , it apply 90$ to order then it came Checkout by amazon it show 100$ .

 

 

how to solve this ??

Share this post


Link to post
Share on other sites

I am probably the biggest moron on the planet right now but the code in the instructions is not the code in my oscommerce.  I am trying to modify my login.php file but the code is different and I don't see where I plug the new code at. Do I have the wrong version of this or am I missing something?  Please help.  SOS SOS SOS I'm drowing here.  LOL

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×