Jump to content
Sign in to follow this  
Amazon Payments Team

Checkout by Amazon for osCommerce Support Thread

Recommended Posts

So when is the rest of the world going to get it?

 

(just as importantly, when will the rest of the world be allowed to sell on Amazon Marketplace etc?


Wearing a seatbelt prevents head injuries when the computer crashes - - - Yeah Right!!! - not in this office.

Share this post


Link to post
Share on other sites

i just integrated my oscommerce with amazon

& i'm having a problem with my amazon payments

i get this error

 

We're sorry, but there's a problem with this order. Please contact the merchant directly for assistance in completing this order.

 

the amazon error console shows

Date: Nov 18, 2009 3:30:46 AM PST

Client Request ID: N/A

Order Value: N/A

Severity: ERROR

Error Type: CheckoutCart

Error Code: InvalidInput-NoItems

Error Message: This input is not valid. Detail: There are no items in the cart provided.

Share this post


Link to post
Share on other sites

I'm having a strange issue. I set this module up in sandbox mode and have been testing it. It was working fine and then suddenly yesterday I start getting this error. I've done searches and don't see any info on it. Help!

 

The order is not valid. Detail: Invalid Cart XML: The order XML does not validate against the schema [cvc-minLength-valid: Value '' with length = '0' is not facet-valid with respect to minLength '1' for type 'NonEmptyString'.].

 

This is after you go through the OSC cart and click the Confirm Order and redirect to the Amazon payment page.


Cristina

 

Share this post


Link to post
Share on other sites

Is this still only for U.S.? I am in Canada but see no mention of it anywhere...


Contributions installed: Purchase without Account / STS/ All Products/ Header Tags Controller

Share this post


Link to post
Share on other sites

same quertion like the prev. post but from germany?

currently we use pl...-systems and they've a module called amazon payments and it's working ... but we'll move to osc and we need this payment type cause many customers used to use it!!!

 

are there contribs for generating a catalog.csv which i can upload to my sellercentral-europe account, not the s***y .xcl cause i'm on linux and don't like that m$-crap :-" ?

Edited by smurfi_wsz

Share this post


Link to post
Share on other sites

Did you ever get a solution to this??? I am having the same problem.

 

Thanks,

 

Ken

 

 

I'm having a strange issue. I set this module up in sandbox mode and have been testing it. It was working fine and then suddenly yesterday I start getting this error. I've done searches and don't see any info on it. Help!

 

 

 

This is after you go through the OSC cart and click the Confirm Order and redirect to the Amazon payment page.

Share this post


Link to post
Share on other sites

Hello -- seem to have most of it working on the admin side, but I get this error when testing the cart:

 

Fatal error: Call to undefined function: substr_compare() in /homepages/11/d206294808/htdocs/checkout_by_amazon/custom_data.php on line 53

 

 

Any clues what this might mean?

Share this post


Link to post
Share on other sites

Hi,

I have a huge problem about installation of this plugin.

I am using osCommerce 2.2rc2a.

Its giving me several errors of includes & required files.

As I see the code I couldn't find following files/folders in the zip

require_once('PEAR/PEAR.php');

require_once('HTTP/Request.php');

require_once('checkout_by_amazon/checkout_by_amazon_util_dao.php');

require_once('checkout_by_amazon_order_dao.php');

require_once('checkout_by_amazon_order_request_handler.php');

 

How it will work now??

 

 

Please let me know if anybody has the solution I have followed all the necessary steps of installing this plugin mentioned in readme file.

 

Attached is the screenshot of my errors when I click on the option Amazon Orders from left column of admin.

 

Thank you.

post-297360-0-42031400-1316158990_thumb.jpg

Share this post


Link to post
Share on other sites

Since upgrading to the new USPS method 5.2/6.1 it seems amazon checkout has a character limit for DisplayableShippingLabel which is only in Amazon's API code.

 

The exact message response message from Amazon is:

The order is not valid. Detail: Invalid Cart XML: The content of field DisplayableShippingLabel is longer than maximum allowed. For this field, the maximum allowed length is 100.

 

With the new XML feature from USPS, amazon is not reading the code is including the ml characters, which looks like this.

<DisplayableShippingLabel>United States Postal Service&nbsp;<br>0 lbs, 11.36 oz (First-Class Mail Package (---Approx. delivery time 2 Days))</DisplayableShippingLabel>

 

Since it is very doubtful Amazon will increase their field limit or filter to deal with the additional information being returned by USPS, it looks like three files provided by amazon will need some code revision.

./checkout_by_amazon/checkout_by_amazon_cart.php

./checkout_by_amazon/CBAIOPNxml.php

./checkout_by_amazon/checkout_by_amazon_shipping_processor.php

 

I propose setting a max limit in the three files to fix this issue. '#maxlength' => 100 The second option would be $DisplayableShippingLabel = substr($whateverthestringbeingcovertedis,0,100); The last option is to filter. Any suggestions?

Share this post


Link to post
Share on other sites

The plot thickens with Amazon. Under the new USPS xml data as in the previous post, the field reference is too long. Amazon appears to have no clue how to fix the issue.

 

"In talking with the engineers they stated they do not have the ability to increase the number of characters accepted in the shipping console. However, they did provide me with a link here you can use a file to add additional characters. Please see the following link for more information:

 

http://amazonpayments.s3.amazonaws.com/documents/Using_Custom_Data_Fields.pdf

 

There is a few problems with their pdf and solution, One it doesn't work. Two it will never work.

 

The field DisplayableShippingLabel is generated in Amazon's API and is not a customizable or an added field. That means if you customize that field per Amazons publication, it is no longer considered and therefore shipping is no longer considered. See a problem here? The call back feature is also affected and fails.

 

For some reason Amazon cannot understand the shipping data from USPS is being passed directly to Amazon's API

That means Amazons system either must accept the data in its entirety or *AMAZON* must determine which portion of the field they want. It is not up to us.

 

Lastly, anyone using the old rate card is aware USPS is phasing it out by the end of first quarter 2012. That means if you upgrade you will have this problem and amazon payment will *NOT* work for any USPS service over 100 characters. Which in the all of the services.

Share this post


Link to post
Share on other sites

I'm having a hard time figuring out at what point any of the order information is written to my store's database, so that I can manage Amazon Checkout orders from my store's Admin/Orders page rather than having to go to Seller Central on Amazon. The instructions for the mod make it pretty clear that this should happen, but I'm not seeing it.

 

I've installed the Amazon Checkout Integration mod (v 2.3) on my osC store, and after a day of configuring the many settings (both in my store's Admin and in my Amazon Payments seller account) I've got it working, to the point where I can place an order on my site, click the Checkout by Amazon button instead of my usual osC checkout button, fill in my Amazon e-mail/password, and place the order, but nothing ever comes through to my osC store. I see the order in my Amazon Seller Central account, first under Pending and then after a little while under "Total unshipped," but I'm not seeing any integration with my osC store's Orders page, even though I inserted the code and uploaded the necessary files as per the mod's instructions.

 

UPDATE: Hah. It looks like everything WAS working just fine, it just takes quite a long time (about 40 minutes in this case) for the order to show up on my osC's Orders page. I guess it only updates once an hour, every time the XML orders report is generated by Amazon.

Edited by SpongeMaximus

Share this post


Link to post
Share on other sites

Another question: How does the CBA mod determine which shipping options to show to the customer once they've entered their Amazon account email and password and are looking at their order? Because as far as I can tell, it just shows them most (but not all) of the available, active shipping modules from my osC store, whether or not they're applicable. To illustrate, the following is copy-and-pasted from the screen in question:

Choose a shipping speed:
FLAT - Standard Shipping - $4.50
UPS2DAY - 2 Day Shipping (not available to Alaska & Hawaii) - $19.00
ZONES - - $0.00
ZONESPRIORITY - - $0.00
UPS3DAY - 3 Day Shipping - $14.50
UPSNEXTDAY - Next Day Shipping (not available to Alaska & Hawaii) - $35.00

 

The all-uppercase words are literally the php filenames of the shipping mods. In case anyone's interested, I got the actual names of the mods to display instead by changing

 

catalog/checkout_by_amazon/checkout_by_amazon_shipping_processor, line 80

strtoupper($quotes['id'])

to:

 

strtoupper($quotes['module'])

However, the selection still offers the customer shipping options that it shouldn't, such as ZONES and ZONESPRIORITY which are for non-U.S. orders. It also doesn't offer the "Free Shipping for Orders over $X" option (from freeamount.php) even if their cart contains more than $X worth of items.

 

For those who are successfully using the CBA mod, have you run into this issue with the selection of shipping mods?

Edited by SpongeMaximus

Share this post


Link to post
Share on other sites

In case anyone stumbles in here in the future, looking for answers to the problems I've been having...

 

I got around the issue of which shipping modules are displayed by inserting some conditional stuff (i.e. "IF the ship-to country is domestic AND IF the order total is greater than my minimum amount for free shipping, THEN include the freeamount shipping mod").

 

So now everything is working more or less correctly, with two exceptions:

 

1) Sometimes it takes a long time (up to four days, so far) for approved orders to make it to my osC Admin "Orders" page, despite it being set to grab a new XML orders report every hour. We just came back in after Christmas weekend, and there were close to thirty orders sitting in "Total Unshipped" on Amazon Seller Central, some of them going back to December 23rd. As we puzzled over what could be wrong, suddenly they all poured in and finally appeared on our Admin > Orders page around 9:30am Eastern. It was as though someone at Amazon had a 4-day weekend as well, then came in this morning and threw a switch, pushing them all through at once. This was all with zero input or changes on our end. Does anyone know if for some reason Amazon only sends unshipped order reports during business hours? This could be a huge problem if someone selects Overnight shipping and then has to wait four days for us to even see their order on our end.

 

2) When they come through to our Admin > Orders page, items don't have any attributes. The chosen attributes are partially listed in the item's Name field, but it cuts off after 80 characters, as is Amazon's policy for naming items. So it will look like "1 x Jobst Opaque 15-20 mmHg Moderate Compression Pantyhose (Color: Black, Length..." and that's it. On Seller Central, I can see what options the customer chose since Amazon lists the item's SKU including the option values in brackets (i.e. "SKU: 181{3}6{2}33{5}51"). But something isn't getting done in checkout_by_amazon_order_builder.php to populate the orders_products_attributes table in my database.

 

If anyone is reading this (and I know people are) and feels like letting me know where else I might find support for the Checkout By Amazon mod, I'd be very grateful. I've checked the osCMax forums, the Amazon Services Seller forums, and even the Zen Cart forums, but no one else seems to be having these issues.

Share this post


Link to post
Share on other sites

And problem number 3, posted here for future generations to find:

 

When we go to ship the orders in the osC backend, using the fields added to the orders.php by the CBA mod, it inevitably comes back with "Failed" and the error message "We were unable to charge the customer's payment method." There appears to be exactly zero documentation online surrounding this error message or what may be causing it. If I can get an answer from Amazon themselves (although basically no one there seems to have any experience with osCommerce integration, somehow) I'll post it here in case it helps anyone in the future.

Share this post


Link to post
Share on other sites

Update on problem number 3:

 

Every time I attempt to update the status of a CBA order in my osC store's Admin > Orders page, the CBA mod seems to create an order processing report in XML and submit it to Amazon, where it is then rejected with errors, likely causing the "We were unable to charge the customer's payment method" error I mentioned previously. Examining the order processing reports SEEMS to show that for some reason, the Amazon Order ID being submitted contains extra characters that aren't expected, thus throwing the error.

 

The XML report shows, among other things, the following Results (I've replaced the actual order ID numbers with x's):

 

<ResultDescription>XML Parsing Error at Line 2, Column 16: cvc-pattern-valid: Value 'xxx-xxxxxxx-xxxxxxx ' is not facet-valid with respect to pattern '\w{3}-\w{7}-\w{7}' for type '#AnonType_AmazonOrderID'.</ResultDescription>

[and later in the xml file...]


<ResultDescription>XML Parsing Error at Line 2, Column 16: cvc-type.3.1.3: The value 'xxx-xxxxxxx-xxxxxxx ' of element 'AmazonOrderID' is not valid.</ResultDescription>

 

 

Notice the extra space after the last "x" and before the closing "'" ? I'm guessing that shouldn't be there. Another clue as to that being the problem is in my OSC database, in the amazon_orders_status_history table, in the xml column, the Amazon Order ID looks like this:<AmazonOrderID>xxx-xxxxxxx-xxxxxxx\r</AmazonOrderID>

 

That "\r" at the end seems to be throwing the whole thing off. Now to try to find out WHY there is an extra space and/or "\r" (carriage return) being added onto the end of the Amazon Order ID, thereby making it invalid.

Share this post


Link to post
Share on other sites

Hi Everyone,

I am adding another question to this topic.

I can see that it is not straightforward to integrate amazon check out with osCommerce.

However, I would like to know if the API allows people to integrate fully amazon checkout in oscommerce.

I don't want my customers to be redirected at the last minute to amazon checkout... I want them to have the full experience without leaving my sit.

Can someone tell me if that's possible?

Thank you in advance. :)

Share this post


Link to post
Share on other sites

Please explain to forum readers how there is no direct contact info for amazon payments systems. Can you also explain to the readers how log in cookies are not separate on the payment site vs amazon seller account..so it becomes very difficult to log back and forth between sites. Can you also explain the terms of agreement limit what can be sold using aps. If found in violation you account funds will be held for 180 days. Once blocked the account is no longer viewable by amazon support staff and no information can be conveyed.

 

Can you explain that aps has a sub called cba but they dont share information or emails. That no one knows who is who when contacting amazon and they dont record emails sent by cba on either amazon or aps.

Share this post


Link to post
Share on other sites

i would very much appreciate some guidance on getting amazon checkout to work with 2.3.1. on my old 2.2 site it worked fine.

Share this post


Link to post
Share on other sites

unless i'm missing something it doesn't. the last install i saw said 2.2 only. if there is one for 2.3 please point me in that direction and i'll give it a shot.

Share this post


Link to post
Share on other sites

ya im not seeing any instructions that show how to use the CBA for 2.3....even though the package says its for 2.3 its not showing the right instructions.

Share this post


Link to post
Share on other sites

Anyone figure this out.

 

If not would anyone be interested if I recoded this and published it?

 

On the phone with Amazon right now but they do not have the latest code.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×