Jump to content
Sign in to follow this  
bebory

Help with Multiple Image AutoThumbs - MIA

Recommended Posts

I have successfully installed this add on and it is working as far as I can tell.

I need help with how to upload multiple images though through the admin panel. There isn't much documentation on this add on.

It is listed in addons as

http://addons.oscommerce.com/info/6480

 

 

Thank you for your valuable time.

 

Beth

Share this post


Link to post
Share on other sites

I also would like some help with this, how do you acyually load the extra images?

Thanks!

Share this post


Link to post
Share on other sites

I'm also wondering the same thing ... how do you upload multiple images? I installed the http://addons.oscommerce.com/info/6480; now the admin has the additional Thumbnails section and Images has the additional titles. I can change the sizes, watermarks, etc however I don't see a feature to upload multiple images. Which file(s) would would control it; I listed the files from the instruction below? Thanks.

 

/catalog/oscthumb.php

/catalog/phpThumb folder

/catalog/includes/classes/oscthumb.php

 

/catalog/admin/includes/functions/general.php

/catalog/includes/application_top.php

/catalog/includes/functions/html_output.php

Share this post


Link to post
Share on other sites
I'm also wondering the same thing ... how do you upload multiple images? I installed the http://addons.oscommerce.com/info/6480; now the admin has the additional Thumbnails section and Images has the additional titles. I can change the sizes, watermarks, etc however I don't see a feature to upload multiple images. Which file(s) would would control it; I listed the files from the instruction below? Thanks.

 

/catalog/oscthumb.php

/catalog/phpThumb folder

/catalog/includes/classes/oscthumb.php

 

/catalog/admin/includes/functions/general.php

/catalog/includes/application_top.php

/catalog/includes/functions/html_output.php

 

Hey there everybody!

 

I basically just plopped the code up there as useful/reference for anyone who wanted to use it with no plans to support it. That said it sounds like you haven't completely installed it.

 

In /admin/categories.php you should be able to search for: BOF Evolve

 

Inside that you should find multiple edits that are required

<?php // BOF Evolve - update database with new images?>
  <tr>
		<td class="main"><?php echo TEXT_PRODUCTS_IMAGE; ?></td>
		<td class="main"><?php echo tep_draw_separator('pixel_trans.gif', '24', '15') . ' ' . tep_draw_file_field('products_image_1') . '<br>' . tep_draw_separator('pixel_trans.gif', '24', '15') . ' ' . $pInfo->product_image_1 . tep_draw_hidden_field('products_previous_image_1', $pInfo->product_image_1); ?></td>
	  </tr><tr>
		<td class="main"><?php echo TEXT_PRODUCTS_IMAGE; ?></td>
		<td class="main"><?php echo tep_draw_separator('pixel_trans.gif', '24', '15') . ' ' . tep_draw_file_field('products_image_2') . '<br>' . tep_draw_separator('pixel_trans.gif', '24', '15') . ' ' . $pInfo->product_image_2 . tep_draw_hidden_field('products_previous_image_2', $pInfo->product_image_2); ?></td>
	  </tr><tr>
		<td class="main"><?php echo TEXT_PRODUCTS_IMAGE; ?></td>
		<td class="main"><?php echo tep_draw_separator('pixel_trans.gif', '24', '15') . ' ' . tep_draw_file_field('products_image_3') . '<br>' . tep_draw_separator('pixel_trans.gif', '24', '15') . ' ' . $pInfo->product_image_3 . tep_draw_hidden_field('products_previous_image_3', $pInfo->product_image_3); ?></td>
	  </tr><tr>
		<td class="main"><?php echo TEXT_PRODUCTS_IMAGE; ?></td>
		<td class="main"><?php echo tep_draw_separator('pixel_trans.gif', '24', '15') . ' ' . tep_draw_file_field('products_image_4') . '<br>' . tep_draw_separator('pixel_trans.gif', '24', '15') . ' ' . $pInfo->product_image_4 . tep_draw_hidden_field('products_previous_image_4', $pInfo->product_image_4); ?></td>
	  </tr><tr>
		<td class="main"><?php echo TEXT_PRODUCTS_IMAGE; ?></td>
		<td class="main"><?php echo tep_draw_separator('pixel_trans.gif', '24', '15') . ' ' . tep_draw_file_field('products_image_5') . '<br>' . tep_draw_separator('pixel_trans.gif', '24', '15') . ' ' . $pInfo->product_image_5 . tep_draw_hidden_field('products_previous_image_5', $pInfo->product_image_5); ?></td>
	  </tr><tr>
		<td class="main"><?php echo TEXT_PRODUCTS_IMAGE; ?></td>
		<td class="main"><?php echo tep_draw_separator('pixel_trans.gif', '24', '15') . ' ' . tep_draw_file_field('products_image_6') . '<br>' . tep_draw_separator('pixel_trans.gif', '24', '15') . ' ' . $pInfo->product_image_6 . tep_draw_hidden_field('products_previous_image_6', $pInfo->product_image_6); ?></td>
	  </tr>
<?php // EOF Evolve - update database with new images ?>

 

If you don't... well... start again :)

 

If you're using the 1.1 version by jjkweb you might want to PM him about it.

 

Hope that helps,

Iggy


Everything's funny but nothing's a joke...

Share this post


Link to post
Share on other sites

Iggy, I appreciate the response. I think it's funny that you mentioned that I did "not completely installed it" because I was pondering the same thing; I noticed that the HTML directions did not ask to include/modify three potential important files: product_info.php, admin/categories.php and includes/modules/additional_images.php which were included w/ the Zip file.

 

Good news ... I uploaded the ZIP admin/categories.php and now I have the 7 (1+6) additional image options. Bad news ... I used WinMerge and compared the ZIP product_info.php and modifed llines 87-89 and 123-139 that started and ended w/ BOF and EOF however I only 2 images, both of which are the same. The second image seems to link to oscthumb.php. What am I missing to get to display the images? Thanks.

Share this post


Link to post
Share on other sites
Iggy, I appreciate the response. I think it's funny that you mentioned that I did "not completely installed it" because I was pondering the same thing; I noticed that the HTML directions did not ask to include/modify three potential important files: product_info.php, admin/categories.php and includes/modules/additional_images.php which were included w/ the Zip file.

 

Good news ... I uploaded the ZIP admin/categories.php and now I have the 7 (1+6) additional image options. Bad news ... I used WinMerge and compared the ZIP product_info.php and modifed llines 87-89 and 123-139 that started and ended w/ BOF and EOF however I only 2 images, both of which are the same. The second image seems to link to oscthumb.php. What am I missing to get to display the images? Thanks.

 

Generally when installing contribs I'll run through all the files included in the zip and diff them against my store then consult the instructions for any further mods that need to be made.

 

In this case I didn't change the install instructions from the original so only steps 4 and 5 are relevant. The rest is file by file comparison/mod. All the files in Catalog need to be updated/added to your running store and the SQL file needs to be applied to your database. Ought to do it.

 

If your files are not RC2a stock I'm afraid you'll have to make some judgement calls as to how to merge the files.

 

Hope that helps!

Edited by Iggy

Everything's funny but nothing's a joke...

Share this post


Link to post
Share on other sites

I still cannot get the Product page to display the additional images; I can upload them in the admin/catalog "New Product." The DB table "products" shows columns "products_images_1-6." I think the last part of this equation resides somewhere w/ the product_info.php and/or additional_images.php. I have uploaded all the "Uploaded New" as is and uploaded all the "Uploaded Modified" files modified w/ WinMerge ... thus I have now touched all the files in the contribution.

 

Uploaded New:

/catalog/oscthumb.php

/catalog/phpThumb folder

/catalog/css folder

/catalog/images folder

/catalog/admin/categories.php

/catalog/includes/classes/oscthumb.php

/catalog/includes/languages/english/images/buttons folder

/catalog/includes/modules/additional_images.php

 

Uploaded Modified:

catalog/admin/includes/functions/general.php

catalog/includes/application_top.php

catalog/includes/functions/html_output.php

 

Does anyone know which codes/lines on the product_info.php and/or additional_images.php are "supposed" to pull the images from DB? How should/would you need to modified to display the additional images. I tried playing w/ lines 87-89 and 123-139 (BOF and EOF) in the product_info.php but they were not it. Also, I noticed that I cannot change the "Text Watermark Size" even changing the values from 15 to 55 ... has anyone else done it?

Edited by chuglobal

Share this post


Link to post
Share on other sites

Update ... I finally decided to drop this contribution because I couldn't figure out how to access the additional images and no one knew it either as others have posted the same question. I am now playing w/ UltraPics - MS2 Image Addon Pack ... defintiely more progress w/ this in 24hrs than the original over the last few weeks. :)

Share this post


Link to post
Share on other sites

UltraPics is a good choice if you don't need the thumbs generated automagically. I use it myself and stole some bits of it for MIA.


Everything's funny but nothing's a joke...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×