Jump to content
Jack_mcs

Google XML Sitemap SEO

Recommended Posts

The error shows the file to be there. But whether it is or isn't, I can't help you with non-standard setups. If you install the contribution as directed it will work.

 

Jack

Share this post


Link to post
Share on other sites
What error are you getting? Do you mean the specials? Do you have any items on special? Did you see the post regarding removing that part of the contribution? Are your other sitemaps being created?

 

Jack

 

It says failed on all,

 

I will remove the specials to night.

 

Thxs


-Peder Beckman-

Kool Kat Jazz Records

Share this post


Link to post
Share on other sites

Hello

Write D:/www/my-site.fr/htdocs/catalog/sitemapproducts.xml
Generated Google Product Sitemap Successfully[/color]

[color="#2E8B57"]Write D:/www/my-site.fr/htdocs/catalog/sitemapcategories.xml
Generated Google Category Sitemap Successfully[/color]

[color="#FF0000"]ERROR: Google Manufacturers Sitemap Generation FAILED![/color]

Google Sitemap Specials not generated - no specials found!

[color="#2E8B57"]Write D:/www/my-site/htdocs/catalog/sitemapindex.xml
Generated Google Sitemap Index Successfully[/color]

Array
(
   [QUERY] => Array
       (
           [PRODUCTS] => Array
               (
                   [sTATUS] => success
                   [NUM_ROWS] => 514
               )

           [CATEOGRY] => Array
               (
                   [sTATUS] => success
                   [NUM_ROWS] => 130
               )

           [MANUFACTURERS] => Array
               (
                   [sTATUS] => success
                   [NUM_ROWS] => 1
               )

           [sPECIALS] => Array
               (
                   [sTATUS] => success
                   [NUM_ROWS] => 0
               )

       )

   [sAVE_FILE_XML] => Array
       (
           [0] => Array
               (
                   [file] => D:/www/my-site.fr/htdocs/catalog/sitemapproducts.xml
                   [status] => success
                   [file_exists] => true
               )

           [1] => Array
               (
                   [file] => D:/www/my-site.fr/htdocs/catalog/sitemapcategories.xml
                   [status] => success
                   [file_exists] => true
               )

           [2] => Array
               (
                   [file] => D:/www/my-site.fr/htdocs/catalog/sitemapindex.xml
                   [status] => success
                   [file_exists] => true
               )

       )

)

 

Do you know what I can do for this ERROR: Google Manufacturers Sitemap Generation FAILED ??? The xml file is empty and I have at lest 1 manufacturer! Google has an error on it... SITEMAP EMPTY

 

I have open the rights (777) and install all again and it is still the same!

 

Actualy with Google in catalog/sitemapindex.xml I have an error:

 

catalog/sitemapcategories.xml OK

catalog/sitemapmanufacturers.xml Erreurs

catalog/sitemapproducts.xml Avertissements (Google doesn't like the fact that all my URL have the same "priority". Where can I change it (in some URLs)?

catalog/sitemapspecials.xml OK

 

If you have any idea?

 

Thanks

Edited by Eric B

osCommerce Online Merchant v2.2 RC1 W3C Valid FR avec : colissimo_v1.9 // CGV // GoogleXML_sitemap - Update -> googlexml_sitemap_seo_v_1.5 // Ultimate SEO URLs 2.1d - Update -> v22d_12 // AntiRobotRegistrationValidation-3.1 // TinyMCE WYSIWYG HTML EDITOR // HEader Tag SEO 3.1.4 // PDF Invoice 1.5 // Specials_enhanced_v1_3_1 // quick_stock_update_v3.5_FRENCH // xmembers_v2.2 // contact_us_form_in_db_with_amin_v1.1 // photo_display_1 // previous_next_with_details // infoBox Admin v.2.25 // whosonlineturbov1.1fr // customer_discount_v1.3 // flash_bannersv2 // Horizontal_menu_V3 // Loginbox_Best_1 // CCGV // XSell_v2_7_2 // Printable Catalog XSS Flaw Fixed // all_specials_slideshow // Birthdays_v1.4 // Search_price_range_pulldown_menu_1.1 // contrib-categories // Reviews_in_Product_Display_v2.3 // Easy Graphical Borders // Simple Multiple Images (Unlimited) with Fancy Popups V1.3.5 // Guestbook V3.0 // Blacklist_IP_v.3 // Quicker Product Edit v2.1 // Chronopost_2010 // Easy Center // Size Shop with Layers // Safari-Chrome_fix // Protection to Configuration v1.3a // Page_Cache_v1.6... Thanks to everyone!

Share this post


Link to post
Share on other sites

For the manufacturers, be sure you have entries in both maufacturer tables in the database. The priority shouldn't normally be the same but an earlier post covered what to do to fix that.

 

Jack

Edited by Jack_mcs

Share this post


Link to post
Share on other sites
For the manufacturers, be sure you have entries in both maufacturer tables in the database. The priority shouldn't normally be the same but an earlier post covered what to do to fix that.

 

Jack

 

I had only one Manufacturer and when I did had a second one it did work (Google link is showing the manufacturers)!

For the specials, I have done a test (sales on 3 items) and it did work too (google link is showing the items)!

 

Jack as always you have all the answers!

 

And BRAVO for all your work and thanks again for your help always very fast!


osCommerce Online Merchant v2.2 RC1 W3C Valid FR avec : colissimo_v1.9 // CGV // GoogleXML_sitemap - Update -> googlexml_sitemap_seo_v_1.5 // Ultimate SEO URLs 2.1d - Update -> v22d_12 // AntiRobotRegistrationValidation-3.1 // TinyMCE WYSIWYG HTML EDITOR // HEader Tag SEO 3.1.4 // PDF Invoice 1.5 // Specials_enhanced_v1_3_1 // quick_stock_update_v3.5_FRENCH // xmembers_v2.2 // contact_us_form_in_db_with_amin_v1.1 // photo_display_1 // previous_next_with_details // infoBox Admin v.2.25 // whosonlineturbov1.1fr // customer_discount_v1.3 // flash_bannersv2 // Horizontal_menu_V3 // Loginbox_Best_1 // CCGV // XSell_v2_7_2 // Printable Catalog XSS Flaw Fixed // all_specials_slideshow // Birthdays_v1.4 // Search_price_range_pulldown_menu_1.1 // contrib-categories // Reviews_in_Product_Display_v2.3 // Easy Graphical Borders // Simple Multiple Images (Unlimited) with Fancy Popups V1.3.5 // Guestbook V3.0 // Blacklist_IP_v.3 // Quicker Product Edit v2.1 // Chronopost_2010 // Easy Center // Size Shop with Layers // Safari-Chrome_fix // Protection to Configuration v1.3a // Page_Cache_v1.6... Thanks to everyone!

Share this post


Link to post
Share on other sites

I just installed and ran the Google XML Sitemap Admin via the admin panel. I saw a blank screen popup. Is that all their is to it? Where does the sitemap get created to? I would like to be able to take a peek at the xml that was created before I actually try submitting it to google.

Share this post


Link to post
Share on other sites
I just installed and ran the Google XML Sitemap Admin via the admin panel.

Please post your question in the correct support thread. This one is for a different contribution than what you installed.

 

Jack

Share this post


Link to post
Share on other sites

Hi Jack,

 

Im bit of a new b to this mate. I installed the contribution. Big thanks.

 

However google now reports errors that...

 

1. catalog/sitemapproducts.xml Warnings

All the URLs in your Sitemap have the same priority.

 

What do i need to do about this warning? Im tottaly lost.

 

 

2. catalog/sitemapspecials.xml Errors

Empty Sitemap

 

How do i comnfigure so that google does not look for specials?

 

 

Any help greatly appreciated.

 

Thanks.

 

Amit.

Share this post


Link to post
Share on other sites

Hi Jack,

 

Just 2 new questions ;)

 

Is Google XML Sitemap SEO working normaly with: Header Tags SEO V 3.1.3 and Anti Robot Registration Validation V3.1?

 

By the way, do you have any advice about which versions should I use cause from now I have try on localhost Anti Robot Registration Validation but wasn't working?!

 

Thanks Jack


osCommerce Online Merchant v2.2 RC1 W3C Valid FR avec : colissimo_v1.9 // CGV // GoogleXML_sitemap - Update -> googlexml_sitemap_seo_v_1.5 // Ultimate SEO URLs 2.1d - Update -> v22d_12 // AntiRobotRegistrationValidation-3.1 // TinyMCE WYSIWYG HTML EDITOR // HEader Tag SEO 3.1.4 // PDF Invoice 1.5 // Specials_enhanced_v1_3_1 // quick_stock_update_v3.5_FRENCH // xmembers_v2.2 // contact_us_form_in_db_with_amin_v1.1 // photo_display_1 // previous_next_with_details // infoBox Admin v.2.25 // whosonlineturbov1.1fr // customer_discount_v1.3 // flash_bannersv2 // Horizontal_menu_V3 // Loginbox_Best_1 // CCGV // XSell_v2_7_2 // Printable Catalog XSS Flaw Fixed // all_specials_slideshow // Birthdays_v1.4 // Search_price_range_pulldown_menu_1.1 // contrib-categories // Reviews_in_Product_Display_v2.3 // Easy Graphical Borders // Simple Multiple Images (Unlimited) with Fancy Popups V1.3.5 // Guestbook V3.0 // Blacklist_IP_v.3 // Quicker Product Edit v2.1 // Chronopost_2010 // Easy Center // Size Shop with Layers // Safari-Chrome_fix // Protection to Configuration v1.3a // Page_Cache_v1.6... Thanks to everyone!

Share this post


Link to post
Share on other sites
Hi Jack,

 

Im bit of a new b to this mate. I installed the contribution. Big thanks.

 

However google now reports errors that...

 

1. catalog/sitemapproducts.xml Warnings

All the URLs in your Sitemap have the same priority.

 

What do i need to do about this warning? Im tottaly lost.

 

 

2. catalog/sitemapspecials.xml Errors

Empty Sitemap

 

How do i comnfigure so that google does not look for specials?

 

 

Any help greatly appreciated.

 

Thanks.

 

Amit.

Please take the time to read the last few pages or use the search function at the bottom of the page before posting.

 

Jack

Share this post


Link to post
Share on other sites
Hi Jack,

 

Just 2 new questions ;)

 

Is Google XML Sitemap SEO working normaly with: Header Tags SEO V 3.1.3 and Anti Robot Registration Validation V3.1?

 

By the way, do you have any advice about which versions should I use cause from now I have try on localhost Anti Robot Registration Validation but wasn't working?!

 

Thanks Jack

This contribution doesn't have any interaction with Header Tags but they can both work on the same shop fine. I am not familiar with the other contribution.

 

Jack

Share this post


Link to post
Share on other sites
This contribution doesn't have any interaction with Header Tags but they can both work on the same shop fine. I am not familiar with the other contribution.

 

Jack

 

Thanks Jack,

 

I will try Header Tags SEO V 3.1.3 today then!

 

About the other contribution it is a Captcha. Maybe you know an other Captcha and that you are sure it is working properly cause when I have tried that one, it didn't work on my localhost but I heard that it does work finally online?

 

Thanks


osCommerce Online Merchant v2.2 RC1 W3C Valid FR avec : colissimo_v1.9 // CGV // GoogleXML_sitemap - Update -> googlexml_sitemap_seo_v_1.5 // Ultimate SEO URLs 2.1d - Update -> v22d_12 // AntiRobotRegistrationValidation-3.1 // TinyMCE WYSIWYG HTML EDITOR // HEader Tag SEO 3.1.4 // PDF Invoice 1.5 // Specials_enhanced_v1_3_1 // quick_stock_update_v3.5_FRENCH // xmembers_v2.2 // contact_us_form_in_db_with_amin_v1.1 // photo_display_1 // previous_next_with_details // infoBox Admin v.2.25 // whosonlineturbov1.1fr // customer_discount_v1.3 // flash_bannersv2 // Horizontal_menu_V3 // Loginbox_Best_1 // CCGV // XSell_v2_7_2 // Printable Catalog XSS Flaw Fixed // all_specials_slideshow // Birthdays_v1.4 // Search_price_range_pulldown_menu_1.1 // contrib-categories // Reviews_in_Product_Display_v2.3 // Easy Graphical Borders // Simple Multiple Images (Unlimited) with Fancy Popups V1.3.5 // Guestbook V3.0 // Blacklist_IP_v.3 // Quicker Product Edit v2.1 // Chronopost_2010 // Easy Center // Size Shop with Layers // Safari-Chrome_fix // Protection to Configuration v1.3a // Page_Cache_v1.6... Thanks to everyone!

Share this post


Link to post
Share on other sites
Thanks Jack,

 

I will try Header Tags SEO V 3.1.3 today then!

 

About the other contribution it is a Captcha. Maybe you know an other Captcha and that you are sure it is working properly cause when I have tried that one, it didn't work on my localhost but I heard that it does work finally online?

 

Thanks

A new version of Header Tags will be uploaded today so you may want to hold off.

 

You should ask for support on that type of contribution in the support thread for it since that is whre the people actually using it will see it.

 

Jack

Share this post


Link to post
Share on other sites
A new version of Header Tags will be uploaded today so you may want to hold off.

 

You should ask for support on that type of contribution in the support thread for it since that is whre the people actually using it will see it.

 

Jack

 

Ok Jack, I'll wait

 

Thanks


osCommerce Online Merchant v2.2 RC1 W3C Valid FR avec : colissimo_v1.9 // CGV // GoogleXML_sitemap - Update -> googlexml_sitemap_seo_v_1.5 // Ultimate SEO URLs 2.1d - Update -> v22d_12 // AntiRobotRegistrationValidation-3.1 // TinyMCE WYSIWYG HTML EDITOR // HEader Tag SEO 3.1.4 // PDF Invoice 1.5 // Specials_enhanced_v1_3_1 // quick_stock_update_v3.5_FRENCH // xmembers_v2.2 // contact_us_form_in_db_with_amin_v1.1 // photo_display_1 // previous_next_with_details // infoBox Admin v.2.25 // whosonlineturbov1.1fr // customer_discount_v1.3 // flash_bannersv2 // Horizontal_menu_V3 // Loginbox_Best_1 // CCGV // XSell_v2_7_2 // Printable Catalog XSS Flaw Fixed // all_specials_slideshow // Birthdays_v1.4 // Search_price_range_pulldown_menu_1.1 // contrib-categories // Reviews_in_Product_Display_v2.3 // Easy Graphical Borders // Simple Multiple Images (Unlimited) with Fancy Popups V1.3.5 // Guestbook V3.0 // Blacklist_IP_v.3 // Quicker Product Edit v2.1 // Chronopost_2010 // Easy Center // Size Shop with Layers // Safari-Chrome_fix // Protection to Configuration v1.3a // Page_Cache_v1.6... Thanks to everyone!

Share this post


Link to post
Share on other sites
Please take the time to read the last few pages or use the search function at the bottom of the page before posting.

 

Jack

 

 

HI Jack,

 

 

Sorry. I had a look straight after posting. My appologies.

 

Amit

Share this post


Link to post
Share on other sites

I've installed the Google XML Sitemap and generated my sitemaps and successfully manually loaded them up to Google.

I tried to set up a Cron task to schedule the updates and keep getting the following messages. I've checked my site and SafeMode is off. From the messages below, I'm assuming that if I can fix the first one, the others may also be fixed?

 

Warning: chdir(): SAFE MODE Restriction in effect. The script whose uid is 10004 is not allowed to access ../ owned by uid 0 in /var/www/vhosts/carxtreme.co.uk/httpdocs/googlesitemap/index.php on line 20

 

Warning: require_once(includes/configure.php): failed to open stream: No such file or directory in /var/www/vhosts/carxtreme.co.uk/httpdocs/googlesitemap/index.php on line 46

 

Fatal error: require_once(): Failed opening required 'includes/configure.php' (include_path='.:') in /var/www/vhosts/carxtreme.co.uk/httpdocs/googlesitemap/index.php on line 46

 

Can anyone suggest a solution?

 

Thanks.

Share this post


Link to post
Share on other sites

You will need to ask your host to turn safe mode off. Some will - some won't.

 

Jack

Share this post


Link to post
Share on other sites
You will need to ask your host to turn safe mode off. Some will - some won't.

 

Jack

 

According to my PHP settings, Safe Mode is already Off. I've also checked my PHP.ini file to make sure too.

 

Nigel.

Share this post


Link to post
Share on other sites

I can't help you with that. The safe mode error is definately a server problem.

 

Jack

Share this post


Link to post
Share on other sites

I am totally stumped, I know... what else is new. :blush:

 

I had to use the sitemap.class_Alternative.php in order to get things working.

 

I thought the sitemap generation was working correctly, until I finally received an email from the Cron Job. :huh:

 

http://handeshobbies.com/googlesitemap/index.php says all is a success.

 

But I receive a FAILED in the Cron Job email:

 

X-Powered-By: PHP/5.2.9
Content-type: text/html

<pre>
<b>Warning</b>:  fopen(/sitemapproducts.xml) [<a href='function.fopen'>function.fopen</a>]: failed to open stream: Permission denied in <b>/home3/handesho/public_html/googlesitemap/sitemap.class.php</b> on line <b>300</b>

ERROR: Google Product Sitemap Generation FAILED!

<b>Warning</b>:  fopen(/sitemapcategories.xml) [<a href='function.fopen'>function.fopen</a>]: failed to open stream: Permission denied in <b>/home3/handesho/public_html/googlesitemap/sitemap.class.php</b> on line <b>300</b>

ERROR: Google Category Sitemap Generation FAILED!

<b>Warning</b>:  fopen(/sitemapmanufacturers.xml) [<a href='function.fopen'>function.fopen</a>]: failed to open stream: Permission denied in <b>/home3/handesho/public_html/googlesitemap/sitemap.class.php</b> on line <b>300</b>

ERROR: Google Manufacturers Sitemap Generation FAILED!

Google Sitemap Specials not generated - no specials found!

<b>Warning</b>:  fopen(/sitemapindex.xml) [<a href='function.fopen'>function.fopen</a>]: failed to open stream: Permission denied in <b>/home3/handesho/public_html/googlesitemap/sitemap.class.php</b> on line <b>300</b>

ERROR: Google Sitemap Index Generation FAILED!

Array
(
[QUERY] => Array
	(
		[PRODUCTS] => Array
			(
				[STATUS] => success
				[NUM_ROWS] => 427
			)

		[CATEOGRY] => Array
			(
				[STATUS] => success
				[NUM_ROWS] => 37
			)

		[MANUFACTURERS] => Array
			(
				[STATUS] => success
				[NUM_ROWS] => 11
			)

		[SPECIALS] => Array
			(
				[STATUS] => success
				[NUM_ROWS] => 0
			)

	)

[SAVE_FILE_XML] => Array
	(
		[0] => Array
			(
				[file] => /sitemapproducts.xml
				[status] => failure
				[file_exists] => false
			)

		[1] => Array
			(
				[file] => /sitemapcategories.xml
				[status] => failure
				[file_exists] => false
			)

		[2] => Array
			(
				[file] => /sitemapmanufacturers.xml
				[status] => failure
				[file_exists] => false
			)

		[3] => Array
			(
				[file] => /sitemapindex.xml
				[status] => failure
				[file_exists] => false
			)

	)

)
</pre>

 

sitemap.class.php line 300 = if ($fp = fopen($filename, 'w+')){

All files have 755 permission, same as my images directory.

I seen in early post -

It looks like your configure file settings are not being loaded. Please try this: In the googlesitemap/sitemap_class.php file, find this line around line 299
$filename .= '.xml';

and add this after it

		 echo 'Opening   '.$filename. '
FS_CAT	'.DIR_FS_CATALOG. '
Server	' . HTTP_SERVER . '
Save Path '. $this->savepath . '
WS_CAT	'. DIR_WS_HTTP_CATALOG.' 
';

Upload the changed file and run the code by going to http://yourdomain.com/googlesitemap/index.php. Post the output here.

 

Jack

 

http://handeshobbies.com/googlesitemap/index.php

 

Current Cron Job email with above added code -

 

PHP Warning:  require_once(includes/configure.php): failed to open stream: No such file or directory in /home3/handesho/public_html/googlesitemap/index.php on line 46

Warning: require_once(includes/configure.php): failed to open stream: No such file or directory in /home3/handesho/public_html/googlesitemap/index.php on line 46
PHP Fatal error:  require_once(): Failed opening required 'includes/configure.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home3/handesho/public_html/googlesitemap/index.php on line 46

Fatal error: require_once(): Failed opening required 'includes/configure.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home3/handesho/public_html/googlesitemap/index.php on line 46

 

:(


- :: Jim :: -

- My Toolbox ~ Adobe Web Bundle, XAMPP & WinMerge | Install ~ osC v2.3.3.4 -

Share this post


Link to post
Share on other sites

That is mostly a path problem with cron. You may need to do something like

cd /home3/handesho/public_html/; php googlesitemap/index.php

But your host would know better since it varies with the host. Explain to your host that the script runs manually but fails with cron. They should be able to adjust it.

 

Jack

Share this post


Link to post
Share on other sites

I am having a minor issue. I did as what was in post #7 & 13. Did not help. Upgraded to the latest as per your instructions, Jack.

 

My email consists of .the same info as when going here, Website. Now I do not see any errors on that page. Not sure what a correct email or googlesitemap/index.php should look like. But also categories and etc. displays (Number of URLs in this Sitemap: 0). That is incorrect, I believe. Also permission is set at 755.

 

So am I doing something wrong or what?

 

Thamks.

 

Bennett

Edited by blr044

Share this post


Link to post
Share on other sites
That is mostly a path problem with cron. You may need to do something like
cd /home3/handesho/public_html/; php googlesitemap/index.php

But your host would know better since it varies with the host. Explain to your host that the script runs manually but fails with cron. They should be able to adjust it.

 

Jack

 

Thank you Jack

 

I'll double check with my host.


- :: Jim :: -

- My Toolbox ~ Adobe Web Bundle, XAMPP & WinMerge | Install ~ osC v2.3.3.4 -

Share this post


Link to post
Share on other sites
I am having a minor issue. I did as what was in post #7 & 13. Did not help. Upgraded to the latest as per your instructions, Jack.

 

My email consists of .the same info as when going here, Website. Now I do not see any errors on that page. Not sure what a correct email or googlesitemap/index.php should look like. But also categories and etc. displays (Number of URLs in this Sitemap: 0). That is incorrect, I believe. Also permission is set at 755.

 

So am I doing something wrong or what?

 

Thamks.

 

Bennett

Be sure the permissions on the sitemap files are set the same as those of the images directories before running the script. Also try running the alternate script to see if that helps.

 

Jack

Share this post


Link to post
Share on other sites

The permission is the same as images. Even tried using 755 instaed of 777. After using the (alternate) sitemap, this is what I get now.

 

ERROR: Google Product Sitemap Generation FAILED!

 

ERROR: Google Category Sitemap Generation FAILED!

 

Google Sitemap Manufacturers not generated - no Manufacturers found!

 

ERROR: Google Specials Sitemap Generation FAILED!

 

ERROR: Google Sitemap Index Generation FAILED!

 

Array

(

[QUERY] => Array

(

[PRODUCTS] => Array

(

[sTATUS] => success

[NUM_ROWS] => 1256

)

 

[CATEOGRY] => Array

(

[sTATUS] => success

[NUM_ROWS] => 45

)

 

[MANUFACTURERS] => Array

(

[sTATUS] => success

[NUM_ROWS] => 0

)

 

[sPECIALS] => Array

(

[sTATUS] => success

[NUM_ROWS] => 13

)

 

)

 

[sAVE_FILE_XML] => Array

(

[0] => Array

(

[file] => /sitemapproducts.xml

[status] => failure

[file_exists] => false

)

 

[1] => Array

(

[file] => /sitemapcategories.xml

[status] => failure

[file_exists] => false

)

 

[2] => Array

(

[file] => /sitemapspecials.xml

[status] => failure

[file_exists] => false

)

 

[3] => Array

(

[file] => /sitemapindex.xml

[status] => failure

[file_exists] => false

)

 

)

 

)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×