Jump to content
Jack_mcs

Google XML Sitemap SEO

Recommended Posts

ecartz

THANK YOU.

I am ALWAYS amazed by those that can find an error induced by a module other than the one that is failing.  Incorporating your change above solved the unescaped apostrophe.

I, myself, would have never looked outside of the module that I had just installed.

Thanks again.

BJ

Edited by Chadduck

Share this post


Link to post
Share on other sites

@Jack_mcs

Your add on works fine to me, thank you for developing it.

I have some questions to the add on:

1. After first time installation, can i remove google_xml_sitemap_seo_install.php from the root directory or is it still required?
2. I have set up 2 languages in my shop, German (default) and English.
    a) Is this add on supporting multi lingual or just one language? 
    b) if only one language is supported, how do I tell google by the "xml files" my English description links eq parameters ?language=de or ?language=en?
        The description of articles, categories and manufactures in my shop are different in german and english!

Thanks for responding

 

Share this post


Link to post
Share on other sites

@Philo20051 - Yes, that file should be deleted. You should have seen a button to delete it when you ran the file.

2 - Unfortunately, it does not create multiple language map files. There's a way to do it manually but it requires editing files. If that was a one-time thing then it would be Ok for a temp solution. But this addon should be ran frequently so that is not a good solution. I've added this to things to do for the next version but it will not be completed anytime soon.

Share this post


Link to post
Share on other sites
1 hour ago, Jack_mcs said:

@Philo20051 - Yes, that file should be deleted. You should have seen a button to delete it when you ran the file.

2 - Unfortunately, it does not create multiple language map files. There's a way to do it manually but it requires editing files. If that was a one-time thing then it would be Ok for a temp solution. But this addon should be ran frequently so that is not a good solution. I've added this to things to do for the next version but it will not be completed anytime soon.

@Jack_mcs

Thanks for the fast respond!

1 - okay i deleted the file manually, maybe this should be mentioned at the end of point 3) in the "readme.txt"  file of the add on.

2 - okay thank you for adding it to you to do list, this seems important to me to be present on google in more than one language .

Have a nice day 🙂

Share this post


Link to post
Share on other sites
39 minutes ago, Philo2005 said:

1 - okay i deleted the file manually, maybe this should be mentioned at the end of point 3) in the "readme.txt"  file of the add on.

Did you make the database changes with the google_xml_sitemap_seo_install.php file? If so, it has a delete button. Did you not see that? I would think that button is more obvious than text in the install file. If the button is ignored then the text would be too, most likely.

Yes, the language is important. But I don't have multi-language sites so unless such a problem is mentioned, it won't be fixed because I won't be aware of it..

Share this post


Link to post
Share on other sites
1 hour ago, Jack_mcs said:

Did you make the database changes with the google_xml_sitemap_seo_install.php file? If so, it has a delete button. Did you not see that? I would think that button is more obvious than text in the install file. If the button is ignored then the text would be too, most likely.

Yes you got me 😝 but all works fine 😎

Share this post


Link to post
Share on other sites

Jack,

I have downloaded the latest version as in indicated in the LAST POST of the old thread (

)

but have run into another problem.  In the latest version, you added code for SECURE_IP to keep "just anyone" from being able to run the script manually. 

  if (! empty(GOOGLE_XML_SITEMAP_SECURE_IP)) {
     $safe_ips = explode(',', GOOGLE_XML_SITEMAP_SECURE_IP);
  
     if (! in_array($_SERVER['REMOTE_ADDR'], $safe_ips)) {
        header("location:http:127.0.0.1");
     }
  }

That new code throws a php error (that hebrew double colon error) since my site is on Godaddy and currently running php 5.4.  I have commented out that section of code and can now get it to run manually while I continue to work at getting my site moved to the latest OSC version on a new server running php 7.2.  However, it would be nice to have that 'protection' from anyone else executing the script until I get that completed.  Is there any OTHER way to provide that secure_ip check using the old 5.4 php?

Steve

Share this post


Link to post
Share on other sites
29 minutes ago, Steve80 said:

Is there any OTHER way to provide that secure_ip check using the old 5.4 php?

One of these should work:

if (defined('GOOGLE_XML_SITEMAP_SECURE_IP') && GOOGLE_XML_SITEMAP_SECURE_IP) {

or

if (strlen(GOOGLE_XML_SITEMAP_SECURE_IP) > 0 {

of 

if (GOOGLE_XML_SITEMAP_SECURE_IP == 'your IP') {

For the last one, enter your IP in place of your IP but leave the quotes.

Share this post


Link to post
Share on other sites

Thanks for the reply, Jack.  I have gotten it to work MANUALLY .. but only by COMMENTING OUT all that code about the secure_IP (in the index file).  I executed the 'install' for the update and it would APPEAR that the proper stuff got written to the db, but the additional options aren't showing up in Admin and I get instant errors with the 'secure_ip' code in there.  I still see the old options in Admin - just not the new ones (all about the IP options).  Did I miss something in the install process?  I got the followup page that gave me the DELETE or RESET options, but I didn't have enough info at the time to know which was appropriate, so I just went back to HOME.  I see the code in the install file that updated the db, but nothing that I recognize as 'enabling' them in the Configuration by Admin. I did check from phpMyAdmin that the new ( I think there are 4) items ARE there in the db .. immediately following the original options (I think there are 5).

Thoughts?

At least I can get the files created again by running it manually now. :-).

Steve

Share this post


Link to post
Share on other sites

@Steve80When you run the database script, click on the delete button and then install again. I think that will clean up the database. If not, you may need to do it manually. Be sure to delete all entries for it in the configuration_group and configuration tables.

Share this post


Link to post
Share on other sites

OK.. I hate to be DUMB.. but I AM that :-(.. So....

Using the DELETE option from the install file appears to have done NOTHING.  Running the install again also does nothing (new) as far as I can tell.

I WAS able to finally figure out that the original add-on installed GOOGLE XML SEO as _group = 289 in the configuration_group table and has the original options in the configuration table. The NEW version that I installed chose a different group_ID of 6502 - but that doesn't show in the configuration_group table.  I'm assuming THAT is the source of the problem.  Now.. just to be certain .. are you telling me to use phpMyAdmin to go into the Configuration table and DELETE all references to the options for the original version as well as all options for the new version.. then also go into the configuration_group table and also delete the entry for Google XML SEO .. and THEN run the install script file again and THAT should fix it all ??

Sorry.. just trying to make as certain as possible that I don't do something to HOSE my entire shop.

I'm assuming that after I delete all those items, I could go into my site Admin and see that the Google XML SEO option is GONE.. and then after REinstallation, it should come back .. and work correctly this time .. I hope.

Of course, while I'm having this issue, both FF And Chrome have decided that I don't have secure access to my phpMyAdmin so won't let me work on it.  Fortunately, MSIE still seems to work OK.  Something to do with TLS versions .. I guess GoDaddy is falling behind .. and so must MSIE.  Don't know how much longer MSIE is going to work.;

Steve

Edited by Steve80

Share this post


Link to post
Share on other sites

@Steve80Yes, you need to delete anything in the database that has to do with this addon in both tables. Once you do that, run the script again and you should be all set.

Share this post


Link to post
Share on other sites

Thanks, Jack.  Finally got it done.

Really appreciate your work with regards to things a lot of us don't know too much about 👍👏.

Steve

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×