Jump to content
Jack_mcs

Google XML Sitemap SEO

Recommended Posts

8 hours ago, Jack_mcs said:

That's two groups so you must have ran the script twice. In the database there is a table named configuration and configuration_groups. If you look in the latter, you will see two entries for the addon. Note the group ID for one of them and then delete it. The click into the configuration table and run this command, where XX is the id you copied. You should then only have one entry in your admin.


delete from configuration where configuration_group_id = XX

 

Thanks, appreciate it. And am I correct that if it isn't permitted by my host to have safe mode disabled, I will be unable to get this addon to function properly?

Share this post


Link to post
Share on other sites

I don't recall this addon needing safe mode to be off though I suppose it is possible.

Share this post


Link to post
Share on other sites
On 5/24/2009 at 2:55 PM, Jack_mcs said:

You will need to ask your host to turn safe mode off. Some will - some won't.

 

Jack

I guess I misunderstood this part a few pages ago in this thread......

Share this post


Link to post
Share on other sites

A lot has changed in the 8 years since that post. For one thing, safe mode has been removed as an option from php starting with version 5.4. So if your host is still using it, it means they are using a very old version of php and that will cause you more problems than what it does with this addon.

Some hosts are confused about the purpose of safe mode and think it offers more security. That was not its purpose and having it enabled does not increase security. I think you will have more problems than with just this addon with it enabled so if your host won't turn it off, I suggest looking for a new host. But, more importantly, you should look into getting your shop to run with a later version of php..

Share this post


Link to post
Share on other sites
6 hours ago, Jack_mcs said:

A lot has changed in the 8 years since that post.

Thanks, yeah, that's been an ongoing problem for me. What still applies? What's different? Some 2.2 stuff is compatible with 2.3.4bs, some not. Any questions tend to result in replies like, "There's a support thread, just RTFT." OK, but unless a new thread is started for 2.3.4bs, this is a 67 page thread, and silly people like me get twisted in circles not knowing what, if anything, in this thread (or any other) is outdated or still information worth following.

Thanks for clearing this part up for me, though, I appreciate it.......

Share this post


Link to post
Share on other sites

Please keep in mind that the people that answers questions in these forums are just regular people providing help as they can. There are many different versions of oscommerce. If a support thread was started for each one, it would cause the same questions to be asked many times, thus increasing the workload of the people trying to help. And many shop owners don't know what version they use so they might post in the wrong thread anyway.

All you can do is ask in the support thread if the addon will work in your version. Sometimes the instructions that come with an addon will state what version it is for, but most times it doesn't.  But even then, it doesn't mean that an addon will work in your shop if it needs something that safe mode, or some other setting, disables.

Share this post


Link to post
Share on other sites

OK, I have completely removed everything related to this addon, re-installed it to the T (uploaded all new stuff in catalog folder where my shop is located), run the SQL thing, set permissions on the 8 sitemap files to 0755, which is the same as my images folder, changed nothing in admin, just left default stuff, and when I go to http://MY-DOMAIN.com/catalog/googlesitemap/index.php

the page is just blank. So I go to admin and enable diagnostic output. I have read the install instructions, and I can't see where I'm supposed to even find where these errors should be located. Instructions just say:

If the sitemaps fail to generate, enable the diagnostic option in the settings and
   try again. If the error isn't obvious at that point, post the problem, along with
   the diagnostic output in the support thread.

I'm sure this is obvious to someone, but not me. Last time I spent an hour or so trying to read this entire thread and acting on the help given, you said I was reading old stuff that doesn't apply to 2.3.4bs. Can you at least tell me what page of this 67 page thread starts applying to what's going on now? I keep thinking I have downloaded the wrong thing that is missing any actual instructions, but every time I look, the only thing I can find to download is version 1.11, which seems like a complete package.

Anyway, if anyone knows what I'm missing, I'd appreciate it.

Share this post


Link to post
Share on other sites

Hello @brian_cee

I am just trying to configure this addon as well.

After you enable the diagnostic element and try to run the contribution, any errors are found in your catalog/error_log.

HTH Shaun

Share this post


Link to post
Share on other sites
38 minutes ago, RAC said:

Hello @brian_cee

I am just trying to configure this addon as well.

After you enable the diagnostic element and try to run the contribution, any errors are found in your catalog/error_log.

HTH Shaun

Hey, thanks for replying. I gave up on this addon. 67 page "support" thread and people still can't seem to  make it work. I just used a third party sitemap generator that updates it to Google, etc.  and got on with my project, no more fiddling and messing with buggy junk.

Share this post


Link to post
Share on other sites

Hello

Although I agree 67 pages of support is overwhelming,  but “buggy junk”!!!

This is totally unfair, Many thousands of Oscommerce users, like me, rely on people such as @Jack_mcs, and without them there would be no Osc.

Share this post


Link to post
Share on other sites

byronio18 Do you understand that you need to put in, at least, a little effort when there is a problem? Where's the diagnostic output from your site, or even mention of what the problem is? Since you only have one post, I assume it was done just to complain and there really wasn't a problem in the first place.

Share this post


Link to post
Share on other sites

Hi

I  can not seem to get this to work, (however I am blaming the flue that I am suffering with).

When attempting to call googlesitemap/index.php

The error log shows :

[20-Mar-2018 13:57:08 Europe/London] PHP Notice:  Use of undefined constant DIR_WS_HTTP_CATALOG - assumed 'DIR_WS_HTTP_CATALOG' in /home/****/public_html/*****/googlesitemap/index.php on line 33
[20-Mar-2018 13:57:08 Europe/London] PHP Notice:  Use of undefined constant DIR_WS_INCLUDES - assumed 'DIR_WS_INCLUDES' in /home/*****/public_html/*****/googlesitemap/index.php on line 36
[20-Mar-2018 13:57:08 Europe/London] PHP Warning:  require_once(DIR_WS_INCLUDESfilenames.php): failed to open stream: No such file or directory in /home/*****/public_html/*****/googlesitemap/index.php on line 36
[20-Mar-2018 13:57:08 Europe/London] PHP Fatal error:  require_once(): Failed opening required 'DIR_WS_INCLUDESfilenames.php' (include_path='.:/opt/alt/php55/usr/share/pear:/opt/alt/php55/usr/share/php') in /home/*****/public_html/*****/googlesitemap/index.php on line 36

Any kick in the right direction could help.

Regards Shaun

 

Share this post


Link to post
Share on other sites

RAC  - Please be sure you are using the latest version of this addon. The defined file names were removed in V 1.11 but the error you are having says they are still there.

Share this post


Link to post
Share on other sites

Hi

 

Thank you for your replies.

 

@Dan ColeI already have the compatibility module installed, I am sorry though you will need to explain, (in SIMPLE terms) what you mean by “change those constants to the actual file names”.

 

@Jack_mcs I have checked, and it seems that I have been using the latest version!

 

I uploaded the files in the package, I set the permission of googlesitemap to 0775, the same as my images folder, do the files inside the googlesitemap need to be changed to 0755? Currently they are 0644.

 

I have opted for the manual run, (as I still need to get my head around cron jobs), I uploaded the code, however there was no final ?> on that file, so I just put it at the end after the LINUXUK HTTP Errors and IP TRAP.

 

When I call mydomain/shop/googlesitemap/index.php I get

This page isn’t working

www.retro-antiques-curios.co.uk is currently unable to handle this request.

HTTP ERROR 500

 

When I call mydomain/shop/sitemapindex.xml I get

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@retro-antiques-curios.co.uk and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

 

Please, respond in simple step by step, (with diagrams if needed, lol).

Your huge techie brains are different to ours.

Regards Shaun

 

Share this post


Link to post
Share on other sites

Oh and in my Admin the settings are

Google XML SEO pixel_trans.gif
Title Value Action 
Enable Images Map true icon_arrow_right.gif 
Enable Manufacturers Map false Info 
Enable Specials Map false Info 
Enable Standard Pages Map true Info 
Enable Article Manager Topics Map false Info 
Enable Diagnostic Output true Info 
Exclude these pages advanced_search_result.php,advanced_search.php,password_reset.php Info 
Manual Run 7 Info 
Manual IP .0.0.1 Info 
Mobile URL   Info 
Secure IP .0.0.1 Info
Edited by RAC
security

Share this post


Link to post
Share on other sites
5 hours ago, RAC said:

what you mean by “change those constants to the actual file names”.

If you are now using the latest version (in which Jack has already done this) this will no longer be an issue. 

Dan

Share this post


Link to post
Share on other sites
6 hours ago, RAC said:

I have checked, and it seems that I have been using the latest version!

If you are still getting the errors you mentioned previously, please post lines 20 through 40 from the googlesitemap/index.php .

Also, what php version are you using? See admin->Tools->Server info to find out.

Share this post


Link to post
Share on other sites

 

OK thank you for your clarification Dan.

 

Jack, thank you for your nice simple instructions, my php version is      5.5.38 (Zend: 2.5.0)

 

 

      Line 20-40

<td colspan="2" class="header-menu"> [ <a href="classtrees_Google-XML-Sitemap-Feed.html" class="menu">class tree: Google-XML-Sitemap-Feed</a> ] [ <a href="elementindex_Google-XML-Sitemap-Feed.html" class="menu">index: Google-XML-Sitemap-Feed</a> ] [ <a href="elementindex.html" class="menu">all elements</a> ] </td>
    </tr>
    <tr>
        <td colspan="2" class="header-line"><img src="media/empty.png" width="1" height="1" border="0" alt=""  /></td>
    </tr>
</table>
<table width="100%" border="0" cellpadding="0" cellspacing="0">
    <tr valign="top">
        <td width="195" class="menu"><div class="package-title">Google-XML-Sitemap-Feed</div>
            <b>Packages:</b><br />
            <div class="package"> <a href="li_Google-XML-Sitemap-Feed.html">Google-XML-Sitemap-Feed</a><br />
            </div>
            <br />
            <b>Files:</b><br />
            <div class="package"> <span style="padding-left: 1em;"><a href="Google-XML-Sitemap-Feed/_googlesitemap_index_php.html">index.php</a></span><br />
                <span style="padding-left: 1em;"><a href="Google-XML-Sitemap-Feed/_googlesitemap_sitemap_class_php.html">sitemap.class.php</a></span><br />
            </div>
            <br />
            <b>Classes:</b><br />
            <div class="package"> <a href="Google-XML-Sitemap-Feed/GoogleSitemap.html">GoogleSitemap</a> <br />
                <a href="Google-XML-Sitemap-Feed/MySQL_DataBase.html"

 

Regards Shaun

 

 

Share this post


Link to post
Share on other sites

The code you posted is from the googlesitemap/index.html file. I need the code from the googlesitemap/index.php file.

Share this post


Link to post
Share on other sites

My sincere apologies Jack.

if ($categories_products['total'] > 0) {
      $category_depth = 'products'; // display products
    } else {
      $category_parent_query = tep_db_query("select count(*) as total from " . TABLE_CATEGORIES . " where parent_id = '" . (int)$current_category_id . "'");
      $category_parent = tep_db_fetch_array($category_parent_query);
      if ($category_parent['total'] > 0) {
        $category_depth = 'nested'; // navigate through the categories
      } else {
        $category_depth = 'products'; // category has no products, but display the 'no products' message
      }
    }
  }

  require('includes/languages/' . $language . '/index.php');

  require('includes/template_top.php');

  if ($category_depth == 'nested') {
    $category_query = tep_db_query("select cd.categories_name, c.categories_image, cd.categories_description from " . TABLE_CATEGORIES . " c, " . TABLE_CATEGORIES_DESCRIPTION . " cd where c.categories_id = '" . (int)$current_category_id . "' and cd.categories_id = '" . (int)$current_category_id . "' and cd.language_id = '" . (int)$languages_id . "'");
    $category = tep_db_fetch_array($category_query);
?>
 

Share this post


Link to post
Share on other sites

Are you still getting the errors you mentioned previously? Like the one below. That is failing because it is looking for a file named filenames.php but that is not shown in the code you posted.

[20-Mar-2018 13:57:08 Europe/London] PHP Warning:  require_once(DIR_WS_INCLUDESfilenames.php): failed to open stream: No such file or directory in /home/*****/public_html/*****/googlesitemap/index.php on line 36

If you are no longer getting the errors, let's start over. Go to the settings for this addon and enable the diagnostic setting. Then run the script by going to http:// your site /googlesitemap/index.php and post what is displayed on the page here.

Share this post


Link to post
Share on other sites

OK, I have just reinstalled all the files and called the googlesitemap/index.php and it now seems to work.

I get the message.

If you have not already submitted the sitemap index to Google or Bing click the link(s) below.
Before doing that, please be sure to view the XML files to make sure the data is correct.

These XML files are quite large 2-35kb what correct data am I looking for?

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×