Jump to content
Latest News: (loading..)
Jack_mcs

Google XML Sitemap SEO

Recommended Posts

Last I checked this addon is not compatible with SEO 5 so if you are using that addon, that is probably the reason.

Share this post


Link to post
Share on other sites

Hi Jack. Thanks for the quick reply!

I just upgraded my store to :

Ultimate SEO 2-2.2d-15

The Sitemap now has the the SEO URL's in it. I just need to fix some issues with .htaccess and I should be good. I was using 2.1 and I belive that was the issue.

I will post back here when i have everything working.

Share this post


Link to post
Share on other sites

Hi Jack

 

I know there has been an answer posted somewhere for my prob, I can't for the  life of me find it. When I type www.XXXXXXX.co.nz/sitemapindex.xml in  the browser the following is what I get. Apparently the installation was correctly completed.  Here's the disagnostics

Not sure how to correct.

Appreciate any comments.

Many thanks

Grandpa

 

Opening   /home/xxxxx/public_html/sitemapproducts.xml

FS_CAT    /home/xxxxx/public_html/

Server    https://www.xxxxxxxx.co.nz

Save Path /home/xxxxx/public_html/

WS_CAT    /

Write /home/xxxxxx/public_html/sitemapproducts.xml
Generated Google Product Sitemap Successfully

Opening   /home/xxxxx/public_html/sitemapcategories.xml

FS_CAT    /home/xxxxxx/public_html/

Server    https://www.xxxxxxx.co.nz

Save Path /home/xxxxxxx/public_html/

WS_CAT    /

Write /home/xxxxxx/public_html/sitemapcategories.xml
Generated Google Category Sitemap Successfully

Opening   /home/xxxxxxx/public_html/sitemapmanufacturers.xml

FS_CAT    /home/xxxxxxxx/public_html/

Server    https://www.xxxxxx.co.nz

Save Path /home/xxxxxxx/public_html/

WS_CAT    /

Write /home/xxxxxx/public_html/sitemapmanufacturers.xml
Generated Google Manufacturers Sitemap Successfully

Opening   /home/xxxxxxx/public_html/sitemappages.xml

FS_CAT    /home/xxxxxx/public_html/

Server    https://www.grandpas.co.nz

Save Path /home/xxxxxxx/public_html/

WS_CAT    /

Write /home/xxxxxxx/public_html/sitemappages.xml
Generated Google Pages Sitemap Successfully

Opening   /home/xxxxxx/public_html/sitemapspecials.xml

FS_CAT    /home/xxxxxx/public_html/

Server    https://www.grandpas.co.nz

Save Path /home/xxxxxxx/public_html/

WS_CAT    /

Write /home/xxxxxx/public_html/sitemapspecials.xml
Generated Google Specials Sitemap Successfully

Opening   /home/xxxxxx/public_html/sitemapindex.xml

FS_CAT    /home/xxxxxxx/public_html/

Server    https://www.xxxxxxxx.co.nz

Save Path /home/xxxxxxx/public_html/

WS_CAT    /

Write /home/xxxxxxxx/public_html/sitemapindex.xml
Generated Google Sitemap Index Successfully

The following is what is produced

Google Sitemap https://www.XXXXXXX.co.nz/sitemapindex.xml

Number of sitemaps in this Google sitemap index: 0

Click on the table headers to change sorting.

Sitemap URL Last modification date

Share this post


Link to post
Share on other sites

It's because the script used to display the sitemap no longer works with this addon because it uses the google sitemap rules and this addon no longer does. But the map information is there. You can view the source of the page to see it. Since the search engines only use the source and the sitemap pages are not viewed by visitors this is not anything to be concerned about.

Share this post


Link to post
Share on other sites

i just updated to the BS friendly version and i get this when running the script (with diagnostic output off:

 

 
ERROR: Google Pages Sitemap Generation FAILED!

Array
(
    [QUERY] => Array
        (
            [PRODUCTS] => Array
                (
                    [STATUS] => success
                    [NUM_ROWS] => 156
                )

            [CATEOGRY] => Array
                (
                    [STATUS] => success
                    [NUM_ROWS] => 19
                )

        )

    [SAVE_FILE_XML] => Array
        (
            [0] => Array
                (
                    [file] => /var/www/xxxxxxxxxxxxxxxxx/test/sitemapproducts.xml
                    [status] => success
                    [file_exists] => true
                )

            [1] => Array
                (
                    [file] => /var/www/xxxxxxxxxxxxxxxxx/test/sitemapcategories.xml
                    [status] => success
                    [file_exists] => true
                )

            [2] => Array
                (
                    [file] => /var/www/xxxxxxxxxxxxxxxxx/test/sitemapindex.xml
                    [status] => success
                    [file_exists] => true
                )

        )

)
ERROR: Google Pages Sitemap Generation FAILED!

Array
(
    [QUERY] => Array
        (
            [PRODUCTS] => Array
                (
                    [STATUS] => success
                    [NUM_ROWS] => 156
                )

            [CATEOGRY] => Array
                (
                    [STATUS] => success
                    [NUM_ROWS] => 19
                )

        )

    [SAVE_FILE_XML] => Array
        (
            [0] => Array
                (
                    [file] => /var/www/xxxxxxxxxxxxxxxxx/test/sitemap_mobileproducts.xml
                    [status] => success
                    [file_exists] => true
                )

            [1] => Array
                (
                    [file] => /var/www/xxxxxxxxxxxxxxxxx/test/sitemap_mobilecategories.xml
                    [status] => success
                    [file_exists] => true
                )

            [2] => Array
                (
                    [file] => /var/www/xxxxxxxxxxxxxxxxx/test/sitemap_mobileindex.xml
                    [status] => success
                    [file_exists] => true
                )

        )

)
Completed!

with diag on i get

Opening   /var/www/xn--pizzalg-v1a.dk/test/sitemapproducts.xml

FS_CAT    /var/www/xxxxxxxxxxxxxxxxx/test/

Server    http://test.xxxxxxxxxxxxxxxxx

Save Path /var/www/xxxxxxxxxxxxxxxxx/test/

WS_CAT    /

Write /var/www/xxxxxxxxxxxxxxxxx/test/sitemapproducts.xml
Generated Google Product Sitemap Successfully

Opening   /var/www/xxxxxxxxxxxxxxxxx/test/sitemapcategories.xml

FS_CAT    /var/www/xxxxxxxxxxxxxxxxx/test/

Server    http://test.xxxxxxxxxxxxxxxxx

Save Path /var/www/xxxxxxxxxxxxxxxxx/test/

WS_CAT    /

Write /var/www/xxxxxxxxxxxxxxxxx/test/sitemapcategories.xml
Generated Google Category Sitemap Successfully

ERROR: Google Pages Sitemap Generation FAILED!

Opening   /var/www/xxxxxxxxxxxxxxxxx/test/sitemapindex.xml

FS_CAT    /var/www/xxxxxxxxxxxxxxxxx/test/

Server    http://test.xxxxxxxxxxxxxxxxx

Save Path /var/www/xxxxxxxxxxxxxxxxx/test/

WS_CAT    /

Write /var/www/xxxxxxxxxxxxxxxxx/test/sitemapindex.xml
Generated Google Sitemap Index Successfully

Array
(
    [QUERY] => Array
        (
            [PRODUCTS] => Array
                (
                    [STATUS] => success
                    [NUM_ROWS] => 156
                )

            [CATEOGRY] => Array
                (
                    [STATUS] => success
                    [NUM_ROWS] => 19
                )

        )

    [SAVE_FILE_XML] => Array
        (
            [0] => Array
                (
                    [file] => /var/www/xxxxxxxxxxxxxxxxx/test/sitemapproducts.xml
                    [status] => success
                    [file_exists] => true
                )

            [1] => Array
                (
                    [file] => /var/www/xxxxxxxxxxxxxxxxx/test/sitemapcategories.xml
                    [status] => success
                    [file_exists] => true
                )

            [2] => Array
                (
                    [file] => /var/www/xxxxxxxxxxxxxxxxx/test/sitemapindex.xml
                    [status] => success
                    [file_exists] => true
                )

        )

)
Opening   /var/www/xxxxxxxxxxxxxxxxx/test/sitemap_mobileproducts.xml

FS_CAT    /var/www/xxxxxxxxxxxxxxxxx/test/

Server    http://test.xxxxxxxxxxxxxxxxx

Save Path /var/www/xxxxxxxxxxxxxxxxx/test/

WS_CAT    /

Write /var/www/xxxxxxxxxxxxxxxxx/test/sitemap_mobileproducts.xml
Generated Google Product Sitemap Successfully

Opening   /var/www/xxxxxxxxxxxxxxxxx/test/sitemap_mobilecategories.xml

FS_CAT    /var/www/xxxxxxxxxxxxxxxxx/test/

Server    http://test.xxxxxxxxxxxxxxxxx

Save Path /var/www/xxxxxxxxxxxxxxxxx/test/

WS_CAT    /

Write /var/www/xxxxxxxxxxxxxxxxx/test/sitemap_mobilecategories.xml
Generated Google Category Sitemap Successfully

ERROR: Google Pages Sitemap Generation FAILED!

Opening   /var/www/xxxxxxxxxxxxxxxxx/test/sitemap_mobileindex.xml

FS_CAT    /var/www/xxxxxxxxxxxxxxxxx/test/

Server    http://test.xxxxxxxxxxxxxxxxx

Save Path /var/www/xxxxxxxxxxxxxxxxx/test/

WS_CAT    /

Write /var/www/xxxxxxxxxxxxxxxxx/test/sitemap_mobileindex.xml
Generated Google Sitemap Index Successfully

Array
(
    [QUERY] => Array
        (
            [PRODUCTS] => Array
                (
                    [STATUS] => success
                    [NUM_ROWS] => 156
                )

            [CATEOGRY] => Array
                (
                    [STATUS] => success
                    [NUM_ROWS] => 19
                )

        )

    [SAVE_FILE_XML] => Array
        (
            [0] => Array
                (
                    [file] => /var/www/xxxxxxxxxxxxxxxxx/test/sitemap_mobileproducts.xml
                    [status] => success
                    [file_exists] => true
                )

            [1] => Array
                (
                    [file] => /var/www/xxxxxxxxxxxxxxxxx/test/sitemap_mobilecategories.xml
                    [status] => success
                    [file_exists] => true
                )

            [2] => Array
                (
                    [file] => /var/www/xxxxxxxxxxxxxxxxx/test/sitemap_mobileindex.xml
                    [status] => success
                    [file_exists] => true
                )

        )

)
Completed!

any pointers are welcome

my hoster has forced php7 on me so i have no choice here, could that be it?


Quo plus habent, eo plus cupiunt

Share this post


Link to post
Share on other sites

It's failing on creating the pages map file. Be sure the sitemappages.xml file exists on the server and you may have to change its permissions to 755. I neither of those fix it, then it is probably one of the pages causing a problem. But there's no way for me to troubleshoot that in a support thread. You can turn the pages option off to get around it. But if you want that option, you will have to figure out the file it is failing on.

Share this post


Link to post
Share on other sites

all the files in root are present and set to 755

but it still fails on sitemappages.xml 

i guess that it has been tested with php7 and that is not the issue

are there ways you can help without it costing me an arm and leg?


Quo plus habent, eo plus cupiunt

Share this post


Link to post
Share on other sites

i have tested my php7 idea

on a php7 server i get a 500 error but if on a test server with php5 same config and same files it runs

so maybe there is something about it?

 

EDIT: i also have to disable creation of standard pages. to make it run 

Edited by boelle

Quo plus habent, eo plus cupiunt

Share this post


Link to post
Share on other sites

There's nothing unique about the code to create a pages map, that I can think of, that would cause a failure under php 7. Most of the code used to create the maps is shared so if the others are all working, it seems to me it has to be something to do with the pages themselves.

Share this post


Link to post
Share on other sites

Same 500 error on php 7.1 here...

/googlesitemap/index.php gives a deprecated code for:

function tep_session_is_registered($var){
return false;
}# end function

Share this post


Link to post
Share on other sites

Is it only failing on the pages file like boelle mentioned? Try removing the code you mentioned. I can't find it with a quick search of the files so it may not be necessary. There are other functions that follow it they may also cause problems. But I can't see anything wrong with that code. The $var variable isn't used so 7.1 might complain about that but I wouldn't think it would fail.

Share this post


Link to post
Share on other sites

Hai Jack,

Thank you for your quick respons.

1. I changed the files boelle mentioned to 755. Unfortunately no change.

2. I uncommented :

function tep_session_is_registered($var){
return false;
}# end function

Unfortunately no change.

3. ran de /googlesitemaps/index.php verbose with curl:

php 5.6  --> succes

Quote

> GET /googlesitemap/index.php HTTP/1.1
> User-Agent: curl/7.21.4 (universal-apple-darwin11.0) libcurl/7.21.4 OpenSSL/0.9.8z zlib/1.2.5
> Host: www.yoursite.com
> Accept: */*
>
< HTTP/1.1 200 OK
< Date: Sat, 02 Dec 2017 17:14:35 GMT
< Server: Apache/2
< X-Powered-By: PHP/5.6.32
< Upgrade: h2,h2c
< Connection: Upgrade
< Cache-Control: max-age=172800
< Expires: Mon, 04 Dec 2017 17:14:35 GMT
< Vary: Accept-Encoding,User-Agent
< Transfer-Encoding: chunked
< Content-Type: text/html; charset=UTF-8
<
<pre>CONGRATULATIONS! All files generated successfully.

 

php 7.0 ---> 500 error

Quote

> GET /googlesitemap/index.php HTTP/1.1
> User-Agent: curl/7.21.4 (universal-apple-darwin11.0) libcurl/7.21.4 OpenSSL/0.9.8z zlib/1.2.5
> Host: www.yoursite.com
> Accept: */*
>
< HTTP/1.1 500 Internal Server Error
< Date: Sat, 02 Dec 2017 17:12:11 GMT
< Server: Apache/2
< X-Powered-By: PHP/7.1.11
< Upgrade: h2,h2c
< Connection: Upgrade, close
< Vary: User-Agent
< Content-Length: 0
< Content-Type: text/html; charset=UTF-8
<
* Closing connection #0

 

4. I checked the googlesitemap/index.php here: https://phpcodechecker.com/

Rusult:

 

Not sure off course if this reported error is related to the 500 error...

 

I hope this helps?

Share this post


Link to post
Share on other sites

Deprecated warnings shouldn't cause a failure. But, more importantly, if you see those warnings it means your code may not be able to run on php V 7. Are you sure it will? If uncommenting the function you mentioned didn't make a change, it means the shops function is what is causing the problem. And the last function you mentioned is also a shop function. So it looks like your version of oscommerce is not ready to run on php 7. I'm not saying there isn't a problem with this addon when ran with 7 but, in this case, the code in it doesn't look to be the cause of the failures. 

Share this post


Link to post
Share on other sites

Thank you Jack, for pointing that out... I ll look at the shop functions for php 7.1 problems, (thought i catched them all, must be missing one...)

 

Share this post


Link to post
Share on other sites

This addon is only fully compatible with the Ultimate SEO rewriter. You will either need to switch rewriters or turn off the one you are using if you want to use this one. If you are using the SEO 5 rewriter, there was a change for it posted here not too long ago. I don't know if it works but you may want to try it.

With that said, as long as you have a canonical meta tag for the pages, the additional url's shouldn't cause any problems.

Share this post


Link to post
Share on other sites

A new version has been uploaded with these changes:

- Changed email links based on if the script was created via cron or not.
- Removed the styling code since it no longer works and can cause failures.

 

Share this post


Link to post
Share on other sites

Hey Jack, do you know if it possible to run this on localhost ?

I'm testing my new store locally using WAMP.  Howver, when I try to run this manually, I get a 500 error.

Share this post


Link to post
Share on other sites

Yes, that is how I test changes. Someone reported problems with php 7 and I haven't had time to check that. So if you are running that version, that may be the problem. Otherwise, as long as the shop works as it should, I can't think of any reason it would fail.

Share this post


Link to post
Share on other sites
32 minutes ago, Jack_mcs said:

Yes, that is how I test changes. Someone reported problems with php 7 and I haven't had time to check that. So if you are running that version, that may be the problem. Otherwise, as long as the shop works as it should, I can't think of any reason it would fail.

Ha, yes, I'm running PHP 7.  Guess that is why!

Share this post


Link to post
Share on other sites

Hello everyone,
I have the following problem with generating the links in my XML files.
The software I use is oscommerse 2.3.4, Seo Urls 5, Google Xml Sitemap SEO v-1-12
All files are generated without problem, but the links inside are not good
for example:
https://mysite.net/
product_info.php?products_id=462
but they should be:
https://mysite.net/acqua-parma-peonia-nobile-edp-jeni-50ml-p-12292.html
Google Webmaster did not like them and therefore does not want to index my files.
Someone with same problem?

Share this post


Link to post
Share on other sites

The two addons are not compatible. There was a post not too long ago about a possible code change for this but I've no idea if it works or not. Your choices are to turn off the url rewriter, switch to the Ultimate SEO rewriter or change the code so the two will work together. This addon is far more important from an SEO perspective than url-rewriting so you should do what is needed to get it to work.

Share this post


Link to post
Share on other sites

Looks like I must have run the sql twice, or maybe had an older version still in the database from when I upgraded everything from 2.2 to 2.3.4bs, because I have Google XML SEO listed twice in my catalog admin's configuration section. How can I delete one of them from the db? I think I did other stuff wrong as well, as I can't get the sitemap's index.php to even show up, I get a 404 not found error page.......I think I'll uninstall everything and start over........Any help on uninstalling from the db appreciated in advance, if anyone can help....

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×