Latest News: (loading..)
Jack_mcs

Google XML Sitemap SEO

1,619 posts in this topic

@@Eim2 When the sitemap script is ran on your site, it shows failures when trying to save the files. So, as mentioned, you don't have the permissions set correctly or there is something else preventing that.

Share this post


Link to post
Share on other sites

Posted (edited)

This post fixed it for me: http://forums.oscommerce.com/topic/330175-google-xml-sitemap-seo/page-79#entry1753634  #1577

 

This is exactly what I have done. I also renamed and uploaded the file to the same location and got the same result.

Google Sitemap http://shop.domain.com/sitemaptest.xml Number of sitemaps in this Google sitemap index: 0

Click on the table headers to change sorting.

Edited by dsolutions

Share this post


Link to post
Share on other sites

@@Jack_mcs

 

Sorry, sure the sitemap files, while I was absent, were chmoded to prevent them from being modified meantime.

I can send the creation debug output, but except for the parent categories in sitemapcategories.xml without special caracters,

all files are created fine, just they cant be read from a browser.

 

I will try above comment by dsolutions in catalog/googlesitemap/index.php with:

$domainArray[] = HTTPS_SERVER . DIR_WS_HTTP_CATALOG;

 

as my shop is all https.

 

Would be fine if that would be the only needed change.

Share this post


Link to post
Share on other sites

I was able to reproduce this. The sitemap files show empty in the browser because the file used to list the links is not compatible with sitemaps.org. I haven't had time to look at the cause but it is a non-issue. If you view the source of the files, you should see the links and that is what the search engines use. The code to display the links on the site was added in an early version to make them human readable. But since the maps are not linked to on the site, customers don't know they exist and won't be looking at them.

 

Check your search console to make sure the maps are working correctly as far as google is concerned. If they are, then you can ignore this.

Share this post


Link to post
Share on other sites

@@Jack_mcs

 

You say it, a non issue. No problems at all as indeed Google sees the files without errors

and with a little tweaking through unix sed the missing special characters are added easily in no time.

 

Thanks a lot

Share this post


Link to post
Share on other sites

IMPORTANT: If your shop is using the mobile addon, you can't use V 1.11 because the lack of the use of defined filenames will cause the urls for the mobile sitemaps to be incorrect. Use V 1.1.0 instead.

Share this post


Link to post
Share on other sites

Hi,

 

I'm at a los...

 

I have the shop end SSL - the admin end not.

 

I have Ultimate SEO V 2.2 - 14 installed for the search friendly urls.

 

But the links in the XML Sitemap are http:// and old id paths.

 

??

 

Greetings, Anne

Share this post


Link to post
Share on other sites

@@Dj-Viper It depends on a number of things. Are you using the latest version of Ultimate SEO and this addon? If so, have you tried backing up your version as I mentioned above? What version of oscommerce are you using? What php version?

Share this post


Link to post
Share on other sites

Hi,

 

XML 1.11

2.2 - 14 of the ultimate, version 16 is for edge i have gold.

2.3.4 gold

 

Have no mobile addon.

 

Php 5.3 active.

 

Greetings , Anne

Share this post


Link to post
Share on other sites

I don't see a version 16 for Ultimate SEO - maybe that was a typo. But I suggest you install V15. There's nothing in it to cause it to fail with the Gold version. But all that is needed to upgrade it is to replace the includes/classes/seo.class.php file. If the upgrade causes a failure, just replace that file with the original. Or, you could use V10 of this addon.

Share this post


Link to post
Share on other sites

I don't see a version 16 for Ultimate SEO - maybe that was a typo. But I suggest you install V15. There's nothing in it to cause it to fail with the Gold version. But all that is needed to upgrade it is to replace the includes/classes/seo.class.php file. If the upgrade causes a failure, just replace that file with the original. Or, you could use V10 of this addon.

 

Did mean 15 but dit the upgrade from that only the seo.class file and it worked. 

 

Greetings, Anne

Share this post


Link to post
Share on other sites

Got the latest version installed on a 2.3.4 shop and was wondering how do I update the xml files on my database manually?

The older version for 2.2 had a section in the admin to manually update the various files.

Share this post


Link to post
Share on other sites

Nothing has changed in that regard. If it is a new install, you have to make the changes to the tools file. Sounds like you missed that step.

Share this post


Link to post
Share on other sites

Hi,

I receive a mail from cron job every day saying CONGRATULATIONS! All files generated successfully ...

should I click the link to submit the sitemap every time i receive this email ?

thanks

Share this post


Link to post
Share on other sites

No, that isn't necessary. Once the search engines are aware of the maps they will look at them automatically. Just be sure you have added them to your google and Bing webmaster accounts. But if you want to click on the links, it won't hurt anything.

Psytanium likes this

Share this post


Link to post
Share on other sites
On 4/27/2015 at 6:28 PM, phi148 said:

 

Jack

 

I have SEO URLS 5 by FWD Media installed.  Do you know how to modify this update (1.8) to have proper SEO URLS?

 

I added the above, and that got all my sitemaps created, yet all my links are not SEO URL formatted.

 

Any clues?

 

Thanks!!!

Bill

Anyone get Google XML Sitemap to work with SEO URLs 5? XML links are not SEO URL formatted.

Psytanium likes this

Share this post


Link to post
Share on other sites

In Google Webmaster Tools I have many duplicates

 e.g.

/product_info.php/targus-bag-tss588us-156-black-p-6437
/product_info.php?products_id=6437

is it because Google XML Sitemap is not compatible with SEO URLs 5  ??

Share this post


Link to post
Share on other sites

@Cary  @Psytanium

This is the contents of my SiteMapProducts.php sitemap (note the php extension, enter it exactly like that in Google Webmaster Tools).

I am using USU5 and it works perfectly.

<?php
  header('Content-type: application/xml');
 
  include ('includes/application_top.php');
 $products_query = tep_db_query("select products_id from products where products_status = '1' order by products_id DESC");
 
  $output = '<?xml version="1.0" encoding="UTF-8"?>' . "\n";
  $output .= '<urlset xmlns="http://www.sitemaps.org/schemas/sitemap/0.9">' . "\n";
  echo $output;
?>
<?php
  while ($products = tep_db_fetch_array($products_query)) {
    $str = $products['products_id'];
    $exclude_list = array(); // add any product ids you wish to exclude with a comma separating each i.e. 12,28,36
    if(!in_array($str, $exclude_list)) {
    ?>
<url>
  <loc><?php echo tep_href_link('product_info.php', 'products_id=' . (int)$products['products_id'], 'NONSSL', false); ?></loc>
</url>
<?php
    }
  }
 ?>
</urlset>

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now