Jump to content
Jack_mcs

Google XML Sitemap SEO

Recommended Posts

The warning are due to the level of error reporting your account is using. After 5.6, or so, php enabled STRICT mode by default and that reports things like you are seeing. They can be ignored.

 

I only see one entry for Manual IP in the shops I use this in here. If you are seeing two then something must have went wrong with the database update, though I can't imagine how that could happen.

Share this post


Link to post
Share on other sites

Hi,

 

With BS edge, there is no filename.php file.

 

Additionally, I have the ultimate SEO urls as updated by @@piernas installed.

 

Some feedback: it was not clear to me before downloading this add-on what the required installs are for it to work.

 

If you have any ideas about how to make it work the above considered I would be grateful.

 

Otherwise, is there an easy way to uninstall it, or do I need to manually remove all the database entries.

 

Peter

Edited by peterpil19

PROUDLY PASSIONATE PHOENIX SUPPORTER

Full-time I am a C-suite executive of a large retail company in Australia. In my spare time, I enjoying learning about web-design.

Download the latest version of CE Phoenix from gitHub here

Join the Phoenix Club. Become a Phoenix Supporter.  Gain access to special codes and modules and help the project thrive. Read here

 

Share this post


Link to post
Share on other sites

Figured out how to uninstall.

 

Again, grateful for my learning, what would need to change to make it work without filenames.php

 

Peter


PROUDLY PASSIONATE PHOENIX SUPPORTER

Full-time I am a C-suite executive of a large retail company in Australia. In my spare time, I enjoying learning about web-design.

Download the latest version of CE Phoenix from gitHub here

Join the Phoenix Club. Become a Phoenix Supporter.  Gain access to special codes and modules and help the project thrive. Read here

 

Share this post


Link to post
Share on other sites

Share this post


Link to post
Share on other sites

A new version has been uploaded with these changes:

 

  • Removed references for filenames and tables to make it compatibile with the BS version.
  • Moved the error reporting code up so strict warnings are not displayed.

Share this post


Link to post
Share on other sites

 

A new version has been uploaded with these changes:

 

  • Removed references for filenames and tables to make it compatibile with the BS version.
  • Moved the error reporting code up so strict warnings are not displayed.

 

 

Wow that was quick!

I never expected a response so quickly...


PROUDLY PASSIONATE PHOENIX SUPPORTER

Full-time I am a C-suite executive of a large retail company in Australia. In my spare time, I enjoying learning about web-design.

Download the latest version of CE Phoenix from gitHub here

Join the Phoenix Club. Become a Phoenix Supporter.  Gain access to special codes and modules and help the project thrive. Read here

 

Share this post


Link to post
Share on other sites

I updated my "Google XML Sitemap SEO" add-on from 1.6 to 1.11. When I go to generate the sitemaps, it says that all files generated successfully. When I download the separate XML files, the data seems to be correct too. However, when I view the map files in the browser, it's not showing any data and just says: "Google Sitemap http://domain.com/sitemapcategories.xml Number of sitemaps in this Google sitemap index: 0". Am I doing something wrong?

Share this post


Link to post
Share on other sites

@@Irin It sounds like the files are being stored in the wrong location. Please try enabling the diagnostic setting and see what that shows.

Share this post


Link to post
Share on other sites

The diagnostic doesn't show any errors. It seems that all the maps are generated successfully.

Opening   /home/.../public_html/.../sitemapproducts.xmlFS_CAT    /home/.../public_html/.../Server    http://domain.comSave Path /home/.../public_html/.../WS_CAT    /Write /home/.../public_html/.../sitemapproducts.xmlGenerated Google Product Sitemap Successfully

Share this post


Link to post
Share on other sites

Are the paths correct? In the example link you originally posted, the shop is located in the root directory. But the diagnostic is showing the files are being written to a sub-directory. For the root, this

 

Save Path /home/.../public_html/.../

 

should be

 

Save Path /home/.../public_html/

Share this post


Link to post
Share on other sites

All the map files are located in the same sub-directory as my shop, /home/.../public_html/.../. The add-on files are located in /home/.../public_html/.../googlesitemap/ sub-directory. I can see that the map files are updated every time I point my browser to http://domain/googlesitemap/index.php, and they have data written into them. Also, when I download the separate XML files and open them directly from my computer, the data seems to be correct.

Share this post


Link to post
Share on other sites

Your use of public_html/.../ is confusing me. That indicates there is something after public_html but you say there isn't. Assuming there isn't, I think the problem is caused by an incorrectly setup includes/configure.php file. It's been a while since I've seen this problem but, as I recall that is what caused it. Take a look at that file and find the DIR_FS_CATALOG line and change it to look like this and see if that fixes it.

  define('DIR_FS_CATALOG', '/home/YOUR USER NAME/public_html/');

Share this post


Link to post
Share on other sites

Yes, the shop is installed in the sub-directory called shop, so the path is /home/name/public_html/shop/. The map files are located in the same sub-directory, /home/name/public_html/shop/. I can't change the catalog path, because it will not be able find my shop. It's not a new installation, it's been working with these settings for many years. The previous version was also working ok.

Share this post


Link to post
Share on other sites

You say you can view the contents of the files if you download them but not if you use a browser. Are you absolutely sure the files you are downloading are the same ones you are viewing? Try changing the name of one of the files you download to something else, like sitemapproducts.xml to sitemaptest.xml, and upload that to the same location you downloaded it from. Then view that file in a browser. If it doesn't display its contents then there is something wrong with your browser. If you can't find it, then you are looking at two different locations.

Share this post


Link to post
Share on other sites

I uploaded the xml files into the same sub-directory as the add-on, /googlesitemap/ and called the map from the browser, and I can see the contents in the text format, there is no header to it. Now, I need to find where in the index.php to change the location of the generated xmls.

Edited by Irin

Share this post


Link to post
Share on other sites

We seem to be going in circle. :/ This is how the addon works:

 

- Place the addon files as they are in the package. So there are sitemap files in the shops root directory, named shop in your case, and a new directory named googlesitemap.

 

- Run the script by going to ...com/googlesitemap/index.php

 

- The sitemap files in the root should get updated.

 

I suggested downloading the files, presumably from the shops root directory if the addon is working correctly. Then rename one and upload it to the same location. You uploaded it to the googlesitemap directory for some reason. That won't work properly and changing the code to make it work is a mistake since the maps may not be visible to the search engines, depending upon your server settings.

Share this post


Link to post
Share on other sites

This is exactly what I have done. I also renamed and uploaded the file to the same location and got the same result.

Google Sitemap http://shop.domain.com/sitemaptest.xml Number of sitemaps in this Google sitemap index: 0

Click on the table headers to change sorting.

Share this post


Link to post
Share on other sites

Well, if you have looked at the file on your computer and it is fine and then uploaded it and looked at it on the server and it is not fine, then something is preventing it from being written correctly on the server. Maybe you didn't se the permissions on the file as mentioned in the instructions.

Share this post


Link to post
Share on other sites

Well, if you have looked at the file on your computer and it is fine and then uploaded it and looked at it on the server and it is not fine, then something is preventing it from being written correctly on the server. Maybe you didn't se the permissions on the file as mentioned in the instructions.

 

Hello Jack,

 

Here it is the same as with IRIN .

With the last 2 versions, we have to look at the source of the page to see it filled with either categories or products,

i.e CTRL+U otherwise there is follwing message:

 

"Google Sitemap http://aaabbbccc.xy/sitemapcategories.xml

Number of sitemaps in this Google sitemap index: 0

Click on the table headers to change sorting."

 

Of course with the source there is no sort options ... .-)

 

I am using this addon since 2009 without any major problems except for special characters. I use a text editor to add them

before sumbitting the fields to google, I thought that was now resolved but on problem remains :

 

Special characters are ommited in parent categories urls when in Ultimate SEO URLS  the option

"Add category parent to begining of URLs?" is set to true.


david

Share this post


Link to post
Share on other sites

@@Eim2 Unfortunately, I can't reproduce the problem so I've gone as far as I can without having access to the site. Maybe the steps I went through with the previous op will help identify the problem. It is possible that it is something in the code but trying to fix something that can't be seen is just wild guessing.

Share this post


Link to post
Share on other sites

Hello Jack,

 

Here it is the same as with IRIN .

With the last 2 versions, we have to look at the source of the page to see it filled with either categories or products,

i.e CTRL+U otherwise there is follwing message:

 

"Google Sitemap http://aaabbbccc.xy/sitemapcategories.xml

Number of sitemaps in this Google sitemap index: 0

Click on the table headers to change sorting."

 

Of course with the source there is no sort options ... .-)

 

I am using this addon since 2009 without any major problems except for special characters. I use a text editor to add them

before sumbitting the fields to google, I thought that was now resolved but on problem remains :

 

Special characters are ommited in parent categories urls when in Ultimate SEO URLS  the option

"Add category parent to begining of URLs?" is set to true.

The permissions are set to 755. Just like Eim2 I can only see the contents by looking at the source of the page.

Share this post


Link to post
Share on other sites

@@Eim2 When the sitemap script is ran on your site, it shows failures when trying to save the files. So, as mentioned, you don't have the permissions set correctly or there is something else preventing that.

Share this post


Link to post
Share on other sites

This post fixed it for me: http://forums.oscommerce.com/topic/330175-google-xml-sitemap-seo/page-79#entry1753634  #1577

 

This is exactly what I have done. I also renamed and uploaded the file to the same location and got the same result.

Google Sitemap http://shop.domain.com/sitemaptest.xml Number of sitemaps in this Google sitemap index: 0

Click on the table headers to change sorting.

Edited by dsolutions

Share this post


Link to post
Share on other sites

@@Jack_mcs

 

Sorry, sure the sitemap files, while I was absent, were chmoded to prevent them from being modified meantime.

I can send the creation debug output, but except for the parent categories in sitemapcategories.xml without special caracters,

all files are created fine, just they cant be read from a browser.

 

I will try above comment by dsolutions in catalog/googlesitemap/index.php with:

$domainArray[] = HTTPS_SERVER . DIR_WS_HTTP_CATALOG;

 

as my shop is all https.

 

Would be fine if that would be the only needed change.


david

Share this post


Link to post
Share on other sites

I was able to reproduce this. The sitemap files show empty in the browser because the file used to list the links is not compatible with sitemaps.org. I haven't had time to look at the cause but it is a non-issue. If you view the source of the files, you should see the links and that is what the search engines use. The code to display the links on the site was added in an early version to make them human readable. But since the maps are not linked to on the site, customers don't know they exist and won't be looking at them.

 

Check your search console to make sure the maps are working correctly as far as google is concerned. If they are, then you can ignore this.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×