Jump to content
Jack_mcs

Google XML Sitemap SEO

Recommended Posts

Ok, thanks for the information. You addon is great, it's just so frustrating when you can't get it to work and have tried everything. My output in standard mode is:

 

define('DIR_FS_CATALOG', '/customers/3/7/f/shop.se//httpd.www/');

 

Any hints will be appreciated. Thanks...

I don't know if it is causing your problem but the above is wrong. It should be

define('DIR_FS_CATALOG', '/customers/3/7/f/shop.se/httpd.www/');

Share this post


Link to post
Share on other sites

Hi Jack,

 

Thanks for the updated contribution. Everything is working for except for the Pages sitemap. I have downloaded the latest version of the contribution and installed today.

I have changed the line of code at line 299 - $filename, as suggested in the begining of the discussion. It seems to return exactly the same result.

I have used the alternate file but that returns False on all sitemaps. I'm not completely sure if its a path problem?

Will it be a path problem if the other sitemaps are produced correctly?

Please post your configure file (without the login entries).

Share this post


Link to post
Share on other sites

Greetings Chemo,

 

I hope that you can assist me please. I am new to osCommerce and site development, and am somewhat confused with what and how to install Add-ons. In searching for an seo solution I came across your contribution, which seems to me to be the better option, Unfortunately, as I have said, I have very little knowledge of osCommerce and no idea as to how to install add-ons.

 

Please help me.

 

mysuccess

Share this post


Link to post
Share on other sites

Greetings Chemo,

 

I hope that you can assist me please. I am new to osCommerce and site development, and am somewhat confused with what and how to install Add-ons. In searching for an seo solution I came across your contribution, which seems to me to be the better option, Unfortunately, as I have said, I have very little knowledge of osCommerce and no idea as to how to install add-ons.

 

Please help me.

 

mysuccess

First, there isn't just one contribution that will SEO your site. See my signature for the ones I recommend. That still won't completely SEO it since you have to setup the pages, but they will give you a big jump on it. For any contribution, you download the package, unzip it and follow the included instructions. For all of my contributions, I alway supply a full install with instructions and completed file. There aren't many other contributors that do that and many just upload one file, which won't help in your case.

Share this post


Link to post
Share on other sites

Please post your configure file (without the login entries).

 

Hi Jack, as requested my config file

 

 

<?php

define('HTTP_SERVER', 'http://www.hopscotchhandmadegifts.co.uk');

define('HTTPS_SERVER', 'http://www.hopscotchhandmadegifts.co.uk');

define('ENABLE_SSL', false);

define('HTTP_COOKIE_DOMAIN', '');

define('HTTPS_COOKIE_DOMAIN', '');

define('HTTP_COOKIE_PATH', '/eshop/');

define('HTTPS_COOKIE_PATH', '/eshop/');

define('DIR_WS_HTTP_CATALOG', '/eshop/');

define('DIR_WS_HTTPS_CATALOG', '/eshop/');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 

define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');

define('DIR_FS_CATALOG', '/var/www/vhosts/hopscotchhandmadegifts.co.uk/httpdocs/eshop/');

define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

 

define('DB_SERVER', 'localhost');

define('DB_SERVER_USERNAME', '*************');

define('DB_SERVER_PASSWORD', '*************');

define('DB_DATABASE', '*************');

define('USE_PCONNECT', 'false');

define('STORE_SESSIONS', 'mysql');

?>

 

Thanks for looking

 

Richard

Share this post


Link to post
Share on other sites

 

Hi Jack, as requested my config file

 

 

define('HTTP_COOKIE_DOMAIN', '');

define('HTTPS_COOKIE_DOMAIN', '');

The above are incorrect, though I don't know if they will cure your problem. Here is what they should be.

 
define('HTTP_COOKIE_DOMAIN', '.:www.hopscotchhandmadegifts.co.uk');
define('HTTPS_COOKIE_DOMAIN', '.:www.hopscotchhandmadegifts.co.uk');

Also, are you sure the following is correct? There's no way for me to tell without knowing your hosts path but it doesn't look rigth:

define('DIR_FS_CATALOG', '/var/www/vhosts/hopscotchhandmadegifts.co.uk/httpdocs/eshop/'); 

You should ask your host if /var/www/vhosts/hopscotchhandmadegifts.co.uk/httpdocs/eshop is the correct path;

Share this post


Link to post
Share on other sites

The above are incorrect, though I don't know if they will cure your problem. Here is what they should be.

define('HTTP_COOKIE_DOMAIN', '.:www.hopscotchhandmadegifts.co.uk');
define('HTTPS_COOKIE_DOMAIN', '.:www.hopscotchhandmadegifts.co.uk');

Also, are you sure the following is correct? There's no way for me to tell without knowing your hosts path but it doesn't look rigth:

define('DIR_FS_CATALOG', '/var/www/vhosts/hopscotchhandmadegifts.co.uk/httpdocs/eshop/');

You should ask your host if /var/www/vhosts/hopscotchhandmadegifts.co.uk/httpdocs/eshop is the correct path;

 

Hi Jack,

 

Changed those same result. I spoke to the host and they say the path is correct. It looks like it does because its on a Plesk virtual host/server apparently.

It's not however overly important for me, I can write a manual sitemap for the pages as there's only about 6 or so. I get the important products and manufacturers sitemaps. I will keep my eye on the thread and if I find a solution, will post here.

 

Thanks for looking

 

Regards

 

Richard

Share this post


Link to post
Share on other sites

Hi Chemo,

I think I have a common trouble with this report after the googlesitemap/index.php calling.

 

Could you please, show me the way how to get out of it?

 

Thankfully, Antonin

 

ERROR: Google Product Sitemap Generation FAILED!
ERROR: Google Category Sitemap Generation FAILED!
ERROR: Google Sitemap Index Generation FAILED!
Array
(
   [QUERY] => Array
	    (
			    [PRODUCTS] => Array
					    (
							    [sTATUS] => success
							    [NUM_ROWS] => 54
					    )
			    [CATEOGRY] => Array
					    (
							    [sTATUS] => success
							    [NUM_ROWS] => 22
					    )
	    )
   [sAVE_FILE_XML] => Array
	    (
			    [0] => Array
					    (
							    [file] => /sitemapproducts.xml
							    [status] => failure
							    [file_exists] => false
					    )
			    [1] => Array
					    (
							    [file] => /sitemapcategories.xml
							    [status] => failure
							    [file_exists] => false
					    )
			    [2] => Array
					    (
							    [file] => /sitemapindex.xml
							    [status] => failure
							    [file_exists] => false
					    )
	    )
)

Share this post


Link to post
Share on other sites

Hi Chemo,

I think I have a common trouble with this report after the googlesitemap/index.php calling.

 

Could you please, show me the way how to get out of it?

What happens when you try the alternate setting, per the instructions?

Share this post


Link to post
Share on other sites

What happens when you try the alternate setting, per the instructions?

 

Hi,

I tried again today. And I am a step further.

Today I have run the sql file, an error occure (no database selected), so I input the values manually. So these datas are in the database. Now I go admin/configuration/google xml seo and - the file is empty, no values, nothing to set. I would like to follow your instructions and try to do the alternate setting, but there is nothing to do it on. Was the failure to input the data manually? I dont think so. Am I right?

Thank you very much. Antonin

Share this post


Link to post
Share on other sites

 

Hi,

I tried again today. And I am a step further.

Today I have run the sql file, an error occure (no database selected), so I input the values manually. So these datas are in the database. Now I go admin/configuration/google xml seo and - the file is empty, no values, nothing to set. I would like to follow your instructions and try to do the alternate setting, but there is nothing to do it on. Was the failure to input the data manually? I dont think so. Am I right?

 

Thank you very much. Antonin

 

Hi, it is me again. Sorry, I panicked a bit...

This time, I am much succesfuller. The problem with no data at admin/configuration... is already fixed.

Only two buts: there is no: "If you have not already submitted the sitemap index to Google click the link below".on the page after the googlesitemap/index.php is displayed as you wrote in the googlesitemap/index.html but it is supposed to be there.

 

And there is also this: ERROR: Google Pages Sitemap Generation FAILED!

 

Could you comment this, please? Thank you very much.

Antonin

 

PS Just for sure, this is the code:

Opening   /hosting/www/dospisil.com/www/sitemapproducts.xmlFS_CAT    /hosting/www/dospisil.com/www/Server    http://www.dospisil.comSave Path /hosting/www/dospisil.com/www/WS_CAT    / Write /hosting/www/dospisil.com/www/sitemapproducts.xmlGenerated Google Product Sitemap Successfully
Opening   /hosting/www/dospisil.com/www/sitemapcategories.xmlFS_CAT    /hosting/www/dospisil.com/www/Server    http://www.dospisil.comSave Path /hosting/www/dospisil.com/www/WS_CAT    / Write /hosting/www/dospisil.com/www/sitemapcategories.xmlGenerated Google Category Sitemap Successfully
Opening   /hosting/www/dospisil.com/www/sitemapmanufacturers.xmlFS_CAT    /hosting/www/dospisil.com/www/Server    http://www.dospisil.comSave Path /hosting/www/dospisil.com/www/WS_CAT    / Write /hosting/www/dospisil.com/www/sitemapmanufacturers.xmlGenerated Google Manufacturers Sitemap Successfully
Google Sitemap Specials not generated - no specials found!
ERROR: Google Pages Sitemap Generation FAILED!
Opening   /hosting/www/dospisil.com/www/sitemapindex.xmlFS_CAT    /hosting/www/dospisil.com/www/Server    http://www.dospisil.comSave Path /hosting/www/dospisil.com/www/WS_CAT    / Write /hosting/www/dospisil.com/www/sitemapindex.xmlGenerated Google Sitemap Index Successfully
Array
(
   [QUERY] => Array
    (
	    [PRODUCTS] => Array
		    (
			    [sTATUS] => success
			    [NUM_ROWS] => 54
		    )
	    [CATEOGRY] => Array
		    (
			    [sTATUS] => success
			    [NUM_ROWS] => 22
		    )
	    [MANUFACTURERS] => Array
		    (
			    [sTATUS] => success
			    [NUM_ROWS] => 2
		    )
	    [sPECIALS] => Array
		    (
			    [sTATUS] => success
			    [NUM_ROWS] => 0
		    )
    )
   [sAVE_FILE_XML] => Array
    (
	    [0] => Array
		    (
			    [file] => /hosting/www/dospisil.com/www/sitemapproducts.xml
			    [status] => success
			    [file_exists] => true
		    )
	    [1] => Array
		    (
			    [file] => /hosting/www/dospisil.com/www/sitemapcategories.xml
			    [status] => success
			    [file_exists] => true
		    )
	    [2] => Array
		    (
			    [file] => /hosting/www/dospisil.com/www/sitemapmanufacturers.xml
			    [status] => success
			    [file_exists] => true
		    )
	    [3] => Array
		    (
			    [file] => /hosting/www/dospisil.com/www/sitemapindex.xml
			    [status] => success
			    [file_exists] => true
		    )
    )
)

Share this post


Link to post
Share on other sites

Greetings Chemo,

I installed your Gooble XML Sitemap SEO and now I would like to submit my sitemap file to the Google. I am not too much experienced in this, so I am asking to help me, please.

Which file I am supposed to submit to the Google? Is it the http://www.mydomain.com/googlesitemap/index.php?

I am struggling with this since days.

Thank you very much.

Antonin

Share this post


Link to post
Share on other sites

 

Hi, it is me again. Sorry, I panicked a bit...

This time, I am much succesfuller. The problem with no data at admin/configuration... is already fixed.

Only two buts: there is no: "If you have not already submitted the sitemap index to Google click the link below".on the page after the googlesitemap/index.php is displayed as you wrote in the googlesitemap/index.html but it is supposed to be there.

 

And there is also this: ERROR: Google Pages Sitemap Generation FAILED!

 

Turn off the pages option in the settings to get by that so the script can complete. Once it does, setup your account as instructed. If you want to wok on the pages problem then, review the posts in this thread regarding it.

Share this post


Link to post
Share on other sites

Thanks a lot for your instructions. Now, I have only 1 question:

Should I return the settings back to "true"?

Share this post


Link to post
Share on other sites

Thanks a lot for your instructions. Now, I have only 1 question:

Should I return the settings back to "true"?

I don't know what settings you are referring to but the ones for this contribution should be set to whatever allows it to work.

Share this post


Link to post
Share on other sites

Hi,

I use the oscommerce 2.3.1 and added the Google xml Sitemap seo on.

Using the google webmaster tool i have sent 3 xml files to google:

sitemapindex.xml

sitemapcategories.xml

sitemapproducts.xml

 

Only the sitemapindex was able to apply the urls to the web index.

The other 2 contain reports like: the url address in the location of the sitemap file is not allowed

therefore both of them are signed with a red cross in the list.

 

Could I ask you for help, how to fix this thing, please?

When they arent allowed I need not to have them there, but I want.

 

thank you very much

Antonin

Share this post


Link to post
Share on other sites

Only the sitemapindex was able to apply the urls to the web index.

The other 2 contain reports like: the url address in the location of the sitemap file is not allowed

therefore both of them are signed with a red cross in the list.

What is the location?

Share this post


Link to post
Share on other sites

For the sitemapindex.xml is the location: www.dospisil.com/sitemapindex.xml

the sitemappages.xml, sitemapcategories.xml, sitemapmanufacturers.xml and sitemapproducts.xml have the identical location: www.dospisil.com/sitemap....

 

Antonin

Share this post


Link to post
Share on other sites

For the sitemapindex.xml is the location: www.dospisil.com/sitemapindex.xml

the sitemappages.xml, sitemapcategories.xml, sitemapmanufacturers.xml and sitemapproducts.xml have the identical location: www.dospisil.com/sitemap....

 

Antonin

Your maps look fine to me. My guess is that you entered them incorrectly in your google account somehow. There is an option in your account to test the sitemaps so you should try that to, hopefully, find the problem. If you can't, you can ask in the google forums or send google and email asking them what the problem is

Share this post


Link to post
Share on other sites

Hello,

First of all I would like to thank for the amazing work!!!

I tried to install it..

From creating the sql phpmyadmin... all the choises were 'false' ...

When I am linking to the mydomain/googlesitemap/index.php I see the above...

 

 

Opening /var/www/vhosts/monokouki.gr/httpdocs/sitemapproducts.xml

FS_CAT /var/www/vhosts/monokouki.gr/httpdocs/

Server http://www.monokouki.gr

Save Path /var/www/vhosts/monokouki.gr/httpdocs/

WS_CAT /

ERROR: Google Product Sitemap Generation FAILED!

 

Opening /var/www/vhosts/monokouki.gr/httpdocs/sitemapcategories.xml

FS_CAT /var/www/vhosts/monokouki.gr/httpdocs/

Server http://www.monokouki.gr

Save Path /var/www/vhosts/monokouki.gr/httpdocs/

WS_CAT /

ERROR: Google Category Sitemap Generation FAILED!

 

Opening /var/www/vhosts/monokouki.gr/httpdocs/sitemapindex.xml

FS_CAT /var/www/vhosts/monokouki.gr/httpdocs/

Server http://www.monokouki.gr

Save Path /var/www/vhosts/monokouki.gr/httpdocs/

WS_CAT /

ERROR: Google Sitemap Index Generation FAILED!

 

Array

(

[QUERY] => Array

(

[PRODUCTS] => Array

(

[sTATUS] => success

[NUM_ROWS] => 268

)

 

[CATEOGRY] => Array

(

[sTATUS] => success

[NUM_ROWS] => 88

)

 

)

 

[sAVE_FILE_XML] => Array

(

[0] => Array

(

[file] => /var/www/vhosts/monokouki.gr/httpdocs/sitemapproducts.xml

[status] => failure

[file_exists] => true

)

 

[1] => Array

(

[file] => /var/www/vhosts/monokouki.gr/httpdocs/sitemapcategories.xml

[status] => failure

[file_exists] => true

)

 

[2] => Array

(

[file] => /var/www/vhosts/monokouki.gr/httpdocs/sitemapindex.xml

[status] => failure

[file_exists] => true

)

 

)

 

)

 

 

 

Can you please tell me what I am doing wrong??? I made the change at line 229 on the php file...

 

Thank you very much!

Share this post


Link to post
Share on other sites

 

Can you please tell me what I am doing wrong??? I made the change at line 229 on the php file...

I've no idea what you mean by changing the " line 229 on the php file" so I can't comment on that but as far as the failure, did you try the other map setting as mentioned in the instructions?

Share this post


Link to post
Share on other sites

thank you very much for the fast response...I dont know how to edit them :S should i make a new value in the table??? when I say the line in 229 ... I have a same problem with the person on the first post.. so i made what was suggested about the sitemaps.class.php...

 

But when i did the changes.. the problem was changed as well... now.. what should i do??? i must edit the values or make new??

Share this post


Link to post
Share on other sites

thank you very much for the fast response...I dont know how to edit them :S should i make a new value in the table??? when I say the line in 229 ... I have a same problem with the person on the first post.. so i made what was suggested about the sitemaps.class.php...

 

But when i did the changes.. the problem was changed as well... now.. what should i do??? i must edit the values or make new??

First post? Of this thread? No, you shouldn't be making file changes. Just change the setting as the instructions state and you should be OK.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×