Jump to content
Jack_mcs

Google XML Sitemap SEO

Recommended Posts

i also have got some problems (i changed to alternative and and the permissions at the image folder and the google xml seo sitemap are both 777)

 

Opening /sitemapproducts.xml

 

Warning: fopen(/sitemapproducts.xml) [function.fopen]: failed to open stream: Permission denied in /home/content/68/7349768/html/googlesitemap/sitemap.class_Alternate.php on line 353

The path is incorrect. See the previous posts regarding this problem.

Share this post


Link to post
Share on other sites

The path is incorrect. See the previous posts regarding this problem.

 

well i checked the previous posts before i registrate myself at this forum.

 

but i dont know where i can change the path and what should be wrong about it :S

 

this is my absolute hosting path home/content/68/7349768/html

 

the rest is the directory /googlesitemap/sitemap.class_Alternate.php

 

 

maybe you can help me out of this?

Share this post


Link to post
Share on other sites

well i checked the previous posts before i registrate myself at this forum.

 

but i dont know where i can change the path and what should be wrong about it :S

 

this is my absolute hosting path home/content/68/7349768/html

 

the rest is the directory /googlesitemap/sitemap.class_Alternate.php

 

 

maybe you can help me out of this?

You can start here.

Share this post


Link to post
Share on other sites

thanks

 

according to this link its the configure.php where i have to change the path but i checked the previous posts and what ive seen my path seems to be right.

 

so there must be another problem, is it probably seo urls in combination with seo xml sitemap?

 

thanks for fasty reply

Share this post


Link to post
Share on other sites

thanks

 

according to this link its the configure.php where i have to change the path but i checked the previous posts and what ive seen my path seems to be right.

 

so there must be another problem, is it probably seo urls in combination with seo xml sitemap?

 

thanks for fasty reply

If you are not using Ultimate SEO V2.2d, which is what I recommend, then you may have problems.

Share this post


Link to post
Share on other sites

is trange,i dont get any error in the files, but looks like cant create some files...

 

 

ERROR: Google Product Sitemap Generation FAILED!

 

Opening /usr/home/rosariokendo/domains/insumosrosario.com/public_html/sitemapcategories.xmlFS_CAT /usr/home/rosariokendo/domains/insumosrosario.com/public_html/Server http://insumosrosario.comSave Path /usr/home/rosariokendo/domains/insumosrosario.com/public_html/WS_CAT / Write /usr/home/rosariokendo/domains/insumosrosario.com/public_html/sitemapcategories.xmlGenerated Google Category Sitemap Successfully

 

Google Sitemap Manufacturers not generated - no Manufacturers found!

 

Google Sitemap Specials not generated - no specials found!

 

ERROR: Google Pages Sitemap Generation FAILED!

 

Opening /usr/home/rosariokendo/domains/insumosrosario.com/public_html/sitemapindex.xmlFS_CAT /usr/home/rosariokendo/domains/insumosrosario.com/public_html/Server http://insumosrosario.comSave Path /usr/home/rosariokendo/domains/insumosrosario.com/public_html/WS_CAT / Write /usr/home/rosariokendo/domains/insumosrosario.com/public_html/sitemapindex.xmlGenerated Google Sitemap Index Successfully

 

Array

(

[QUERY] => Array

(

[PRODUCTS] => Array

(

[sTATUS] => success

[NUM_ROWS] => 0

)

 

[CATEOGRY] => Array

(

[sTATUS] => success

[NUM_ROWS] => 4

)

 

[MANUFACTURERS] => Array

(

[sTATUS] => success

[NUM_ROWS] => 0

)

 

[sPECIALS] => Array

(

[sTATUS] => success

[NUM_ROWS] => 0

)

 

)

 

[sAVE_FILE_XML] => Array

(

[0] => Array

(

[file] => /usr/home/rosariokendo/domains/insumosrosario.com/public_html/sitemapcategories.xml

[status] => success

[file_exists] => true

)

 

[1] => Array

(

[file] => /usr/home/rosariokendo/domains/insumosrosario.com/public_html/sitemapindex.xml

[status] => success

[file_exists] => true

)

 

)

 

)

Share this post


Link to post
Share on other sites

is trange,i dont get any error in the files, but looks like cant create some files...

 

 

ERROR: Google Product Sitemap Generation FAILED!

Have you tried using the alternate sitemap? Are the permissions on the sitemap files the same as on your images directory?

Share this post


Link to post
Share on other sites

Hello

I agonized for two days with these problems.

But everything turned out

It turned out that simply did not properly filled in the file. sql into the database

A little more rearranged the files from the archive

Thank you!

Share this post


Link to post
Share on other sites

I'm wondering if someone could shed some light on why I get this error:

 

<b>Fatal error</b>: Call to a member function retrieveDependencies() on a non-object in <b>/home/mydir/public_html/v23/includes/modules/ultimate_seo_urls5/main/bootstrap.php</b> on line <b>409</b><br />

 

This error only occurs w3ithin the cron job - I don't get it when I run from the web page. The sitemaps are created correctly

Here is the function where the error occurs:

 

private function uriModulesParsePath() {

if ( !is_readable( Usu_Main::i()->getVar( 'page_modules_path' ) . Usu_Main::i()->getVar( 'filename' ) ) ) {

return false;

}

409-> $dependencies = Usu_Main::i()->getVar( 'page_modules', substr( Usu_Main::i()->getVar( 'filename' ), 0, -4 ) )->retrieveDependencies();

$uri_modules = Usu_Main::i()->getVar( 'uri_modules' );

foreach ( $uri_modules as $object ) {

if ( false !== ( $object->isValidUri() ) ) {

$object->parsePath();

}

}

} // end method

 

Please help, I would love to get this resolved.

 

Thanks.

Share this post


Link to post
Share on other sites

I'm wondering if someone could shed some light on why I get this error:

 

<b>Fatal error</b>: Call to a member function retrieveDependencies() on a non-object in <b>/home/mydir/public_html/v23/includes/modules/ultimate_seo_urls5/main/bootstrap.php</b> on line <b>409</b><br />

 

This error only occurs w3ithin the cron job - I don't get it when I run from the web page. The sitemaps are created correctly

Here is the function where the error occurs:

 

private function uriModulesParsePath() {

 

That's not anything to do with this contribution. You'll need to determine the file that is causing it and proceed from there. Though it will probably end up being a server problem so you may want to start with your host first.

Share this post


Link to post
Share on other sites

Hello Jack_mcs,

 

Thanks for the great work. Everything went well for the first time. I am using osc 2.3.1. I just have a question regarding to the output.

Question: can the output show the actual product names and manufacturers vs only the path? Did I get the right output?

Here is what I got so far:

 

Write /homepages/17/xxxxxxxxx/htdocs/sitemapproducts.xml

Generated Google Product Sitemap Successfully

 

Write /homepages/17/xxxxxxxxx/htdocs/sitemapcategories.xml

Generated Google Category Sitemap Successfully

 

Write /homepages/17/xxxxxxxxx/htdocs/sitemapmanufacturers.xml

Generated Google Manufacturers Sitemap Successfully

 

Write /homepages/17/xxxxxxxxx/htdocs/sitemapindex.xml

Generated Google Sitemap Index Successfully

 

CONGRATULATIONS! All files generated successfully.

 

If you have not already submitted the sitemap index to Google click the link below.

Before you do I HIGHLY recommend that you view the XML files to make sure the data is correct.

 

www.google.com/webmasters/sitemaps/ping?sitemap=http%3A%2F%2Fyourcompany.com%2Fsitemapindex.xml

 

For your convenience here is the CRON command for your site:

php /kunden/homepages/17/xxxxxxxxx/htdocs/googlesitemap/index.php

 

Here is your sitemap index: yourcompany.com/sitemapindex.xml

Here is your product sitemap: yourcompany.com/sitemapproducts.xml

Here is your category sitemap: yourcompany.com/sitemapcategories.xml

Here is your manufacturers sitemap: yourcompany.com/sitemapmanufacturers.xml

 

Although my sitemapindex is blank, there is nothing listed. Products, Categories, Manufacturers has the actual links in it, but only the path.

i.e.: yourcompany.com/product_info.php?products_id=75

Thanks in advance.

 

Csaba

Share this post


Link to post
Share on other sites

Although my sitemapindex is blank, there is nothing listed. Products, Categories, Manufacturers has the actual links in it, but only the path.

i.e.: yourcompany.com/product_info.php?products_id=75

Thanks in advance.

The url's will only rewrite if you have a rewriter contribution installed. If you are using SEO 5, it won't work with this contribution due to how its coded. You will need use a different contribution if you want to use it. I recommend Ultimate SEO V 2.2d.

Share this post


Link to post
Share on other sites

Thank you for the advise. I am fairly new to this.

Do I have to remove the Google XML Sitemap from the site or just leave it.

It had a sql file I had to import into the database. I can delete the rest of files.

I will try the suggested method.

Share this post


Link to post
Share on other sites

Stuck on here................

 

 

 

Warning: fopen(

/home/content/32/6828432/html/sitemapproducts.xml) [function.fopen]: failed to open stream: No such file or directory in /home/content/32/6828432/html/sitemap.class.php on line 593

 

ERROR: Google Product Sitemap Generation FAILED!

 

 

 

Warning: fopen(

/home/content/32/6828432/html/sitemapcategories.xml) [function.fopen]: failed to open stream: No such file or directory in /home/content/32/6828432/html/sitemap.class.php on line 593

 

ERROR: Google Category Sitemap Generation FAILED!

 

 

 

Warning: fopen(

/home/content/32/6828432/html/sitemapindex.xml) [function.fopen]: failed to open stream: No such file or directory in /home/content/32/6828432/html/sitemap.class.php on line 593

 

ERROR: Google Sitemap Index Generation FAILED!

 

Array

(

[QUERY] => Array

(

[PRODUCTS] => Array

(

[sTATUS] => success

[NUM_ROWS] => 568

)

 

[CATEOGRY] => Array

(

[sTATUS] => success

[NUM_ROWS] => 127

)

 

)

 

[sAVE_FILE_XML] => Array

(

[0] => Array

(

[file] =>

/home/content/32/6828432/html/sitemapproducts.xml

[status] => failure

[file_exists] => false

)

 

[1] => Array

(

[file] =>

/home/content/32/6828432/html/sitemapcategories.xml

[status] => failure

[file_exists] => false

)

 

[2] => Array

(

[file] =>

/home/content/32/6828432/html/sitemapindex.xml

[status] => failure

[file_exists] => false

)

 

)

 

)

 

 

Pls help me !!

Share this post


Link to post
Share on other sites

Warning: fopen(

/home/content/32/6828432/html/sitemapproducts.xml) [function.fopen]: failed to open stream: No such file or directory in /home/content/32/6828432/html/sitemap.class.php on line 593

The error is saying it can't find the sitemap file. Did you upload it to your shops root directory?

Share this post


Link to post
Share on other sites

Hi

 

i use this conitrb http://addons.oscommerce.com/info/6583

V 1.5

 

 

it must be possilbe to create the sitemapproducts.xml with seo URls

 

right now it looks like this:

 

sitemapproducts.xml

....de/catalog/product_info.php?products_id=507

 

but i saw that it casn be looks also like this:

 

...de/catalog/Football-Equipment.220/Football-Accessories.123/Captains-Armband.569.html

 

is there a special setup? or what i must/can do to create the sitemapproducts.xml with seo URls

 

rgds

alfred

Share this post


Link to post
Share on other sites

i use this conitrb http://addons.oscommerce.com/info/6583

V 1.5

 

it must be possilbe to create the sitemapproducts.xml with seo URls

If you are using Ultimate SEO V 2.2d, which is what I recommend, then the links are created automatically. Is you have are using SEO 5, then you have to use the sitemap conribution altered to allow it to work.

Share this post


Link to post
Share on other sites

Think is Contrib http://addons.oscommerce.com/info/2823 so yes i use this also

hen it should work without any problems. Are the urls being rewritten correctly in the shop?

Share this post


Link to post
Share on other sites

yes shop looks like this:

 

.de/catalog/kofferanhaenger-kanpur-silver-p-507.html

 

same product in de/catalog/sitemapproducts.xml

looks like this:

 

.de/catalog/product_info.php?products_id=507

 

the htacess file loks like this

# Begin Ultimate SEO V2.2d

Options +FollowSymLinks

RewriteEngine On

 

RewriteBase /catalog/

 

RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-m-(.*).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pi-(.*).html$ popup_image.php?pID=$2&%{QUERY_STRING}

RewriteRule ^(.*)-by-(.*).html$ all-products.php?fl=$2&%{QUERY_STRING}

RewriteRule ^(.*)-t-(.*).html$ articles.php?tPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-a-(.*).html$ article_info.php?articles_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-au-(.*).html$ articles.php?authors_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pr-(.*).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pri-(.*).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-f-(.*).html$ faqdesk_info.php?faqdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-fc-(.*).html$ faqdesk_index.php?faqPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-fri-(.*).html$ faqdesk_reviews_info.php?faqdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-fra-(.*).html$ faqdesk_reviews_article.php?faqdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-i-(.*).html$ information.php?info_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-links-(.*).html$ links.php?lPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pm-([0-9]+).html$ info_pages.php?pages_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-n-(.*).html$ newsdesk_info.php?newsdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-nc-(.*).html$ newsdesk_index.php?newsPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-nri-(.*).html$ newsdesk_reviews_info.php?newsdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-nra-(.*).html$ newsdesk_reviews_article.php?newsdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-po-([0-9]+).html$ pollbooth.php?pollid=$2&%{QUERY_STRING}

# End Ultimate SEO V2.2d

Edited by stragami

Share this post


Link to post
Share on other sites

yes shop looks like this:

 

.de/catalog/kofferanhaenger-kanpur-silver-p-507.html

 

same product in de/catalog/sitemapproducts.xml

looks like this:

 

.de/catalog/product_info.php?products_id=507

Then all I can suggest is that you confirm that you acutally have this contribution installed since there are two others with similar names.

Share this post


Link to post
Share on other sites

Jack

 

yes your right .... i got the wrong one

 

now it works

 

thx for your help

 

rgds

alfred

Share this post


Link to post
Share on other sites

Hello

 

When I load up my feed, I get the following errors. Will they hurt my lisitngs and can they be fixed?

 

Thanks In Advance

 

Item Errors - 7 items with errors 7 items affected

7

Encoding problem in attribute: description (7 errors)

Some of the characters in your items seem to be invalid. Please verify all the characters in your feed are valid for your selected encoding.

 

Item Warnings - 4723 items with warnings 4723 items affected

3191

Unrecognized attribute: department (3191 warnings)Your feed contains an attribute name our system doesn't recognize. Please verify your attribute name as necessary, and please be aware that this attribute may no longer be included in our Feed Specification.

Learn more.

Examples: Examples:

 

Item Nr. Line Nr.

1 2

1 2

2 3

2 3

101 102

 

1532

Expiration date is too far in the future (1532 warnings)

Please make sure the value doesn't exceed the default expiration date for your item type.Learn more. Examples: Examples:

 

Item Nr. Line Nr. Value

201 202 2011-04-09T22:32:21

202 203 2011-04-09T22:32:21

204 205 2011-04-09T22:32:21

209 210 2011-04-09T22:32:21

211 212 2011-04-09T22:32:21

Share this post


Link to post
Share on other sites

When I load up my feed, I get the following errors. Will they hurt my lisitngs and can they be fixed?

Google won't list the items that have errors so if you want them listed, you have to fix them.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×