Jump to content
Jack_mcs

Google XML Sitemap SEO

Recommended Posts

I get below error.

Please help.

Thanks.

 

Opening   /sitemapproducts.xml
FS_CAT    /home/sakari/public_html/catalog/
Server    http://www.sakarimotorsports.com
Save Path /
WS_CAT    /catalog/ 


Warning:  fopen(/sitemapproducts.xml) [function.fopen]: failed to open stream: Permission denied in /home/sakari/public_html/catalog/googlesitemap/sitemap.class_Alternate.php on line 353

ERROR: Google Product Sitemap Generation FAILED!

Opening   /sitemapcategories.xml
FS_CAT    /home/sakari/public_html/catalog/
Server    http://www.sakarimotorsports.com
Save Path /
WS_CAT    /catalog/ 


Warning:  fopen(/sitemapcategories.xml) [function.fopen]: failed to open stream: Permission denied in /home/sakari/public_html/catalog/googlesitemap/sitemap.class_Alternate.php on line 353

ERROR: Google Category Sitemap Generation FAILED!

Opening   /sitemapindex.xml
FS_CAT    /home/sakari/public_html/catalog/
Server    http://www.sakarimotorsports.com
Save Path /
WS_CAT    /catalog/ 


Warning:  fopen(/sitemapindex.xml) [function.fopen]: failed to open stream: Permission denied in /home/sakari/public_html/catalog/googlesitemap/sitemap.class_Alternate.php on line 353

ERROR: Google Sitemap Index Generation FAILED!

Array
(
   [QUERY] => Array
       (
           [PRODUCTS] => Array
               (
                   [sTATUS] => success
                   [NUM_ROWS] => 831
               )

           [CATEOGRY] => Array
               (
                   [sTATUS] => success
                   [NUM_ROWS] => 656
               )

       )

   [sAVE_FILE_XML] => Array
       (
           [0] => Array
               (
                   [file] => /sitemapproducts.xml
                   [status] => failure
                   [file_exists] => false
               )

           [1] => Array
               (
                   [file] => /sitemapcategories.xml
                   [status] => failure
                   [file_exists] => false
               )

           [2] => Array
               (
                   [file] => /sitemapindex.xml
                   [status] => failure
                   [file_exists] => false
               )

       )

)

Share this post


Link to post
Share on other sites

I get below error.

Please help.

Did you set the permissions on the sitemap files? Did you try the alternate sitemap setting?

Share this post


Link to post
Share on other sites

Did you set the permissions on the sitemap files? Did you try the alternate sitemap setting?

 

 

Yes permissions set same as images folder and did try the alternate setting.

 

Thanks.

Share this post


Link to post
Share on other sites

I get the same error. All files are chmod to 777. The Alternate version gives the same result. I haven't had time to play with it, but I suspect that one of my security additions to the .htaccess may be blocking file writes to the root directory.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

I get the same error. All files are chmod to 777. The Alternate version gives the same result. I haven't had time to play with it, but I suspect that one of my security additions to the .htaccess may be blocking file writes to the root directory.

 

Regards

Jim

 

I have additional security when accessing admin and renamed admin to something else.

 

Does this have anything to do with it?

 

Please advise.

Share this post


Link to post
Share on other sites

Yes permissions set same as images folder and did try the alternate setting.

Then there is probably something wrong with your configure file since teh save path should be the full path to the account. Post it here, if you want, and I will take a look at it. Don't include your login information though.

Share this post


Link to post
Share on other sites

Then there is probably something wrong with your configure file since teh save path should be the full path to the account. Post it here, if you want, and I will take a look at it. Don't include your login information though.

 

<?php
 define('HTTP_SERVER', 'http://www.sakarimotorsports.com');
 define('HTTPS_SERVER', 'https://www.sakarimotorsports.com');
 define('ENABLE_SSL', true);
 define('HTTP_COOKIE_DOMAIN', 'www.sakarimotorsports.com');
 define('HTTPS_COOKIE_DOMAIN', 'www.sakarimotorsports.com');
 define('HTTP_COOKIE_PATH', '/catalog/');
 define('HTTPS_COOKIE_PATH', '/catalog/');
 define('DIR_WS_HTTP_CATALOG', '/catalog/');
 define('DIR_WS_HTTPS_CATALOG', '/catalog/');
 define('DIR_WS_IMAGES', 'sakariimages/');
 define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
 define('DIR_WS_INCLUDES', 'includes/');
 define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
 define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
 define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
 define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
 define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');
 define('DIR_FS_CATALOG', '/home/sakari/public_html/catalog/');
 define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');
 define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

 

and the admin config below.

 

<?php
 define('HTTP_SERVER', 'http://www.sakarimotorsports.com');
 define('HTTP_CATALOG_SERVER', 'http://www.sakarimotorsports.com');
 define('HTTPS_CATALOG_SERVER', 'https://www.sakarimotorsports.com');
 define('ENABLE_SSL_CATALOG', 'true');
 define('DIR_FS_DOCUMENT_ROOT', '/home/sakari/public_html/catalog/');
 define('DIR_WS_ADMIN', '/catalog/sakariadmin/');
 define('DIR_FS_ADMIN', '/home/sakari/public_html/catalog/sakariadmin/');
 define('DIR_WS_CATALOG', '/catalog/');
 define('DIR_FS_CATALOG', '/home/sakari/public_html/catalog/');
 define('DIR_WS_IMAGES', 'images/');
 define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
 define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'sakariimages/');
 define('DIR_WS_INCLUDES', 'includes/');
 define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
 define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
 define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
 define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
 define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');
 define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');
 define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');
 define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'sakariimages/');
 define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');
 define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');

Thanks.

Edited by gomikeyp

Share this post


Link to post
Share on other sites

 define('DIR_FS_DOCUMENT_ROOT', '/home/sakari/public_html/catalog/');
 define('DIR_WS_ADMIN', '/catalog/sakariadmin/');
 define('DIR_FS_ADMIN', '/home/sakari/public_html/catalog/sakariadmin/');
 define('DIR_WS_CATALOG', '/catalog/');
 define('DIR_FS_CATALOG', '/home/sakari/public_html/catalog/');

 

Try replacing the above in admin/includes/configure.php with the following. I'm not sure if it will fix the problem you are having but it will fix the mistake that is there.

  
 define('DIR_FS_DOCUMENT_ROOT', '/home/sakari/public_html');
 define('DIR_WS_ADMIN', '/catalog/sakariadmin/');
 define('DIR_FS_ADMIN', DIR_FS_DOCUMENT_ROOT . DIR_WS_ADMIN);
 define('DIR_WS_CATALOG', '/catalog/');
 define('DIR_FS_CATALOG', DIR_FS_DOCUMENT_ROOT . DIR_WS_CATALOG);

Edited by Jack_mcs

Share this post


Link to post
Share on other sites

 define('DIR_FS_DOCUMENT_ROOT', '/home/sakari/public_html/catalog/');
 define('DIR_WS_ADMIN', '/catalog/sakariadmin/');
 define('DIR_FS_ADMIN', '/home/sakari/public_html/catalog/sakariadmin/');
 define('DIR_WS_CATALOG', '/catalog/');
 define('DIR_FS_CATALOG', '/home/sakari/public_html/catalog/');

 

Try replacing the above in admin/includes/configure.php with the following. I'm not sure if it will fix the problem you are having but it will fix the mistake that is there.

  
 define('DIR_FS_DOCUMENT_ROOT', '/home/sakari/public_html');
 define('DIR_WS_ADMIN', '/catalog/sakariadmin/');
 define('DIR_FS_ADMIN', DIR_FS_DOCUMENT_ROOT . DIR_WS_ADMIN);
 define('DIR_WS_CATALOG', '/catalog/');
 define('DIR_FS_CATALOG', DIR_FS_DOCUMENT_ROOT . DIR_WS_CATALOG);

 

I did update above and still get below error.

 

Warning:  fopen(/sitemapproducts.xml) [function.fopen]: failed to open stream: Permission denied in /home/sakari/public_html/catalog/googlesitemap/sitemap.class_Alternate.php on line 353

ERROR: Google Product Sitemap Generation FAILED!

Opening   /sitemapcategories.xml
FS_CAT    /home/sakari/public_html/catalog/
Server    http://www.sakarimotorsports.com
Save Path /
WS_CAT    /catalog/ 


Warning:  fopen(/sitemapcategories.xml) [function.fopen]: failed to open stream: Permission denied in /home/sakari/public_html/catalog/googlesitemap/sitemap.class_Alternate.php on line 353

ERROR: Google Category Sitemap Generation FAILED!

Opening   /sitemapindex.xml
FS_CAT    /home/sakari/public_html/catalog/
Server    http://www.sakarimotorsports.com
Save Path /
WS_CAT    /catalog/ 


Warning:  fopen(/sitemapindex.xml) [function.fopen]: failed to open stream: Permission denied in /home/sakari/public_html/catalog/googlesitemap/sitemap.class_Alternate.php on line 353

ERROR: Google Sitemap Index Generation FAILED!

Array
(
   [QUERY] => Array
       (
           [PRODUCTS] => Array
               (
                   [sTATUS] => success
                   [NUM_ROWS] => 831
               )

           [CATEOGRY] => Array
               (
                   [sTATUS] => success
                   [NUM_ROWS] => 656
               )

       )

   [sAVE_FILE_XML] => Array
       (
           [0] => Array
               (
                   [file] => /sitemapproducts.xml
                   [status] => failure
                   [file_exists] => false
               )

           [1] => Array
               (
                   [file] => /sitemapcategories.xml
                   [status] => failure
                   [file_exists] => false
               )

           [2] => Array
               (
                   [file] => /sitemapindex.xml
                   [status] => failure
                   [file_exists] => false
               )

       )

)

Share this post


Link to post
Share on other sites

I did update above and still get below error.

 

Opening /sitemapcategories.xml

FS_CAT /home/sakari/public_html/catalog/

Server http://www.sakarimotorsports.com

Save Path /

WS_CAT /catalog/

The paths are still wrong. I don't know what is causing it and can't tell in a support thread like this but that is what you need to look at.

Share this post


Link to post
Share on other sites

The paths are still wrong. I don't know what is causing it and can't tell in a support thread like this but that is what you need to look at.

 

What is correct paths supposed to be?

 

I have a redirect setup from sakarimotorsports.com to sakarimotorsports.com/catalog from cpanel.

 

Could that be a possible problem?

 

Thanks.

Share this post


Link to post
Share on other sites

What is correct paths supposed to be?

 

I have a redirect setup from sakarimotorsports.com to sakarimotorsports.com/catalog from cpanel.

 

Could that be a possible problem?

 

Thanks.

A site installed in the root would have something like this

Opening   /home/username/public_html/sitemapproducts.xml
FS_CAT    /home/username/public_html/googlesitemap/
Server    http://domain_name.com
Save Path /home/username/public_html/
WS_CAT    / 
Write     /home/username/public_html/sitemapproducts.xml

I don't think that redirect would cause a problem as long as the rest of the shop is working correctly.

Share this post


Link to post
Share on other sites

I created some pages by my own. they are not shown in the sitemappages. what did I wrong? Is there a place to add it manually?

 

Thanks for answering!

Share this post


Link to post
Share on other sites

I created some pages by my own. they are not shown in the sitemappages. what did I wrong? Is there a place to add it manually?

If they are pages in the shop that one can click on a link to, then they should be oscommerce-type pages. Otherwise, you will run into problems with the loss of sessin ID's. If they are oscommerce-type pages, they should add automatically when you re-run the script. If they are not, there isn't anything in the code that will allow you to add them.

Share this post


Link to post
Share on other sites

Only 1 of my sitemaps failed to be created with the standard file. Alternate was a complete fail.

 

Any help would be greatly appreciated!

 

Kurt

 

Opening   sitemapproducts.xml
FS_CAT    
Server    http://dnbdubrecords.com
Save Path 
WS_CAT    / 
Write sitemapproducts.xml
Generated Google Product Sitemap Successfully

Opening   sitemapcategories.xml
FS_CAT    
Server    http://dnbdubrecords.com
Save Path 
WS_CAT    / 
Write sitemapcategories.xml
Generated Google Category Sitemap Successfully

Opening   sitemapmanufacturers.xml
FS_CAT    
Server    http://dnbdubrecords.com
Save Path 
WS_CAT    / 
Write sitemapmanufacturers.xml
Generated Google Manufacturers Sitemap Successfully



Warning:  chdir() [function.chdir]: No such file or directory (errno 2) in /hermes/bosweb/web139/b1395/ipg.dnbdubcom/googlesitemap/sitemap.class.php on line 775

ERROR: Google Pages Sitemap Generation FAILED!

Opening   sitemapindex.xml
FS_CAT    
Server    http://dnbdubrecords.com
Save Path 
WS_CAT    / 
Write sitemapindex.xml
Generated Google Sitemap Index Successfully

Array
(
   [QUERY] => Array
       (
           [PRODUCTS] => Array
               (
                   [sTATUS] => success
                   [NUM_ROWS] => 924
               )

           [CATEOGRY] => Array
               (
                   [sTATUS] => success
                   [NUM_ROWS] => 6
               )

           [MANUFACTURERS] => Array
               (
                   [sTATUS] => success
                   [NUM_ROWS] => 344
               )

       )

   [sAVE_FILE_XML] => Array
       (
           [0] => Array
               (
                   [file] => sitemapproducts.xml
                   [status] => success
                   [file_exists] => true
               )

           [1] => Array
               (
                   [file] => sitemapcategories.xml
                   [status] => success
                   [file_exists] => true
               )

           [2] => Array
               (
                   [file] => sitemapmanufacturers.xml
                   [status] => success
                   [file_exists] => true
               )

           [3] => Array
               (
                   [file] => sitemapindex.xml
                   [status] => success
                   [file_exists] => true
               )

       )

)

Share this post


Link to post
Share on other sites

Only 1 of my sitemaps failed to be created with the standard file. Alternate was a complete fail.

The error appears to be that the permissions for the pages file are not correct. You might also want to actually look at the contents of the other maps to be sure they are being created correctly since the paths don't look right.

Share this post


Link to post
Share on other sites

The error appears to be that the permissions for the pages file are not correct. You might also want to actually look at the contents of the other maps to be sure they are being created correctly since the paths don't look right.

 

What should the permission for the pages file be? Its the same as the other files. Tried other permissions with no difference.

The manufacturer, index and products files seem to be fine (when i looked inside them) but the categories file lists each of my categories 3 times (i only have 2 categories and there are 6 entries in the file)

 

I am at a loss.

 

Kurt

Share this post


Link to post
Share on other sites

What should the permission for the pages file be? Its the same as the other files. Tried other permissions with no difference.

The manufacturer, index and products files seem to be fine (when i looked inside them) but the categories file lists each of my categories 3 times (i only have 2 categories and there are 6 entries in the file)

 

I am at a loss.

 

Kurt

The permissions should usually be whatever the images directory use. This won't work for all hosts but will for most. For the categories file, I can't even think of what that might be.

Share this post


Link to post
Share on other sites

I am having a problem generating the index and categories sitemap. I am only getting the sitemapproducts.xml. All files and directories related to the contrib. are 777 and the sitemapproducts.xml looks good and works, know I have around 47,000 products and over 100,000 categories where most products are located under several categories.

 

This is all the confirmation I get whenI run the googlesitemaps/index.php:

Opening   /web/se/www.abergsvtc.se//shop/sitemapproducts.xml
FS_CAT    /web/se/www.abergsvtc.se/
Server    http://www.abergsvtc.se
Save Path /web/se/www.abergsvtc.se//shop/
WS_CAT    /shop/ 
Write /web/se/www.abergsvtc.se//shop/sitemapproducts.xml
Generated Google Product Sitemap Successfully

 

Do I have too many categories?

Edited by murrew

Share this post


Link to post
Share on other sites

I am having a problem generating the index and categories sitemap. I am only getting the sitemapproducts.xml. All files and directories related to the contrib. are 777 and the sitemapproducts.xml looks good and works, know I have around 47,000 products and over 100,000 categories where most products are located under several categories.

 

This is all the confirmation I get whenI run the googlesitemaps/index.php:

Opening   /web/se/www.abergsvtc.se//shop/sitemapproducts.xml
FS_CAT    /web/se/www.abergsvtc.se/
Server    http://www.abergsvtc.se
Save Path /web/se/www.abergsvtc.se//shop/
WS_CAT    /shop/ 
Write /web/se/www.abergsvtc.se//shop/sitemapproducts.xml
Generated Google Product Sitemap Successfully

 

Do I have too many categories?

The problem is, most likely, your configure file is not setup correctly. Notice the // in the urls. See here to correct that.

Share this post


Link to post
Share on other sites

The problem is, most likely, your configure file is not setup correctly. Notice the // in the urls. See here to correct that.

 

I solved on problem and got another error, could there be a problem with the server, because the site is slow in general.

 

Opening   /web/se/www.abergsvtc.se/shop/sitemapproducts.xml
FS_CAT    /web/se/www.abergsvtc.se/
Server    http://www.abergsvtc.se
Save Path /web/se/www.abergsvtc.se/
WS_CAT    /shop/ 
Write /web/se/www.abergsvtc.se/shop/sitemapproducts.xml
Generated Google Product Sitemap Successfully



Fatal error:  Maximum execution time of 30 seconds exceeded in /web/se/www.abergsvtc.se/shop/googlesitemap/sitemap.class.php on line 692

Share this post


Link to post
Share on other sites

I solved on problem and got another error, could there be a problem with the server, because the site is slow in general.

 

Fatal error: Maximum execution time of 30 seconds exceeded in /web/se/www.abergsvtc.se/shop/googlesitemap/sitemap.class.php on line 692[/code]

All shared servers have a timeout limit and it appears yors is being reached. That is not due to any broken code, it is just a limit. I've never had a case where this script failed like that but you have a very large number of categories and products so that is most likely the case. To get around it, you could see if your host will increase that limit (though that is probably unlikely), move to a server that has a higher limit (you'll need to ask your host what options are available) or modify the code so it runs without timing out.

Share this post


Link to post
Share on other sites

All shared servers have a timeout limit and it appears yors is being reached. That is not due to any broken code, it is just a limit. I've never had a case where this script failed like that but you have a very large number of categories and products so that is most likely the case. To get around it, you could see if your host will increase that limit (though that is probably unlikely), move to a server that has a higher limit (you'll need to ask your host what options are available) or modify the code so it runs without timing out.

Ok, any tips on how to run the script without timing out? I have a hosted server and absolutely no control over it.

Share this post


Link to post
Share on other sites

Ok, any tips on how to run the script without timing out? I have a hosted server and absolutely no control over it.

No, it would take a while to go through it. You can try putting in sleep commands but where and for how long will make a big difference.

Share this post


Link to post
Share on other sites

Hello,

 

i also have got some problems (i changed to alternative and and the permissions at the image folder and the google xml seo sitemap are both 777)

 

 

Opening /sitemapproducts.xml

FS_CAT /home/content/68/7349768/html/

Server http://www.chinese-products.net

Save Path /

WS_CAT /

 

 

Warning: fopen(/sitemapproducts.xml) [function.fopen]: failed to open stream: Permission denied in /home/content/68/7349768/html/googlesitemap/sitemap.class_Alternate.php on line 353

 

ERROR: Google Product Sitemap Generation FAILED!

 

Opening /sitemapcategories.xml

FS_CAT /home/content/68/7349768/html/

Server http://www.chinese-products.net

Save Path /

WS_CAT /

 

 

Warning: fopen(/sitemapcategories.xml) [function.fopen]: failed to open stream: Permission denied in /home/content/68/7349768/html/googlesitemap/sitemap.class_Alternate.php on line 353

 

ERROR: Google Category Sitemap Generation FAILED!

 

Opening /sitemapindex.xml

FS_CAT /home/content/68/7349768/html/

Server http://www.chinese-products.net

Save Path /

WS_CAT /

 

 

Warning: fopen(/sitemapindex.xml) [function.fopen]: failed to open stream: Permission denied in /home/content/68/7349768/html/googlesitemap/sitemap.class_Alternate.php on line 353

 

ERROR: Google Sitemap Index Generation FAILED!

 

Array

(

[QUERY] => Array

(

[PRODUCTS] => Array

(

[sTATUS] => success

[NUM_ROWS] => 30

)

 

[CATEOGRY] => Array

(

[sTATUS] => success

[NUM_ROWS] => 15

)

 

)

 

[sAVE_FILE_XML] => Array

(

[0] => Array

(

[file] => /sitemapproducts.xml

[status] => failure

[file_exists] => false

)

 

[1] => Array

(

[file] => /sitemapcategories.xml

[status] => failure

[file_exists] => false

)

 

[2] => Array

(

[file] => /sitemapindex.xml

[status] => failure

[file_exists] => false

)

 

)

 

)

 

 

Please help mee~~~~~~ thanks in advance

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×