Jump to content
Jack_mcs

Google XML Sitemap SEO

Recommended Posts

Thanks for your replies. Stupid question I know but I have installed Sitemap_SEO_V_1.7, but don't have any xml files. How do I generate them? Do I need to have the original contribution installed? The sitemap.php works fine, but can't find the xmls.....any advice very much appreciated...

This is the support thread for Google XML Sitemap SEO, not Sitemap SEO. You may want to look in the support thread for that contribution for answers to your question but, in short, it won't create the map files since that is not its purpose.

Share this post


Link to post
Share on other sites

This is the support thread for Google XML Sitemap SEO, not Sitemap SEO. You may want to look in the support thread for that contribution for answers to your question but, in short, it won't create the map files since that is not its purpose.

 

Ah...that would explain it then - thanks, apologies for silly question! by the way, yr contrib is awesome!

 

graham

Share this post


Link to post
Share on other sites

Hi Jack

 

I've got Google XML Sitemap SEO installed fine and everything work fine, except one thing. My URLs are generated by Ultimate SEO URLs 5, and so reflect the actual product or category name. Unfortunately the sitemap just reflects the original naming convention...

 

i.e.

 

http://www.mygreatsite.co.uk/product_info.php?products_id=63

 

should be

 

http://www.mygreatsite.co.uk/my-lovely-product-p-63.html

 

Any ideas, I would be very grateful for any advice you could give.

 

cheers

 

Graham

Share this post


Link to post
Share on other sites

Hi Jack

 

I've got Google XML Sitemap SEO installed fine and everything work fine, except one thing. My URLs are generated by Ultimate SEO URLs 5, and so reflect the actual product or category name. Unfortunately the sitemap just reflects the original naming convention...

 

i.e.

 

http://www.mygreatsite.co.uk/product_info.php?products_id=63

 

should be

 

http://www.mygreatsite.co.uk/my-lovely-product-p-63.html

 

Any ideas, I would be very grateful for any advice you could give.

 

cheers

 

Graham

 

There are files in the USU5 download to correct this contribution.

Share this post


Link to post
Share on other sites

There are files in the USU5 download to correct this contribution.

 

 

Hi,

 

I have the same problem with not showing the correct urls when using Ultimate SEO URLs 5, could you be more specific where the download files are, becuse I cant find them.

Share this post


Link to post
Share on other sites

Hi,

 

I have the same problem with not showing the correct urls when using Ultimate SEO URLs 5, could you be more specific where the download files are, becuse I cant find them.

 

extras/Google XML Sitemap SEO/

Share this post


Link to post
Share on other sites

Hi Jack,

I guess I'd better phrase that differently if I meet you on a flight to Florida! :lol:

I added a large group of products recently after which the cron job gave errors. "Allowed memory size of 33554432 bytes exhausted". So I upped the php.ini limit from 32M to 64M.

That fixed it I thought, manually running it yes, but the cron job failed again. This time "[<a href='function.fopen'>function.fopen</a>]: failed to open stream: Permission denied in /home/_____/public_html/googlesitemap/sitemap.class.php on line 581"

Assuming it might still be a memory issue I up'd it again to 128M - no effect.

That's when I hit the forums and eventually loaded this contrib rather than using the older google XML sitemap of Chemo's.

Loaded and ran it in a matter of minutes! Thanks for the good easy instructions.

Here's what I searched all over for; An example of correct sitemap output

	<url>
	<loc>http://www.~~~~~~.com/steel-ring-n223123-p-1845.html</loc>
	<lastmod>2009-11-09</lastmod>
	<changefreq>weekly</changefreq>
	<priority>0.1</priority>
</url>

And now my question;

Something in this contribution is causing an overflow file to be created, both are formatted correctly, but I'm getting sitemapproducts.xml and sitemapproducts1.xml

I'm not sure if that was the cause of the failed cron job, both the original Chemo & this contrib make the extra products xml file. The file length is just over 300,000 lines. And it's size is 9003 KB.

Any thoughts or suggestions?

Edited by motorcity

Share this post


Link to post
Share on other sites

Hi Jack,

 

I'm back for more questions :-) I just found out in my Google webmaster tool account, under the submitted sitemap area, it says:

 

URLs not followed

When we tested a sample of URLs from your Sitemap, we found that some URLs redirect to other locations. We recommend that your Sitemap contain URLs that point to the final destination (the redirect target) instead of redirecting to another URL.

 

And Google didn't index most of my pages. Do you know how can I fix that?

 

Thanks soooooo much!

 

 

Sabrina

Share this post


Link to post
Share on other sites

Hi Jack,

I guess I'd better phrase that differently if I meet you on a flight to Florida! :lol: And now my question;

I would just reply, "Not right now but I will be shortly. ;)

Something in this contribution is causing an overflow file to be created, both are formatted correctly, but I'm getting sitemapproducts.xml and sitemapproducts1.xml

Google has a maximum size. When the map gets to that maximum, it starts another map with a number. So there isn't anything wrong. It is just due to the number of your products.

Share this post


Link to post
Share on other sites

URLs not followed

When we tested a sample of URLs from your Sitemap, we found that some URLs redirect to other locations. We recommend that your Sitemap contain URLs that point to the final destination (the redirect target) instead of redirecting to another URL.

 

And Google didn't index most of my pages. Do you know how can I fix that?

You have to look at the errors and see the reason for it. They will list the links that have problems. Try actually going to the link to see if it fails or redirects to somewhere else and go from there.

Share this post


Link to post
Share on other sites

I would just reply, "Not right now but I will be shortly. ;)

Google has a maximum size. When the map gets to that maximum, it starts another map with a number. So there isn't anything wrong. It is just due to the number of your products.

Okay then. Regardless of your height, you're one of those I'll always look up to around here.

~~~ All kidding aside, thanks a million!

Share this post


Link to post
Share on other sites

You have to look at the errors and see the reason for it. They will list the links that have problems. Try actually going to the link to see if it fails or redirects to somewhere else and go from there.

 

The links Google said redirect are the product_info.php files. The links are something like: ...shop/product_info.php?products_id=29, but if I click on it, the "?" part actually changed into the name of the product, I think it's the effect of USU5. How can I fix it? Thanks so much Jack!!

 

Sabrina

Share this post


Link to post
Share on other sites

The links Google said redirect are the product_info.php files. The links are something like: ...shop/product_info.php?products_id=29, but if I click on it, the "?" part actually changed into the name of the product, I think it's the effect of USU5. How can I fix it? Thanks so much Jack!!

 

Sabrina

 

The sitemap looks like it is producing standard urls and when it reaches the site USU5 is correctly 301 redirecting them. There are revised files for this contribution in the extras folder of the USU5 download.

Share this post


Link to post
Share on other sites

The sitemap looks like it is producing standard urls and when it reaches the site USU5 is correctly 301 redirecting them. There are revised files for this contribution in the extras folder of the USU5 download.

 

Hi Robert, thanks for helping me again :-) There are many folders and files in the extras folder of USU5. Would you pleeease tell me how to do it exactly? I love the standard url and would love to keep the way it is :-)

 

Thanks a lot!!!

 

Sabrina

Share this post


Link to post
Share on other sites

sitemapspecials.xml

I have total of 8 products in category specials, however sitemapspecials.xml shows four identical (all English language) links for each product, 32 links in total. The sitemapcategories.xml and sitemapproducts.xml are OK - one link per category and one link per product.

 

Any ideas please?

 

Hi Jack,

 

any updates on the above please?


Absinthe Original Liquor Store

Share this post


Link to post
Share on other sites

I have read several replies on similar issues but have still had no luck resolving this:

 

Warning: require_once(includes/configure.php) [function.require-once]: failed to open stream: No such file or directory in /home/public_html/includes/modules/googlexml/googlesitemap/index.php on line 47

 

Fatal error: require_once() [function.require]: Failed opening required 'includes/configure.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/public_html/includes/modules/googlexml/googlesitemap/index.php on line 47

Share this post


Link to post
Share on other sites

Fatal error: require_once() [function.require]: Failed opening required 'includes/configure.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/public_html/includes/modules/googlexml/googlesitemap/index.php on line 47

If you are using a url rewriter and it works when you turn it off, then that is the reason and installing my latest version (see my signature) will fix it.

Edited by Jack_mcs

Share this post


Link to post
Share on other sites

If you are using a url rewriter and it works when you turn it off, then that is the reason and installing my latest version (see my signature) will fix it.

 

I am using a URL rewriter but I turned it off and get the same error.

Share this post


Link to post
Share on other sites

I am using a URL rewriter but I turned it off and get the same error.

Is your shop located in the root - is there an includes directory in the public_html directory?

Share this post


Link to post
Share on other sites

Is your shop located in the root - is there an includes directory in the public_html directory?

 

The store is located in the root and there is an includes directory in public_html directory. I put the files in includes/modules/ directory. Do they need to be in the root?

 

Thanks in advance for your assistance. Very nice of you to put together such a great contrib but also take time out of your day to answer questions.

Edited by smartin513

Share this post


Link to post
Share on other sites

The store is located in the root and there is an includes directory in public_html directory. I put the files in includes/modules/ directory. Do they need to be in the root?

 

Thanks in advance for your assistance. Very nice of you to put together such a great contrib but also take time out of your day to answer questions.

You're welcome.:)

 

Please enable the diagnostic setting and post the results here.

Share this post


Link to post
Share on other sites

Hi Jack,

 

When I run http:.../shop/googlesitemap/index.php, it says: "Warning: chdir() [function.chdir]: No such file or directory (errno 2) in /hermes/web04/b1844/moo.harperds/shop/googlesitemap/sitemap.class.php on line 535

 

ERROR: Google Pages Sitemap Generation FAILED!"

 

Would you please help me?

 

Thanks a toooon!

 

 

Sabrina

Share this post


Link to post
Share on other sites

When I run http:.../shop/googlesitemap/index.php, it says: "Warning: chdir() [function.chdir]: No such file or directory (errno 2) in /hermes/web04/b1844/moo.harperds/shop/googlesitemap/sitemap.class.php on line 535

 

ERROR: Google Pages Sitemap Generation FAILED!"

 

If you have tried te alternate setting, do that first. If it still fails, please run the dianostic and post the results here.

Share this post


Link to post
Share on other sites

If you have tried te alternate setting, do that first. If it still fails, please run the dianostic and post the results here.

 

Yes, I have tried the alternate setting. It shows the same message:

 

Write /home/users/web/b1844/moo.XXXX/shop/googlesitemap/sitemapproducts.xml

Generated Google Product Sitemap Successfully

 

Write /home/users/web/b1844/moo.XXXX/shop/googlesitemap/sitemapcategories.xml

Generated Google Category Sitemap Successfully

 

Google Sitemap Manufacturers not generated - no Manufacturers found!

 

Write /home/users/web/b1844/moo.XXXX/shop/googlesitemap/sitemapspecials.xml

Generated Google Specials Sitemap Successfully

 

 

 

Warning: chdir() [function.chdir]: No such file or directory (errno 2) in /hermes/web04/b1844/moo.XXXX/shop/googlesitemap/sitemap.class.php on line 535

 

ERROR: Google Pages Sitemap Generation FAILED!

 

Write /home/users/web/b1844/moo.XXXX/shop/googlesitemap/sitemapindex.xml

Generated Google Sitemap Index Successfully

 

Array

(

[QUERY] => Array

(

[PRODUCTS] => Array

(

[sTATUS] => success

[NUM_ROWS] => 62

)

 

[CATEOGRY] => Array

(

[sTATUS] => success

[NUM_ROWS] => 10

)

 

[MANUFACTURERS] => Array

(

[sTATUS] => success

[NUM_ROWS] => 0

)

 

[sPECIALS] => Array

(

[sTATUS] => success

[NUM_ROWS] => 3

)

 

)

 

[sAVE_FILE_XML] => Array

(

[0] => Array

(

[file] => /home/users/web/b1844/moo.XXXX/shop/googlesitemap/sitemapproducts.xml

[status] => success

[file_exists] => true

)

 

[1] => Array

(

[file] => /home/users/web/b1844/moo.XXXX/shop/googlesitemap/sitemapcategories.xml

[status] => success

[file_exists] => true

)

 

[2] => Array

(

[file] => /home/users/web/b1844/moo.XXXX/shop/googlesitemap/sitemapspecials.xml

[status] => success

[file_exists] => true

)

 

[3] => Array

(

[file] => /home/users/web/b1844/moo.XXXX/shop/googlesitemap/sitemapindex.xml

[status] => success

[file_exists] => true

)

 

)

 

)

 

So mostly it shows the successful message, except that one part which says:

 

Warning: chdir() [function.chdir]: No such file or directory (errno 2) in /hermes/web04/b1844/moo.XXXX/shop/googlesitemap/sitemap.class.php on line 535

 

ERROR: Google Pages Sitemap Generation FAILED!

 

Thank a lot for helping me, Jack!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×