Jump to content
Jack_mcs

Google XML Sitemap SEO

Recommended Posts

Jack,

 

I read mention of this in this forum back around page 14, but no solution.

 

I can generate succesfully (with those NOTICE warnings mentioned previously) but when I run CRON

php /var/www/xxx/googlesitemap/index.php

 

I get errors:

PHP Warning: require_once(includes/configure.php): failed to open stream: No such file or directory in /var/www/xxx/googlesitemap/index.php on line 46

PHP Fatal error: require_once(): Failed opening required 'includes/configure.php' (include_path='.:/usr/share/pear:/usr/share/php') in /var/www/xxx/googlesitemap/index.php on line 46

 

Earlier suggestions say converting all of the Require_once to full path may help, but that seems like a hack workaround instead of a fix. I'm running RHEL5.

 

Would you have any suggestion?


-Dave

Share this post


Link to post
Share on other sites

hi Jack,

 

i have installed the contribution ULTIMATE_Seo_Urls_5

how can i generate the sitemap for this urls?

my index are here

 

thanks

See the previous posts on this topic or see the SEO5 thread.

Share this post


Link to post
Share on other sites

I get errors:

PHP Warning: require_once(includes/configure.php): failed to open stream: No such file or directory in /var/www/xxx/googlesitemap/index.php on line 46

PHP Fatal error: require_once(): Failed opening required 'includes/configure.php' (include_path='.:/usr/share/pear:/usr/share/php') in /var/www/xxx/googlesitemap/index.php on line 46

It's due to how permissions are setup on the server. Your host should be able to help with fixing that. It involves cd'ing into the googlesitemap directory before running the script.

Share this post


Link to post
Share on other sites

Thanks Jack.

 

This worked:

 

cd /var/www/xxx/googlesitemap/; php index.php

Edited by Roaddoctor

-Dave

Share this post


Link to post
Share on other sites

See the previous posts on this topic or see the SEO5 thread.

 

 

i replace two files from old version

 

catalog/googlesitemap/index.php

catalog/googlesitemap/sitemap.class

 

it is a problem?

Share this post


Link to post
Share on other sites

If you are reverting to an old version, you lose whatever fixes or improvements were made in the new version. Reverting to an older version just to get another contribution to work is, generally, a bad idea. If SEO5 can't be made to work with this contribution then I suggest you switch to Ultimate SEO V 2.2d.

Share this post


Link to post
Share on other sites

Share this post


Link to post
Share on other sites

Good Morning Jack,

 

New products I am adding to my database are not being added to sitemapproducts.xml file.

 

I installed GoogleXmlSitemaps SEO without a problem. It found every product in the database and generated sitemapproducts.xml with all the products in the database at the time. I set up the cron job for daily and every day I get a success message.

 

Even though I continue to add new products to my catalog, the new products are not added to the sitemap. The sitemap is identical to the original one generated. I have verified 777 as the permissions on all sitemaps. What could be the problem?

 

url: http://www.forkliftsystems.com

sitemap: http://www.forklifts...itemapindex.xml

http://www.forklifts...temap/index.php to manually generate sitemap

Share this post


Link to post
Share on other sites

Try running the script manually and see if the products show up in the map.

Share this post


Link to post
Share on other sites

 

The language is picked by the current setting. You can run them manually by switching to the other lanauge in the shop and then creating the sitemaps. But to have it done automatically, the code will need to be changed. I will add that to the list (it's probably already there) and include it with the next update.

 

Jack

 

Hi Jack,

I was wondering if you'd had a chance to add the languages in the latest update, and if so, will special character conversions be taken care of?

 

Thank you


~ Don't mistake my kindness for weakness ~

Share this post


Link to post
Share on other sites

Hi Jack,

I was wondering if you'd had a chance to add the languages in the latest update, and if so, will special character conversions be taken care of?

 

Thank you

No, I haven't worked on it. I can't say about the special characters.

Share this post


Link to post
Share on other sites

Hi Jack.

 

I've installed Google XML Sitemap and after a few changes with Ultimate Seo URL contribution it works fine.

 

But there is one thing that i cant get thru.

When i'm opening http://www.mysite.com/googlesitemap/index.php everything is genereting fine.

But all the maps are genereting withous "www" in address.

So it looks like this:

Here is your sitemap index: http://mysite.com/sitemapindex.xml

Here is your product sitemap: http://mysite.com/sitemapproducts.xml

Here is your category sitemap: http://mysite.com/sitemapcategories.xml

Here is your manufacturers sitemap: http://mysite.com.pl/sitemapmanufacturers.xml

 

 

 

Do You have any idea why it happends?

What i need to change to get full site address with "www" ?

Thanks!

Share this post


Link to post
Share on other sites

The url is built using the domain name in the configure file. You will have to edit that to have the url's as you want them. There shouldn't have been any need to change anything in Ultimate SEO though. If you had to do that to get it to work, then there might be something wrong with the version you are using. This contribution is 100% compatible with my last version of Ultimate SEO - v 2.2d.

Share this post


Link to post
Share on other sites

Hello!

 

I have the same problem as Roaddoctor

 

 

Notice: Undefined variable: cName in / home / catalog / includes / classes / seo.class.php on line 1001

 

There's a workaround for this bug?

 

Thanks !

Edited by polo37

Share this post


Link to post
Share on other sites

There's a workaround for this bug?

Sounds like you have an old version of Ultimate SEO installed. It should be updated.

Share this post


Link to post
Share on other sites

Sounds like you have an old version of Ultimate SEO installed. It should be updated.

 

I installed the version "Ultimate_SEO_URLSv22d_5"

 

After verification, the problem just the contrib Flash Carousel actually.

Share this post


Link to post
Share on other sites

Thanks Jack

 

 

Does the add-on can be used in DEUTSCH or ESPANOL?

 

 

and how to make it generates the DEUTSCH or ESPANOL sitemap?

 

 

 

Thanks

Edited by zozzoozzz

Share this post


Link to post
Share on other sites

I installed the version "Ultimate_SEO_URLSv22d_5"

 

After verification, the problem just the contrib Flash Carousel actually.

This contribution doesn't know about contributions. It just handles the url's it is given and converts them. If the url isn't in the correct format, then it will fail. So it seems that contribution has some coding problem and you would need to ask in its support thread. I should add though that I have installed both contributions into a shop and they work fine together, but that was eariler in the year so maybe that contribution has changed since then.

Share this post


Link to post
Share on other sites

Does the add-on can be used in DEUTSCH or ESPANOL?

 

and how to make it generates the DEUTSCH or ESPANOL sitemap?

I was planning this for the next version but haven't had time to test it (see note below regarding this). So if you try it, please let me know how it works.

 

In googlesitemap/index.php, find this code

	include_once(DIR_WS_CLASSES . 'language.php');
$lng = new language();
$languages_id = $lng->language['id'];

and replace it with

    if (isset($_GET['language']))
     $languages_id = (int)$_GET['language'];
   else
   {
  include_once(DIR_WS_CLASSES . 'language.php');
  $lng = new language();
  $languages_id = $lng->language['id'];
}

Then to create sitemaps for other languages, use a url like this

where 2 is the id of the language you want the maps in.

 

If you have more than one language, you then need to rename the maps to something else, like sitemapcategories_spanish.xml and add that new map to your google account.

 

The above is not a simple thing to do all of the time and I plan on automating it but it is better than nothing. The problem with this is that without some indication the pages are in different languages, google may see them as duplicate pages. I don't know of any way to know for sure though other than to try it.

Edited by Jack_mcs

Share this post


Link to post
Share on other sites

I have Ultimate SEO URLs 2-2.2d-4 and GoogleXML_sitemap_1.4 installed and all appears to be working fine. My problem is that when I generate the "sitemapproducts.xml" the links there contain the category parent but the actual links generated by Ultimate SEO URL is configured not to include the category (and in fact they are not visible in the browser). I don't include the category parent in the URLs and don't want it included in the sitemap.

For example the link

appears in "sitemapproducts.xml" as

Both URLs will reach the correct page.

I have "Reset SEO URLs Cache" and toggled the Enable cache for both Products and Categories in the Admin panel.

I'm no doubt overlooking something obvious but I've run out of ideas. Any thoughts or guidance?

Thanks,

Ralph

Share this post


Link to post
Share on other sites

There is a coding mistake in 2.2d-4 that doesn't test for the category name correctly. You need to upgrade to the 2.2d-5.

Share this post


Link to post
Share on other sites

I was planning this for the next version but haven't had time to test it (see note below regarding this). So if you try it, please let me know how it works.

 

In googlesitemap/index.php, find this code

	include_once(DIR_WS_CLASSES . 'language.php');
$lng = new language();
$languages_id = $lng->language['id'];

and replace it with

    if (isset($_GET['language']))
     $languages_id = (int)$_GET['language'];
   else
   {
  include_once(DIR_WS_CLASSES . 'language.php');
  $lng = new language();
  $languages_id = $lng->language['id'];
}

Then to create sitemaps for other languages, use a url like thiswhere 2 is the id of the language you want the maps in.

 

If you have more than one language, you then need to rename the maps to something else, like sitemapcategories_spanish.xml and add that new map to your google account.

 

The above is not a simple thing to do all of the time and I plan on automating it but it is better than nothing. The problem with this is that without some indication the pages are in different languages, google may see them as duplicate pages. I don't know of any way to know for sure though other than to try it.

 

 

 

 

Thank your very much Jack.

 

 

 

I will try and at then response to you.

Share this post


Link to post
Share on other sites

Is it common to see only 2% of the URLs in a sitemap indexed after 24 hours? Should we expect the percentage to increase over time? Or only after each re-submission?

Edited by mdtaylorlrim

Community Bootstrap Edition, Edge

 

Avoid the most asked question. See How to Secure My Site and How do I...?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×