Jump to content
Jack_mcs

Google XML Sitemap SEO

Recommended Posts

I'm sorry but I don't have an answer for you. Nor do I have a setup with Greek instaled so I can't test it either.

 

Jack

 

Hi Jack.

 

The issue wit Greek is the same like Germa, spanish,cyrillic etc where some specialchars (ie φ, ξ, ä, ü) are in use. If I turn my shops default language to english, the everything works fine. But I need to have greek as the default language, and I don't want to change this each time I'm creating a new sitemap

 

One solution would be to make the sitemap.class.php to use the english language ID, doesn't matter what's the default language. It would turn out the same result, as each product is listed once and not separately for each language. But I don't know how this will affect the search results, as people are searching in google using Greek characters

 

The other solution is to make the sitemap.class.php to create the url's using the greek characters. As I understand, the url's descriptions are coming from the database using the product_name from table products IF SEO url's is enabled

 

My particular questions are (code from sitemap.class.php):

1) Is the url "text" getting created from the beginning (doesn't matter what happened in seo.class.php) here?

while( $result = $this->DB->FetchArray($products_query) ){
			$top = max($top, $result['products_ordered']);
			$location = $this->hrefLink(FILENAME_PRODUCT_INFO, 'products_id=' . $result['pID'], 'NONSSL', false);
			$lastmod = $this->NotNull($result['last_mod']) ? $result['last_mod'] : $result['date_added'];
			$changefreq = GOOGLE_SITEMAP_PROD_CHANGE_FREQ;
			$ratio = $top > 0 ? $result['products_ordered']/$top : 0;
			$priority = $ratio < .1 ? .1 : number_format($ratio, 1, '.', ''); 

			$container[] = array('loc' => htmlspecialchars(utf8_encode($location)),
								 'lastmod' => date ("Y-m-d", strtotime($lastmod)),
								 'changefreq' => $changefreq,
								 'priority' => $priority

Here I see 2 things to alter

1.1)The one is the

$container[] = array('loc' => htmlspecialchars(utf8_encode($location)),

Is the character encoding defined here? Is this line passing the character through html chars?

1.2)The other is the

$location = $this->hrefLink(FILENAME_PRODUCT_INFO, 'products_id=' . $result['pID'], 'NONSSL', false);

If I take the ---- 'NONSSL', false ---- out, then I'm getting an error about missing parameters that are getting used in the code of point 2. So I need to replace them with something

 

2) Or are the parameters coming from e seo.class.php here?

function hrefLink($page, $parameters, $connection, $add_session_id) {
	if ( defined('SEO_URLS') && SEO_URLS == 'true' || defined('SEO_ENABLED') && SEO_ENABLED == 'true' ) {
		return tep_href_link($page, $parameters, $connection, $add_session_id);
	} else {
		return $this->base_url . $page . '?' . $parameters;
	}
} # end function

If I take the IF/ELSE away, using the "else" part all the time, then I get url's in the original manner.

 

Sometimes I wish I would live in an english speaking country !

Edited by multimixer

Share this post


Link to post
Share on other sites

Jack, hallelujah, I found it :) :) :)

 

Trying last night, I didn't try the obvious, but I did today in the morning

 

In line 468 of sitemap.class.php there is the code

$container[] = array('loc' => htmlspecialchars(utf8_encode($location)),

 

I just took the htmlspecialchars thing out and converted the line to:

$container[] = array('loc' => $location,

 

And I'm getting very nice greek character for google :)

 

I think that people using any type of special characters in their url's like German, spanish,cyrillic etc where some specialchars (ie φ, ξ, ä, ü) appear will have the same problem.

 

Why to use this "...... htmlspecialchars(utf8_encode ........" at all? It doesn't hurt English and other charsets don't benefit from

 

Is, taking this out, causing any other problems?

Edited by multimixer

Share this post


Link to post
Share on other sites

I do hate to sound like a wet fart here but I have run into a problem.

 

When going to MYDOMAIN/googlesitemap/index.php I am taken to the install instructions (MYDOMAIN/googlesitemap/index.html / Google XML Sitemap Feed Documentation)

 

I have triple checked my files are all there, set all the permissions to 777 :blink:

 

Kinda stumped, could it be something to do with my HTAcess file?

 

# $Id: .htaccess 1739 2007-12-20 00:52:16Z hpdl $

#

# This is used with Apache WebServers

#

# For this to work, you must include the parameter 'Options' to

# the AllowOverride configuration

#

# Example:

#

#<Directory "/usr/local/apache/htdocs">

# AllowOverride Options

#</Directory>

 

Options +FollowSymlinks

RewriteEngine on

RewriteBase /

RewriteCond %{HTTP_HOST} ^(www\.)?ukgamingcomputers\.com [NC]

RewriteRule ^(.*)$ http://www.ukgamingcomputers.co.uk/$1 [R=301,L]

RewriteCond %{THE_REQUEST} ^[A-Z]{3,9}\ /.*index\.html\ HTTP/

RewriteRule ^(.*)index\.html$ http://www.ukgamingcomputers.co.uk/$1 [R=301,L]

RewriteCond %{HTTP_HOST} ^ukgamingcomputers\.co.uk

RewriteRule (.*) http://www.ukgamingcomputers.co.uk/$1 [R=301,L]

RewriteCond %{THE_REQUEST} ^.*/index.php

RewriteRule ^(.*)index.php$ http://www.ukgamingcomputers.co.uk/$1 [R=301,L]

#Ultimate SEO URLS#

RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-m-([0-9]+).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pi-([0-9]+).html$ popup_image.php?pID=$2&%{QUERY_STRING}

RewriteRule ^(.*)-t-([0-9]+).html$ articles.php?tPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-a-([0-9]+).html$ article_info.php?articles_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pr-([0-9]+).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pri-([0-9]+).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-i-([0-9]+).html$ information.php?info_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pm-([0-9]+).html$ extra_info_pages.php?pages_id=$2&%{QUERY_STRING}

 

SetEnvIfNoCase Request_URI IP_Trapped\.txt ban

<Files ~ "^.*$">

order allow,deny

allow from all

deny from env=ban

</Files>

 

 

 

#

#

#

# 'All' with also work. (This configuration is in the

# apache/conf/httpd.conf file)

 

# The following makes adjustments to the SSL protocol for Internet

# Explorer browsers

 

#<IfModule mod_setenvif.c>

# <IfDefine SSL>

# SetEnvIf User-Agent ".*MSIE.*" \

# nokeepalive ssl-unclean-shutdown \

# downgrade-1.0 force-response-1.0

# </IfDefine>

#</IfModule>

 

# If Search Engine Friendly URLs do not work, try enabling the

# following Apache configuration parameter

 

# AcceptPathInfo On

 

# Fix certain PHP values

# (commented out by default to prevent errors occuring on certain

# servers)

 

# php_value session.use_trans_sid 0

#php_value register_globals 1

Share this post


Link to post
Share on other sites

You're seing the install instructions. Your server is probably setup to load index.html before index.php. Try deleting the googlesitemap/index.html file to see if it helps. If not, you'll need to have your host adjust how the files are loaded.

 

Jack

Share this post


Link to post
Share on other sites

Wow! Thankyou for the prompt reply :)

 

I have deleted the index.html file and now receive;

 

Internal Server Error

 

The server encountered an internal error or misconfiguration and was unable to complete your request.

 

Please contact the server administrator, webmaster@ukgamingcomputers.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

 

More information about this error may be available in the server error log.

 

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Apache/2.2.11 (Unix) mod_ssl/2.2.11 OpenSSL/0.9.8e-fips-rhel5 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 mod_jk/1.2.25 Server at www.ukgamingcomputers.co.uk Port 80

Share this post


Link to post
Share on other sites

Just incase this helps, thse are the entries from my error log;

 

[Mon Jul 13 19:55:48 2009] [error] [client 82.23.38.199] File does not exist: /home/ukgaming/public_html/500.shtml

[Mon Jul 13 19:55:48 2009] [error] [client 82.23.38.199] SoftException in Application.cpp:252: File "/home/ukgaming/public_html/googlesitemap/index.php" is writeable by group

[Mon Jul 13 19:55:44 2009] [error] [client 82.23.38.199] File does not exist: /home/ukgaming/public_html/404.shtml, referer: http://www.ukgamingcomputers.co.uk/stylesheet.css

[Mon Jul 13 19:55:44 2009] [error] [client 82.23.38.199] File does not exist: /home/ukgaming/public_html/images/line_x.gif, referer: http://www.ukgamingcomputers.co.uk/stylesheet.css

[Mon Jul 13 19:55:44 2009] [error] [client 82.23.38.199] File does not exist: /home/ukgaming/public_html/404.shtml, referer: http://www.ukgamingcomputers.co.uk/stylesheet.css

[Mon Jul 13 19:55:44 2009] [error] [client 82.23.38.199] File does not exist: /home/ukgaming/public_html/404.shtml, referer: http://www.ukgamingcomputers.co.uk/stylesheet.css

[Mon Jul 13 19:55:44 2009] [error] [client 82.23.38.199] File does not exist: /home/ukgaming/public_html/images/name2_bg.gif, referer: http://www.ukgamingcomputers.co.uk/stylesheet.css

[Mon Jul 13 19:55:44 2009] [error] [client 82.23.38.199] File does not exist: /home/ukgaming/public_html/images/line_y.gif, referer: http://www.ukgamingcomputers.co.uk/stylesheet.css

[Mon Jul 13 19:55:44 2009] [error] [client 82.23.38.199] File does not exist: /home/ukgaming/public_html/404.shtml, referer: http://www.ukgamingcomputers.co.uk/stylesheet.css

[Mon Jul 13 19:55:44 2009] [error] [client 82.23.38.199] File does not exist: /home/ukgaming/public_html/images/bg_list_hline.gif, referer: http://www.ukgamingcomputers.co.uk/stylesheet.css

Share this post


Link to post
Share on other sites
Wow! Thankyou for the prompt reply :)

 

I have deleted the index.html file and now receive;

..............

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

 

Is it possible that you uploaded the html file instead of the php?

Share this post


Link to post
Share on other sites
Is it possible that you uploaded the html file instead of the php?

 

Its definitely there multimixer...

 

Re-uploaded it too.

Share this post


Link to post
Share on other sites

Working on "[Mon Jul 13 19:55:48 2009] [error] [client 82.23.38.199] SoftException in Application.cpp:252: File "/home/ukgaming/public_html/googlesitemap/index.php" is writeable by group"

 

I checked my permissions again and again to no avail :( Submitted a help ticket to my hosts. Then reset the permissions and now it seems to work :D

 

Sorry to clog up this most excellent thread.

 

Cheers for the help though guys, appreciate it.

Share this post


Link to post
Share on other sites

Hello,

 

I just want to say thank you very much to Jack.

Your contribution work like a charm.

Install it and everything work perfect.

 

Btw, is this Google XML Sitemap SEO will be automatically send update to Google ?

 

Thank you very much.

Edited by midave

Share this post


Link to post
Share on other sites
Hello,

 

I just want to say thank you very much to Jack.

Your contribution work like a charm.

Install it and everything work perfect.

 

Btw, is this Google XML Sitemap SEO will be automatically send update to Google ?

 

Thank you very much.

You're welcome. :)

 

You have to setup a cron job for the maps to be created automatically. You also have to create entries for them in a google sitemap account. Once both of those are done,the process is automatic.

 

Jack

Share this post


Link to post
Share on other sites

Hi. I had an older version installed, now I installed the latest. But when i go to http://www.mysite.com/googlesitemap/index.php I get this error:

 

Fatal error: Call to undefined function tep_get_parent_categories() in /home/muccelmi/public_html/includes/seo_cache.php on line 180

 

The lines are (second is 180): I have to mention I'm not sute what else I installed some time ago...

 

		# Get the category path
	tep_get_parent_categories($c, $record['id']);
	# For some reason it seems to return in reverse order so reverse the array
	$c = array_reverse($c);
	# Implode the array to get the full category path
	$id = (implode('_', $c) ? implode('_', $c) . '_' . $record['id'] : $record['id']);
	# Add the defines to the output string		
	$cat_cache .= 'define(\'CATEGORY_NAME_' . $id . '\', \'' . $parent_name . $name . '\'); ' . "\n";
	$cat_cache .= 'define(\'' . $parent_name . $name . '\', \'cPath=' . $id . '\'); ' . "\n";		
	# Add the category name to the container array 
	$cat_container[$parent_name . $name] = array('id' => $id, 'counter' => 1);
}
# Save the cached data to the database
# Params: [ cache name, cache data, compressed, global ]
$cache->save_cache($cache_file . 'categories', $cat_cache, 'EVAL', 1 , 1);
# Unset the arrays used - could be large, clean as we go!
unset($cat_array, $cat_container, $cat_cache);
}# end if categories is not cached

 

 

Thank you


My Tiny Contribution - Romanian Buttons

Share this post


Link to post
Share on other sites
Hi. I had an older version installed, now I installed the latest. But when i go to http://www.mysite.com/googlesitemap/index.php I get this error:

 

Fatal error: Call to undefined function tep_get_parent_categories() in /home/muccelmi/public_html/includes/seo_cache.php on line 180

If you have a /includes/seo_cache.php file, remove it.

 

Jack

Share this post


Link to post
Share on other sites

Jack can you help please?

 

I have installed version 1.3.

I have 2 concerns:

 

First, on permissions, if I understand the instructions correctly these files need to have 777 permission?

 

sitemapcategories.xml

sitemapspecials.xml

sitemapproducts.xml

sitemappages.xml

sitemapindex.xml

sitemapmanufacturers.xml

 

what about the googlesitemap directory?

 

 

My second concern is this, the sitemap only picks up English language.

I had to tick "alternate" in configuration for it to generate the sitemap, but it only generates the english links, the other languages aren't getting picked up. I have a 4 language site.

How do I make it generate all links in all languages?

 

 

Thank you in advance.


~ Don't mistake my kindness for weakness ~

Share this post


Link to post
Share on other sites

Hi, Ive do the install, but when i try to load the googlesitemap/index.php i'm getting the below error message,

 

Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 262144 bytes) in /home/kuauptfk/public_html/googlesitemap/sitemap.class_Alternate.php on line 477

 

I have 90,000 products.. would that have anything to do with it?

 

if anyone could help i would be very grateful,

 

thank you

Share this post


Link to post
Share on other sites

The permissions should be set to what is correct for your server. Use the images directory to find the correct settings and set them the same. The googlesitemap directory doesn't reqire any special settings.

 

The language is picked by the current setting. You can run them manually by switching to the other lanauge in the shop and then creating the sitemaps. But to have it done automatically, the code will need to be changed. I will add that to the list (it's probably already there) and include it with the next update.

 

Jack

Share this post


Link to post
Share on other sites

Hi Jack mcs!

 

I installed the last 1.3 version. I like it, and Thanks!

 

I use articles manager. In the previous 1.1 version I installed manually the articles into XML files. Now I find it starts to work! But I suggest that over 10 articles number dont inserted in the xml. How could I solve it or where find the inputs? Is it normal or better to put in manually?

 

Gergely


:blink:
osCommerce based shop owner with minimal design and focused on background works. When the less is more.
Email managment with tracking pixel, package managment for shipping, stock management, warehouse managment with bar code reader, parcel shops management on 3000 pickup points without local store.

Share this post


Link to post
Share on other sites
Hi Jack mcs!

 

I installed the last 1.3 version. I like it, and Thanks!

 

I use articles manager. In the previous 1.1 version I installed manually the articles into XML files. Now I find it starts to work! But I suggest that over 10 articles number dont inserted in the xml. How could I solve it or where find the inputs? Is it normal or better to put in manually?

 

Gergely

 

 

Yes, I find the reason :D You sort the Path= and not the Articles_id=. Sorry for it. :blush:


:blink:
osCommerce based shop owner with minimal design and focused on background works. When the less is more.
Email managment with tracking pixel, package managment for shipping, stock management, warehouse managment with bar code reader, parcel shops management on 3000 pickup points without local store.

Share this post


Link to post
Share on other sites

Hi Guys!!...

 

I just uploaded the last google sitemap SEO into example.com/sitemapindex.xml. But when i try to open in a browser, show this error

 

XML Parsing Error: not well-formed

Location: http://example.com/sitemapindex.xml

Line Number 345, Column 15:

$content = '<?xml-stylesheet type="text/xsl" href="gss.xsl"?>' . "\n";

----------------------------^

 

 

How can i solve this problem?

 

Thanks before..

Share this post


Link to post
Share on other sites
Hi Guys!!...

 

I just uploaded the last google sitemap SEO into example.com/sitemapindex.xml. But when i try to open in a browser, show this error

 

 

 

 

How can i solve this problem?

 

Thanks before..

Start by running the dianogstic routine.

 

Jack

Share this post


Link to post
Share on other sites

Actually i got same error like Benjjj6 (first page)... i do as your suggestion on ur #7 post.

and i got this error

 

====

Opening http://jengayu.com/www/sitemapproducts.xml

FS_CAT http://jengayu.com/www/

Server http://jengayu.com

Save Path http://jengayu.com/www/

WS_CAT /

 

 

Warning: fopen() [function.fopen]: URL file-access is disabled in the server configuration in /home/sloki/user/h88182/sites/jengayu.com/www/googlesitemap/sitemap.class.php on line 293

 

 

 

Warning: fopen(http://jengayu.com/www/sitemapproducts.xml) [function.fopen]: failed to open stream: no suitable wrapper could be found in /home/sloki/user/h88182/sites/jengayu.com/www/googlesitemap/sitemap.class.php on line 293

 

ERROR: Google Product Sitemap Generation FAILED!

 

Opening http://jengayu.com/www/sitemapcategories.xml

FS_CAT http://jengayu.com/www/

Server http://jengayu.com

Save Path http://jengayu.com/www/

WS_CAT /

 

 

Warning: fopen() [function.fopen]: URL file-access is disabled in the server configuration in /home/sloki/user/h88182/sites/jengayu.com/www/googlesitemap/sitemap.class.php on line 293

 

 

 

Warning: fopen(http://jengayu.com/www/sitemapcategories.xml) [function.fopen]: failed to open stream: no suitable wrapper could be found in /home/sloki/user/h88182/sites/jengayu.com/www/googlesitemap/sitemap.class.php on line 293

 

ERROR: Google Category Sitemap Generation FAILED!

 

Opening http://jengayu.com/www/sitemapindex.xml

FS_CAT http://jengayu.com/www/

Server http://jengayu.com

Save Path http://jengayu.com/www/

WS_CAT /

 

 

Warning: fopen() [function.fopen]: URL file-access is disabled in the server configuration in /home/sloki/user/h88182/sites/jengayu.com/www/googlesitemap/sitemap.class.php on line 293

 

 

 

Warning: fopen(http://jengayu.com/www/sitemapindex.xml) [function.fopen]: failed to open stream: no suitable wrapper could be found in /home/sloki/user/h88182/sites/jengayu.com/www/googlesitemap/sitemap.class.php on line 293

 

ERROR: Google Sitemap Index Generation FAILED!

 

Array

(

[QUERY] => Array

(

[PRODUCTS] => Array

(

[sTATUS] => success

[NUM_ROWS] => 47

)

 

[CATEOGRY] => Array

(

[sTATUS] => success

[NUM_ROWS] => 18

)

 

)

 

[sAVE_FILE_XML] => Array

(

[0] => Array

(

[file] => http://jengayu.com/www/sitemapproducts.xml

[status] => failure

[file_exists] => false

)

 

[1] => Array

(

[file] => http://jengayu.com/www/sitemapcategories.xml

[status] => failure

[file_exists] => false

)

 

[2] => Array

(

[file] => http://jengayu.com/www/sitemapindex.xml

[status] => failure

[file_exists] => false

)

 

)

 

)

====

 

 

I save my "sitemapproducts.xml" on my root, but why this error said that my sitemapproducts.xml on my www directory??

 

 

 

You said on your 9# post that we must edited line 266, which file? sitemap_class.php? but i didn't find that line...??

 

I only find this

$this->savepath = DIR_FS_CATALOG;

 

 

Best Regards

Edited by leebra

Share this post


Link to post
Share on other sites
Warning: fopen() [function.fopen]: URL file-access is disabled in the server configuration

This is due to a server setting. You'll need to ask your host to enable that setting.

 

Jack

Share this post


Link to post
Share on other sites

Jack, i change my server setting. So fopen function can be loaded but still show an error.

 

(googlesitemap directory set to 775)

 

Opening http://jengayu.com/www/sitemapproducts.xml

FS_CAT http://jengayu.com/www/

Server http://jengayu.com

Save Path http://jengayu.com/www/

WS_CAT /

Opening http://jengayu.com/www/sitemapproducts.xml

FS_CAT http://jengayu.com/www/

Server http://jengayu.com

Save Path http://jengayu.com/www/

WS_CAT /

 

 

Warning: fopen(http://jengayu.com/www/sitemapproducts.xml) [function.fopen]: failed to open stream: HTTP wrapper does not support writeable connections in /home/sloki/user/h88182/sites/jengayu.com/www/googlesitemap/sitemap.class.php on line 349

 

ERROR: Google Product Sitemap Generation FAILED!

 

Opening http://jengayu.com/www/sitemapcategories.xml

FS_CAT http://jengayu.com/www/

Server http://jengayu.com

Save Path http://jengayu.com/www/

WS_CAT /

Opening http://jengayu.com/www/sitemapcategories.xml

FS_CAT http://jengayu.com/www/

Server http://jengayu.com

Save Path http://jengayu.com/www/

WS_CAT /

 

 

Warning: fopen(http://jengayu.com/www/sitemapcategories.xml) [function.fopen]: failed to open stream: HTTP wrapper does not support writeable connections in /home/sloki/user/h88182/sites/jengayu.com/www/googlesitemap/sitemap.class.php on line 349

 

ERROR: Google Category Sitemap Generation FAILED!

 

Opening http://jengayu.com/www/sitemapindex.xml

FS_CAT http://jengayu.com/www/

Server http://jengayu.com

Save Path http://jengayu.com/www/

WS_CAT /

Opening http://jengayu.com/www/sitemapindex.xml

FS_CAT http://jengayu.com/www/

Server http://jengayu.com

Save Path http://jengayu.com/www/

WS_CAT /

 

 

Warning: fopen(http://jengayu.com/www/sitemapindex.xml) [function.fopen]: failed to open stream: HTTP wrapper does not support writeable connections in /home/sloki/user/h88182/sites/jengayu.com/www/googlesitemap/sitemap.class.php on line 349

 

ERROR: Google Sitemap Index Generation FAILED!

 

Array

(

[QUERY] => Array

(

[PRODUCTS] => Array

(

[sTATUS] => success

[NUM_ROWS] => 51

)

 

[CATEOGRY] => Array

(

[sTATUS] => success

[NUM_ROWS] => 18

)

 

)

 

[sAVE_FILE_XML] => Array

(

[0] => Array

(

[file] => http://jengayu.com/www/sitemapproducts.xml

[status] => failure

[file_exists] => false

)

 

[1] => Array

(

[file] => http://jengayu.com/www/sitemapcategories.xml

[status] => failure

[file_exists] => false

)

 

[2] => Array

(

[file] => http://jengayu.com/www/sitemapindex.xml

[status] => failure

[file_exists] => false

)

 

)

 

)

 

 

Am i have to set googlesitemap directory into 777 ??

Share this post


Link to post
Share on other sites
Jack, i change my server setting. So fopen function can be loaded but still show an error.

 

(googlesitemap directory set to 775)

 

Am i have to set googlesitemap directory into 777 ??

The permissions on the googlesitemap directory don't need to be changed. Those on the sitemap files do have to be changed though. Although I suspect it has something to do with your confiugre file since all of those locations shown in the output should not be the same. You might want to look at this thread.

 

Jack

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×