Jump to content
Latest News: (loading..)
bumbarash

[Contribution] iOSC - mobile version of OSC on your iPhone

Recommended Posts

Hello Larry @@Lary_an,

 

Your mobile rewrite rules are wrong. It should be:

# IOSC mobile site
RewriteRule ^(.*)-mp-([0-9]+).html$ mobile/product_info.php?products_id=$2&%{QUERY_STRING}

and so on, always "m" in front of the mobile page code see SEO Support installation.

 

regards

Rainer

Hi Rainer,

 

Thank you very much for your help and quick reply,

i made the changes (see below), but i still no luck:

i can't get catalog page and products, the only page i am getting is home page, links to products give back error loading page, can't sign in or create new account.

I tried using htaccess file from SEO Support installation first but it didn't work, and i can't install Usu_General_Functions.php because it breaks both my classic and mobile sites.

Thanks again, Larry

 

Options +SymLinksIfOwnerMatch

RewriteEngine on

RewriteBase /

#############################

## Begin Google Base File Rewrite Code

RewriteRule googlebaseOut.txt googlebase.php

## End Google Base File Rewrite Code

#############################

 

# redirect

# For security reasons, Option followsymlinks cannot be overridden.

#Options +FollowSymLinks

Options +SymLinksIfOwnerMatch

RewriteEngine on

RewriteCond %{HTTP_HOST} ^www.babyfavorsandgifts\.com$ [NC]

RewriteRule ^(.*)$ http://babyfavorsandgifts.com/$1 [R=301,L]

## end redirect

 

## Error process

ErrorDocument 404 /includes/modules/ultimate_seo_urls5/includes/notfound_404.php

 

## ULTIMATE SEO 5

## If you are getting errors you may need to comment this out like ..

## Options +FollowSymLinks

# For security reasons, Option followsymlinks cannot be overridden.

#Options +FollowSymLinks

Options +SymLinksIfOwnerMatch

<IfModule mod_rewrite.c>

  RewriteEngine On

#

RewriteBase /

#

RewriteCond %{THE_REQUEST} ^[A-Z]{3,9}\ /index\.php\ HTTP/

RewriteRule ^index\.php$ http://babyfavorsandgifts.com/ [R=301,L]

#

RewriteRule ^(.*)-p-([0-9]+).html$ product_info.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-c-([0-9_]+).html$ index.php?cPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-m-([0-9]+).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pi-([0-9]+).html$ popup_image.php?pID=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pr-([0-9]+).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pri-([0-9]+).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}

# IOSC mobile site

RewriteRule ^(.*)-mp-([0-9]+).html$ mobile/product_info.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-mc-([0-9_]+).html$ mobile/index.php?cPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-mm-([0-9]+).html$ mobile/index.php?manufacturers_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-mpi-([0-9]+).html$ mobile/popup_image.php?pID=$2&%{QUERY_STRING}

RewriteRule ^(.*)-mpr-([0-9]+).html$ mobile/product_reviews.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-mpri-([0-9]+).html$ mobile/product_reviews_info.php?products_id=$2&%{QUERY_STRING}

## Articles contribution

RewriteRule ^(.*)-t-([0-9_]+).html$ articles.php?tPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-a-([0-9]+).html$ article_info.php?articles_id=$2&%{QUERY_STRING}

## Information pages

RewriteRule ^(.*)-i-([0-9]+).html$ information.php?info_id=$2&%{QUERY_STRING}

## Links contribution

RewriteRule ^(.*)-links-([0-9_]+).html$ links.php?lPath=$2&%{QUERY_STRING}

## Newsdesk contribution

RewriteRule ^(.*)-n-([0-9]+).html$ newsdesk_info.php?newsdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-nc-([0-9]+).html$ newsdesk_index.php?newsPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-nri-([0-9]+).html$ newsdesk_reviews_info.php?newsdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-nra-([0-9]+).html$ newsdesk_reviews_article.php?newsdesk_id=$2&%{QUERY_STRING}

# Mobile Articles contribution

RewriteRule ^(.*)-mt-([0-9_]+).html$ mobile/articles.php?tPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-ma-([0-9]+).html$ mobile/article_info.php?articles_id=$2&%{QUERY_STRING}

## Information pages

RewriteRule ^(.*)-mi-([0-9]+).html$ mobile/information.php?info_id=$2&%{QUERY_STRING}

## Links contribution

RewriteRule ^(.*)-mlinks-([0-9_]+).html$ mobile/links.php?lPath=$2&%{QUERY_STRING}

## Newsdesk contribution

RewriteRule ^(.*)-mn-([0-9]+).html$ mobile/newsdesk_info.php?newsdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-mnc-([0-9]+).html$ mobile/newsdesk_index.php?newsPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-mnri-([0-9]+).html$ mobile/newsdesk_reviews_info.php?newsdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-mnra-([0-9]+).html$ mobile/newsdesk_reviews_article.php?newsdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-mpri-([0-9]+).html$ mobile/mobile/product_reviews_info.php?products_id=$2&%{QUERY_STRING}

</IfModule>

 

### Error No Input File Specified

RewriteEngine On

RewriteCond %{REQUEST_URI} ^/system.*

RewriteRule ^(.*)$ index.php?/$1 [L]

RewriteCond %{REQUEST_FILENAME} !-f

RewriteCond %{REQUEST_FILENAME} !-d

RewriteRule ^(.+)$ index.php?/$1 [L]

 

<FilesMatch "\.(ico|pdf|flv|jpg|jpeg|png|gif|js|css|swf)$">

Header set Cache-Control "public"

Header set Expires "Fri, 24 Apr 2015 23:59:00 GMT"

</FilesMatch>

 

Share this post


Link to post
Share on other sites

I tried using htaccess file from SEO Support installation first but it didn't work, and i can't install Usu_General_Functions.php because it breaks both my classic and mobile sites.

@@Lary_an

 

You NEED to install all of the modified SEO URL files included in the support package. If it breaks your main store the problem is somewhere else. Recheck the configuration file and all other changes.

 

You have still an error in your rewrite:

RewriteRule ^(.*)-mpri-([0-9]+).html$ mobile/mobile/product_reviews_info.php?products_id=$2&%{QUERY_STRING}

Check also the modifications in includes/functions/html_output.php

and

includes/functions/general.php

Edited by raiwa

Share this post


Link to post
Share on other sites

@@Lary_an

 

You NEED to install all of the modified SEO URL files included in the support package. If it breaks your main store the problem is somewhere else. Recheck the configuration file and all other changes.

 

You have still an error in your rewrite:

RewriteRule ^(.*)-mpri-([0-9]+).html$ mobile/mobile/product_reviews_info.php?products_id=$2&%{QUERY_STRING}

Check also the modifications in includes/functions/html_output.php

and

includes/functions/general.php

Hi, Rainer,

Thank you very much for your help, i really appreciate it.

I installed all the files and changes from both contributions, including changes in includes/functions/general.php, but not in

catalog/includes/functions/html_output.php because the code is not present there.

If i missed something i can't figure it out.

The problems i mentioned are after all files are installed and modified, its just that i found out that when i apply changes in usu_general_functions.php my main site is no longer works.

At this point i am almost crying from frustration.

Share this post


Link to post
Share on other sites

Hi, Rainer,

Thank you very much for your help, i really appreciate it.

I installed all the files and changes from both contributions, including changes in includes/functions/general.php, but not in

catalog/includes/functions/html_output.php because the code is not present there.

If i missed something i can't figure it out.

The problems i mentioned are after all files are installed and modified, its just that i found out that when i apply changes in usu_general_functions.php my main site is no longer works.

At this point i am almost crying from frustration.

 

@@Lary_an,

 

Sure you are working with the correct SEO URL support version??

Why do you think you need to change SEO URL files?? Just replace them.

Share this post


Link to post
Share on other sites

@@Lary_an,

 

Sure you are working with the correct SEO URL support version??

Why do you think you need to change SEO URL files?? Just replace them.

Thank you Rainer, i really appreciate your help.

I replaced the ones that said replace and modified as per instructions, the only one i was playing with was htaccess because it did't work to begin with, and moved my old usu_general_functions.php back because the new one broke my site. I downloaded the latest full package, the only thing i forgot to mention is that some files referred to in the package are not in the download, but I thought that i didn't get that far to worry about payment files

 

Mobile_OsC_7.5.7r2 --> for_OsC_2.2rc2a

Support. 4.3.  MOsC 7.5.x --> SEO URLs USU5_vers3.2 --> standard_Ultimate Seo Urls 5 PRO ( r205 )

 

 

17a)Upload and replace the following payment modules (standard modules included with OsCommerce 2.2rc2a - 2.3.3.x):

This will add the “data-theme=a” tag to the additional input fields and drop-down menus used by these modules in checkout_payment or checkout_confirmation to fit the mobile page design.

The tags will not disturb on the main pages.

common files/catalog/includes/modules/payment/authorizenet_cc_aim.php

common files/catalog/includes/modules/payment/cc.php

common files/catalog/includes/modules/payment/ipayment_elv.php

common files/catalog/includes/modules/payment/moneriscampg.php

common files/catalog/includes/modules/payment/paypal_express.php

common files/catalog/includes/modules/payment/paypal_pro_dp.php

common files/catalog/includes/modules/payment/paypal_pro_payflow_dp.php

common files/catalog/includes/modules/payment/psigate.php

common files/catalog/includes/modules/payment/sage_pay_direct.php

 

Edited by Lary_an

Share this post


Link to post
Share on other sites

@@Lary_an,

 

Try to temporary remove your additional rewrite rules:

RewriteCond %{THE_REQUEST} ^[A-Z]{3,9}\ /index\.php\ HTTP/
RewriteRule ^index\.php$ http://babyfavorsandgifts.com/ [R=301,L] 

and:

RewriteCond %{HTTP_HOST} ^www.babyfavorsandgifts\.com$ [NC]
RewriteRule ^(.*)$ http://babyfavorsandgifts.com/$1 [R=301,L] 

and:

### Error No Input File Specified
RewriteEngine On
RewriteCond %{REQUEST_URI} ^/system.*
RewriteRule ^(.*)$ index.php?/$1 [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.+)$ index.php?/$1 [L]

If this helps, move them below the SEO URL rewrite rules or leave them out.

Share this post


Link to post
Share on other sites

Hi Rainer @@raiwa

 

Sorry for the late answer, i've been out for some days.

 

Does this happen only from your iPhone or also when you resize your desktop browser window?

It happens also if i resize window on desktop browser.

 

Can you please check if the following styles are included in the html source code of your advanced_search_result page (in your browser select: "display source code" or similar):

It seems that I cannot see the source code, chrome says it's because of a redirect loop, unless i use IE, strange behaviour, i've never seen before.

Anyway the code is included, i can see it in firebug

 

If it's not there, then check if in your mobile/includes/header.php line 54 includes the advanced search result filename:

Yes that's included correctly

 

I just pm you link to the test area, kindly check it.

Edited by fozzo

Share this post


Link to post
Share on other sites

Hi Rainer @@raiwa

 

I just moved to a subdomain on the production site, all links have the "osCsid" at the end, do you have any idea how i can prevent it?

Thanks!

Share this post


Link to post
Share on other sites

@@Lary_an,

 

Try to temporary remove your additional rewrite rules:

RewriteCond %{THE_REQUEST} ^[A-Z]{3,9}\ /index\.php\ HTTP/
RewriteRule ^index\.php$ http://babyfavorsandgifts.com/ [R=301,L] 

and:

RewriteCond %{HTTP_HOST} ^www.babyfavorsandgifts\.com$ [NC]
RewriteRule ^(.*)$ http://babyfavorsandgifts.com/$1 [R=301,L] 

and:

### Error No Input File Specified
RewriteEngine On
RewriteCond %{REQUEST_URI} ^/system.*
RewriteRule ^(.*)$ index.php?/$1 [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.+)$ index.php?/$1 [L]

If this helps, move them below the SEO URL rewrite rules or leave them out.

Hi @@raiwa

Thank you very much for your help,

i made the temporary changes in htaccessit didn't work.

I only get header pictures and breadcrumb everything else is blank on my classic site and mobile site shows home page only.

Thank you. Larry

Share this post


Link to post
Share on other sites

Hi @@raiwa

Thank you very much for your help,

i made the temporary changes in htaccessit didn't work.

I only get header pictures and breadcrumb everything else is blank on my classic site and mobile site shows home page only.

Thank you. Larry

I sent you a private messgae, please check.

Share this post


Link to post
Share on other sites

Hello Lorraine @@herbsandhelpers

 

It seems you succeeded in putting the pieces together with SPPC.

 

I actually did the main changes in mobile/includes/modules/products.php to get the prices

for every customers groups (OSC 2.2rc2a).Though new products listing work also fine,

the new_products module for the home page doesn't and shows only retail prices.

 

Could you share what you achieved with regard to this particular module:

mobile/includes/modules/new_products.php

 

Would also be extremly niece to have  more hints on hide products and categories as it

would save much time searching.

 

Thanks for your help

 

Kind regards

David


david

Share this post


Link to post
Share on other sites

Hello Lorraine @@herbsandhelpers

 

It seems you succeeded in putting the pieces together with SPPC.

 

I actually did the main changes in mobile/includes/modules/products.php to get the prices

for every customers groups (OSC 2.2rc2a).Though new products listing work also fine,

the new_products module for the home page doesn't and shows only retail prices.

 

Could you share what you achieved with regard to this particular module:

mobile/includes/modules/new_products.php

 

Would also be extremly niece to have  more hints on hide products and categories as it

would save much time searching.

 

Thanks for your help

 

Kind regards

David

 

Hello Lorraine,

 

I got it right now. Thanks anyways, still I'd be glad to know

how you managed hide products and categories from groups.

 

Kind regards.

David


david

Share this post


Link to post
Share on other sites

i debug my website with firebug and received this message

 

<div class="errorMsg">This mobile web shop requires Javascript. Please enable Javascript in your browser or change the view:<br><a rel="external" href="http://mysite.com/product_info.php?products_id=121&amp;MredirectCancelled=true">CLASSIC View</a></div>

 

 

Any help is appreciate

Marco

Share this post


Link to post
Share on other sites

@@FranzderFranke,

 

support for 2.2rc2a is included, 2.2ms2 is possible. Support package for the most common add-ons including header tags is available.

 

Commercial support enquiries should be posted in the commercial support forum.

Edited by raiwa

Share this post


Link to post
Share on other sites

Hello David,

 

What would you like to know? My mobile site currently now works fully for SPPC and Hide Categories. Happy to help. been away for a few days recently,

 

Lorraine

Share this post


Link to post
Share on other sites

Hello David,

 

What would you like to know? My mobile site currently now works fully for SPPC and Hide Categories. Happy to help. been away for a few days recently,

 

Lorraine

 

Hello Lorraine,

 

Thanks for replying and your willingness to share. I got hide products and categories from

customer groups working too by now :sweating: . I like your site :thumbsup: ! Fyi though the mobile link

"shop online" redirects on my phone (iPhone5) to the classic site.

 

I like especially the start menu linking to all your services and informations pages.

How did you achieve this? That would definitively be great to know.

 

 

Thanks a lot if you could give a hint.

 

Kind regards

David


david

Share this post


Link to post
Share on other sites

I'm trying to use this contrib with the new Paypal App and am getting the following error where it cannot find hooks.php.

 

Warning require /catalog/mobile/includes/classes/hooks.php

falied to open stream. No such file or directory.

 

I didn't see anything in the install docs about moving the Paypal App files to the mobile directory so of course it's not finding hooks.php file.

 

Please advise. Thanks much!

Edited by MarcellaE

Share this post


Link to post
Share on other sites

in my oscommerce 2.3.4 I installed QPBPP, i'm trying to modify this add to work in mobile site and I need to detect when the site is in mobile, i tried

if(isset($_GET['redirectCancelled']) && $_GET['redirectCancelled'] == 'true')	{
........
}	else {

but not always is possible to use this code, can you help me?

When is finish i'll post all the code for thsi add

happy Easter to all

Marco

Share this post


Link to post
Share on other sites

in my oscommerce 2.3.4 I installed QPBPP, i'm trying to modify this add to work in mobile site and I need to detect when the site is in mobile, i tried

if(isset($_GET['redirectCancelled']) && $_GET['redirectCancelled'] == 'true')	{
........
}	else {

but not always is possible to use this code, can you help me?

When is finish i'll post all the code for thsi add

happy Easter to all

Marco

read Add-On Support.doc point 10b

Share this post


Link to post
Share on other sites

Hi,

 

I've just installed the movile version of OSC in my shop oscommerce 2rc2a. It works fine. But there is a problem, the mobile pages take a lot of time to load. I've changed "enable ajax page load" to false in the admin settings and the mobile pages load quicker, although only if iI see them on my computer, if I change to my mobile they still load very slowly.

 

I'd be very grateful if somebody could help me to solve this problem.

 

Regards

Share this post


Link to post
Share on other sites

Hi,

 

I've just installed the movile version of OSC in my shop oscommerce 2rc2a. It works fine. But there is a problem, the mobile pages take a lot of time to load. I've changed "enable ajax page load" to false in the admin settings and the mobile pages load quicker, although only if iI see them on my computer, if I change to my mobile they still load very slowly.

 

I'd be very grateful if somebody could help me to solve this problem.

 

Regards

Hello @@famaca,

 

It shouldn't load more slow than your desktop store. It your desktop version seems to load faster it may be that these pages are already prresent in your browser cahe, while the mobile pages load for the first time. However on your mobile it depends on your connection speed which may slow down the page loads if its G3 or G2.

Do you have an image thumbnail add-on installed?? Oversized images which are resized by the browser are the most common problem for slow page load. For more specific help you may post your store URL.

 

Kind regards

Rainer

Edited by raiwa

Share this post


Link to post
Share on other sites

I sent you a private messgae, please check.

I don't have an image thumbnail add-on installed. If you'd like to check my store URL is: www.joyeriaplaor.com

 

Thank you

 

Regards

Share this post


Link to post
Share on other sites

I don't have an image thumbnail add-on installed. If you'd like to check my store URL is: www.joyeriaplaor.com

 

Thank you

 

Regards

Hello Fátima,

 

This looks more like redirect loops which I also got reported from another user of the last version.

 

Please try the before version 7.5.7r2 which should be stable.

Maybe there is something messed up with the update, I'll have a look and testing as soon as possible.

See the update doc 7.5.7r2 to 7.5.8 for the changes, there are very little.

 

regards

Rainer

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×