Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

bumbarash

[Contribution] iOSC - mobile version of OSC on your iPhone

Recommended Posts

hi, a great contribution

 

hoping for a few pointers here

 

im using show shipping in cart for guests http://addons.oscommerce.com/info/7821

 

is there anyway to make this show when viewing via iphone etc ?

 

many thanks

 

Hello,

 

just replace the same line in mobile_shopping_cart.php which you replaced in shopping_cart.php.

 

It is this line there:

echo '<br><div style="padding-right:4px; float:right;"><strong>' . SUB_TITLE_TOTAL . $currencies->format($cart->show_total()) . '</strong></div><br><br>';

with:

<?php include(DIR_WS_INCLUDES . 'fdp_panier.php'); ?>

 

or if the layout doesn`t fit the mobile layout, make a copy of fdp_panier.php and rename it to mobile_fdp_panier.php, move it to: mobile/includes/, the above line you pasted in mobile_shopping_cart.php change to:

<?php include(DIR_MOBILE_INCLUDES . 'mobile_fdp_panier.php'); ?>

Now you can do the appropiate layout changes in the new file to match your mobile layout.

 

regards

Rainer

Edited by raiwa

Share this post


Link to post
Share on other sites

@@raiwa

 

ok so i was testing on the laptop prior to now.

 

just tested on my iphone and mobile site not showing or loading.

 

using iphone it takes me to www.mysite.com/mobile_

 

that gives me a 404 Not Found page.

 

but i can access it no probs on the laptop.

 

any ideas why this is ? many thanks

Share this post


Link to post
Share on other sites

also just to add, i have added the contribution support for this and ULTIMATE Seo Urls 5 ( r205 )

 

iv followed it to the letter, but im still getting url like,, mobile_product_info.php?products_id=117

 

i know the seo module is working correctly as i get product_name urls on classic theme

 

again any ideas ? many thanks

Share this post


Link to post
Share on other sites

Hello again,

 

I downloaded the Protx Direct v2.0 add-on which seems to be what you are using.

 

In the installation file I saw that there are modifications to do in checkout_confirmation.php

Did you apply the same modifications in mobile_checkout_confirmation.php?

 

Another try could be to add the additional filename definitions:

 

define('FILENAME_POPUP_CVS_HELP', 'cvs_help.php');
define('FILENAME_PROTX_PROCESS', 'protx_process.php');
define('FILENAME_PROTX_PROCESS_WIN', 'protx_process_win.php');

 

to: mobile/includes/configure.php

 

regards

Rainer

 

Have tried this, still causes the same problem. Here is a copy of the error as on my Iphone:

 

 

https://www.red-onions.co.uk/mobile_protx_process.php?action=process

 

(This is the URL that it tried to access, 'protx_process.php' exists on the server but 'mobile_protx_process.php does not. If I was to copy the existing protx_process.php and rename to mobile_protx_process php, would this work?)

The rest of the errror is as follows:

 

 

Not Found

 

The requested URL /mobile_protx_process.php was not found on this server.

 

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

 

Apache/2.2.23 (Unix) mod_ssl/2.2.23 OpenSSL/1.0.0-fips mod_bwlimited/1.4 Server at www.red-onions.co.uk Port 443

 

 

I will look at applying the Paypal Express update.

 

Regards

Share this post


Link to post
Share on other sites

Have tried this, still causes the same problem. Here is a copy of the error as on my Iphone:

 

 

https://www.red-onions.co.uk/mobile_protx_process.php?action=process

 

(This is the URL that it tried to access, 'protx_process.php' exists on the server but 'mobile_protx_process.php does not. If I was to copy the existing protx_process.php and rename to mobile_protx_process php, would this work?)

The rest of the errror is as follows:

 

 

Not Found

 

The requested URL /mobile_protx_process.php was not found on this server.

 

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

 

Apache/2.2.23 (Unix) mod_ssl/2.2.23 OpenSSL/1.0.0-fips mod_bwlimited/1.4 Server at www.red-onions.co.uk Port 443

 

 

I will look at applying the Paypal Express update.

 

Regards

 

yes it is what you should do.

 

Make a copy of protx_process.php and rename it to 'mobile_protx_process.php

 

regards

Rainer

Share this post


Link to post
Share on other sites

Hi... Rainer...

 

I was wondering if its possible to include the discount code on the mobile shop 2.3.3

 

Thanks

 

it is included in the support package

Share this post


Link to post
Share on other sites

also just to add, i have added the contribution support for this and ULTIMATE Seo Urls 5 ( r205 )

 

iv followed it to the letter, but im still getting url like,, mobile_product_info.php?products_id=117

 

i know the seo module is working correctly as i get product_name urls on classic theme

 

again any ideas ? many thanks

 

Hello,

 

both errors sounds like you didn't upload the following files included in the ULTIMATE Seo Urls 5 support package for iosc:

 

catalog/includes/modules/ultimate_seo_urls5/includes/usu_general_functions.php

catalog/includes/modules/ultimate_seo_urls5/page_modules/mobile_catalogue.php

catalog/includes/modules/ultimate_seo_urls5/page_modules/mobile_product_info.php

catalog/includes/modules/ultimate_seo_urls5/page_modules/mobile_product_reviews.php

 

if the errors persist please post a link to your shop.

 

regards

Rainer

Share this post


Link to post
Share on other sites

Hi @@Rainer

 

in the Contribution support package, those files dont exist,

 

i have checked , i can only find one file

catalog/includes/modules/ultimate_seo_urls5/includes/usu_general_functions.php

 

that comes from the Ultimate Seo package, again the rest of above files dont exist in either package.

 

these files are in deed missing.

 

catalog/includes/modules/ultimate_seo_urls5/page_modules/mobile_catalogue.php

catalog/includes/modules/ultimate_seo_urls5/page_modules/mobile_product_info.php

catalog/includes/modules/ultimate_seo_urls5/page_modules/mobile_product_reviews.php

 

cant find them even on a fresh download, rather strange.

 

cheers my site is http://VWPartsInternational.com

Edited by benny2012

Share this post


Link to post
Share on other sites

Hi @@Rainer

 

in the Contribution support package, those files dont exist,

 

i have checked , i can only find one file

catalog/includes/modules/ultimate_seo_urls5/includes/usu_general_functions.php

 

that comes from the Ultimate Seo package, again the rest of above files dont exist in either package.

 

these files are in deed missing.

 

catalog/includes/modules/ultimate_seo_urls5/page_modules/mobile_catalogue.php

catalog/includes/modules/ultimate_seo_urls5/page_modules/mobile_product_info.php

catalog/includes/modules/ultimate_seo_urls5/page_modules/mobile_product_reviews.php

 

cant find them even on a fresh download, rather strange.

 

cheers my site is http://VWPartsInternational.com

 

Hello,

 

please download this package: Contribution support V. 1.5. for iOSC 5.x uploaded by me (raiwa)

 

I just downloaded and checked and the files are missing in the packages uploaded by roaddoctor.

 

I'll correct this as soon as possible

 

regards

Rainer

Share this post


Link to post
Share on other sites

Rainer - somethings amiss with my Winrar apparently... The "missing files" are getting truncated each time I zip the package up... I will resolve this before any future upload. I think it has something to do with my version of winrar and a path character limit of 260... sorry about that.

 

benny2012 - sorry for the inconvenience caused


-Dave

Share this post


Link to post
Share on other sites

hi @@raiwa thanks for your efforts in helping, it was only seeing the post you made above and looking at the package you just uploaded that confirmed exactly what i needed to acheive.

 

all is running now, i just extracted the files from the rar, rather than extracting the whole rar, worked :)

 

@@Roaddoctor no problem its ok we all make mistakes sometimes, yes you are correct to many characters. least its an easy fix.

 

 

Guys id like to say a big thank you to both of you, you make this open source possible :)

 

what on earth we'd do without you helping, not have the contribution for a start. or not get it configured properly. hats off to both of you.

Share this post


Link to post
Share on other sites

raiwa

 

I have been trying to get empty categories to not show but am having issues working out how to do it do you have and clues on how/if it does a count of products and if =0 not to add the empty categorie to the array?

 

Thanks for any help in advance.

Share this post


Link to post
Share on other sites

raiwa

 

I have been trying to get empty categories to not show but am having issues working out how to do it do you have and clues on how/if it does a count of products and if =0 not to add the empty categorie to the array?

 

Thanks for any help in advance.

 

Hello,

 

If you achieved this on the normal site, try to apply the same changes you did in index.php to mobile_catalogue.php.

If you need help to do this please post the changes made in index.php and I'll try to find a solution.

 

regards

Rainer

Share this post


Link to post
Share on other sites

Hello,

 

If you achieved this on the normal site, try to apply the same changes you did in index.php to mobile_catalogue.php.

If you need help to do this please post the changes made in index.php and I'll try to find a solution.

 

regards

Rainer

 

Thanks, managed to get it working I was editing the wrong part of mobile_catalogue.php.

Share this post


Link to post
Share on other sites

My mobile page still has enormous product images. Please help, I'm sure it has something to do with KISSit Thumbnailer

Thanks

Share this post


Link to post
Share on other sites

Thank you all so much for your work on this contribution!!! I've wroked out a few issues but am stuck on a little problem. The icon to go to the mobile site does not take you there. The little arrow in the box heading does but not the iphone icon. It was working, but I did the Header Tags SEO ans Ultimate SEO URL fixes and now the icon does not go... It appears to be the mobile_version.php but I am not savy enough to figure it out. Here is the code:

 

$info_box_contents = array();

$info_box_contents[] = array('text' => BOX_HEADING_MOBILE_VERSION);



new infoBoxHeading($info_box_contents, false, false, tep_href_link('mobile_index.php'));



global $mobile_url;

if ((SEO_ENABLED != 'true') and ((!isset($lng) || (isset($lng) && !is_object($lng))))) {

$mobile_url .= (strpos($mobile_url,'language=') > 0) ? '' : ((strpos($mobile_url,'?') > 0) ? '&language=' . $current_lang_key : '?language=' . $current_lang_key ) ;

}

$mobile_version_link = '[url="'%20.%20$mobile_url%20.%20'"]' . tep_image(DIR_WS_IMAGES . 'icons/iphone_logo.gif') . '[/url]' ;



$info_box_contents = array();

$info_box_contents[] = array('align' => 'center',

'text' => $mobile_version_link);



new infoBox($info_box_contents);

?>



 

Any help greatly appreciated! :)


Log Cabin Fever Gifts

Share this post


Link to post
Share on other sites

I think I cheated but it seems to be working noe. I chnaged the ' . $mobile_url . ' to mobile_index.php. Please give it a try cabinfevergifts.com in right column. Will it be ok like that?


Log Cabin Fever Gifts

Share this post


Link to post
Share on other sites

I think I cheated but it seems to be working noe. I chnaged the ' . $mobile_url . ' to mobile_index.php. Please give it a try cabinfevergifts.com in right column. Will it be ok like that?

 

Hello,

 

what you did works, but it will link always to the mobile_index.php page instead to toggle always to the correspondent mobile page (product_info, information pages etc.).

 

So I recomend you to double check the installation instructions, the error should be in the SEO URL support installation. Or in the changes in application_top or you didn't upload the modified: /includes/classes/seo.class.php. or you didn't apply the mods in .htaccess.

There is one difference in the mobile version box code you posted to the original version for osc2.2 with Chemo's SEO URLS:

 

this line:

$mobile_version_link = '[url="'%20.%20$mobile_url%20.%20'"]' . tep_image(DIR_WS_IMAGES . 'icons/iphone_logo.gif') . '[/url]' ;

 

should be:

 $mobile_version_link = '<a href="' . $mobile_url . '">' . tep_image(DIR_WS_IMAGES . 'icons/iphone_logo.gif') . '</a>' ;

 

For the header text you could remove the link, it is obsolete, it will always link to the mobile_index, i forgot to remove this since development. It is not necessary with the big mobile icon in the box. I`ll remove this in the next update:

 

change:

  new infoBoxHeading($info_box_contents, false, false, tep_href_link('mobile_index.php'));

 

to:

 new infoBoxHeading($info_box_contents);

 

regards

Rainer

Share this post


Link to post
Share on other sites

My mobile page still has enormous product images. Please help, I'm sure it has something to do with KISSit Thumbnailer

Thanks

 

Hello,

 

It seems you have an older iosc version installed which has a bug in mobile_product_info.php

 

The image size tags where missing.

 

Please change this line:

 

	 $pi_entry .= '" target="_blank" rel="fancybox">' . tep_image(DIR_WS_IMAGES . $pi['image']) . '</a>';

 

to:

	 $pi_entry .= '" target="_blank" rel="fancybox">' . tep_image(DIR_WS_IMAGES . $pi['image'], MOBILE_IMAGE_WIDTH, MOBILE_IMAGE_HEIGHT) . '</a>';

 

In any case I would recomend to update to the last version iosc5.3rev3

 

regards

Rainer

Edited by raiwa

Share this post


Link to post
Share on other sites

Hello,

 

what you did works, but it will link always to the mobile_index.php page instead to toggle always to the correspondent mobile page (product_info, information pages etc.).

 

So I recomend you to double check the installation instructions, the error should be in the SEO URL support installation. Or in the changes in application_top or you didn't upload the modified: /includes/classes/seo.class.php. or you didn't apply the mods in .htaccess.

There is one difference in the mobile version box code you posted to the original version for osc2.2 with Chemo's SEO URLS:

 

this line:

$mobile_version_link = '[url="'%20.%20$mobile_url%20.%20'"]' . tep_image(DIR_WS_IMAGES . 'icons/iphone_logo.gif') . '[/url]' ;

 

should be:

$mobile_version_link = '<a href="' . $mobile_url . '">' . tep_image(DIR_WS_IMAGES . 'icons/iphone_logo.gif') . '</a>' ;

 

For the header text you could remove the link, it is obsolete, it will always link to the mobile_index, i forgot to remove this since development. It is not necessary with the big mobile icon in the box. I`ll remove this in the next update:

 

change:

new infoBoxHeading($info_box_contents, false, false, tep_href_link('mobile_index.php'));

 

to:

new infoBoxHeading($info_box_contents);

 

regards

Rainer

 

Rainer,

Thank you so much for your response! I have double checked and can not find my error, I'm sure it is there. I will keep searching :-)

Thanks again,


Log Cabin Fever Gifts

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×