Jump to content
Sign in to follow this  
bubbasplitshot

Need Tips with Google Analytics eCommerce Self Referral Problem

Recommended Posts

Hi,

I need help with the Google Analytics eCommerce setup.

 

I've read Google help, my web host help and osCommerce trying to figure out why my Google Analytics install only shows (direct) / (none) and mysite.com / referral sources for eCommerce transations. No joy.

 

These results are wrong:

Source/Medium Visits Revenue Transactions Average Value Ecommerce Conversion Rate Per Visit Value

1. google / organic 4,615 $0.00 0 $0.00 0.00% $0.00

2. (direct) / (none) 670 $190.52 2 $95.26 0.30% $0.28

3. google / cpc 547 $0.00 0 $0.00 0.00% $0.00

4. yahoo / organic 416 $0.00 0 $0.00 0.00% $0.00

5. other_site.com / referral 199 $0.00 0 $0.00 0.00% $0.00

6. msn / organic 173 $0.00 0 $0.00 0.00% $0.00

7. my_site.com / referral 140 $1,408.70 31 $45.44 22.14% $10.06

 

There should be values for other Source/Mediums.

 

I know that once the user goes to cart checkout my site routes them to a https:// address but these pages also have the Google Analytics code in them.

 

How can I troubleshoot this problem?

 

Thanks!

Share this post


Link to post
Share on other sites
Hi,

I need help with the Google Analytics eCommerce setup.

 

I've read Google help, my web host help and osCommerce trying to figure out why my Google Analytics install only shows (direct) / (none) and mysite.com / referral sources for eCommerce transations. No joy.

 

These results are wrong:

Source/Medium Visits Revenue Transactions Average Value Ecommerce Conversion Rate Per Visit Value

1. google / organic 4,615 $0.00 0 $0.00 0.00% $0.00

2. (direct) / (none) 670 $190.52 2 $95.26 0.30% $0.28

3. google / cpc 547 $0.00 0 $0.00 0.00% $0.00

4. yahoo / organic 416 $0.00 0 $0.00 0.00% $0.00

5. other_site.com / referral 199 $0.00 0 $0.00 0.00% $0.00

6. msn / organic 173 $0.00 0 $0.00 0.00% $0.00

7. my_site.com / referral 140 $1,408.70 31 $45.44 22.14% $10.06

 

There should be values for other Source/Mediums.

 

I know that once the user goes to cart checkout my site routes them to a https:// address but these pages also have the Google Analytics code in them.

 

How can I troubleshoot this problem?

 

Thanks!

 

Anyone? Bueller?

 

;)

Share this post


Link to post
Share on other sites

Hi,

 

I have the same problem. Have you found a solution?

 

Jesper

 

 

 

 

Anyone? Bueller?

 

;)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×