Jump to content

Archived

This topic is now archived and is closed to further replies.

casch

Unable to determine the page link?

Recommended Posts

Ok Dudes,

If you are having this connection type problem - at checkout - i suggest check your checkout modules at includes/modules/payment/

 

You may notice that they have this this PM_AFTER_PROCESS where they just redirect the browser to checkout_success.php

 

 

Make sure that the connection type is set to NONSSL or SSL there. I have had that problem - aparently there was a bug in the original code where in place of NONSSL it was just NOSSL....

 

 

Anyway, hope that helps

 

Simon

Share this post


Link to post
Share on other sites

This problem has already been solved.

 

/includes/classes/order_total.php

 

Change this:

$GLOBALS[$post_var] = $HTTP_POST_VARS[$post_var];

 

To This:

if ($HTTP_POST_VARS[$post_var]) $GLOBALS[$post_var] =

$HTTP_POST_VARS[$post_var];

 

You can thank Ian, a Team Member: ian@phesis.co.uk

You can thank me for allowing Ian to have full access to my live shop to trouble-shoot the error. ;)

 

Ryan

Share this post


Link to post
Share on other sites

Hey, Guys.

 

I have php 4.3.0 and register globals off

 

I used the 2.1 version. I am about to use the development version 2.2

 

Would this problem still exist? What if the host of the client I am uploading for won't change reg. globals to 'on'

 

I tried to use the fixes but received a blank page

Maybe I am a picklehead

 

Any suggestions? Ideas if 2.2 solves it? Well, regardless, I am about to upload the new version, hope it solves this

 

Thanks. And yes, i will read the other threads, I just want to be responsible and ask, instead of sit and assume.

Share this post


Link to post
Share on other sites

Ask your host. They should have it on/turn it on for you. You may or may not receive this error fresh out of the box, but if you do this will fix the issue.

 

Ryan

Share this post


Link to post
Share on other sites

Ok, thanks

 

I found out they can turn it on

 

But is it a security threat we should be concerned about?

 

That is the concern of the client, who has root access and is willing to turn it 'on'

 

As when I uploaded the development release, it said to turn it on (it won't load otherwise)

 

I just want to confirm it isn't a major security threat (Most php scripting on that domain will really be from this script, it seems)

 

thanks for your time. I am considering telling him to use the trick in apache config file to just set it to his website to on, and leave it off for the rest.

Share this post


Link to post
Share on other sites

Thanks Ian & Ryan for the solution to this! I just started having that problem at the checkout-confirmation page after adding some mods.... it was driving me buggy, but as usual, all I had to do was search the forums for an answer... *thanks guys!* :)

Share this post


Link to post
Share on other sites
Thanks Ian & Ryan for the solution to this! I just started having that problem at the checkout-confirmation page after adding some mods.... it was driving me buggy, but as usual, all I had to do was search the forums for an answer... *thanks guys!* :)

 

 

Hi, im getting this error message everytime i click on the category links, nothing will appear on a click but only a

Error! Unable to determine the page link!

 

Let me know what to do

 

Thanks

Share this post


Link to post
Share on other sites

hi all,

 

I am having this problem 'Unable to determine page link' - i am using OSC 2.2 and all the solutions seem to be for 2.1, has anybody gor a fix for OSC 2.2.

 

Thanks

Geoff


I told you Ryan, if one gets through, its a miracle. (Trevor Howard to Frank Sinatra: Von Ryan's Express)

Share this post


Link to post
Share on other sites

It usually means you have "Use Search-Engine Safe URLs (still in development)" set to True. Go into your Admin>Configuration look down the options to find it and make sure it is set to False.

Share this post


Link to post
Share on other sites
It usually means you have "Use Search-Engine Safe URLs (still in development)" set to True. Go into your Admin>Configuration look down the options to find it and make sure it is set to False.

 

 

Thanks man - worked a treat. :thumbsup:

 

Geoff


I told you Ryan, if one gets through, its a miracle. (Trevor Howard to Frank Sinatra: Von Ryan's Express)

Share this post


Link to post
Share on other sites

I have found the resolve answer to the issue with the ERROR - unable to link to page thingy ma jiggy!

 

ANSWER:

 

Just go into your carts admin section and turn off the "Use Search-Engine Safe URLs (still in development)" thingy and it will solve all your issues.....GOD DAM ITS....LIKE HOURS LATER AND LOADS OF FAGS - DRUGS - AND COFFEE!!!!!!

 

Played Around And Found It - Whaooooooooooooooo!!!!!

 

Simply go into your Admin> Configuration> and look down the options to find it and make sure it is set to False.

 

Case Closed People!!!

 

Wonkey Wizard :rolleyes:

Share this post


Link to post
Share on other sites

I HAVE FOUND THE ANSWER PEEPS!!!!

 

The ERROR seen at the base of the page and marked "Unable To Link To Page" thingy ma jiggy is not an ERROR of sorts, its a config issue that can be sorted in like 10 seconds from now...ready!

 

1) Go into the carts admin section

2) Look under configuration

3) Set "Use Search-Engine Safe URLs (still in development)" set to false - AND NOT TRUE!

4) Then refresh your cart

 

ALL DONE!!!!

 

And all should be well in the land of sex, drugs, milk, and bikini clad honey bears!

 

Wonkey Wizard :rolleyes:

Share this post


Link to post
Share on other sites
I HAVE FOUND THE ANSWER PEEPS!!!!

 

The ERROR seen at the base of the page and marked "Unable To Link To Page" thingy ma jiggy is not an ERROR of sorts, its a config issue that can be sorted in like 10 seconds from now...ready!

 

1) Go into the carts admin section

2) Look under configuration

3) Set "Use Search-Engine Safe URLs (still in development)" set to false - AND NOT TRUE!

4) Then refresh your cart

 

ALL DONE!!!!

 

And all should be well in the land of sex, drugs, milk, and bikini clad honey bears!

 

Wonkey Wizard :rolleyes:

 

hallo I have this error too and Use Search-Engine Safe URLs (still in development) setting is false by me :(

ihave already installed oscommerce and it has worked fine. and then I had problem with my computer. now I have installed everything from begining and use my old catalog and db backup files.

 

but it doesn't work anymore :(

 

I get at the bottom of the page Unable to determine the page link! error.

 

I have now php 5.2 installed and before this I had php 4.4.6 can it be the reason??

 

if I go to admin page I get this error :

 

Warning: include(includes/languages/german/) [function.include]: failed to open stream: No such file or directory in C:\Programme\Apache Group\Apache2\htdocs\catalog\admin\includes\application_top.php on line 136

 

Warning: include() [function.include]: Failed opening 'includes/languages/german/' for inclusion (include_path='.;C:\php5\pear') in C:\Programme\Apache Group\Apache2\htdocs\catalog\admin\includes\application_top.php on line 136

 

I didn't understand from where include_path='.;C:\php5\pear is coming and how to I set it.

 

many thanks

Share this post


Link to post
Share on other sites
hallo I have this error too and Use Search-Engine Safe URLs (still in development) setting is false by me :(

ihave already installed oscommerce and it has worked fine. and then I had problem with my computer. now I have installed everything from begining and use my old catalog and db backup files.

 

but it doesn't work anymore :(

 

I get at the bottom of the page Unable to determine the page link! error.

 

I have now php 5.2 installed and before this I had php 4.4.6 can it be the reason??

 

if I go to admin page I get this error :

 

Warning: include(includes/languages/german/) [function.include]: failed to open stream: No such file or directory in C:\Programme\Apache Group\Apache2\htdocs\catalog\admin\includes\application_top.php on line 136

 

Warning: include() [function.include]: Failed opening 'includes/languages/german/' for inclusion (include_path='.;C:\php5\pear') in C:\Programme\Apache Group\Apache2\htdocs\catalog\admin\includes\application_top.php on line 136

 

I didn't understand from where include_path='.;C:\php5\pear is coming and how to I set it.

 

many thanks

 

 

 

I have installed php 4 and it works again.

Share this post


Link to post
Share on other sites

Hi,

 

Very first i want to inform you those are not much familiar with oscommerce.

 

The function tep_href_link is not in general.php, this is in html_output.php in the same directory.

 

 

I have just added given lines in tep_href_link function and then all working fine on my server:

 

global $link,

if($page == '') { $page = basename($_SERVER['PHP_SELF']); }

 

 

Now the function will look like this..

 

function tep_href_link($page = '', $parameters = '', $connection = 'NONSSL', $add_session_id = true, $search_engine_safe = true) {

 

global $request_type, $session_started, $SID, $spider_flag;

 

global $link;

if($page == '') { $page = basename($_SERVER['PHP_SELF']); }

 

/* if (!tep_not_null($page)) {

// die('</td></tr></table></td></tr></table><br><br><font color="#ff0000"><b>Error!</b></font><br><br><b>Unable to determine the page link!<br><br>');

die('</td></tr></table></td></tr></table><br><br><font color="#ff0000">'.TEP_HREF_LINK_ERROR1);

}*/

 

if ($connection == 'NONSSL') {

$link = HTTP_SERVER . DIR_WS_HTTP_CATALOG;

} elseif ($connection == 'SSL') {

if (ENABLE_SSL == true) {

$link = HTTPS_SERVER . DIR_WS_HTTPS_CATALOG;

} else {

$link = HTTP_SERVER . DIR_WS_HTTP_CATALOG;

}

} else {

//die('</td></tr></table></td></tr></table><br><br><font color="#ff0000"><b>Error!</b></font><br><br><b>Unable to determine connection method on a link!<br><br>Known methods: NONSSL SSL</b><br><br>');

die('</td></tr></table></td></tr></table><br><br><font color="#ff0000">'.TEP_HREF_LINK_ERROR2);

}

.

.

.

.

.

 

On includes/function/general.php

 

go to like 24.

 

See how it has the function tep_href_link ???

 

on line 27 to 29, u will see the that :

 

if ($page == '') {

  die('</td></tr></table></td></tr></table><br><br><font color="#ff0000"><b>Error!</b></font><br><br><b>Unable to determine the page link!<br><br>');

}

 

Replace this with :

if($page == ''){

	$page = basename($HTTP_SERVER_VARS['PHP_SELF']);

}

 

 

On line 25 you have :

 

		global $link;

 

 

make it

 

		global $link, $HTTP_SERVER_VARS;

 

Note that this is osCommerce 2.1 code that I am talking about.

 

Hope that helps.

 

simon

Share this post


Link to post
Share on other sites

It doesn't seem to help every site, but going to admin and changing "Use Search-Engine Safe URLs (still in development)" from true to false solved that problem for me.

Share this post


Link to post
Share on other sites

this:

function tep_href_link($page = '', $parameters = '', $connection = 'NONSSL', $add_session_id = true, $search_engine_safe = true) {

 

global $request_type, $session_started, $SID, $spider_flag;

 

global $link;

if($page == '') { $page = basename($_SERVER['PHP_SELF']); }

 

 

works fine with my site finially. Great help. Thanks a lot .

 

 

Hi,

 

Very first i want to inform you those are not much familiar with oscommerce.

 

The function tep_href_link is not in general.php, this is in html_output.php in the same directory.

 

 

I have just added given lines in tep_href_link function and then all working fine on my server:

 

global $link,

if($page == '') { $page = basename($_SERVER['PHP_SELF']); }

 

 

Now the function will look like this..

 

function tep_href_link($page = '', $parameters = '', $connection = 'NONSSL', $add_session_id = true, $search_engine_safe = true) {

 

global $request_type, $session_started, $SID, $spider_flag;

 

global $link;

if($page == '') { $page = basename($_SERVER['PHP_SELF']); }

 

/* if (!tep_not_null($page)) {

// die('</td></tr></table></td></tr></table><br><br><font color="#ff0000"><b>Error!</b></font><br><br><b>Unable to determine the page link!<br><br>');

die('</td></tr></table></td></tr></table><br><br><font color="#ff0000">'.TEP_HREF_LINK_ERROR1);

}*/

 

if ($connection == 'NONSSL') {

$link = HTTP_SERVER . DIR_WS_HTTP_CATALOG;

} elseif ($connection == 'SSL') {

if (ENABLE_SSL == true) {

$link = HTTPS_SERVER . DIR_WS_HTTPS_CATALOG;

} else {

$link = HTTP_SERVER . DIR_WS_HTTP_CATALOG;

}

} else {

//die('</td></tr></table></td></tr></table><br><br><font color="#ff0000"><b>Error!</b></font><br><br><b>Unable to determine connection method on a link!<br><br>Known methods: NONSSL SSL</b><br><br>');

die('</td></tr></table></td></tr></table><br><br><font color="#ff0000">'.TEP_HREF_LINK_ERROR2);

}

.

.

.

.

.

Share this post


Link to post
Share on other sites

My solution was to execute a phpinfo() on application_top.php

Find out what variable contains the "self" script name.

-- in my case $_SERVER["SCRIPT_NAME"] contains the self script name

 

 

Go to application_top.php

 

find this line:

 

// set php_self in the local scope

$PHP_SELF = (isset($HTTP_SERVER_VARS['PHP_SELF']) ? $HTTP_SERVER_VARS['PHP_SELF'] : $HTTP_SERVER_VARS['SCRIPT_NAME']);

 

change to:

// set php_self in the local scope

$PHP_SELF = [your self script name variable]

 

(in my case I made it

$PHP_SELF = $_SERVER["SCRIPT_NAME"]; )

Share this post


Link to post
Share on other sites

What I did is download the latest version of oscommerce replaced the html_output under includes/funtions and did the fix this poster recomended and it solve the problem I had the same problem I am posting this incase someone else has this problem as the strings I could not find in the general.php file

 

hope this helps

 

On includes/function/general.php

 

go to like 24.

 

See how it has the function tep_href_link ???

 

on line 27 to 29, u will see the that :

 

if ($page == '') {

     die('</td></tr></table></td></tr></table><br><br><font color="#ff0000"><b>Error!</b></font><br><br><b>Unable to determine the page link!<br><br>');

   }

 

Replace this with :

   if($page == ''){

       $page = basename($HTTP_SERVER_VARS['PHP_SELF']);

}

 

 

On line 25 you have :

 

        global $link;

 

 

make it

 

        global $link, $HTTP_SERVER_VARS;

 

Note that this is osCommerce 2.1 code that I am talking about.

 

Hope that helps.

 

simon

Share this post


Link to post
Share on other sites

Hi Every One please Change Application_top.php all problems will be solved

Share this post


Link to post
Share on other sites

This hasn't been the case for me.. None of the fixes here have worked but my version is a bit newer than this thread disccusses. I just did a manaul upgrade to RC1 from MS 2.2 (2 patches applied) and now I get the error

 

Error!

 

Unable to determine the page link!

 

I have SEO links set to false in the admin panel

I have register globals on in my php.ini

I have tried adding the the globals snippet of code to the tep_href_link function in html.output.php as the function does not exist in general.php.

 

As well with my newer installation than some of these dated conversations my files do not include much of the same code mentioned... Bad luck with searching for the error with OsC search restrictions. Ill keep trying. Anybody let me know what might be going on with my RC1 installation. Get this headache out of the way and I can continue on to RC2a. Trying to update an old store so that I can update my server to php5..

 

Thanks as always.

Share this post


Link to post
Share on other sites

Unable to determine the page link!

 

has too many possible causes to be certain what your issue is, need specific error plus related code


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

I agree.. Wish I could produce it. Trying to work any support from the host right now to help with trouble shooting.. Has to be done delicately though because they will not support outside scripts.

Share this post


Link to post
Share on other sites

×