Jump to content
Jack_mcs

Sitemap SEO

Recommended Posts

Hello - and many thanks for your great work!

 

Well, I recently installed your contribution and now get the messages (ADMIN and FRONT)

 

Warning: Call-time pass-by-reference has been deprecated; If you would like to pass it by reference, modify the declaration of [runtime function name](). If you would like to enable call-time pass-by-reference, you can set allow_call_time_pass_reference to true in your INI file in /srv/www/htdocs/web2/html/admin/includes/functions/sitemap.php on line 101 Warning: Call-time pass-by-reference has been deprecated; If you would like to pass it by reference, modify the declaration of GetFilesArray(). If you would like to enable call-time pass-by-reference, you can set allow_call_time_pass_reference to true in your INI file in /srv/www/htdocs/web2/html/admin/includes/functions/sitemap.php on line 274

 

 

Could you please help?

 

Thanks a lot!

 

Best Regards

 

Tom

Share this post


Link to post
Share on other sites

Please use the search option at the bottom of this page to search this thread for that problem. It has been addressed several times.

 

Jack

Share this post


Link to post
Share on other sites

Jack,

 

i just noticed that there is a sitemap on my website after so many weeks. haha..... well, here it is (located under the information box labeled as "BOX_INFORMATION_SITEMAP_SEO") here's a screenshot.

3369504852_351be93148_o.jpg

 

 

 

but then when u click on it, this is what it shows (with errors) :

i check /includes/functions/sitemap.php as per the error, this is what i get

 

line 25 : if (GetFilesArray($path, &$lines))

line 132 : if (GetFilesArray($path, &$lines))

 

may i know whats wrong with this 2 lines?

 

3368679455_30df4d12bb_o.jpg

Share this post


Link to post
Share on other sites

The BOX_INFORMATION_SITEMAP_SEO in the error means you didn't properly complete the installation.

 

The fix for the other errors is posted in this thread.

 

Jack

Share this post


Link to post
Share on other sites

Jack, i refer back a few pages, fixed the 2 errors above, i remove the "&" from those 2 lines. the error is gone, but then under the info box, it still shows : BOX_INFORMATION_SITEMAP_SEO

 

may i ask how shd i fix it?

Share this post


Link to post
Share on other sites
Jack, i refer back a few pages, fixed the 2 errors above, i remove the "&" from those 2 lines. the error is gone, but then under the info box, it still shows : BOX_INFORMATION_SITEMAP_SEO

 

may i ask how shd i fix it?

Did you do step 8?


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites

hey coopco,

 

thank you for your help man. i check back step 8, its gone, well, i guess maybe either i left out or somehow backup and restore make it gone. now its fixed. once again, thanks bro, u solved my problem.

Share this post


Link to post
Share on other sites
hey coopco,

 

thank you for your help man. i check back step 8, its gone, well, i guess maybe either i left out or somehow backup and restore make it gone. now its fixed. once again, thanks bro, u solved my problem.

No problem. Once you get it working, it stays working.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites

hello jack;

its a great work for sitmap, i downloaded few but like this one v much, thnx 4 ur work.

i have installed it on osc rc2, i got the problem that...

the error messsage is :

Select a Box

 

Fatal error: Call to undefined function curl_init() in C:\AppServ\www\ebooks\admin\includes\functions\sitemap.php on line 214

 

Thank you!

Share this post


Link to post
Share on other sites
hello jack;

its a great work for sitmap, i downloaded few but like this one v much, thnx 4 ur work.

i have installed it on osc rc2, i got the problem that...

the error messsage is :

Select a Box

 

Fatal error: Call to undefined function curl_init() in C:\AppServ\www\ebooks\admin\includes\functions\sitemap.php on line 214

 

Thank you!

Thank you.

 

The error is saying the curl function can't be found. The code should check for it before using it so I can't say why it fails that way but you'll need to talk to your host to sort it out since that is where the problem is at.

 

Jack

Share this post


Link to post
Share on other sites
Thank you.

 

The error is saying the curl function can't be found. The code should check for it before using it so I can't say why it fails that way but you'll need to talk to your host to sort it out since that is where the problem is at.

 

Jack

 

its giving me on my local sever. but sitemap seems right.

on my domain its giving me that error.

Failed to read file /home/allebook/public_html//includes/boxes//Array

thnx for ur time and consideration

Share this post


Link to post
Share on other sites

I don't have an answer for the Array problem. Others have mentioned it but I can't see where it is coming from nor cause the failure.

 

Jack

Share this post


Link to post
Share on other sites
I don't have an answer for the Array problem. Others have mentioned it but I can't see where it is coming from nor cause the failure.

 

Jack

ok, thnx

Best of luck

Share this post


Link to post
Share on other sites
Seems to have installed ok, but when I press update in the boxes group control I get the following error:

 

Failed to read file /home/www/mysite.com//includes/boxes//Array

 

Same problem for me as well. I know Jack mentioned he can not figure this one out but has anyone noticed the double "//" in the file path reference?

 

Failed to read file /home/www/mysite.com//includes/boxes//Array

 

Why is that the file path being shown that way? Is that the actual problem?

Edited by XxWickedxX

Share this post


Link to post
Share on other sites

hello jack,

 

google is giving error on this sitemap, y?

and how could it b solved.

regards,

afridi

Share this post


Link to post
Share on other sites
Same problem for me as well. I know Jack mentioned he can not figure this one out but has anyone noticed the double "//" in the file path reference?

 

 

 

Why is that the file path being shown that way? Is that the actual problem?

That would be caused by the way the configure file is setup. It shouldn't cause such a problem but would be worth fixing just in case.

 

Jack

Share this post


Link to post
Share on other sites
hello jack,

 

google is giving error on this sitemap, y?

and how could it b solved.

regards,

afridi

That seems unlikely since this sitemap is on the site and has nothing to do with google other than they scan the page.

 

Jack

Share this post


Link to post
Share on other sites

Hello

 

I just installed this contribution. We have 4 languages: Everything works perfect exept with English: there we have double entries and if a page is excluded in the page control there is no effect. Anyone can help? Thanks :)

Share this post


Link to post
Share on other sites

The exclude may not work if there are double entries. Why there would be double entries though, I can't say. I would try the uninstall andinstall scripts to see if that fixes it. The number of languages shouldn't make a difference, other than you have to fill in that additional information in Settings Control.

 

Jack

Share this post


Link to post
Share on other sites

Hi Jack,

First off let me say thank you for all your hard work and tons of contributions for the community. I value your work.

I could use a little bit of your help with this one though.

I am getting this error when I go to install on the Database:

 

1062 - Duplicate entry '545' for key 'PRIMARY'

 

INSERT INTO `configuration_group` ( `configuration_group_id` , `configuration_group_title` , `configuration_group_description` , `sort_order` , `visible` ) VALUES ('545', 'Sitemap SEO', 'Sitemap SEO site wide options', '22' , '1')

 

[TEP STOP]

 

Any idea what this is or How I can work around?

Thanks a million and have a great day

Share this post


Link to post
Share on other sites

The sql file is trying to make database changes to the group with ID of 545 but your database already has a group with that ID so it isn't allowed. You need to edit the sql file and change all of the instances of 545 to some other number. It doesn't matter what the number is as long as it isn't used already. The only way to know if it is or not is to look at the database. Or you can just try a number and see if it works. So try 546, 789, 111 or whatever you like. Just be sure to change them all in the file.

 

Jack

Share this post


Link to post
Share on other sites

HI Jack Hope you are still advising on you great contribution.

 

a novice with php and osc but i have installed it.

 

When i select "sitemap seo" in admin i get this error .. 404 not found showing this ...

/admin/FILENAME_SITEMAP_SEO_PAGE_CONTROL?selected_box=sitemap_seo

 

Have i missed something can you advise please.

 

Thanks Alan

Share this post


Link to post
Share on other sites

Capital letters in an error almost always means a definition is missing. Search the install instructions for FILENAME_SITEMAP_SEO_PAGE_CONTROL and then make sure you have made the change associated with it on your server.

 

Jack

Share this post


Link to post
Share on other sites
Capital letters in an error almost always means a definition is missing. Search the install instructions for FILENAME_SITEMAP_SEO_PAGE_CONTROL and then make sure you have made the change associated with it on your server.

 

Jack

 

Thank Jake that was quick i will have a look.

Share this post


Link to post
Share on other sites
Thank Jake that was quick i will have a look.

 

 

Yep all ok now, it was me i missed that page.

 

Being new to this, is there any guide instructions on what to use and what it means etc or even a screen shot of a setup.

 

Thanks for your help.

 

Alan

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×