Jump to content
Jack_mcs

Sitemap SEO

Recommended Posts

Hello (again), i am wondering if this add-on (and the Google XML Sitemap SEO one) is suitable for a v2.3.1 store ?

Thank you,

Christine

Sitemap SEO - no. Google XML Sitemap SEO - yes.

Edited by Jack_mcs

Share this post


Link to post
Share on other sites

Hello all,

 

At the sitemap_seo_page_control.php I have some custom pages, they are not checked to be excluded, and they are not shown in the front-end

 

What could be wrong?

 

Thank you.

Share this post


Link to post
Share on other sites

Hello all,

 

At the sitemap_seo_page_control.php I have some custom pages, they are not checked to be excluded, and they are not shown in the front-end

 

What could be wrong?

 

Thank you.

If they were not setup as standard oscommerce pages are (two files and an entry in the filenames file), that might cause it. If they were, I don't know what the problem might be. You could try adding the page using the option to add pages in box control though.

Share this post


Link to post
Share on other sites

Hi there,

I am wondering if anyone can help me with this error when I click on the Sitemap link in my store -

 

Fatal error: Call to undefined function curl_init() in C:\wamp\www\catalog\includes\functions\sitemap.php on line 97

 

Thanks in advance.

Tim

Share this post


Link to post
Share on other sites

Hi there,

I am wondering if anyone can help me with this error when I click on the Sitemap link in my store -

 

Fatal error: Call to undefined function curl_init() in C:\wamp\www\catalog\includes\functions\sitemap.php on line 97

 

Thanks in advance.

Tim

It's due to a mistake in the code. In that file, find this line

 if (! function_exists('curl_init'))

and change it to

 if ( function_exists('curl_init'))

Share this post


Link to post
Share on other sites

It's due to a mistake in the code. In that file, find this line

 if (! function_exists('curl_init'))

and change it to

 if ( function_exists('curl_init'))

 

Thanks for your quick response Jack. That has fixed it.thumbsup.gif

Tim

Share this post


Link to post
Share on other sites

Hello jack ,

 

I am running 2.3.1 and I am having trouble installing Google Sitemap XML on my store, I have written the errors in the Google Sitemap thread. So I tried installing this Sitemap on, everything went well; however, the backend got shifted downard, (thinking it is the sql which did that) and I read that it is not supported for 2. 3.1 ? What do you think my best option is? Please let me know, thank you!

Share this post


Link to post
Share on other sites

Hello jack ,

 

I am running 2.3.1 and I am having trouble installing Google Sitemap XML on my store, I have written the errors in the Google Sitemap thread. So I tried installing this Sitemap on, everything went well; however, the backend got shifted downard, (thinking it is the sql which did that) and I read that it is not supported for 2. 3.1 ? What do you think my best option is? Please let me know, thank you!

This contribution hasn't been converted for 2.3.

Share this post


Link to post
Share on other sites

Hello jack,

I am using OSCommerce 2.3.1 and finding it difficult to set up Sitemap_SEO_V_1.7 on my store. I can't find this part: includes/boxes/information.php

 

This is what I needed http://www.finalyearproject.net/screenshot.gif am not sure if Sitemap_SEO_V_1.7 will enable me achieve that? Please I need fast solution for this, I need to fix the Site map as soon as possible.

 

Thanks for your usual support.

Share this post


Link to post
Share on other sites

Read the post above yours.


REMEMBER BACKUP, BACKUP AND BACKUP

Get the latest Responsive osCommerce CE (community edition) here

It's very easy to over complicate what are simple things in life

Share this post


Link to post
Share on other sites

 

Ok, I can see. Do you have any contribution on getting this done? All I needed is a Site Map like this: http://www.finalyear.../screenshot.gif

 

Thanks in advance

 

 

Search through the addons for sitemap. There is one there for 2.3.1


REMEMBER BACKUP, BACKUP AND BACKUP

Get the latest Responsive osCommerce CE (community edition) here

It's very easy to over complicate what are simple things in life

Share this post


Link to post
Share on other sites

@ Steve,

Thank you for the support. However, am finding it difficult to located the Site Map for OSC 2.3.1 I will appreciate of you can give me the direct link.

Thanks

Edited by shintaku

Share this post


Link to post
Share on other sites

 

Ok, I can see. Do you have any contribution on getting this done? All I needed is a Site Map like this: http://www.finalyear.../screenshot.gif

This one will be updated before the end of the year, if you can wait that long.

Share this post


Link to post
Share on other sites

Hey Jack

 

 

I installed in ver 2.3.1 but in my admin/sitemap seo i only get one page that is Pages Group Control I am kinda a newbie with this so I am not sure why I am missing pages and why my sitemap is not working can you help me out

 

 

 

ok I see now that this may not work for 2.3.1 which must be why I am having problems let me know when this is good for 2.3.1

Edited by techs21

Share this post


Link to post
Share on other sites

A new version has been uploaded with the following changes:

 

- Added a manufacturer link for the products page

- Added show/hide products on sitemap page

- Added error checking for addons that Sitemap SEO works with, like Article Manager, to prevent failure if set

- Added code to display extra text on the sitemap page

- Added missing charset meta tag for non-Header Tags SEO shops

- Changed code in Page Control to handle languages better

- Changed products querry string to ignore quote products

- Cleaned up Page Control code so only viewable pages are seen

- Converted all ereg calls

- Fixed box display code

- Fixed several html coding errors

- Fixed coding mistake in sitemap.php

- Fixed coding mistake in includes/functions/sitemap.php regarding curl

- Fixed coding mistake in includes/functions/sitemap.php regarding path to catalog

- Fixed problem where related categories caused invalid links

- Made it 2.3 compatible

- Removed the sql file in favor of the sql.php file

Share this post


Link to post
Share on other sites

Hello Jack, I am attemping to update my 2.2 shop from 1.7 to V 1.8 via myPHPAdmin and running the mysql command, got an error. Contacted my host tech support they say it appeared to be something with the statement.

 

INSERT INTO `contrib_sitemap_seo`.`configuration` (`configuration_id`, `configuration_title`, `configuration_key`, `configuration_value`, `configuration_description`, `configuration_group_id`, `sort_order`, `last_modified`, `date_added`, `use_function`, `set_function`) VALUES (NULL, 'Show Related Products by Mnufacturer', 'SITEMAP_SEO_SHOW_INDIVIDUAL_MANUFACTURER_SITEMAP', 'true', 'Display a link on the category and product pages to display all products in the current category (by manufacturer).', '545', '28', NULL, '', NULL, NULL);

 

Any ideas?

 

Thanks


I am not a professional webmaster or PHP coder by background or training but I will try to help as best I can.

I remember what it was like when I first started with osC. It can be overwhelming.

However, I strongly recommend considering hiring a professional for extensive site modifications, site cleaning, etc.

There are several good pros here on osCommerce. Look around, you'll figure out who they are.

Share this post


Link to post
Share on other sites

Hello Jack, I am attemping to update my 2.2 shop from 1.7 to V 1.8 via myPHPAdmin and running the mysql command, got an error. Contacted my host tech support they say it appeared to be something with the statement.

Yes, there is a mistake in it. It should be

INSERT INTO `configuration` (`configuration_id`, `configuration_title`, `configuration_key`, `configuration_value`, `configuration_description`, `configuration_group_id`, `sort_order`, `last_modified`, `date_added`, `use_function`, `set_function`) VALUES (NULL, 'Show Related Products by Mnufacturer', 'SITEMAP_SEO_SHOW_INDIVIDUAL_MANUFACTURER_SITEMAP', 'true', 'Display a link on the category and product pages to display all products in the current category (by manufacturer).', '545', '28', NULL, '', NULL, NULL);

Please give that a try and let me know if there is still a problem.

Share this post


Link to post
Share on other sites

Jack I tweaked the code as follows:

 

INSERT INTO `configuration` (`configuration_id`, `configuration_title`, `configuration_key`, `configuration_value`, `configuration_description`, `configuration_group_id`, `sort_order`, `last_modified`, `date_added`, `use_function`, `set_function`) VALUES (NULL, 'Show Related Products by Mnufacturer', 'SITEMAP_SEO_SHOW_INDIVIDUAL_MANUFACTURER_SITEMAP', 'true', 'Display a link on the category and product pages to display all products in the current category (by manufacturer).', '545', '28', NULL, '', NULL, NULL);

 

deleting the `contrib_sitemap_seo`.

 

I ran it and it worked, but the configuration_id was a very high number so I manually edited it to be one higher than the one just before.

 

Looking at the site, via store front and admin all seems to be in order.

 

So FYI on that.


I am not a professional webmaster or PHP coder by background or training but I will try to help as best I can.

I remember what it was like when I first started with osC. It can be overwhelming.

However, I strongly recommend considering hiring a professional for extensive site modifications, site cleaning, etc.

There are several good pros here on osCommerce. Look around, you'll figure out who they are.

Share this post


Link to post
Share on other sites

Yes, there is a mistake in it. It should be

 

We just crossed each other posting...I think I have it but the high configuration_id that myphpadmin generated has me confused, I thought that would on auto increment....

 

Anyway, I think it's good now.

 

Thanks and may your holidays treat you and yours well.


I am not a professional webmaster or PHP coder by background or training but I will try to help as best I can.

I remember what it was like when I first started with osC. It can be overwhelming.

However, I strongly recommend considering hiring a professional for extensive site modifications, site cleaning, etc.

There are several good pros here on osCommerce. Look around, you'll figure out who they are.

Share this post


Link to post
Share on other sites

Back again....just noticed in a product display page the body is shifted to the left a bit and not centered as before.

 

Might have something to do with:

 

 

No other products were found for this manufacturer.

 

Which shows, situated at the bottom of the page, but shift to the right.

 

Just guessing but something in the product_info.php file?


I am not a professional webmaster or PHP coder by background or training but I will try to help as best I can.

I remember what it was like when I first started with osC. It can be overwhelming.

However, I strongly recommend considering hiring a professional for extensive site modifications, site cleaning, etc.

There are several good pros here on osCommerce. Look around, you'll figure out who they are.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×