Jump to content
Sign in to follow this  
iankil

[Contribution] Mindsparx admin

Recommended Posts

I'M confused... this mindsparx_admin 4.0 will only work with oscommerce 3?

 

 

No its only for Oscommerce v2.2


My contributions

Mindsparx admin for 2.2

Mindsparx admin for 2.3

Mindsparx admin for 3.0

Mindsparx specials 2.2

Starproduct pimped for 2.2

Starproduct pimped for 2.3

Mindsparx template osc Sport 2.2

Mindsparx template Horizon 2.3

+ a few more...

Share this post


Link to post
Share on other sites

Does this version mean that there are no submenu's anymore? Or is it still possible to have them? I hope it's still possible because I use them a lot

Share this post


Link to post
Share on other sites
Does this version mean that there are no submenu's anymore? Or is it still possible to have them? I hope it's still possible because I use them a lot

 

Lot of my time went to explain to people on how to add submenues wich was pretty complicated, so i had to swich back to the old menu.

But i´ll look in to another nav bar that will do the job better and in a future version all this can be done in the admin area.

 

For users that needs to add sub menues use the 2.1 version, it still works but is a bit more complicated.

 

/Janne.K

Edited by iankil

My contributions

Mindsparx admin for 2.2

Mindsparx admin for 2.3

Mindsparx admin for 3.0

Mindsparx specials 2.2

Starproduct pimped for 2.2

Starproduct pimped for 2.3

Mindsparx template osc Sport 2.2

Mindsparx template Horizon 2.3

+ a few more...

Share this post


Link to post
Share on other sites

on specials.php the insert button is still windows gui button not your own graphic button but otherwise THANKS!

 

admin panel doesnt look so dead anymore

Share this post


Link to post
Share on other sites

hi there. i am also having the blank screen problem. i have tried the fix listed below (removing the extra } ) and i still get the blank page. can someone please look over this and see if there isn't something else wrong?

 

  function tep_image_button($image, $alt = '', $params = '') {
   global $language;

 if (ADMIN_BUTTON =="true"){
	  return tep_image(DIR_WS_ADMIN . 'mindsparx_admin/template/'. ADMIN_TEMPLATE.'/images/buttons/'. $language . '/' . $image, $alt, '', '', $params);
 } else {
   return tep_image(DIR_WS_LANGUAGES . $language . '/images/buttons/' . $image, $alt, '', '', $params);
 }

 

 

nope, happening to me as well.

I installed this admin ages ago and it worked fine, now on a new installation the top links dont work, maybe something is different???

The javascript is also VERY buggy in the latest firefox, is opens up then instantly shuts, need a fix for this please?

 

Not all take though, got a bug fix for you all.

For those complaining of a blank screen there is a bug in the latest release.

 

in html_output.php

 

////
// Output a function button in the selected language
 function tep_image_button($image, $alt = '', $params = '') {
global $language;

 if (ADMIN_BUTTON =="true"){
	  return tep_image(DIR_WS_ADMIN . 'mindsparx_admin/template/'. ADMIN_TEMPLATE.'/images/buttons/'. $language . '/' . $image, $alt, '', '', $params);
 }else {
return tep_image(DIR_WS_LANGUAGES . $language . '/images/buttons/' . $image, $alt, '', '', $params);
 }

}

 

should be:

 

////
// Output a function button in the selected language
 function tep_image_button($image, $alt = '', $params = '') {
global $language;

 if (ADMIN_BUTTON =="true"){
	  return tep_image(DIR_WS_ADMIN . 'mindsparx_admin/template/'. ADMIN_TEMPLATE.'/images/buttons/'. $language . '/' . $image, $alt, '', '', $params);
 }else {
return tep_image(DIR_WS_LANGUAGES . $language . '/images/buttons/' . $image, $alt, '', '', $params);
 }

 

there is a rogue } in the code causing the page to stall.

 

Also, those with boxes_configuration_administrators prob.

 

remove this line from the admin header:

<li><div class="line"><a href="<?php echo tep_href_link(FILENAME_ADMINISTRATORS) ?> "><?php echo BOX_CONFIGURATION_ADMINISTRATORS ?></a></div></li>

 

It's being called from the configuration dropdown already and is not needed in the header nav.

Share this post


Link to post
Share on other sites

Hello

I have used the admin for over 100 sites and i have had no blank screen this far, so im not sure why it hapens to you, it might be coliding with some other contributions, im not sure.

 

/Janne.K


My contributions

Mindsparx admin for 2.2

Mindsparx admin for 2.3

Mindsparx admin for 3.0

Mindsparx specials 2.2

Starproduct pimped for 2.2

Starproduct pimped for 2.3

Mindsparx template osc Sport 2.2

Mindsparx template Horizon 2.3

+ a few more...

Share this post


Link to post
Share on other sites

KawaiiShop i think i know why you have a blank page, in the install instruction it says:

 

***serach for:

 

function tep_image_button($image, $alt = '', $params = '') {

 

***Replace the whole function with this:

 

 

Note that the whole function has to be replaced, not just that text, so replace (if your function is defult)

 

function tep_image_button($image, $alt = '', $params = '') {

global $language;

 

return tep_image(DIR_WS_LANGUAGES . $language . '/images/buttons/' . $image, $alt, '', '', $params);

}

 

with:

 

function tep_image_button($image, $alt = '', $params = '') {

global $language;

 

if (ADMIN_BUTTON =="true"){

return tep_image(DIR_WS_ADMIN . 'mindsparx_admin/template/'. ADMIN_TEMPLATE.'/images/buttons/'. $language . '/' . $image, $alt, '', '', $params);

}else {

return tep_image(DIR_WS_LANGUAGES . $language . '/images/buttons/' . $image, $alt, '', '', $params);

}

}

 

 

 

That should do it ;)

 

/Janne


My contributions

Mindsparx admin for 2.2

Mindsparx admin for 2.3

Mindsparx admin for 3.0

Mindsparx specials 2.2

Starproduct pimped for 2.2

Starproduct pimped for 2.3

Mindsparx template osc Sport 2.2

Mindsparx template Horizon 2.3

+ a few more...

Share this post


Link to post
Share on other sites

Got the following error when I try clicking on the green or red lamps to activate/deactivate products:

 

Fatal error: Call to undefined function: tep_set_product_featured() in /var/www/vhosts/teamzg.com/httpdocs/shop/admin/categories.php on line 28

 

Here is line 28 of categories.php

            tep_set_product_featured($HTTP_GET_VARS['pID'], $HTTP_GET_VARS['flag']);

 

Let me know, thanks.

Edited by itzbjorn

Share this post


Link to post
Share on other sites

Hi Itzbjorn

 

I dont think that is caused by mindsparx admin...


My contributions

Mindsparx admin for 2.2

Mindsparx admin for 2.3

Mindsparx admin for 3.0

Mindsparx specials 2.2

Starproduct pimped for 2.2

Starproduct pimped for 2.3

Mindsparx template osc Sport 2.2

Mindsparx template Horizon 2.3

+ a few more...

Share this post


Link to post
Share on other sites

Hi, this looks like a great contrib and cant wait to have it working.

 

My issue is when i try to load my admin page i receive errors. This is a clean install, new database to go with it and this is the 1st contrib to be added.

 

I have an osC2.x store currently running but decided to create a fresh store to try contribs on 1st before adding them to the live site...so...here is the error i get upon loading the admin after following the install instructions provided :

 

Warning: require(includes/classes/sts.php) [function.require]: failed to open stream: No such file or directory in ***/admin/includes/application_top.php on line 174

 

Warning: require(includes/classes/sts.php) [function.require]: failed to open stream: No such file or directory in ***/admin/includes/application_top.php on line 174

 

Fatal error: require() [function.require]: Failed opening required 'includes/classes/sts.php' (include_path='.:/usr/share/pear-php5') in ***/admin/includes/application_top.php on line 174

 

I have tried searching for this issue in previous posts but none that I have read so far are exactly the same.

 

I notice there is 'require(includes/classes/sts.php)' sts...is that the file for Simple Template System? If so then this is even more starange as this is a clean install.

 

 

Any help would be really appreciated :)


· · · — — — · · ·

Share this post


Link to post
Share on other sites

Im getting an error message in the Newsletter manager Page.

 

Newsletter Manager

 

Newsletters Size Module Sent Status Action

1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '-6, 6' at line 1

 

select newsletters_id, title, length(content) as content_length, module, date_added, date_sent, status, locked from newsletters order by date_added desc limit -6, 6

 

[TEP STOP]

 

 

Anybody have some insight into how ot fix this?

Share this post


Link to post
Share on other sites

Administration Access Level Accounts 2.0

 

Hi. I love your contribution! I have one small problem. I am kind of new to php and css so I don't know how to change this code, and I was wondering if there is any way you could point me in the right direction.

 

I have Mindsparx Admin 4.0 contribution installed, and I am attempting to install Administration Access Level Accounts 2.0. (addons.oscommerce.com/info/1359) I am having a problem with header.php. I was wondering if you could possibly help me with this? I am thinking of cross-posting for the other contribution as well.

 

I have installed Mindsparx header.php; of course you know what the code is for that. Here are the instructions from the other contribution:

 

+++++++++++++++++++++++++++++++++++++++++

File: admin/includes/header.php

+++++++++++++++++++++++++++++++++++++++++

 

---------------------------------------------------------------------

---------------------------------------------------------------------

 

Look for

 

<td class="headerBarContent">  <?php echo '<a href="' . tep_href_link(FILENAME_DEFAULT, '', 'NONSSL') . '" class="headerLink">' . HEADER_TITLE_TOP . '</a>'; ?></td>

 

replace with

 

<?php

// BOF: KategorienAdmin / OLISWISS

if ($login_groups_id == 1) {

// BOF: KategorienAdmin / OLISWISS

?>

<!--//Secure admin-->

<!--<td class="headerBarContent">  <?php echo '<a href="' . tep_href_link(FILENAME_DEFAULT, '', 'NONSSL') . '" class="headerLink">' . HEADER_TITLE_TOP . '</a>  |  <a href="' . tep_href_link(FILENAME_LOGOFF, '', 'SSL') . '" class="headerLink">' . HEADER_LOGOFF . '</a>'; ?></td>-->

<!--//Secure admin-->

<td class="headerBarContent">  <?php echo '<a href="' . tep_href_link(FILENAME_DEFAULT, '', 'NONSSL') . '" class="headerLink">' . HEADER_TITLE_TOP . '</a>'; ?></td>

<?php

// BOF: KategorienAdmin / OLISWISS

}else

{

?>

<!--<td class="headerBarContent">  </td>-->

<?php

}

// BOF: KategorienAdmin / OLISWISS

?>

 

<!-- BOE Access with Level Account (v. 2.2 RC2A) for the Admin Area of osCommerce (MS2) 1 of 1 -->

<td class="headerBarContent">  <?php

if (tep_session_is_registered('login_id')) {

echo '<a href="' . tep_href_link(FILENAME_ADMIN_ACCOUNT, '', 'SSL') . '" class="headerLink">' . HEADER_TITLE_ACCOUNT . '</a> | <a href="' . tep_href_link(FILENAME_LOGOFF_ADMIN, '', 'NONSSL') . '" class="headerLink">' . HEADER_TITLE_LOGOFF_ADMIN . '</a>';

} else {

echo '<a href="' . tep_href_link(FILENAME_DEFAULT, '', 'NONSSL') . '" class="headerLink">' . HEADER_TITLE_TOP . '</a>';

}

?></td>

<!-- BOE Access with Level Account (v. 2.2 RC2A) for the Admin Area of osCommerce (MS2) 1 of 1 -->

 

<?php

// BOF: KategorienAdmin / OLISWISS

if ($login_groups_id == 1) {

// BOF: KategorienAdmin / OLISWISS

?>

 

---------------------------------------------------------------------

---------------------------------------------------------------------

 

Look for

<td class="headerBarContent" align="right"><?php echo '<a href="http://www.oscommerce.com" class="headerLink">' . HEADER_TITLE_SUPPORT_SITE . '</a>  |  <a href="' . tep_catalog_href_link() . '" class="headerLink">' . HEADER_TITLE_ONLINE_CATALOG . '</a>  |  <a href="' . tep_href_link(FILENAME_DEFAULT, '', 'NONSSL') . '" class="headerLink">' . HEADER_TITLE_ADMINISTRATION . '</a>'; ?>  </td>

 

add bellow

 

<?php

// BOF: KategorienAdmin / OLISWISS

}

else

{

?>

<td class="headerBarContent">  </td>

<?php

}

// BOF: KategorienAdmin / OLISWISS

?>

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

 

I don't know where to begin with this because I don't understand enough about what it is attempting to do. Any help would be greatly appreciated.

Share this post


Link to post
Share on other sites

Hello,

 

I am using OSC 3.0 with your MS 3.0 release for the admin section.

 

While adding new admins, and granting them access to specific sections, the icons on the right stagger downward instead of all aligning to the right on top of each other.

 

I don't know if this is a OSC bug or a MS bug, but I have a screenshot here.

 

osc3.0_ms3.0.jpg

Share this post


Link to post
Share on other sites

Hi Suzibird,

 

Those links in the code you were pasting is not used by mindsparx admin, so i guess that you could just paste those codes after eachother right after any </td> ,just to get the links visible. If that works you could try to find the best </td> to place that code after so it looks good, It doesnt look like its that dificult to make it work propperly.

 

But im not sure since i have never tried that contribution. Anyone who has some php skills and know this contribution can make this work i guess.. so.. plz help Suzi ;)


My contributions

Mindsparx admin for 2.2

Mindsparx admin for 2.3

Mindsparx admin for 3.0

Mindsparx specials 2.2

Starproduct pimped for 2.2

Starproduct pimped for 2.3

Mindsparx template osc Sport 2.2

Mindsparx template Horizon 2.3

+ a few more...

Share this post


Link to post
Share on other sites

Hello,

 

I am using OSC 3.0 with your MS 3.0 release for the admin section.

 

While adding new admins, and granting them access to specific sections, the icons on the right stagger downward instead of all aligning to the right on top of each other.

 

I don't know if this is a OSC bug or a MS bug, but I have a screenshot here.

 

osc3.0_ms3.0.jpg

 

 

Hi

Im glad that people using the admin for version 3.0 since the admin for that version looks pretty good as it is.

Im not sure if that is caused by MS since not that many files are changed... If you have a copy of the original admin, please have a look, and if it happen over there to, i´ll look in to that.


My contributions

Mindsparx admin for 2.2

Mindsparx admin for 2.3

Mindsparx admin for 3.0

Mindsparx specials 2.2

Starproduct pimped for 2.2

Starproduct pimped for 2.3

Mindsparx template osc Sport 2.2

Mindsparx template Horizon 2.3

+ a few more...

Share this post


Link to post
Share on other sites

Hi

 

Thanks for this great contribution - a big project with a pretty simple install that 'just works' - almost :) I installed version 4.0.

 

I just have one problem with it, over the sort options for displaying order information. I am seeing buttons like 'Sort Customers -> A B C From Top', 'Sort Customers -> Z Y X From Top' etc. etc. laid out side by side with a missing image graphic. They are all like this, which stretches the table far across the screen instead of displaying within the normal width. I suspect they are supposed to be toggle buttons that overlay each other rather than appearing side by side and perhaps the missing graphic images have something to do with it.

 

So what do I need to do to get the sort buttons on the order display working properly?

 

Thanks


www.jyoshna.com. Currently using OsC with STS, Super Download Store, Categories Descriptons, Manufacturers Description, Individual Item Status, Infopages unlimited, Product Sort, Osplayer with flashmp3player, Product Tabs 2.1 with WebFx Tabpane and other bits and pieces including some I made myself. Many thanks to all whose contributions I have used!

Share this post


Link to post
Share on other sites

Have just noticed the spreading out horizontally beyond the edge of the screen happens in IE. FireFox wraps the buttons around so the table width is preserved. Seems like there is some styling issue around the appearance of the menu for sorting order information (customers/order total/date purchased and status).


www.jyoshna.com. Currently using OsC with STS, Super Download Store, Categories Descriptons, Manufacturers Description, Individual Item Status, Infopages unlimited, Product Sort, Osplayer with flashmp3player, Product Tabs 2.1 with WebFx Tabpane and other bits and pieces including some I made myself. Many thanks to all whose contributions I have used!

Share this post


Link to post
Share on other sites

Hi there,

 

Thanks very much for this contribution, it's definitley a HUGE improvement on the standard admin section!

 

Most of my contribs seem to have been installed in to their relevant sections, except the InfoBox. I've fixed this to be in my Tools box.. but as soon as I click on the link the corresponding page is blank!

 

It takes me to .../infobox_configuration.php which I know is the right file - and the header/footer are there but there's no content to be displayed!

 

Any ideas?

 

Cheers

Share this post


Link to post
Share on other sites

And on other problem I have.... I also have the "Store Mode (Open | Closed | Maintenance)" contrib which basically puts a link to the store opening/closing on the configuration.php page... but since the installation it isn't displayed! Now I have looked at the coding for this page, and the installation for this contrib is still present!

 

Again, any thoughts with this?

 

Cheers!

Share this post


Link to post
Share on other sites

Great contribution.

 

I am having problems with the drop down boxes working when on ssl. Seems to work ok in i.e. 7 but not in i.e 8. Anybody else noticed this?

 

Webpage error details

 

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; GTB6; InfoPath.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)

Timestamp: Thu, 28 May 2009 11:29:49 UTC

 

 

Message: Object expected

Line: 115

Char: 2

Code: 0

URI: hxxps://blabla/admin/mindspar...ddsmoothmenu.js

 

In fact ive just noticed this problem when trying to insert a codebox on the forums with invalid argument errors! Maybe its the new buggy ie thats the problem.

 

Rich

 

 

I am having exactly the same problem. Can anyone help please. It is the first time i have tried to use SSL and this is my first store. It is giving me a mixed cotent error and diabling the menu drop downs.

 

Help appreciated.

 

Matt S

Share this post


Link to post
Share on other sites

I am having exactly the same problem. Can anyone help please. It is the first time i have tried to use SSL and this is my first store. It is giving me a mixed cotent error and diabling the menu drop downs.

 

Help appreciated.

 

Matt S

 

 

Okay - i have solved the issue with the SSL constantly throwing up errors making it unusable in IE.

 

In admin/includes/header.php at about line 59 is the following:

 

<script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jquery/1.2.6/jquery.min.js"></script>'>http://ajax.googleapis.com/ajax/libs/jquery/1.2.6/jquery.min.js"></script>

<script type="text/javascript" src="mindsparx_admin/template/<?php echo ADMIN_TEMPLATE?>/js/ddsmoothmenu.js">

 

 

 

This refers to a .js file that is not in the store and is accessed by http not https.

To fix the problem i downloaded the file from http://ajax.googleapis.com/ajax/libs/jquery/1.2.6/jquery.min.js by pasting that in the a browser window and saved the file to admin/mindsparx_admin/template/<YOUR CHOSEN TEMPLATE>/js/ the same path as the ddsmoothmenu.js file referenced in the second line of original text above.

 

I then just changed the original lines of code to:

<script type="text/javascript" src="mindsparx_admin/template/<?php echo ADMIN_TEMPLATE?>/js/jquery.min.js"></script>

<script type="text/javascript" src="mindsparx_admin/template/<?php echo ADMIN_TEMPLATE?>/js/ddsmoothmenu.js">

 

 

and everything is looking good.

 

Hope this helps anyone else having a problem with SSL in Mindsparx Admin for OSCommerce.

 

Matt S

Share this post


Link to post
Share on other sites

Hello Matt S Thanks for finding a solution for that, Please post that fix on the contribution page so that all of us can find it :)

 

/Janne


My contributions

Mindsparx admin for 2.2

Mindsparx admin for 2.3

Mindsparx admin for 3.0

Mindsparx specials 2.2

Starproduct pimped for 2.2

Starproduct pimped for 2.3

Mindsparx template osc Sport 2.2

Mindsparx template Horizon 2.3

+ a few more...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×