Jump to content
Sign in to follow this  
iankil

[Contribution] Mindsparx admin

Recommended Posts

Can someone explain me how can I make the admin login work?

 

My oscommerce admin enter automatic, dont ask for password. :(

 

Regards,

Share this post


Link to post
Share on other sites

This is regarding

Mindsparx Specials &

Star Product

 

I Redid my shop from scratch 3days ago but something went wrong after adding Mindsparx Specialst & Star Product , the Index page keeps placing them a box (.infoBoxContents). <_<

 

I'm sure it's something stupid I'm missing / misplaced. :blush:

 

This is a snippet from Index.php

		<td><table border="0" width="100%" cellspacing="0" cellpadding="0">
	  <tr>
			<img src="images/Sunline.png" width="1040" height="3">
	  </tr>
	  <tr>
	  <td>
		<?php include(DIR_WS_MODULES . FILENAME_STAR_PRODUCT);?><br />
		<?php include(DIR_WS_MODULES . MINDSPARX_SPECIALS);?><br />
		<?php include(DIR_WS_MODULES . FILENAME_NEW_PRODUCTS); ?><br />
		</td>
	</tr>
<?php
include(DIR_WS_MODULES . FILENAME_UPCOMING_PRODUCTS);
?>
	</table></td>
  </tr>
</table></td>
<?php
 }
?>
<!-- body_text_eof //-->

 

Sorry for bothering you with this, but I'm @ my 4th cup of coffee on this :(

Edited by Stephan (VS)

"I have no special talent. I am only passionately curious"

- Albert Einstein

Share this post


Link to post
Share on other sites

Hello Janne.k

I have the mindsparx running great! This is such a wonderful masterpiece you added to osc - thank you very much.

 

I do have one challenge. I installed the contribution "Individual Item Status" (http://addons.oscommerce.com/info/5644) and I was wondering if you knew of anyway to help me out in getting its admin panel to show up. For some reason I cant find it. The contribution itself runs great - but there's just no way for me to modify the contributions settings (because i dont see it).

 

 

Thanks a lot!

Kenz

Edited by kenz

Share this post


Link to post
Share on other sites

hi janne,

 

i have a problem, when creating submenus one after another, or when a submenu is at the top or the bottom of the dropdown-menu. here's an image of my problem:

 

imagesag.png

 

as you can see, there is a space between the menus. if i create submenus between two "normal" links it shows it correctly. this problem only appears on internet explorer. firefox displays it correctly. i've tried to customize the css-file, but i can't figure it out. maybe you have a solution for my problem.

 

regards.

 

ps: sorry for my english

Edited by sak1981

Share this post


Link to post
Share on other sites
hi janne,

 

i have a problem, when creating submenus one after another, or when a submenu is at the top or the bottom of the dropdown-menu. here's an image of my problem:

 

imagesag.png

 

as you can see, there is a space between the menus. if i create submenus between two "normal" links it shows it correctly. this problem only appears on internet explorer. firefox displays it correctly. i've tried to customize the css-file, but i can't figure it out. maybe you have a solution for my problem.

 

regards.

 

ps: sorry for my english

 

 

This is probably not a direct answer, but an easy way to check validate your HTML and CSS admin setup, is to download firebug from firefox and customize your code to your likings with some editing skills. From that point if its impossible to fix, then ask away.

Edited by kenz

Share this post


Link to post
Share on other sites
This is probably not a direct answer, but an easy way to check validate your HTML and CSS admin setup, is to download firebug from firefox and customize your code to your likings with some editing skills. From that point if its impossible to fix, then ask away.

 

hi kenz,

 

i've tried to use firebug before i posted my message. there is no way to change the css-file to display it correctly in internet explorer. with other browser, e.g. firefox and safari, there are no problems...

Share this post


Link to post
Share on other sites
hi janne,

 

i have a problem, when creating submenus one after another, or when a submenu is at the top or the bottom of the dropdown-menu. here's an image of my problem:

 

imagesag.png

 

as you can see, there is a space between the menus. if i create submenus between two "normal" links it shows it correctly. this problem only appears on internet explorer. firefox displays it correctly. i've tried to customize the css-file, but i can't figure it out. maybe you have a solution for my problem.

 

regards.

 

ps: sorry for my english

 

 

First of all; Janne thanks for this great contribution!!

 

sak1981,

 

Look in your admin\includes\boxes directory for localization.php and look in the code for (example):

 

$contents[] = array('text' => '<a href="' . tep_href_link(FILENAME_CURRENCIES, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_LOCALIZATION_CURRENCIES . '</a><br>' .

 

Remove the <br> at the end of the sentence. Do this for all the menu items where you have this problem.

 

/Martin.

Share this post


Link to post
Share on other sites
First of all; Janne thanks for this great contribution!!

 

sak1981,

 

Look in your admin\includes\boxes directory for localization.php and look in the code for (example):

 

$contents[] = array('text' => '<a href="' . tep_href_link(FILENAME_CURRENCIES, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_LOCALIZATION_CURRENCIES . '</a><br>' .

 

Remove the <br> at the end of the sentence. Do this for all the menu items where you have this problem.

 

/Martin.

 

 

Thank you all for your kind words and for helping , thats probably the issue with the menu ;)

 

/Janne


My contributions

Mindsparx admin for 2.2

Mindsparx admin for 2.3

Mindsparx admin for 3.0

Mindsparx specials 2.2

Starproduct pimped for 2.2

Starproduct pimped for 2.3

Mindsparx template osc Sport 2.2

Mindsparx template Horizon 2.3

+ a few more...

Share this post


Link to post
Share on other sites

martin,

 

thank you for your supprt. there was no br-tag in my code. but i found the solution by myself.

 

i changed this part this

echo '<li class="title">'.$value['text'].'</li>';

to

echo $value['text'];

 

at the beginning of every subcat

$taxSub1= '</li><li><a class="menuBoxContentLink" href="#">'.BOX_HEADING_HEADER_TAGS_SEO.'</a>

to

$taxSub1= '<li><a class="menuBoxContentLink" href="#">' . BOX_HEADING_LOCATION_AND_TAXES . '</a>

 

and at the end of every sub-categorie, i changed this:

</ul>
</li><li>';

to

</ul>
</li>';

Share this post


Link to post
Share on other sites

Hi Janne,

 

Your latest amendment to Mindsparx Admin says to edit in admin/mindsparx_admin/template/xxxx/ddsmoothmenu.css as follows:-

transition: {overtime:300, outtime:300}, //duration of slide in/ out animation, in milliseconds

change to

transition: {overtime:50, outtime:50}, //duration of slide in/ out animation, in milliseconds

The correct file to edit should be the /ddsmoothmenu.js and not /ddsmoothmenu.css

 

:mellow:

Share this post


Link to post
Share on other sites

Hi there,

 

great contribution, really, really great.

 

There is although one small thing that I mis, and I also missed in the the original admin. When I am in the catalog section, adding products, surfing to all the categories, is not very user friendly. This is why I added "category box as nested unordered" contribution, intended for the front end use, in the admin as a horizontal menu. Works really great and fast.

 

Because I missed it in Mindsparx, I also add this piece of code in it. But the dynamic menu of mindsparx looks really better then the one I was using, so I changed it to work with the dynamic menu. The problem is, I see only the head categories, but the child's categories are not folding.

 

Somebody tried it and got it to work?

I have added my piece of code in this message.

 

	$list = $table[$parcat];

while(list($key,$val) = each($list)){

	if ($GLOBALS['this_level'] != $level) {

			if ($GLOBALS['this_level'] < $level) {
					$output .= "\n".'<ul>';
				} else {
			for ($nest = 1; $nest <= ($GLOBALS['this_level'] - $level); $nest++) {
				$output .= '</ul></li>'."\n";	
				}
					}

			$GLOBALS['this_level'] = $level;
	}

	if (isset($cPath_array) && in_array($key, $cPath_array) && $classname_for_selected) {
		$this_cat_class = $classname_for_selected . ' ';
	} else {
		$this_cat_class = '';		
		}	

//		$output .= '<li class="'.$this_cat_class.'cat_lev_'.$level.'"><a class="link_lev_' .$level.'" href="';
	$output .= '<li><div class="line"><a  href="';

	if (!$level) {
				unset($GLOBALS['cPath_set']);
					$GLOBALS['cPath_set'][0] = $key;
		$cPath_new = 'cPath=' . $key;

	} else {
					$GLOBALS['cPath_set'][$level] = $key;		
		$cPath_new = 'cPath=' . implode("_", array_slice($GLOBALS['cPath_set'], 0, ($level+1)));
	}

	if (tep_has_category_subcategories2($key) && $classname_for_parent) {
		$this_parent_class = ' class="'.$classname_for_parent.'"';
	} else {
		$this_parent_class = '';		
		}				

	$output .= tep_href_link(FILENAME_CATEGORIES, $cPath_new) . '"'.$this_parent_class.'>'.$val;

	$output .= '';	

	if (!tep_has_category_subcategories2($key)) {
		$output .= '</li>'."\n";	
	}						 

	if ((isset($table[$key])) AND (($maxlevel > $level + 1) OR ($maxlevel == '0'))) {
		$output .= tep_make_cat_ulbranch2($key,$table,$level + 1,$maxlevel);
	}

	} // End while loop

return $output;

}	


?>

Share this post


Link to post
Share on other sites

Please help - i really dont know where to start and have been trying to fix this for days now and have yet to make any progress.

 

Info:

Store: 2.2 rc.2a

Various mods but nothing too heavy.

Fist time store so learning as go and lerning php through trial and error.

 

Problem:

Midsparx admin worked great locally on my test machine - I have now uploaded to a hosted 'live' environment. Store looks fine, DB uplaoded fine, admin fine although.... the images for buttons are not showing up.

 

On the index page - using the blue template - the green links across the top all show up fine, the logo is gine, but the buttons for packign slip, invoice etc are not downloading. Right clicking and selecting properties shows the image path as http://admin/mindsparx_admin/template/blue...packingslip.gif which is missing out the website URL completely.

 

What has gone wrong and where so I go to address this? As mentioned the url for the other images on the page are all fine.

 

Please help - i'm not sleeping trying to sort this without really knowing what i am looking for,

 

Many thanks - and thank you for a great contibution.

 

Matt S

Share this post


Link to post
Share on other sites

I installed Mindsparx Admin and it looks and works great, except for one thing... broken product images in the admin. The images upload successfully and show up in the cart. They are only broken in the admin. Where and how do I tell it to find the images?

 

Thank you, in advance.

 

Kathy

Share this post


Link to post
Share on other sites

Could someone please give me some advice. Uploaded Mindsparx admin and receive this message

The requested URL /admin/FILENAME_LOGIN was not found on this server.

 

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

 

Help :blink:

Share this post


Link to post
Share on other sites
Could someone please give me some advice. Uploaded Mindsparx admin and receive this message

The requested URL /admin/FILENAME_LOGIN was not found on this server.

 

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

 

Help :blink:

 

Problem was a typing error.

 

Now have new problem

1146 - Table 'pacartco_demo.TABLE_ADMINISTRATORS' doesn't exist

 

select id from TABLE_ADMINISTRATORS limit 1

 

Think it is to do with database but not sure, Please help! :blush:

Share this post


Link to post
Share on other sites
Problem was a typing error.

 

Now have new problem

1146 - Table 'pacartco_demo.TABLE_ADMINISTRATORS' doesn't exist

 

select id from TABLE_ADMINISTRATORS limit 1

 

Think it is to do with database but not sure, Please help! :blush:

 

All is ok now, Inserted define('TABLE_ADMINISTRATORS', 'administrators'); into database_tables.php

Thanks for great contrib. :rolleyes:

Share this post


Link to post
Share on other sites

Cool contribution, thanks!

 

I really like the index page, which lays outs a lot of good information in one place and is easy to look at, however, whenever I go back to it, it requires I log in again. I find myself constantly having to type and retype my login constantly. Is this normal, or is something not right? I am using the Mindsparx Admin V2.1 and OS Commerce 2.2RC2.

 

Also, I will try to figure this one out, but when I clicked administrators after I first install it used to work, but now I go to a blank page. I must have changed something somewhere, but thought I would mention it in case someone had a quick suggestion as to where I should look.

 

Thanks!

 

Chris

Edited by dauerc

Share this post


Link to post
Share on other sites

Hello - wonderful contribution - thank you!!

 

I have the following contrib's added:

 

Comments-at-a-glance: http://addons.oscommerce.com/info/3370/v,22

Orders-at-a-glance: http://addons.oscommerce.com/info/3454

 

 

After installing your Mindsparx admin contribution, the talk bubbles are still there, there are no error messages on the orders page, but nothing happens when I roll over the talk bubbles.

 

Any help would be greatly appreciated - I use this "at a glance" function ALL the time, it saves quite a few steps -

 

Thanks!!

Share this post


Link to post
Share on other sites

After reviewing the installation instructions for the Orders-at-a-glace and Comments-at-a-glance contributions I realized that I had to add something back to the admin/includes/header.php file that was overwritten with your contrib. Here is what I had to add:

 

FIND this code at the top of admin/includes/header.php:

 

---------------------------------------------

 

if ($messageStack->size > 0) {

echo $messageStack->output();

}

?>

---------------------------------------------

 

 

 

ADD this code immediately after it:

 

----------------------------------------------

 

<div id="dhtmltooltip"></div>

 

<script type="text/javascript">

 

/***********************************************

* Cool DHTML tooltip script- © Dynamic Drive DHTML code library (www.dynamicdrive.com)

* This notice MUST stay intact for legal use

* Visit Dynamic Drive at http://www.dynamicdrive.com/ for full source code

***********************************************/

 

var offsetxpoint=-60 //Customize x offset of tooltip

var offsetypoint=20 //Customize y offset of tooltip

var ie=document.all

var ns6=document.getElementById && !document.all

var enabletip=false

if (ie||ns6)

var tipobj=document.all? document.all["dhtmltooltip"] : document.getElementById? document.getElementById("dhtmltooltip") : ""

 

function ietruebody(){

return (document.compatMode && document.compatMode!="BackCompat")? document.documentElement : document.body

}

 

function ddrivetip(thetext, thecolor, thewidth){

if (ns6||ie){

if (typeof thewidth!="undefined") tipobj.style.width=thewidth+"px"

if (typeof thecolor!="undefined" && thecolor!="") tipobj.style.backgroundColor=thecolor

tipobj.innerHTML=thetext

enabletip=true

return false

}

}

 

function positiontip(e){

if (enabletip){

var curX=(ns6)?e.pageX : event.clientX+ietruebody().scrollLeft;

var curY=(ns6)?e.pageY : event.clientY+ietruebody().scrollTop;

//Find out how close the mouse is to the corner of the window

var rightedge=ie&&!window.opera? ietruebody().clientWidth-event.clientX-offsetxpoint : window.innerWidth-e.clientX-offsetxpoint-20

var bottomedge=ie&&!window.opera? ietruebody().clientHeight-event.clientY-offsetypoint : window.innerHeight-e.clientY-offsetypoint-20

 

var leftedge=(offsetxpoint<0)? offsetxpoint*(-1) : -1000

 

//if the horizontal distance isn't enough to accomodate the width of the context menu

if (rightedge<tipobj.offsetWidth)

//move the horizontal position of the menu to the left by it's width

tipobj.style.left=ie? ietruebody().scrollLeft+event.clientX-tipobj.offsetWidth+"px" : window.pageXOffset+e.clientX-tipobj.offsetWidth+"px"

else if (curX<leftedge)

tipobj.style.left="5px"

else

//position the horizontal position of the menu where the mouse is positioned

tipobj.style.left=curX+offsetxpoint+"px"

 

//same concept with the vertical position

if (bottomedge<tipobj.offsetHeight)

tipobj.style.top=ie? ietruebody().scrollTop+event.clientY-tipobj.offsetHeight-offsetypoint+"px" : window.pageYOffset+e.clientY-tipobj.offsetHeight-offsetypoint+"px"

else

tipobj.style.top=curY+offsetypoint+"px"

tipobj.style.visibility="visible"

}

}

 

function hideddrivetip(){

if (ns6||ie){

enabletip=false

tipobj.style.visibility="hidden"

tipobj.style.left="-1000px"

tipobj.style.backgroundColor=''

tipobj.style.width=''

}

}

 

document.onmousemove=positiontip

 

</script>

 

 

 

 

HOWEVER - still no success in getting the function to work!! Help!! :blink:

Share this post


Link to post
Share on other sites

I was wondering is there a chance to specify in different language the words "Delivered: 0, Pending: 0, Processing: 0, Σήμερα: 0" as you can see I can change the very last word "Today" with greek word "Σήμερα" but it seams I am unable to do the same with the rest. Any ideas ?

Share this post


Link to post
Share on other sites

Hello

A new version is out, mindsparx_admin 4.0 now there is 5 different themes available one of them is Stefan VS good looking theme. The old menu from version 2.0 is back, i had to many complaints with the menu from 2.1 so i changed it back, and i think its much better than the old one.

 

You can see what the admin and themes looks like here http://www.mindsparx.org/mindsparx_admin/

 

/Janne.k


My contributions

Mindsparx admin for 2.2

Mindsparx admin for 2.3

Mindsparx admin for 3.0

Mindsparx specials 2.2

Starproduct pimped for 2.2

Starproduct pimped for 2.3

Mindsparx template osc Sport 2.2

Mindsparx template Horizon 2.3

+ a few more...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×