Jump to content

Archived

This topic is now archived and is closed to further replies.

atjhza

Easy Populate........how to?

Recommended Posts

Hi,

 

I've just started to create a store and want to use the Easy Populate add on.

 

I have downloaded the zip file but apart from that I'm getting nowhere and a bit lost. Is there a stupid idiots guide on how to install? I've installed it to where I thought it should go but I'm still no further on. It's not showing in admin-tools-easypopulate.

 

Any help for this poor fool would be greatly appreciated

 

Thanks.

Share this post


Link to post
Share on other sites

You need to follow all the installation instructions that come with the contribution.

 

Try looking in the doc folder.


Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites

I've read them but I'm not sure as to where to place the folders.

 

for example, do they go into the root folder alongside the current admin folder and all the others that are currently in there?

 

It may seem a bit simple but I'm really confused.

 

:blush:

Share this post


Link to post
Share on other sites

Not sure what is not clear here:-

 

1. Copy file easypopulate.php and easypopulate_functions.php into

/catalog/admin/ or whatever folder you have placed the osCommerce admin.

 

 

2. Copy the file /catalog/admin/includes/classes/table_block.php into

/catalog/admin/includes/classes/ folder, overwriting the current file

if you have not made any changes to this file before.

This file fixes a bug documented here: http://www.oscommerce.com/community/bugs,2003

(well, it was documented there, seems like the 2.2MS2 bug tracking is gone now)

 

 

3. For adding link to the Admin, edit file admin/includes/boxes/catalog.php.

 

## After:

 

'<a href="' . tep_href_link(FILENAME_PRODUCTS_ATTRIBUTES, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_CATEGORIES_PRODUCTS_ATTRIBUTES . '</a><br>' .

 

## Add this:

 

'<a href="' . tep_href_link('easypopulate.php', '', 'NONSSL') . '" class="menuBoxContentLink">Easy Populate</a><br>' .


Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites

Ok.......I thought i'd copied the code correctly but can you advise me where I've gone wrong please! Below is the amended code:

 

 

 

 

 

<?php

/*

$Id: catalog.php 1739 2007-12-20 00:52:16Z hpdl $

 

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2002 osCommerce

 

Released under the GNU General Public License

*/

?>

<!-- catalog //-->

<tr>

<td>

<?php

$heading = array();

$contents = array();

 

$heading[] = array('text' => BOX_HEADING_CATALOG,

'link' => tep_href_link(FILENAME_CATEGORIES, 'selected_box=catalog'));

 

if ($selected_box == 'catalog') {

$contents[] = array('text' => '<a href="' . tep_href_link(FILENAME_CATEGORIES, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_CATEGORIES_PRODUCTS . '</a><br>' .

'<a href="' . tep_href_link(FILENAME_PRODUCTS_ATTRIBUTES, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_CATEGORIES_PRODUCTS_ATTRIBUTES . '</a><br>' .

'<a href="' . tep_href_link('easypopulate.php', '', 'NONSSL') . '" class="menuBoxContentLink">Easy Populate</a><br>'

'<a href="' . tep_href_link(FILENAME_MANUFACTURERS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_MANUFACTURERS . '</a><br>' .

'<a href="' . tep_href_link(FILENAME_REVIEWS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_REVIEWS . '</a><br>' .

'<a href="' . tep_href_link(FILENAME_SPECIALS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_SPECIALS . '</a><br>' .

'<a href="' . tep_href_link(FILENAME_PRODUCTS_EXPECTED, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_PRODUCTS_EXPECTED . '</a>');

}

 

$box = new box;

echo $box->menuBox($heading, $contents);

?>

</td>

</tr>

<!-- catalog_eof //-->

Share this post


Link to post
Share on other sites

Geoffery,

 

I assume you know something about easy populate....

Before I download and muddle my way through the DOCs....,

Does this program allow one to populate the products catalog with product listings from lets say an excel spreadsheet ?

I suppose the DOCs clearly tell us how to format the spreadsheet so that all info will be included...

How does it handle images ? Or is that the manual part ?

 

Is it reliable ?

 

Many thanks in advance for your comments !

 

Steve

PerdidoBeach, AL

Share this post


Link to post
Share on other sites

Yes, but it has to have the column titles it expects.

 

If you dont use a column you can normally miss it out.

 

You specify where the images will be stored and upload those yourself using an ftp client.


Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites

Ok.......I thought i'd copied the code correctly but can you advise me where I've gone wrong please! Below is the amended code:

 

 

 

 

 

<?php

/*

$Id: catalog.php 1739 2007-12-20 00:52:16Z hpdl $

 

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2002 osCommerce

 

Released under the GNU General Public License

*/

?>

<!-- catalog //-->

<tr>

<td>

<?php

$heading = array();

$contents = array();

 

$heading[] = array('text' => BOX_HEADING_CATALOG,

'link' => tep_href_link(FILENAME_CATEGORIES, 'selected_box=catalog'));

 

if ($selected_box == 'catalog') {

$contents[] = array('text' => '<a href="' . tep_href_link(FILENAME_CATEGORIES, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_CATEGORIES_PRODUCTS . '</a><br>' .

'<a href="' . tep_href_link(FILENAME_PRODUCTS_ATTRIBUTES, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_CATEGORIES_PRODUCTS_ATTRIBUTES . '</a><br>' .

'<a href="' . tep_href_link('easypopulate.php', '', 'NONSSL') . '" class="menuBoxContentLink">Easy Populate</a><br>'

'<a href="' . tep_href_link(FILENAME_MANUFACTURERS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_MANUFACTURERS . '</a><br>' .

'<a href="' . tep_href_link(FILENAME_REVIEWS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_REVIEWS . '</a><br>' .

'<a href="' . tep_href_link(FILENAME_SPECIALS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_SPECIALS . '</a><br>' .

'<a href="' . tep_href_link(FILENAME_PRODUCTS_EXPECTED, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_PRODUCTS_EXPECTED . '</a>');

}

 

$box = new box;

echo $box->menuBox($heading, $contents);

?>

</td>

</tr>

<!-- catalog_eof //-->

 

Ok.......I thought i'd copied the code correctly but can you advise me where I've gone wrong please! Below is the amended code:

 

 

 

 

 

<?php

/*

$Id: catalog.php 1739 2007-12-20 00:52:16Z hpdl $

 

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2002 osCommerce

 

Released under the GNU General Public License

*/

?>

<!-- catalog //-->

<tr>

<td>

<?php

$heading = array();

$contents = array();

 

$heading[] = array('text' => BOX_HEADING_CATALOG,

'link' => tep_href_link(FILENAME_CATEGORIES, 'selected_box=catalog'));

 

if ($selected_box == 'catalog') {

$contents[] = array('text' => '<a href="' . tep_href_link(FILENAME_CATEGORIES, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_CATEGORIES_PRODUCTS . '</a><br>' .

'<a href="' . tep_href_link(FILENAME_PRODUCTS_ATTRIBUTES, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_CATEGORIES_PRODUCTS_ATTRIBUTES . '</a><br>' .

'<a href="' . tep_href_link('easypopulate.php', '', 'NONSSL') . '" class="menuBoxContentLink">Easy Populate</a><br>'

'<a href="' . tep_href_link(FILENAME_MANUFACTURERS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_MANUFACTURERS . '</a><br>' .

'<a href="' . tep_href_link(FILENAME_REVIEWS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_REVIEWS . '</a><br>' .

'<a href="' . tep_href_link(FILENAME_SPECIALS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_SPECIALS . '</a><br>' .

'<a href="' . tep_href_link(FILENAME_PRODUCTS_EXPECTED, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_PRODUCTS_EXPECTED . '</a>');

}

 

$box = new box;

echo $box->menuBox($heading, $contents);

?>

</td>

</tr>

<!-- catalog_eof //-->

 

 

My Catalog.php looks nothing like this.

Mine is :

 

 

<?php

/*

$Id$

 

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2010 osCommerce

 

Released under the GNU General

 

Public License

*/

 

$cl_box_groups[] = array(

'heading' => BOX_HEADING_CATALOG,

'apps' => array(

array(

'code' => FILENAME_CATEGORIES,

'title' =>

 

BOX_CATALOG_CATEGORIES_PRODUCTS,

'link' => tep_href_link(FILENAME_CATEGORIES)

),

array(

'code' => FILENAME_PRODUCTS_ATTRIBUTES,

'title' =>

 

BOX_CATALOG_CATEGORIES_PRODUCTS_ATTRIBUTES,

'Easy Populate' . 'link' => tep_href_link(FILENAME_PRODUCTS_ATTRIBUTES)

),

array(

'code' =>

 

FILENAME_MANUFACTURERS,

'title' => BOX_CATALOG_MANUFACTURERS,

'link' => tep_href_link(FILENAME_MANUFACTURERS)

),

array(

'code' =>

 

FILENAME_REVIEWS,

'title' => BOX_CATALOG_REVIEWS,

'link' => tep_href_link(FILENAME_REVIEWS)

),

array(

'code' => FILENAME_SPECIALS,

'title' =>

 

BOX_CATALOG_SPECIALS,

'link' => tep_href_link(FILENAME_SPECIALS)

),

array(

'code' => FILENAME_PRODUCTS_EXPECTED,

'title' =>

 

BOX_CATALOG_PRODUCTS_EXPECTED,

'link' => tep_href_link(FILENAME_PRODUCTS_EXPECTED)

)

)

);

?>

 

 

Where can I add the code for EasyPopulate to show up in admin tools?

 

Cheers

Share this post


Link to post
Share on other sites

Anyone??

 

you could write this:

 

'<a href="' . tep_href_link('easypopulate.php', '', 'NONSSL').'" class="menuBoxContentLink">' . 'Easy Populate' . '</a><br>' .

 

in catalog.php after line 25 (like it is written in the instruction). For some reason it is not showing the full part of code to be written there.

Share this post


Link to post
Share on other sites

But,

When I download the file EP_v2_77a.zip it does NOT contain catalog.php anywhere.... the hierarchy is as follows in the directions

 

/catalog/admin/easypopulate.php

/catalog/admin/easypopulate_functions.php

/catalog/admin/EPDocumentation/index.html

/catalog/admin/EPDocumentation/contents.htm

/catalog/admin/EPDocumentation/links.htm

/catalog/admin/includes/classes/table_block.php

/catalog/admin/includes/boxes/catalog.php

/catalog/temp/

 

my download does NOT have /catalog/admin/includes/boxes/catalog.php

 

What do I do?

Share this post


Link to post
Share on other sites

×