Jump to content
Latest News: (loading..)
Sign in to follow this  
Viper0409

Auspost 3.01 update error

Recommended Posts

I have just updated from auspost 2.02c to auspost 3.01. After uploading all the necessary files to the correct folders on the server and then navigating to the admin > shipping module and before I can uninstall and reinstall the shipping modules, I receive this error > > > Fatal error: Cannot redeclare class auspost in catalog/includes/modules/shipping/auspost.php on line 17.

 

Line 17 is class auspost {

 

I get exactly the same error when I try to proceed to checkout in the storefront.

 

Does anyone have ideas or solutions for this error. Thanks in advance.

 

Andrew

Share this post


Link to post
Share on other sites
I have just updated from auspost 2.02c to auspost 3.01. After uploading all the necessary files to the correct folders on the server and then navigating to the admin > shipping module and before I can uninstall and reinstall the shipping modules, I receive this error > > > Fatal error: Cannot redeclare class auspost in catalog/includes/modules/shipping/auspost.php on line 17.

 

Line 17 is class auspost {

 

I get exactly the same error when I try to proceed to checkout in the storefront.

 

Does anyone have ideas or solutions for this error. Thanks in advance.

 

Andrew

My guess is that copied the modules/ etc files into the languaguage/modules/ etc


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites

Hi Coopco

 

Thanks for your quick response. I am sure that I have uploaded the catalog/includes/modules/shipping files and the catalog/includes/languages/english/modules/shipping files to their correct locations. My next step was to uninstall and reinstall the shipping modules in admin but this error came up before I got that far.

 

I would appreciate any further assistance if you have other suggestions. I am stuck at the moment, I just don't understand what the error is pointing to.

 

Thanks again.

 

Andrew

Share this post


Link to post
Share on other sites
Hi Coopco

 

Thanks for your quick response. I am sure that I have uploaded the catalog/includes/modules/shipping files and the catalog/includes/languages/english/modules/shipping files to their correct locations. My next step was to uninstall and reinstall the shipping modules in admin but this error came up before I got that far.

 

I would appreciate any further assistance if you have other suggestions. I am stuck at the moment, I just don't understand what the error is pointing to.

 

Thanks again.

 

Andrew

If you saved the older versions by using a slightly different name eg austpost.php it can happen.

 

You could delete all the austpost files and reupload, the try the uninstall, reinstall. Or, reupload the old version and uninstall that.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites

Hi Coopco

 

Ok, I think you were right the first time, I will reupload the files again and double check each one before hitting the upload button. I will post back here to let you know how I go.

 

Thanks again.

 

Andrew

Share this post


Link to post
Share on other sites
Hi Coopco

 

Ok, I think you were right the first time, I will reupload the files again and double check each one before hitting the upload button. I will post back here to let you know how I go.

 

Thanks again.

 

Andrew

OK, hope all goes well.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites

Thanks Coopco

 

for pointing me in the right direction the first time and apologies, I was sure I got it right but in fact I did upload the wrong files to catalog/includes/languages/english/modules/shipping. It is working ok now, but I need to set it up with my previous settings. .

 

Are the default values for the insurance etc the correct ones ? if not do you have a link to where I can get the correct settings.

 

Thanks again, much appreciated.

 

Andrew

Share this post


Link to post
Share on other sites
Thanks Coopco

 

for pointing me in the right direction the first time and apologies, I was sure I got it right but in fact I did upload the wrong files to catalog/includes/languages/english/modules/shipping. It is working ok now, but I need to set it up with my previous settings. .

 

Are the default values for the insurance etc the correct ones ? if not do you have a link to where I can get the correct settings.

 

Thanks again, much appreciated.

 

Andrew

The default values are not current. You can get the Post Charges September 2008 from the PO, or online.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites
Thanks again, I have a bit of reading to do before I can set the final settings for my store.

 

Andrew

No problem, I hope the PMs helped.

 

The PO issues new booklets each May and September.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×