Jump to content
kymation

[Contribution] Categories Images Box support thread

Recommended Posts

Your error is a well-known session bug in osCommerce. See post #6 in <a href="http://forums.oscommerce.com/topic/346007-first-post-here-please-help-me/page__p__1444591entry1444591">this thread</a>.

 

I see nothing wrong with the code that you posted. Is that still giving you an error, even without the added code? If it is, something is wrong with your editor, or you are using FTP in Binary mode. Either one can cause file corruption.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hi Jim,

 

I'll update that then,

 

Really appreciate you looking into the categories image box problem.

 

I used Dreamweaver's FTP upload, and I don't think that has ever been an issue.

 

Please let me know if you think of something that might re-solve that issue I've got.

 

Again, it was some simple fix, that's all I can remember.

 

Jason

Share this post


Link to post
Share on other sites

Hi Jim,

 

I'm wondering...

 

In the admin section, where you upload your categories images, there are two separate uploading parts.

 

On mine, BOTH say "Category Image:" next to the "Choose File" button (I think that button would be labeled "Browse" on a PC )

 

Should one of these upload tools say "Categories Images Box Image" ?

 

 

Did I find something here that may lead to a fix?

 

Jason

Share this post


Link to post
Share on other sites

That is definitely wrong. It's probably only the text part that's incorrect or your database would not contian the image name that you say is there. It should still be fixed to avoid confusion.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hello,

 

How do we change the text color with also changing the infobox color?

 

I'm just wanting to change the colors of the text under the categories images, and not the infoboxes.

 

do I have to modify something in the categories images php file in the modules directory?

 

I tried adding a text color change to the stylesheet under the categories images box section, with no success

 

Thank you,

 

Jason

Share this post


Link to post
Share on other sites

My previous post should have been written as "How do we change the text color without also changing the infobox color?"

 

Figured it out, here is the solution if anyone needs to do the same.

 

Change your categories_images.php file found in the modules directory from:

 

// Show the products name if selected in Admin
           if (CATEGORIES_IMAGES_BOX_SHOW_NAME == 'True') {
             if ($space_above == true) {
               $info_box_text .= "<br>\n";
             }
             $info_box_text .= $category['name'];
             $space_above = true;
           } //if (CATEGORIES_IMAGES_BOX_SHOW_NAME

 

To this: (insert whichever colour you may need)

 

// Show the products name if selected in Admin
           if (CATEGORIES_IMAGES_BOX_SHOW_NAME == 'True') {
             if ($space_above == true) {
               $info_box_text .= "<br>\n<font color=#302226>";
             }
             $info_box_text .= $category['name'];
             $space_above = true;
           } //if (CATEGORIES_IMAGES_BOX_SHOW_NAME

 

Take care,

 

Jason

Edited by rustyclockwork

Share this post


Link to post
Share on other sites

I am considering adding this to my newbie site but noticed that you stylesheet.css doesn't come close to comparing with mine in the catalog directory.

If your stylesheet.css is correct, which directory is used?

Share this post


Link to post
Share on other sites

The stylesheet in this package is the stock osCommerce stylesheet with one new class for the new box, added at the very end. Make certain that you're looking at the catalog/stylesheet.css and not the one for the demo.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hi Jim,

 

 

I just installed this on a clients website and noticed that no images are being displayed on the index page. I see from previous posts this issue has been discussed but I don't see a resolution. Has a fix been found ?

 

 

 

 

Chris


:|: Was this post helpful ? Click the LIKE THIS button :|:

 

See my Profile to learn more about add ons, templates, support plans and custom coding (click here)

Share this post


Link to post
Share on other sites

Many people have asked this question. I always answer with "Did you upload any images for it to use?" and they disappear without another comment.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hi Jim

 

I sort have figured it out, although the way it is set up in the Admin>catalog is confusing. During the category creation process, it has a separate place for the image as shown in the screen shot. However, I figured out how to use it. Thank you for your reply.

 

screenshot.jpg

 

 

 

 

Chris


:|: Was this post helpful ? Click the LIKE THIS button :|:

 

See my Profile to learn more about add ons, templates, support plans and custom coding (click here)

Share this post


Link to post
Share on other sites

I don't know how to make it less confusing. 4.2 in the instructions tells you how to do this. There's also a screenshot of the Admin page. Maybe you can suggest an improvement?

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hi Jim,

 

 

Is it necessary to have both image upload fields once this contribution is installed ? I mean, would someone choose to have a different image for the category and the index page ?

 

 

 

Chris


:|: Was this post helpful ? Click the LIKE THIS button :|:

 

See my Profile to learn more about add ons, templates, support plans and custom coding (click here)

Share this post


Link to post
Share on other sites

Yes, this was a requested feature. Of all of the stores I have installed this on, I believe that only one has the same images in both places.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hi Jim,

 

Thank you for your responses. All is good, it's working and the client will be happy.

 

 

 

Thanks again

 

 

Chris


:|: Was this post helpful ? Click the LIKE THIS button :|:

 

See my Profile to learn more about add ons, templates, support plans and custom coding (click here)

Share this post


Link to post
Share on other sites

I'm wondering if this addon could be modified to do what I need or if anyone has any ideas:

 

I need to show a banner image across the top of the product listing whenever a category from the menu is selected...very much like what is here, but image only and on the product pages.

 

Anyone have ideas? :)

 

thanks!

Share this post


Link to post
Share on other sites

That's not what this Addon was intended to do. I'm not aware of anything that is, but it shouldn't be all that hard to do.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

That's not what this Addon was intended to do. I'm not aware of anything that is, but it shouldn't be all that hard to do.

 

Regards

Jim

 

Hi Jim -- Yes, of course you're right :)

 

It was actually surprisingly easy to accomplish what I needed.... one line inserted 4 times in index.php.

 

<IMG SRC="/images/category_banners/<?php echo $cPath ?>.jpg">

 

I simply have an image for every category/subcategory that is saved with its correct cPath variable and it works perfectly. Not elegant, but very effective.

Edited by mattvirus

Share this post


Link to post
Share on other sites

Hi Jim

 

Cheers for the great contribution.

This might be a bit of an odd request but a community member "acbatchelor"

Posted this on the 8th Aug 08 in this forum...

 

Thanks for this contribution, it is exactly what i need except for one thing. I would like to add this grid to the subcatagories also. On the top catagories, the grid is there but when you click one of the catagories it takes you to the subcatagories in the regular format. If you can tell me how to add this contribution to the subcatagories i would be grateful. I know the subcatagories is about the same without this grid but i want it to keep the same look, and it works better with the design of my site.

 

Have you any clue as to how this was achieved as I am trying to do the same thing?

appreciate any help.

Cheers Chad

Share this post


Link to post
Share on other sites

There is another addon to change categories to grid form. I don't remember the name, and I've never used it myself, but others claim that it works. Possibly this one?

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Congratulations, you've found a bug. Change Line 72 of that file to:

		  $width = (floor (100 / CATEGORIES_IMAGES_BOX_COLUMNS) );

Sorry for the inconvenience. That's what I get for trying to reuse code and forgetting to change all of the constants.

 

Regards

Jim

 

i keep getting this Warning: Division by zero in /home/goddess7/public_html/includes/modules/product_listing.php on line 121 it shows up on some pages when i choose from categories. i also have some sort of broken image onmy home page can you please tell me how to get rid of this. i would like to have a image or banner going across the top of the page. i some how lost my header and my footer text can you tell me how to fix this too? it shows up in the admin like its there but when i go to the home page it is not there. i would like to get rid of the pink and black images so that the new categories can go there how do i do that? and can i use Simple Multiple Images (Unlimited) with Fancy Popups with this install? thank you or any one else who can help me in advance

Share this post


Link to post
Share on other sites

This topic is here to support the Categories Images Box Addon. It's not for general support. Start a new topic in the appropriate support forum for your questions. I also suggest one question per post, if you really want answers.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

This topic is here to support the Categories Images Box Addon. It's not for general support. Start a new topic in the appropriate support forum for your questions. I also suggest one question per post, if you really want answers.

 

Regards

Jim

 

it this addon compatible with Simple Multiple Images (Unlimited) with Fancy Popups contribution?

Share this post


Link to post
Share on other sites

This Addon adds its own images to use in the box, so it should be safe to use with any of the multiple images addons.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hi, I have installed this contribution on my new store and I thought all was well, however just by chance I saw my home page on my sons laptop using Internet Explorer, I only use firefox, and the categories boxes were not showing. They are showing in Firefox. Can someone please tell me why?

 

I have 2 sites I am currently working on which are classgifts.co.uk and topclassfurniture.co.uk and this is happening with both stores. If someone could look at these via both firefox and IE it would be much appreciated.

 

Thanks, Michael

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×