Latest News: (loading..)
woohah

USPS shipping module setup help

8 posts in this topic

As the topic reads, I am in need of some help setting up the USPS shipping in my store. I have registered with http://www.uspsprioritymail.com/et_regcert.html already and have received my username and password. I input that into the module settings and set the tax class to none and the shipping zone to none. I do not charge a handling fee, so I keep that as default 0. I turn the mod on and then go test. When I test I get the following:

 

Shipping Method

This is currently the only shipping method available to use on this order.

 

United States Postal Service United States Postal Service

An error occured with the USPS shipping calculations.

If you prefer to use USPS as your shipping method, please contact the store owner.

 

 

 

What is the deal with this and how do I solve this? Im using the latest version of OSCommerce. Please help me!!

Share this post


Link to post
Share on other sites

I've got the same exact issue with the same exact errors.

 

Does this have to do with USPS changing it's URL for the API's?

 

Any help would be appreciated.

 

THANKS

Share this post


Link to post
Share on other sites

Just got this...

 

 

Dear Web Tools customer,

 

There will be several changes implemented in Web Tools by November 17, 2008. While the

APIs will remain structurally and syntactically backward compatible, changes are possibly

substantial enough to affect some users. Please contact icustomercare@usps.com (1-800-

344-7779) with any specific schema or enumeration changes.

 

* Effective September 2008, Bound Printed Matter is no longer a valid service type for all

versions of the Delivery Confirmation, Delivery Confirmation PIC, Signature

Confirmation, and Signature Confirmation PIC APIs. On November 14, 2008, Web

Tools will return an error document instead of a successful label response as shown

below:

 

EFFECTIVE 11/14/2008

PRIOR TO 11/14/2008

Code:

 

<DeliveryConfirmPICCertifyV3.0Request

USERID="xxx">

<FromZip5>20770</FromZip5>

<ToZip5>06371</ToZip5>

<ServiceType>Bound Printed

Matter</ServiceType>

</DeliveryConfirmPICCertifyV3.0Request>

 

<?xml version="1.0"?>

<Error>

<Number>-2147218882</Number>

 

<Source>DC_Respond.DelivConfirmV3:clsDelivery

ConfirmationV3.0.ProcessDCRequest;

SOLServerConfrm.DC_Respond</Source>

<Description>Effective September 2008, Bound

Printer Matter is no longer a valid service type for

this API. (BPM is restricted to labels with Permit

Imprint.)</Description>

<HelpFile/>

<HelpContext>1000440</HelpContext>

</Error>

 

<?xml version="1.0"?>

<DeliveryConfirmPICCertifyV3.0Response>

 

<DeliveryConfirmationNumber>4200637191020385557498

74163074</DeliveryConfirmationNumber>

</DeliveryConfirmPICCertifyV3.0Response>

 

 

* The underlying infrastructure for USPS Web Tools will be changing on November 14,

2008. There will be a Domain Name Service change that will change the IP address

resolution for the production.shippingapis.com and secure.shippingapis.com names.

This change will not affect the URLs used to access the API's, so there should be no

impact to existing calls and no interruption of service. If you encounter any

communications problems on or after this time, please contact the Internet Customer

Care Center.

 

* Global Express Guaranteed (GXG) product postage prices will no longer be returned in

the Internationl Rates API (IntlRate) if the value of a shipment exceeds the maximum

value allowed for GXG to the destination country.

 

For the latest API documenation, including Electronic Merchandise Return Service V4 and

Express Mail Hold For Pickup, please see www.usps.com/webtools/technical.htm.

Edited by mondofood

Share this post


Link to post
Share on other sites

Hi,

 

I am using the USPS module. Nothing was working. I tried other versions... no good. Found a post to "call the phone number on your confirmation email from USPS and get them to move you to the production server."

 

I called, they moved me and everything immediately started working.

 

Hope it helps.

 

Dana Haynes

http://www.accularian.com

Online Macintosh Training Videos

Edited by paragonegs

Share this post


Link to post
Share on other sites
I called, they moved me and everything immediately started working.

 

I didn't get any type of phone number when I signed up. The url listed in oscommerce:

http://www.uspsprioritymail.com/et_regcert.html

Resolved to:

http://www.usps.com/webtools/

 

I signed up for an account there and got some type of generic confirmation email that doesn't have any type of number or setup information.

 

Username: *******

Account Type: Business

 

Thank you for registering with USPS.com. With your new username and password, you can immediately take advantage of the following products and services:

 

Buy stamps

http://shop.usps.com/webapp/wcs/stores/ser...p;top_category=

 

Manage PO Boxes Online

https://poboxes.usps.com/poboxonline/search/landingPage.do

 

Order mailing/shipping supplies

http://shop.usps.com/webapp/wcs/stores/ser...p;top_category=

 

Create a shipping label

https://sss-web.usps.com/cns/landing.do

 

Schedule a package pickup

https://carrierpickup.usps.com/cgi-bin/WebO...rrierPickup.woa

 

Sign in and get started!

http://www.usps.com

 

Forgot your password? Reset it here.

https://ecap-ws-prod.usps.com/entreg/forgotPasswordView.do

 

Did I not get signed up to the right type of account?

 

What phone number do I call?

 

Kirk

Edited by kirkdickinson

Share this post


Link to post
Share on other sites
I didn't get any type of phone number when I signed up. The url listed in oscommerce:

http://www.uspsprioritymail.com/et_regcert.html

Resolved to:

http://www.usps.com/webtools/

 

I signed up for an account there and got some type of generic confirmation email that doesn't have any type of number or setup information.

 

Did I not get signed up to the right type of account?

 

What phone number do I call?

 

Kirk

 

Hello Kirk,

I'm happy to help. Hey it looks like you went to the right address. You should have gotten an email titled "USPS Shipping API Activation". If still need the phone number, here it is:

 

If you have any questions, please contact the USPS Internet Customer Care Center (ICCC). The ICCC is staffed from 7:00AM to 11:00PM Eastern Time.

Email: icustomercare@usps.com

Telephone: 1-800-344-7779 (7:00AM to 11:00PM ET)

 

 

I would say your first bet is to call them which works much much faster.

 

BTW, my account is now in production and this module still doesn't work. The USPS Contribution Module seems to be very buggy since it breaks my admin shipping page. I tried different version and same problem. I don't know what else to do.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now