Jump to content
Sign in to follow this  
micheleangle

Check out process

Recommended Posts

Hi! I’ve looked over hundreds of pages in this forum to find what I want and cannot find it. I’ve read about FEC and PWA addons and looked at some of your sites, but have found none that does the following: (I apologize if there is a site which does this – please let me know.)

 

Customer:

• places items in cart

• clicks checkout (subtotal appears)

• enters zip code (indicating where to ship)

• total appears (includes subtotal above of products, plus tax, if applicable, plus shipping)

• clicks yes/no whether to continue to process order

• if yes, then enters shipping details (if no, clicks to continue shopping, etc.)

• proceeds with PayPal (or other) payment

 

The above is what I want to do on my site. Can anyone please help me? I’m new at this and again apologize if I seem to be trying to reinvent the wheel, as I don’t want to do that. If there are answers, would someone please point me in the right direction? Thanks so much! Michele

Share this post


Link to post
Share on other sites

What you want may not be exactly what's available. There are a couple of shipping estimators that will give you the shipping cost -- this is one. There is also the Ship in Cart Contribution, and possibly more that I don't remember.

 

Taxes are a bit more of a problem. Most tax rates are by state. Mapping the Zip code to the state for the whole US would require a database of over 40,000 zip codes. Just think about the increase in load time from querying that monster. Then think about keeping it up to date. If you only need to do it for your state, the number will be smaller (size depending on the state) but still messy.

 

I don't know of any web store that will give you a total without a full address. It's a nice idea, but I'm not sure it would be worth the time and effort to make this work. I suggest adding a shipping estimator and leave it at that.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Jim - Thanks for your reply. I readily admit I don't know, nor understand the "inners" (for a lack of a better word, sorry) of osCommerce. On my site, I already have shipping, taxes and payment all set up. It's basically the order I would like changed. I've been on other sites where one can get subtotals, shipping cost, and tax (it there is tax), it's all figured before I enter any personal data. Maybe that's the way it was a few years ago and now sites have changed because of tighter security. As a customer, I don't mind signing in and giving personal information, if I know I am going to buy - but I want to know all costs first.

 

We have a lot of viewers on our site, but they seem to leave before buying. An SEO consultant suggested that we get rid of customers having to log in and get also remove the password, etc. We're really not a site that the customer is going to return many times. If they do, chances are they would not remember their password, so why have it?

 

I welcome any suggestions/feedback. Thanks! Michele

Share this post


Link to post
Share on other sites

I suggest one of the contributions that allow customers to check out without logging in -- Guest Account or Purchase Without Account. Either one normally allows the customer to log in or not, but could be easily modified to omit the login option if you wanted to.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Does customer know shipping and tax also before entering personal information? I see that Walmart and Best Buy give "estimated shipping" prior to customer entering personal information. That's what I want. I have weight figured for all my products - I use USPS and priority mail is normally used, which I could use. What do you think?

Share this post


Link to post
Share on other sites

That part's easy. Use one of the contributions I mentioned above for estimating shipping. It's more than an estimate; the same modules are used by the shipping estimators as are used in checkout. If you use USPS then so will the estimator.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Jim - Thanks again for your assistance and expertise. I reread all the info again this a.m. (fresher mind here) - that you provided. Guess I missed the 2 sites in the first contribution you mentioned. I believe that's exactly what I want for my site. I'm going to review more today to see if it's something I can do. Do you recommend a novice doing this? May have to ask for more help later on. Thanks! :rolleyes: Michele

Share this post


Link to post
Share on other sites

Either of those contributions should not be too difficult for a novice. I reccomend a file comparison program (such as Winmerge) to add the changes. Makes it much easier to see what you are doing. Of course, always back up your files first.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Ok, Hi - I'm back.

 

Jim - I installed your MVS shipping estimator - so far so good, I think. The box shows up in the middle, but not fully. And, I think it's too wide with the other stuff on the same line. Can you tell me which file I can use to change width? The image does not seem to appear. Once I actually see the entire box, I will work on the image part. I am not able to test it because each time I try, it reverts back to nothing in my cart. Probably security. Unless you have an answer for that, I will get everything else working, then try it live, I guess.

 

Thanks!

michele

Share this post


Link to post
Share on other sites

Width on which page -- the shopping cart of the products info? It shouldn't be dropping the shopping cart either. I have an updated version that I'll be posting in a bit. I'll let you know when it's up.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

The revised Ship Estimator is now up. Try this one if you were having problems with the Products page estimator.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Jim - Thanks for your timely response. I just got to work here this Fri. a.m. The times posted on these forums are way different than central time. It appears that it was the product info page. The "read reviews", "shipping estimator" and "shopping cart" are all on the same line. I will now try your new revision and let you know. Thanks! Michele

Share this post


Link to post
Share on other sites

Jim - Just wondering if you could tell me what files to change from 2.1 to 2.2? I'm perusing the instructions and they look the same. It would sure save me some time. Thanks so much! Michele

Share this post


Link to post
Share on other sites

The only change to the files is in the products_info.php. The remaining changes are instructions and language files.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hi! I'm back again. The box image is still not displaying. Any ideas what I've done wrong? Could it have something to do to the fact that I have it on a test site only? Also, I'm not sure of the optional 3 php's? Where can I find additional information on them? (estimate_shipping.php, firstitemplus.php, table.php) I installed them - don't know if I need them? Thanks! michele

Share this post


Link to post
Share on other sites

What's a box image? If you mean the button, check that the image file exists and is installed in the correct directory. If the rest of the buttons on your site don't show, it's probably a configuration error.

 

ship_estimator.php is the file that does the estimates for the shopping cart, so it's essential. The other two are patched versions of buggy shipping modules. You only need those if you decide to use those particular modules. They're not going to do any harm in any case.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites
What's a box image? If you mean the button, check that the image file exists and is installed in the correct directory. If the rest of the buttons on your site don't show, it's probably a configuration error.

 

ship_estimator.php is the file that does the estimates for the shopping cart, so it's essential. The other two are patched versions of buggy shipping modules. You only need those if you decide to use those particular modules. They're not going to do any harm in any case.

 

Regards

Jim

 

 

Jim - Thanks for your reply. Sorry, I meant the button. Since I had checked and rechecked everything a million times (so it seemed :blink: ), I decided to call my hosting site, figuring it might have something to do with the configuration. And, sure enough, I apparently set the configuration to my live site and I did not have the file there. I uploaded all those images and bingo! Image appeared. Now I think I will try to place on the right column side since it's causing my page to practically go off the screen. I will keep my fingers crossed. Thanks so much for all your help! Michele :lol:

Share this post


Link to post
Share on other sites

Can you believe it - I still don't have the shipping estimator functioning. I'm back at it again. It wouldn't work on my testing site, as it would always revert back to my original site. So, today, I was very cautious - uploaded everything - and error occured. Had to revert to back up because I had a critical mtg.

 

Now, I went step by step and checked out each step as I went along. I believe error occurred when I uploaded the catalog/product_info.php. So, I retraced my steps and reverted back to the original files. I have version 2.2 with the qpbpp addon. Maybe that's causing some problems. Any recommendations?

 

Thanks! :o

Share this post


Link to post
Share on other sites

Jim- I have shipping estimator installed and it's popping up and not causing errors, but it doesn't work when I plug in a zip code. I've tried turning zone to both true and false. That's not it. Also, can I get rid of one of the shipping estimate buttons? One is in the middle and the other show up in the right column. Would prefer to leave in right column.

 

Thanks for all your help! Michele

Share this post


Link to post
Share on other sites
Jim- I have shipping estimator installed and it's popping up and not causing errors, but it doesn't work when I plug in a zip code. I've tried turning zone to both true and false. That's not it. Also, can I get rid of one of the shipping estimate buttons? One is in the middle and the other show up in the right column. Would prefer to leave in right column.

 

Thanks for all your help! Michele

"Doesn't work" isn't very helpful. Does it give an error message? Does it sit there and do nothing at all? Does it blow up? Give me some help here.

 

The button at the bottom of the shopping cart page can be removed by deleting the code added in Step 2 of the installation instructions.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Jim - Sounds like you have a good sense of humor! That was funny! Sorry I wasn't more explicit. Also, I thought I had instant notice of this thread coming in, so don't know when you responded. Will watch more carefully from now on.

 

Well, guess what?! I have the shipping estimator installed now on both my test and regular site. It pops up on both - works on my test site, but not on real site. One good thing, no errors are showing. On live site, if one fills in zip code, it asks for state or zone. If I type in both, it still doesn't give me estimates. It does on test site, although the state part doesn't work.

 

Yesterday I had to apply my backup system, so thought maybe the zone configuration item I inserted in SQL database manager - was perhaps deleted. Called hosting site and they said it wouldn't hurt to run it again. So, I did. I now have 3 "Use Zones" listed in the Shipping/Packing Admin area. And, I don't know how to delete 2.

 

On my test site, according to the dates, it appears that the new configuration data may not have run or taken hold (if that makes sense). Bottom line, it appears to be working.

 

Hope to hear from you and will try to clarify more if necessary. In the meantime, I will review your notes in either deleting the center button, or try placing it below the "read the reviews," "add to cart" buttons.

 

I truly appreciate all your help! Thanks! Michele

Share this post


Link to post
Share on other sites

A little more clarification here - When I say it doesn't work, I mean: When I put in a zip code, it says I need to include the state/province. When I put state info in and/or zip & state, I get no shipping estimates. On my testing site, the zip code comes up along with 3 different shipping prices for express, priority, parcel post.

Share this post


Link to post
Share on other sites

I have MSV installed and got on my site today and it worked on one item. Tried again and it didn't work and now I can't get any information on estimate shipping costs. Anyone happen to know which file I should be looking to find out what happened? Thanks - Michele

Share this post


Link to post
Share on other sites

Sorry, it appears that the forum deleted my subscription to this thread. Again. Well, let's give this a try.

 

1. Do you have Zones set in any of your shipping modules? If not, turn off Zones in the shipping estimator (First paragraph under Usage and Options in the Readme.) Did that help?

 

2.Use the test.php file included in the distribution. Does anything work differently?

 

Oh, and my sense of humor gets a bit strange at times, especially late at night. I try to stay serious here, but if you give me a really good opening, well....

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Jim - Thanks so much for replying and your assistance. I had previously tried all the above you mentioned. I thought maybe the problem was in the products_info.php file - so I compared test file to my site file. I thought they should be the same, except I had SEO codes in test file. I compared last night and now can't remember what was different. Anyway, I decided to copy test products_info.php it to my site products_info.php file. Now it appears that the estimator works off and on. I'm going to shut down for a while and will try it later.

 

Currently, my zones are turned off. I put the test.php file back on - so, now I don't know whether to keep on or take it off?

 

Need to get some shut eye <_< - Thanks again. Michele

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×