Jump to content
Sign in to follow this  
certify

Shipping Module NOT showing up in checkout_shipping.php

Recommended Posts

I install2 contribution add-on and in the admin area I can install them correctly. Files are uploaded correctly but when I do a test and reach checkout_shipping.php I get I only see FlatRate as my only shipping option...

 

I tried reupload the files again and still the same problem... I've been going thru this for couple of hours now trying to figure out the cause.. but no clue...

Share this post


Link to post
Share on other sites
I install2 contribution add-on and in the admin area I can install them correctly. Files are uploaded correctly but when I do a test and reach checkout_shipping.php I get I only see FlatRate as my only shipping option...

 

I tried reupload the files again and still the same problem... I've been going thru this for couple of hours now trying to figure out the cause.. but no clue...

You need to install the shipping modules in your stores Admin. You may have to search the contributions area to find the ones you want to use.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites
You need to install the shipping modules in your stores Admin. You may have to search the contributions area to find the ones you want to use.

 

That is exackly what I did right after I uploaded the files. See the pic I attached.. It shows only the default flat rate and not the added contribution that I've installed.

 

2.jpg

 

1.jpg

Edited by certify

Share this post


Link to post
Share on other sites
That is exackly what I did right after I uploaded the files. See the pic I attached..

There's a note in red, bold text at

http://www.lolyco.com/contributions/

That says:

delivery address that is not your home country

Your pictures show a delivery address in Malaysia, and a store address in Malaysia. The shipping module won't quote.

Share this post


Link to post
Share on other sites

Thanks! It work!... Now a new prob..

 

Its says .."Unable to obtain a Pos Malaysia Air Parcel quote. Please inform the store owner."

Share this post


Link to post
Share on other sites
Thanks! It work!... Now a new prob..

 

Its says .."Unable to obtain a Pos Malaysia Air Parcel quote. Please inform the store owner."

The modules do print some helpful messages to your site’s error log. If you can read your error log, that may tell you what is going wrong. Alternatively (and it’s not ideal for a production site) you can edit includes/modules/shipping/posmyair.php and remove the ‘@’ signs from the front of the network functions (stream_context_create, fopen, stream_get_contents). If the problem is with them, you may see error messages printed to your checkout page. You could also check whether your host is PHPv4 or v5, and adjust the setting in the shipping module's admin panel appropriately.

 

There might be some useful info available at any of these places:

http://lolyco.com/news.php?article=18

http://www.lolyco.com/contributions/

 

For your malaysiastate problems you mentioned in the PM:

http://forums.oscommerce.com/index.php?sho...39938&st=80 (malaysiastate discussion starts at bottom of page and continues on next page)

 

Oh and make sure you read the README included in the zipfile - there's a chance you don't have Malaysian states set up.

 

Hope this helps

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×