Jump to content
Sign in to follow this  
fmossiere

Paypal not redirecting to Checkout_Success.php Page

Recommended Posts

Hi,

 

it worked before and I have no idea what has changed since ... My Paypal module (Paypal Standard) is working fine, payment goes through, but on the last page of Paypal, when you click on the "return to website" button, it links again correctly to the page checkout_process.php with the correct Session ID ... but for some reason, this redirects to the Login page instead of the Checkout_success.php page ...

 

Anyone had that problem before? Is this something that is not passed back by Paypal?

 

It worked yesterday, and all I did today is testing enabling SSL ... I turned everything back on non-secure in the config files so it is back as the initial set-up ...

 

Any help is very welcome.

 

http://www.alinash.com/shop

Share this post


Link to post
Share on other sites

Id autoreturn on.

Are the return url values as they should be.

 

Satish


Ask/Skype for Free osCommerce value addon/SEO suggestion tips for your site.

 

Check My About US For who am I and what My company does.

Share this post


Link to post
Share on other sites
Id autoreturn on.

Are the return url values as they should be.

 

Satish

 

 

I have a similar problem - after payment via PayPal the link says to return to merchant but if the client DOES click the link, it takes customer to the home page so the order is never completed but payment is made. If they don't click the link, payment is made but nothing else happens. I don't get an order in admin, the item remains in the cart, and I just get an email confirming payment with no additional info.

 

I did upgrade to PayPal Business but I never tested it before that so I don't know if that afected anything.

 

Where do I find autoreturn and the return url values you mentioned? Is there anything else I need to do?

Share this post


Link to post
Share on other sites

Ok, I found the areas in PP to make autoreturn on and set the IPN. It is now working but slow. I'm not sure I have the right URL set for IPN. I have www.mystore.com/catalog/ - is that correct or should it be more specific to PP module or something else?

Share this post


Link to post
Share on other sites

Notify URLs are taken care by the code.

 

 

Just make sure autoreturn is on and IPN is on.

 

Satish


Ask/Skype for Free osCommerce value addon/SEO suggestion tips for your site.

 

Check My About US For who am I and what My company does.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×