Jump to content
Sign in to follow this  
p_nyet

URGENT need Your Help [Ultimate SEO Error]

Recommended Posts

I have ready installed Ultimate SEO 2.6 and now i have problem:

 

Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING, expecting ')' in /www/verox23/public_html/includes/classes/seo.class.php on line 626

 

Im trying find to google and im found suggestion for using 2.1 upgrade version. i doing the following step but the problem can't solved.

 

Add info:

my hosting is unix base

apache 2.xx

php5

mysql5

 

Some one help me please....

 

Thanks for Your advice and im sorry for my bad english...

 

regards,

 

pnyet

Share this post


Link to post
Share on other sites

Uninstall it and install Ultimate SEO URLS v21d_UPDATED by FWR Media.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites
Uninstall it and install Ultimate SEO URLS v21d_UPDATED by FWR Media.

 

 

Thanks Bro for Your reply....

 

But i need to know whats wrong with SEO Ultimate 2.6?

 

Thx

Share this post


Link to post
Share on other sites
Thanks Bro for Your reply....

 

But i need to know whats wrong with SEO Ultimate 2.6?

 

Thx

Well, if you must, look here.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites

As Coopco said uninstall 2.6 and install 2.1D by FWR Media.

 

Before you upload 2.1D to your web server, open the /catalog/includes/classes/seo.class.php file, search for this line:

 

# end if ( $cache['cache_expires'] > date("Y-m-d H:i:s") )

 

Then comment the next 4 lines like so:

 

//if ( $this->keep_in_memory || $local_memory ) {
//		if ($global) $this->data['GLOBAL'][$cache_name] = $container['GLOBAL'][$cache_name]; 
//		else $this->data[$cache_name] = $container[$cache_name]; 
//}

 

Those lines aren't needed and if you set the error level reporting high in PHP those 4 lines will come up with warnings in all of your pages if they aren't commented out/removed.

Edited by Sam G

Share this post


Link to post
Share on other sites
Well, if you must, look here.

 

My problem is SOLVED, im so sory im forgoten to upload file some file.

 

first my case is im using seo.class.php is not provided v 2.6 and im forgotten to upload file preventDuplicates.php

 

after checkup and upload all package my site could work with fine..

now i have Ultimate SEO v2.6 on

PHP5

MySql5

 

work great.

 

 

Just wanna say thanks for everything...

 

 

regards,

 

pnyet

Share this post


Link to post
Share on other sites
As Coopco said uninstall 2.6 and install 2.1D by FWR Media.

 

Before you upload 2.1D to your web server, open the /catalog/includes/classes/seo.class.php file, search for this line:

 

# end if ( $cache['cache_expires'] > date("Y-m-d H:i:s") )

 

Then comment the next 4 lines like so:

 

//if ( $this->keep_in_memory || $local_memory ) {
//		if ($global) $this->data['GLOBAL'][$cache_name] = $container['GLOBAL'][$cache_name]; 
//		else $this->data[$cache_name] = $container[$cache_name]; 
//}

 

Those lines aren't needed and if you set the error level reporting high in PHP those 4 lines will come up with warnings in all of your pages if they aren't commented out/removed.

 

Does 2.1D work with osC RC2

 

Documentation says MS-2.2 and sterile osC (i.e., no other add-ons?)

Share this post


Link to post
Share on other sites
Does 2.1D work with osC RC2

 

Documentation says MS-2.2 and sterile osC (i.e., no other add-ons?)

 

2.1d ORIGINAL updated does yes.

Share this post


Link to post
Share on other sites
2.1d ORIGINAL updated does yes.

 

Yes, correct. I should have been more specific, including FWR Media.

 

Thanks for the confirmation.

Share this post


Link to post
Share on other sites
Yes, correct. I should have been more specific, including FWR Media.

 

Thanks for the confirmation.

 

Well, I have gotten really proficient uninstalling Ultimate SEO v2.6!

Share this post


Link to post
Share on other sites
Well, I have gotten really proficient uninstalling Ultimate SEO v2.6!

 

 

Well, just installed Ultimate_SEO_URLSv21d_UPDATED and home page comes up, click on cateogries and a SEO friendly appears for the category, but I get:

 

Not Found

The requested URL /public_html/index.php was not found on this server.

 

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Apache/1.3.41 Server at brightparrots.com Port 80

 

 

rendered in the page.

 

I did rename "directory" to "public_html", but I am guessing I did not do this part quite right.

 

Feedback?

Share this post


Link to post
Share on other sites
Well, just installed Ultimate_SEO_URLSv21d_UPDATED and home page comes up, click on cateogries and a SEO friendly appears for the category, but I get:

 

Not Found

The requested URL /public_html/index.php was not found on this server.

 

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Apache/1.3.41 Server at brightparrots.com Port 80

 

 

rendered in the page.

 

I did rename "directory" to "public_html", but I am guessing I did not do this part quite right.

 

Feedback?

 

 

Per FWR Media:

 

Put rubbish in your .htaccess .. like ..

 

jkfgkleajfgjoireujgoivjsvdklwjdvkjkasjdvkjl'

 

If it doesn't kick errors then you need AllowOveride set to ALL (or to specifics).

 

 

 

----------------------------------------

 

Well, it kicked errors, so I guess AllowOveride is set correctly.

 

Gotta be the rename of the "directory".

Share this post


Link to post
Share on other sites
Per FWR Media:

 

Put rubbish in your .htaccess .. like ..

 

jkfgkleajfgjoireujgoivjsvdklwjdvkjkasjdvkjl'

 

If it doesn't kick errors then you need AllowOveride set to ALL (or to specifics).

 

 

 

----------------------------------------

 

Well, it kicked errors, so I guess AllowOveride is set correctly.

 

Gotta be the rename of the "directory".

 

Please move this to the support topic

 

http://forums.oscommerce.com/index.php?showtopic=154166

 

With a description of the problem, and ideally a link

 

where your shop is located e.g. root = www.mysite.com/

 

How RewriteBase is set e.g. / or /catalog/ etc

Edited by FWR Media

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×