Jump to content
Sign in to follow this  
hwkd

UPSXML_v1_3_5 clean

Recommended Posts

All,

 

First, this is not an emergency as I am doing this on a test site for an already live site.

 

 

Is there a forum for UPSXML_v1_3_5??

 

 

I am trying to install UPSXML_v1_3_5 add-on.

 

As I have no prior version of a UPS module and used the default USPS module for osCommerce V 2.2 RC2, I am following the instructions for

 

Clean Install

-------------

Follow the instructions below this section for a complete fresh install.

 

per the readme.txt file

 

 

Those instructs come after the title

 

Manual Upgrade

 

and there are 4 steps.

 

 

So, all steps followed and all file from add-on uploaded to appropriate folders.

 

 

Well, I log into the admin tool and look at the shipping options and I get a whole bunch of include errors pasted below:

 

Well, I know from reading those error msgs mean the file is not there or there is no include reference or maybe passwords need to be reset.

 

I have verified my files are all uploaded and the SQL query inserted the correct values in the configure.php file from the instructs.

 

So, my first question is did I do the right thing in doing the "clean" "manual" install from the read me file of UPSXML_v1_3_5.

 

Thanks,

Hank

 

 

 

 

 

 

Warning: main(/home/brigh49/public_html/includes/languages/english/modules/shipping/modules.php) [function.main]: failed to open stream: No such file or directory in /home/brigh49/public_html/admin/modules.php on line 166

 

Warning: main(/home/brigh49/public_html/includes/languages/english/modules/shipping/modules.php) [function.main]: failed to open stream: No such file or directory in /home/brigh49/public_html/admin/modules.php on line 166

 

Warning: main() [function.include]: Failed opening '/home/brigh49/public_html/includes/languages/english/modules/shipping/modules.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/brigh49/public_html/admin/modules.php on line 166

Share this post


Link to post
Share on other sites
All,

 

First, this is not an emergency as I am doing this on a test site for an already live site.

 

 

Is there a forum for UPSXML_v1_3_5??

 

 

I am trying to install UPSXML_v1_3_5 add-on.

 

As I have no prior version of a UPS module and used the default USPS module for osCommerce V 2.2 RC2, I am following the instructions for

 

Clean Install

-------------

Follow the instructions below this section for a complete fresh install.

 

per the readme.txt file

 

 

Those instructs come after the title

 

Manual Upgrade

 

and there are 4 steps.

 

 

So, all steps followed and all file from add-on uploaded to appropriate folders.

 

 

Well, I log into the admin tool and look at the shipping options and I get a whole bunch of include errors pasted below:

 

Well, I know from reading those error msgs mean the file is not there or there is no include reference or maybe passwords need to be reset.

 

I have verified my files are all uploaded and the SQL query inserted the correct values in the configure.php file from the instructs.

 

So, my first question is did I do the right thing in doing the "clean" "manual" install from the read me file of UPSXML_v1_3_5.

 

Thanks,

Hank

 

 

 

 

 

 

Warning: main(/home/brigh49/public_html/includes/languages/english/modules/shipping/modules.php) [function.main]: failed to open stream: No such file or directory in /home/brigh49/public_html/admin/modules.php on line 166

 

Warning: main(/home/brigh49/public_html/includes/languages/english/modules/shipping/modules.php) [function.main]: failed to open stream: No such file or directory in /home/brigh49/public_html/admin/modules.php on line 166

 

Warning: main() [function.include]: Failed opening '/home/brigh49/public_html/includes/languages/english/modules/shipping/modules.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/brigh49/public_html/admin/modules.php on line 166

 

 

 

 

 

 

 

Well, I guess this could be part of the problem. From the readme.txt.

 

 

UPS XML Rates v1.3.5 for osCommerce 2.2 MS2 2008/02/15

 

 

Anyone know that UPS XML Rates v1.3.5 for sure will not work with v2.2 RC2a.

Share this post


Link to post
Share on other sites
Is there a forum for UPSXML_v1_3_5??

See the install instructions.

 

Warning: main(/home/brigh49/public_html/includes/languages/english/modules/shipping/modules.php) [function.main]: failed to open stream: No such file or directory in /home/brigh49/public_html/admin/modules.php on line 166

What on earth do you have on line 166 in admin/modules.php? In the standard file it is a }

 

Shipping modules work fine with RC2a by the way.

Share this post


Link to post
Share on other sites
See the install instructions.

 

 

Thanks, I am digging through that forum but construed the readme.txt file to mean the forum was for upgrades from existing installs.

 

I am using a brand new install of osCommerce with no previous version of this add-on, so I followed the 1.3.5 install instructions from the install file.

 

 

What on earth do you have on line 166 in admin/modules.php? In the standard file it is a }

 

Not sure. That file is from a fresh install of osCommerce V 2.2 RC 2. Did not touch it and am comparing it to file from live site. Thanks.

 

 

 

Shipping modules work fine with RC2a by the way.

 

 

Thanks for verifying.

Share this post


Link to post
Share on other sites
What on earth do you have on line 166 in admin/modules.php? In the standard file it is a }

 

 

Well, I have compared line 166:

 

include(DIR_FS_CATALOG_LANGUAGES . $language . '/modules/' . $module_type . '/' . $file);

 

 

to the current live and live backup and it is the same as on the test site.

 

I added a close bracket to the end of line 166 and got:

 

 

 

Parse error: syntax error, unexpected '}' in /home/brigh49/public_html/admin/modules.php on line 222

 

 

Is my editor counting lines differently than your editor?

 

Thanks Jan.

Share this post


Link to post
Share on other sites
Well, I have compared line 166:

 

include(DIR_FS_CATALOG_LANGUAGES . $language . '/modules/' . $module_type . '/' . $file);

Strange, I have that on line 128 in a standard file from RC2a.

Is my editor counting lines differently than your editor?

My text editors were always the same as PHP counted them so I have no reason to believe they are wrong.

 

Anyway, from the looks of it you have a stray modules.php file in your catalog/includes/modules/shipping/ directory. Since you don't have a modules.php as a language file you get an error. Either remove that file or rename it to something that doesn't have a PHP extension (use .txt e.g.).

Share this post


Link to post
Share on other sites
Strange, I have that on line 128 in a standard file from RC2a.

 

My text editors were always the same as PHP counted them so I have no reason to believe they are wrong.

 

Anyway, from the looks of it you have a stray modules.php file in your catalog/includes/modules/shipping/ directory. Since you don't have a modules.php as a language file you get an error. Either remove that file or rename it to something that doesn't have a PHP extension (use .txt e.g.).

 

 

 

Yes, bad file management was the culprit.

 

I managed to get the modules.php file into the unpacked structure of the add-on in the folder indicated and kept rechecking files to upload from the add-on thinking that was from the add-on.

 

I should have gone back to compressed file and unpacked it again.

 

A lesson learned (and always a good one), when you retrace your steps always go all the way back to the start.

 

I will say I was going to go back and reinstall osCommerce and reinstall the add-on, but I bet I could have missed the step or unpacking the compressed file again.

 

Thanks, Jan

Share this post


Link to post
Share on other sites

All,

 

Again, this is not an emergency as this is being done a test site.

 

I have installed UPSXML_v1_3_5 following the 4 steps for v1.3.5 install. There was no previous UPSXML version installed.

 

I am now getting the error:

 

 

[function.constant]: Couldn't find constant UPSXML_Array

 

 

I have not installed USPS Methods or UPS Connections, so I am trying to follow step 3 as indicated in the readme.txt file and Jan Z's support in this thread:

 

http://forums.oscommerce.com/lofiversion/i...hp?t290275.html

 

However, my code for catalog/admin/modules.php does not resemble the code for catalog/admin/modules.php in the readme.txt file for the add-on. Instead my code looks like this:

 

 

if (tep_not_null($action)) {

switch ($action) {

// {{ buySAFE Module

case 'buysafe_save':

 

 

 

 

 

if ( ( $HTTP_POST_VARS['configuration']['MODULE_BUYSAFE_BUYSAFE_SEAL_AUTHENTICATION_DATA'] == '' ||

$HTTP_POST_VARS['configuration']['MODULE_BUYSAFE_BUYSAFE_SEAL_AUTHENTICATION_DATA'] == '-- none --' )

&&

( $HTTP_POST_VARS['configuration']['MODULE_BUYSAFE_BUYSAFE_STORE_AUTHENTICATION_DATA'] == '' ||

$HTTP_POST_VARS['configuration']['MODULE_BUYSAFE_BUYSAFE_STORE_AUTHENTICATION_DATA'] == '-- none --' ) )

{

$seal_data = tep_db_fetch_array(tep_db_query("select configuration_value from " . TABLE_CONFIGURATION . " where configuration_key = 'MODULE_BUYSAFE_BUYSAFE_SEAL_AUTHENTICATION_DATA'"));

$store_data = tep_db_fetch_array(tep_db_query("select configuration_value from " . TABLE_CONFIGURATION . " where configuration_key = 'MODULE_BUYSAFE_BUYSAFE_STORE_AUTHENTICATION_DATA'"));

$HTTP_POST_VARS['configuration']['MODULE_BUYSAFE_BUYSAFE_SEAL_AUTHENTICATION_DATA'] = $seal_data['configuration_value'];

$HTTP_POST_VARS['configuration']['MODULE_BUYSAFE_BUYSAFE_STORE_AUTHENTICATION_DATA'] = $store_data['configuration_value'];

}

 

 

I tried to insert the insert code after case 'buysafe_save': but no luck.

 

 

What am I missing?

 

Thanks.

Share this post


Link to post
Share on other sites
All,

 

Again, this is not an emergency as this is being done a test site.

 

I have installed UPSXML_v1_3_5 following the 4 steps for v1.3.5 install. There was no previous UPSXML version installed.

 

I am now getting the error:

 

 

[function.constant]: Couldn't find constant UPSXML_Array

 

 

I have not installed USPS Methods or UPS Connections, so I am trying to follow step 3 as indicated in the readme.txt file and Jan Z's support in this thread:

 

http://forums.oscommerce.com/lofiversion/i...hp?t290275.html

 

However, my code for catalog/admin/modules.php does not resemble the code for catalog/admin/modules.php in the readme.txt file for the add-on. Instead my code looks like this:

 

 

if (tep_not_null($action)) {

switch ($action) {

// {{ buySAFE Module

case 'buysafe_save':

 

 

 

 

 

if ( ( $HTTP_POST_VARS['configuration']['MODULE_BUYSAFE_BUYSAFE_SEAL_AUTHENTICATION_DATA'] == '' ||

$HTTP_POST_VARS['configuration']['MODULE_BUYSAFE_BUYSAFE_SEAL_AUTHENTICATION_DATA'] == '-- none --' )

&&

( $HTTP_POST_VARS['configuration']['MODULE_BUYSAFE_BUYSAFE_STORE_AUTHENTICATION_DATA'] == '' ||

$HTTP_POST_VARS['configuration']['MODULE_BUYSAFE_BUYSAFE_STORE_AUTHENTICATION_DATA'] == '-- none --' ) )

{

$seal_data = tep_db_fetch_array(tep_db_query("select configuration_value from " . TABLE_CONFIGURATION . " where configuration_key = 'MODULE_BUYSAFE_BUYSAFE_SEAL_AUTHENTICATION_DATA'"));

$store_data = tep_db_fetch_array(tep_db_query("select configuration_value from " . TABLE_CONFIGURATION . " where configuration_key = 'MODULE_BUYSAFE_BUYSAFE_STORE_AUTHENTICATION_DATA'"));

$HTTP_POST_VARS['configuration']['MODULE_BUYSAFE_BUYSAFE_SEAL_AUTHENTICATION_DATA'] = $seal_data['configuration_value'];

$HTTP_POST_VARS['configuration']['MODULE_BUYSAFE_BUYSAFE_STORE_AUTHENTICATION_DATA'] = $store_data['configuration_value'];

}

 

 

I tried to insert the insert code after case 'buysafe_save': but no luck.

 

 

What am I missing?

 

Thanks.

 

 

 

OK, looks like I got it in the right place in after all the buysafe code I found the:

 

 

case 'save':

while (list($key, $value) = each($HTTP_POST_VARS['configuration'])) {

 

 

before the

 

 

tep_db_query("update " . TABLE_CONFIGURATION . " set configuration_value = '" . $value . "' where configuration_key = '" . $key . "'");

}

tep_redirect(tep_href_link(FILENAME_MODULES, 'set=' . $set . '&module=' . $HTTP_GET_VARS['module']));

break;

case 'install':

 

 

So, if you are using the osCommerce v 2.2 RC2 and trying to follow the directions for the readme.txt Step 3 modification to admin/modules.php you have to look past all the buysafe code in admin/modules.php to find the proper insertion point per UPSXML v1.3.5 readme.txt directions.

Share this post


Link to post
Share on other sites

All,

 

So now site's admin for UPS does not show error previously solved.

 

Now test site shows:

 

Warning: curl_setopt() [function.curl-setopt]: CURLOPT_FOLLOWLOCATION cannot be activated when in safe_mode or an open_basedir is set in /home/brigh49/public_html/includes/classes/nusoap.php on line 2160

 

One thread on osCommerce forum ends with no resolution.

 

http://forums.oscommerce.com/index.php?showtopic=305496

 

 

"Try a google search on cannot be activated when in safe_mode or an open_basedir" per Coopco......

 

looks like it might be resolved with php.ini adjustment

 

any ideas?

 

Thanks

Share this post


Link to post
Share on other sites

Here is code from line around 2160 relating to error msg.

 

$hostURL .= $this->path;

curl_setopt($this->ch, CURLOPT_URL, $hostURL);

// follow location headers (re-directs)

curl_setopt($this->ch, CURLOPT_FOLLOWLOCATION, 1);

// ask for headers in the response output

curl_setopt($this->ch, CURLOPT_HEADER, 1);

// ask for the response output as the return value

curl_setopt($this->ch, CURLOPT_RETURNTRANSFER, 1);

Share this post


Link to post
Share on other sites
Warning: curl_setopt() [function.curl-setopt]: CURLOPT_FOLLOWLOCATION cannot be activated when in safe_mode or an open_basedir is set in /home/brigh49/public_html/includes/classes/nusoap.php on line 2160

The class nusoap.php has nothing to do with UPSXML. Must be another shipping module of you that uses it. I guess the nusoap.php class is from some other open source project. Surely they will know how to fix this. If it is a base_dir thing, perhaps your hosting provider can add that file to an exception list (?). I think I read something about that on the PHP site (www.php.net)

Share this post


Link to post
Share on other sites
The class nusoap.php has nothing to do with UPSXML. Must be another shipping module of you that uses it. I guess the nusoap.php class is from some other open source project. Surely they will know how to fix this. If it is a base_dir thing, perhaps your hosting provider can add that file to an exception list (?). I think I read something about that on the PHP site (www.php.net)

 

 

Jan,

 

Clearly, I'll take your word for it. The file nusoap.php does reside in includes/nusoap.php for RC2, but all I am working with is osCommerce so I do not know how it could be from some other open source project.

 

I do agree that the issues is in all likelihood a hosting issue and have found some things in the neighborhood?

 

Like:

 

http://us.php.net/features.safe-mode

 

Thanks again.

Share this post


Link to post
Share on other sites
Jan,

 

Clearly, I'll take your word for it. The file nusoap.php does reside in includes/nusoap.php for RC2, but all I am working with is osCommerce so I do not know how it could be from some other open source project.

 

I do agree that the issues is in all likelihood a hosting issue and have found some things in the neighborhood?

 

Like:

 

http://us.php.net/features.safe-mode

 

Thanks again.

 

 

All,

 

Also seeing advice like this from diffeent open source forums:

 

 

 

Workaround: uncomment the line 2322 in class.t3lib_div.php

or set it like the following

 

 

 

curl_setopt($ch, CURLOPT_RETURNTRANSFER, 0);

 

 

 

 

Change:

curl_setopt($ch, CURLOPT_FAILONERROR, 1);

To:

curl_setopt($ch, CURLOPT_FAILONERROR, 0);

 

 

Tried the RETURN_TRANSFER one with no luck.

Share this post


Link to post
Share on other sites
All,

 

Also seeing advice like this from diffeent open source forums:

 

 

 

Workaround: uncomment the line 2322 in class.t3lib_div.php

or set it like the following

 

 

 

curl_setopt($ch, CURLOPT_RETURNTRANSFER, 0);

 

 

 

 

Change:

curl_setopt($ch, CURLOPT_FAILONERROR, 1);

To:

curl_setopt($ch, CURLOPT_FAILONERROR, 0);

 

 

Tried the RETURN_TRANSFER one with no luck.

 

 

 

Also, this conversation seems largely on point albeit for PayPal.

 

 

http://forums.cubecart.com/index.php?showtopic=21851

Share this post


Link to post
Share on other sites
Tried the RETURN_TRANSFER one with no luck.

But the error is about the follow redirects. Have you tried:

// follow location headers (re-directs)
curl_setopt($this->ch, CURLOPT_FOLLOWLOCATION, 0);

Share this post


Link to post
Share on other sites
But the error is about the follow redirects. Have you tried:

// follow location headers (re-directs)
curl_setopt($this->ch, CURLOPT_FOLLOWLOCATION, 0);

 

Jan,

 

Well, thanks for leading me to water. It appears to have suppressed the warning.

 

Again, for those interested this conversation provided the best discussion of the the issue per SAFE_MODE, cURL and open_basedir and and got us to the point where Jan got me to make the a fix to suppress the warning.

 

My hosting company has not responded as to whether the shared server is running in safe mode though I am guessing it is.

Share this post


Link to post
Share on other sites
Jan,

 

Well, thanks for leading me to water. It appears to have suppressed the warning.

 

Again, for those interested this conversation provided the best discussion of the the issue per SAFE_MODE, cURL and open_basedir and and got us to the point where Jan got me to make the a fix to suppress the warning.

 

My hosting company has not responded as to whether the shared server is running in safe mode though I am guessing it is.

 

 

Well, here is the link to the fourm with the discussion:

 

http://forums.cubecart.com/index.php?showtopic=21851

Share this post


Link to post
Share on other sites
Well, here is the link to the fourm with the discussion:

 

http://forums.cubecart.com/index.php?showtopic=21851

 

All,

 

UPSXML_v1_3_5 migrated to live site and all is well.

 

Except there are now new fields in the add product section and of course those fields do not exist in the products table.

 

So, I know I need to add them to the products table, but was just curious if maybe there was more to the story and someone could point me toward it.

 

Google search only returned thread saying add the fields to the table. Got that.

 

I cannot see where I missed a step from the readme install file for add-on??

 

-Cordially

Share this post


Link to post
Share on other sites
All,

 

UPSXML_v1_3_5 migrated to live site and all is well.

 

Except there are now new fields in the add product section and of course those fields do not exist in the products table.

 

So, I know I need to add them to the products table, but was just curious if maybe there was more to the story and someone could point me toward it.

 

Google search only returned thread saying add the fields to the table. Got that.

 

I cannot see where I missed a step from the readme install file for add-on??

 

-Cordially

 

Looking for the .php file in admin where I can comment them out.

 

Or, not?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×