Jump to content
zonetown

[Contribution] QTpro - Quantity Tracking Professional

Recommended Posts

I have already tried that. I wouldn't have posted this if I hadn't tried that already. Something about what QT Pro does with that area (the product attribute) ignores HTML for some reason.

 

 

Hey! - I am only trying to help you out on your problems - how am I supposed to know what you have tried and what you have not tried. Bilmy, some folk!!

Share this post


Link to post
Share on other sites

Sorry about that... I'm just frustrated that the code for the out of stock message is buried in JavaScript and I can't get it to use HTML.

Share this post


Link to post
Share on other sites

Hi,

 

how can I change the order the attributes are displayed in the stock table? I fixed the order of the attributes in the radioset display (in product_info.php) but in the stock table they are still in a random order. I tried several codes in the qtpro_stock_table.php in the last line of this:

 

// get the option names

$products_options_name_query = tep_db_query("SELECT distinct popt.products_options_id, popt.products_options_name

FROM " . TABLE_PRODUCTS_OPTIONS . " popt, " . TABLE_PRODUCTS_ATTRIBUTES . " patrib

WHERE patrib.products_id='" . (int)$HTTP_GET_VARS['products_id'] . "'

AND patrib.options_id = popt.products_options_id

AND popt.products_options_track_stock = '1'

AND popt.language_id = '" . (int)$languages_id . "'

ORDER BY popt.products_options_id");

but everything I tried did not work. (for example I tried it with that code: . "order by products_options_values_name'"); but the result was the same as with its original code). I don't know much PHP so I can't create codes on my own and I looked everywhere for a right one but I couldn't find one. Does anybody know what code I have to use? Or is it not possible to change with a code? How else could I change it? I did not find a contribution that worked for that matter. Now I'm out of ideas. Can somebody please help me? Thank you very much and excuse my bad english.

Share this post


Link to post
Share on other sites
Sorry about that... I'm just frustrated that the code for the out of stock message is buried in JavaScript and I can't get it to use HTML.

 

Can somebody please help with getting the JavaScript to parse HTML.

Share this post


Link to post
Share on other sites
hey guys iam also having the same problem.. installed qtpro on oscmmerce rc2 site and its not subtracting the stock. It works fine when an order is placed with credit card but it doesnt work when order is placed by PayPal Website Payments Standard . its the payment option that came with rc2..

 

so any help is greatly apprecaited

 

thankyou

 

I am in the same boat. Using RC2a with the Paypal Website Payments Standard and QTPro v4.5, and only my main stock is decremented, not the stock for the individual options. Anyone have any ideas, or have this same setup working?

 

Thanks for any help!

Share this post


Link to post
Share on other sites
Can somebody please help with getting the JavaScript to parse HTML.

 

Hello,

I'm the Swedish guy thats the most recent contributor of QTPro. About this problem with the out of stock message not parsing HTML you are talking about. I have not programmed that part. But it works for me.

 

Perhaps It could have something to do with your serversettings?

Check your languagefile for this line:

// charset for web pages and emails
define('CHARSET', 'iso-8859-1');

Perhaps if you have set the charset to something else it could go wrong?... But why change that. I guess I am of track.

 

Well I'm just telling you that for me the contribution works as it is. Perhaps that can be e little help in your search for the solution.

 

Best Regards,

Olof

Share this post


Link to post
Share on other sites
Till now I did not find a discount contri that works with product attributes. Therefore I work with customer_discount_v1.3 and special prices for the products without attributes.

Now I working on Qtpro to make the stock in productinfo visibale on attribute level

 

thanks!

Share this post


Link to post
Share on other sites

Could someone please tell me how I get the + 2.50 $ back instead of the actual price? It screws up the specials :(

What lines should I change and where? Please help!

 

Gina

Share this post


Link to post
Share on other sites

In my last version this is a setting in the admin panel.

 

Could someone please tell me how I get the + 2.50 $ back instead of the actual price? It screws up the specials :(

What lines should I change and where? Please help!

 

Gina

Share this post


Link to post
Share on other sites

I have installed this on a clean oscommerce 2.2 and have two problems. One is on the product info page. I have the copy Currently on stock: but no box showing the four options. I also have the drop down box, but none of the items shows out of stock if is is out of stock. Any ideas? Lastest version of qtpro is installed. Thanks, Amy

Share this post


Link to post
Share on other sites

Oops - figured out part of it. I did not have 0 in the stock item. But I can still not figure out how to show the box showing 4 options with stock quantity.

 

Thanks, Amy

 

I have installed this on a clean oscommerce 2.2 and have two problems. One is on the product info page. I have the copy Currently on stock: but no box showing the four options. I also have the drop down box, but none of the items shows out of stock if is is out of stock. Any ideas? Lastest version of qtpro is installed. Thanks, Amy

Share this post


Link to post
Share on other sites

After about a month of comparing files and significant hairpulling I have finally got this contribution 4.3 on RC1 to work. But... (allways a but) in my shop it is possible for customers to order products I don't have in stock (short deliverytimes from my suppliers), so the stock regularly goes negative and doesn't show in the report. I know Olof has addressed this in his upgrade, but I don't want to upgrade everything and risk another month of getting it to work properly, especially since this upgrade is for RC2 and I am running RC1. Olof, could you please, please, please tell me what you changed where to make the low stock report show the negative stock?

 

TIA

 

Gina

Share this post


Link to post
Share on other sites

A suggestion: Download the program Beyond Compare and compare your stockreportfile with my stockreportfile :)

 

After about a month of comparing files and significant hairpulling I have finally got this contribution 4.3 on RC1 to work. But... (allways a but) in my shop it is possible for customers to order products I don't have in stock (short deliverytimes from my suppliers), so the stock regularly goes negative and doesn't show in the report. I know Olof has addressed this in his upgrade, but I don't want to upgrade everything and risk another month of getting it to work properly, especially since this upgrade is for RC2 and I am running RC1. Olof, could you please, please, please tell me what you changed where to make the low stock report show the negative stock?

 

TIA

 

Gina

Share this post


Link to post
Share on other sites
A suggestion: Download the program Beyond Compare and compare your stockreportfile with my stockreportfile :)

 

thanks! is it better than winmerge (using that now)?

 

Gina

Share this post


Link to post
Share on other sites
It is mush better :)

 

Hi Olof,

 

I have found out that in your version 4.3a you commented out a line in stats_low_stock_attrib.php, but than my stocklevel page goes blank. In version 4.3b the comment is gone and it works, but the stock below zero is not there...

 

Gina

Share this post


Link to post
Share on other sites

Sorry, I can't help you with this

 

Hi Olof,

 

I have found out that in your version 4.3a you commented out a line in stats_low_stock_attrib.php, but than my stocklevel page goes blank. In version 4.3b the comment is gone and it works, but the stock below zero is not there...

 

Gina

Share this post


Link to post
Share on other sites
Sorry, I can't help you with this

 

found it! turns out a corresponding closing symbol wasn't commented out, hence the blank page.

 

Gina

Share this post


Link to post
Share on other sites
I am in the same boat. Using RC2a with the Paypal Website Payments Standard and QTPro v4.5, and only my main stock is decremented, not the stock for the individual options. Anyone have any ideas, or have this same setup working?

 

This question has been posted three times by separate people and nobody seems to be willing to help :angry:

 

Can somebody please tell me why QTPro v4.5 will not decrement the stock for attributes when using Paypal Website Payments Standard?

 

SOMEBODY PLEASE HELP IF YOU CAN

 

Thanks in advance,

Ben

Edited by Benjamin23

Can somebody please tell me why QTPro v4.5 will not decrement the stock amount for attributes when using Paypal Website Payments Standard?

Share this post


Link to post
Share on other sites
This question has been posted three times by separate people and nobody seems to be willing to help :angry:

 

Can somebody please tell me why QTPro v4.5 will not decrement the stock for attributes when using Paypal Website Payments Standard?

 

SOMEBODY PLEASE HELP IF YOU CAN

 

Thanks in advance,

Ben

 

 

 

Hi Ben,

 

This part of the forum seams to be on the lines of your problem

http://forums.oscommerce.com/index.php?sho...484&st=1580

 

 

I found that if the customer does not click the confirmation button after they have made payment

on the paypal website to navigate back to your site. the checkout system

will not know a purchase has been made and so will not update the database.

 

Which means that there are 2 settings to make in the paypal account to get

this working

 

Go to your paypal account and login to your business account

When you have logged in, follow these instructions

https://www.paypal.com/us/cgi-bin/webscr?cm...summary-outside

 

Andy

Share this post


Link to post
Share on other sites

Hello Andy,

 

Thankyou for your prompt reply. I will check out those links and let you know the result.

 

Kind Regards,

Ben


Can somebody please tell me why QTPro v4.5 will not decrement the stock amount for attributes when using Paypal Website Payments Standard?

Share this post


Link to post
Share on other sites

hi all,

 

I have had a search and can't find a definite answer but I may be missing it! I have got a site that has AJAX attribute manager installed which is great as each product has about 80 different sizes potentially. I now need a way to add the stock level by size and believe that QTPro is the way to do this.

 

Can you let me know if the two contributions are compatible.

 

Many Thanks

 

Clarry

Share this post


Link to post
Share on other sites

Thanks for your advice Andy but unfortunately it made no difference.

 

I am still having the same problem as before - the total stock amount is decremented properly, but the stock for the individual options (small, medium, large, etc) remains the same.

 

I really don't want to have to change this manually every time we receive an order.

 

Can anybody else please help?

 

Ben


Can somebody please tell me why QTPro v4.5 will not decrement the stock amount for attributes when using Paypal Website Payments Standard?

Share this post


Link to post
Share on other sites

I find it hard to believe that my problem has been raised so many times by other people and nobody has been able to come up with a solution.

 

Does anyone support QTPro any more or should I stop wasting my time trying to get help with QTPro like many of those before me?

Edited by Benjamin23

Can somebody please tell me why QTPro v4.5 will not decrement the stock amount for attributes when using Paypal Website Payments Standard?

Share this post


Link to post
Share on other sites

Clare,

 

I use both contri's and it works fine for me.

 

Ben,

 

I use the paypal IPN, it works correct , but in the Netherlands we have a better payment system Ideal.

I set the paypal payment to open, so I have a order. Then delever the order and my stock was oke.

Maybe this will help you.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×