Jump to content
zonetown

[Contribution] QTpro - Quantity Tracking Professional

Recommended Posts

QT Pro allows you to control the individual stock of each attribute. This does not come with the Stock OSC installation. You need to install it from the contributions section.


Search the forum and contributions before posting. If that doesn't work, keep looking, then post. The forum is for seeking help and advice NOT for someone to do your work for you. Try to do something on your on, if you are going to run a shop then learn how it works.

Share this post


Link to post
Share on other sites

I do have qtpro installed, that is why I am asking if anyone knows why its not working for me. If someone knew of a file I may have missed or a page I'd need to look at a little closer. I've looked over my code and didnt see where the problem may lie.

Share this post


Link to post
Share on other sites
I do have qtpro installed, that is why I am asking if anyone knows why its not working for me. If someone knew of a file I may have missed or a page I'd need to look at a little closer. I've looked over my code and didnt see where the problem may lie.

 

Did you read the Manual included in the installation package? If not that would probably be a good place to start reading seeing no one knows what you have installed and what you don't have installed. So if you missed a file we have no clue of knowing since we don't have access to your admin.


Search the forum and contributions before posting. If that doesn't work, keep looking, then post. The forum is for seeking help and advice NOT for someone to do your work for you. Try to do something on your on, if you are going to run a shop then learn how it works.

Share this post


Link to post
Share on other sites
QT Pro allows you to control the individual stock of each attribute. This does not come with the Stock OSC installation. You need to install it from the contributions section.

 

Silverado05, or anyone,

 

I am using Oscommerce MS2.2. Which version of the contribution do you reccomend? Is QtPro 4.3 dated 20 Dec 2006 the right one?

Share this post


Link to post
Share on other sites

Ballards,

Yes, that one will work.

 

I have a different problem at the moment and the solutions I found on the board or in other attributes won't work (at least not for me).

I succesfully installed OSC 2.2 RC1 with QTPro 4.3.

The problem I am having at the moment is that I can't sort the attributes properly on my website.

I have for instance T-shirts with sizes S, M, L, X, XL, XXL.

It doesn;'t matter at all in which order I add them in the product attributes admin-panel, because when I look in the shop, it's all messed up.

It looks like they sort randomly.. like S, L XL, M, XXL

Is there an easy fix to sort the attributes ascend of descend?

I did find some contribs who should do this trick, but as mentioned before.. I didnt'get them to work at all.

A simple sort-command (order by) SOMEWHERE should do the trick, I think, except I have really no idea where to do that and to look for.

Hope someone can and will assist.

Edited by Daros

Share this post


Link to post
Share on other sites
Ballards,

Yes, that one will work.

 

I have a different problem at the moment and the solutions I found on the board or in other attributes won't work (at least not for me).

I succesfully installed OSC 2.2 RC1 with QTPro 4.3.

The problem I am having at the moment is that I can't sort the attributes properly on my website.

I have for instance T-shirts with sizes S, M, L, X, XL, XXL.

It doesn;'t matter at all in which order I add them in the product attributes admin-panel, because when I look in the shop, it's all messed up.

It looks like they sort randomly.. like S, L XL, M, XXL

Is there an easy fix to sort the attributes ascend of descend?

I did find some contribs who should do this trick, but as mentioned before.. I didnt'get them to work at all.

A simple sort-command (order by) SOMEWHERE should do the trick, I think, except I have really no idea where to do that and to look for.

Hope someone can and will assist.

 

 

I enter the stock for each attribute in the sort order I want. If you want to alter the sequence just re-enter the stock 0 for that attribute and it will delete that stock and then you can re-enter that at a sequence you want.

This is working for me.

 

Previously I tried attribute sort contribution but was not working (although was able to install but it mess up product attibutes and did not update sort order either). This was probably due to the fact that I am already using QTPRo 4.3 and add weight contributions which uses same product attribute file in admin and english folders. Therefore need to carefully add the codes in respective files which are for attribute sort from attribute sort contribution as I did for add weight contribution for both of them to work together.

 

I hope these comments help.

 

Cheers

Share this post


Link to post
Share on other sites

Unfortunately the way I enter didn't seem to influence the sort order, but will give it a new try on a fresh install.

I was hoping that adding or modifying 1 or 2 lines in the code somewhere would do the trick permanently by sorting ascend or descend.

 

btw, same problem here with the sort attribute contribution... it didn't work for me since I am using a different language than English.

Share this post


Link to post
Share on other sites

I appologize if someone has already answered this in an earlier post:

 

I use QTpro to track stock for various products attributes. Easy populate seems to work fine if i am only tracking stock on a product with only one attribute.

 

Example:

 

14 Red shirts

15 Large shirts

etc.

 

The problem is when you have more than one type of attribute per product. Example:

 

14 Large Red shirts

17 Small Red shirts

etc.

 

In the spreadsheet EP only lets me put in stock for each attribute yet QTpro lets you assign stock for a products with varied attributes and tracks it properly. So I know the information is being tracked in MySQL but I am not able to import this info (that I know of) in via EP.

 

Any help is greatly appreciated.

Share this post


Link to post
Share on other sites

Sorry if this is a repeatedpost but I can't find the answer...

 

I have QTPro 4.3 installed and working ok but, If I don't enter a quantity for every possible attribute combination, even if the quantity is 0, then everything shows out of stock and I get page error when using a sequential dropdown. I have a 3 tier attributes and that means I would have to enter nearly 900 stocklines for every product we sell, with about 880 of them just with 0 stock.

 

Is there anything I can do so QTPro assumes stock is 0 if it can't find a stock entry for a particular attribute?

 

Please if anyone can help, the store is due to go live on 15th September!!!

 

Thanks,

 

Martin

Share this post


Link to post
Share on other sites

I thought QTPro wasgoing to solve allmy problems but so far its just driving me nuts...

 

It seems to work if I use 2 lots of attributes, eg a customer chooses a bed size and then chooses a storage option relevant to that bed size.

 

Problem is I then need a third option to choose a mattress type relevant to the bed size and storage option. Whn I add the third attribute they can still select a bed size but then the other 2 attributes aren't populated once a size is chosen.

 

Please can anyone help with this.

 

Thanks

Share this post


Link to post
Share on other sites

Hi,

 

I hired someone to solve this problem for me. You have to create a second spreadsheet to populate the products stock table. Email me at studio6000@gmail.com and I'll send you the revised EP file.

 

Thanks,

Michelle

Share this post


Link to post
Share on other sites

All,

 

I have Oscommerce MS2.2 with the register-globals patch installed. I would like to install Qtpro 4.3. Can anyone confirm that Qtpro is compatible with the register-globals patch?

 

Ballards

Share this post


Link to post
Share on other sites
All,

 

I have Oscommerce MS2.2 with the register-globals patch installed. I would like to install Qtpro 4.3. Can anyone confirm that Qtpro is compatible with the register-globals patch?

 

Ballards

 

Yes if you do the manual edits.


Search the forum and contributions before posting. If that doesn't work, keep looking, then post. The forum is for seeking help and advice NOT for someone to do your work for you. Try to do something on your on, if you are going to run a shop then learn how it works.

Share this post


Link to post
Share on other sites

Hi... im trying to install this one for version RC1 but with no success... so please.. if someone have the files update for the versio RC1 share it...

 

Tks

Share this post


Link to post
Share on other sites

hi

 

i have managed to put QTpro contribution on my site after a few attemps, but i have a few snags, all my pages are showing but in the attribute section on admin, i have a colum missing in product options, the option name is not there, i can type it in but then it does not show up in the product option table , but in the option values it shows up in a drop down list, but once i give it a value, it goes and switches the track stock option off, and wont show up in the products attributes section,

 

can some one make head or tail of this problem ?

 

thanks

 

Emma :blush:

Share this post


Link to post
Share on other sites

hi its me again

 

ive gone through my whole site and ive not come across any error quotes on any pages so its not giving me a indication of which php page i should be looking at to try and fix the missing colum in attributes thats messing up my stock tracker option. im really stuck and i cant find anything in the forum similar to my problem.

 

Thanks

 

Emma :'(

Share this post


Link to post
Share on other sites

Hi there,

I have just installed QTpro and have a few issues - apologies if these issues have been addressed in earlier posts.

In the admin section under 'Reports' the text for stock level report is as follows - BOX_REPORTS_STOCK_LEVEL

 

When I click on it i get the following -

Not Found

The requested URL /store/admin/FILENAME_STATS_LOW_STOCK was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

This is a fresh install and not an upgrade, and the file does exist.

Can anyone help me with this?

Also when I input a new stock level and click on 'update' it remains on the same page, although it does update the stock level - is this something that can be fixed as well?

Thank you in advance for your help.

Take care.

Chris

Share this post


Link to post
Share on other sites

Not Found

The requested URL /store/admin/FILENAME_STATS_LOW_STOCK was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

 

Ok, I just deleted that line, and everything worked fine. Go to admin -> includes -> boxes -> reports.php

and change:

 

'<a href="' . tep_href_link(FILENAME_STATS_LOW_STOCK_ATTRIB, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_REPORTS_STATS_LOW_STOCK_ATTRIB . '</a><br>'.

'<a href="' . tep_href_link(FILENAME_STATS_LOW_STOCK, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_REPORTS_STOCK_LEVEL . '</a>');

 

to:

 

'<a href="' . tep_href_link(FILENAME_STATS_LOW_STOCK_ATTRIB, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_REPORTS_STATS_LOW_STOCK_ATTRIB . '</a>');

 

That seemed to work for me.

Good luck,

Adrienne

Share this post


Link to post
Share on other sites

PLEASE HELP

 

I've been using 4.2 for nearly 2 years. It has had the same error ever since I installed it.

 

If someone purchases 3 different items, the first one is deducted from stock and the second two are not. Always just the first one is deducted, never any past the first.

 

I tried to fix this way back when but couldn't get any help and never got it working. But the store was only getting 1 or 2 orders a week, so I would adjust manually. Now the store gets about 15 orders a week, and I just don't have time to adjust manually. I've gotten bitten a few times as well.

 

So, I just upgraded to 4.3 hoping it had been fixed in the meantime, and no luck. I have the exact same problem. For my configuration, absolutely nothing changed from 4.2 to 4.3 except the admin reports section.

 

For reference, most of my items have 2 stock-tracked attributes and 1 non-stock attribute.

 

Any suggestions?? I've spent hours on this, and I'm desperate! :'(

Share this post


Link to post
Share on other sites

hi there, could someone tell me if there is a release of this that is not a beta release? im kind of confused and i cant find the download link with the newest release of this addon

 

thank you!!!

Share this post


Link to post
Share on other sites
sorry but i still dont understand whats about BOX_REPORTS_STOCK_LEVEL

 

- has someone this function in use?

 

what is the right filnename for this in admin/includes/filenames.php

 

thnx. a lot for this great contri and support

 

 

There are only 2 files added in <admin/includes/filenames.php> and the relevant lines are:

 

define ('FILENAME_STATS_LOW_STOCK_ATTRIB', 'stats_low_stock_attrib.php');
define ('FILENAME_STOCK', 'stock.php');

 

and in <admin/includes/languages/english.php> the is the line:

 

define('BOX_REPORTS_STATS_LOW_STOCK_ATTRIB', 'Stock Report');

 

I can find "BOX_REPORTS_STOCK_LEVEL" anywhere, so I suspect that line must be from another contribution.........


* * * * * * * * * * * * * * * * * * * * *

Porpoises are most happy when wet!

\ _ \ _ \ _ \ _ \ _ \ _ \ _ \ _ \ _ \ _ \ _ \ _

Share this post


Link to post
Share on other sites

Hi

 

I have QT Pro and Fast East Checkout Running Great every thing is working.

 

But I cant workout how to get the product box to show the right message if a product is not available in the desired quantity. At the moment it is showing the total quantity and not the attributes quantity.

 

 

Has anyone got this to work or does any one know what needs to be done.

 

 

Thanks if any one can help

Edited by ogg2k

Share this post


Link to post
Share on other sites

Hi, I install this great contibution, and it works Excelent!! I'm using version 3.2 (because its were the only with install step by step) and I want to ask you in wick database table can I edit the stock with excel.

 

Also if anyone can look if I pasted correctly the code in product_info.php (because another contribution were in the middle) Thanks a lot!!

 

<?php

$products_options_name_query = tep_db_query("select distinct popt.products_options_id, popt.products_options_name, popt.special from " . TABLE_PRODUCTS_OPTIONS . " popt, " . TABLE_PRODUCTS_ATTRIBUTES . " patrib where patrib.products_id='" . (int)$HTTP_GET_VARS['products_id'] . "' and patrib.options_id = popt.products_options_id and popt.language_id = '" . (int)$languages_id . "' order by popt.products_options_name");

while ($products_options_name = tep_db_fetch_array($products_options_name_query)) {

$products_options_array = array();

// BOF Linkmatics attributes sets plus

$products_options_query = tep_db_query("

SELECT pov.products_options_values_id, pov.products_options_values_name,

pa.options_values_price, pa.price_prefix , pase.sort_order

FROM " . TABLE_PRODUCTS_ATTRIBUTES . " pa, " .

TABLE_PRODUCTS_ATTRIBUTES_SETS_TO_PRODUCTS . " pas2pa, " .

TABLE_PRODUCTS_ATTRIBUTES_SETS . " pas, " .

TABLE_PRODUCTS_ATTRIBUTES_SETS_ELEMENTS . " pase, " .

TABLE_PRODUCTS_OPTIONS_VALUES . " pov

WHERE pa.products_id = '" . (int)$_GET['products_id'] . "'

AND pa.options_id = '" . $products_options_name['products_options_id'] . "'

AND pas2pa.products_id = pa.products_id

AND pas.products_attributes_sets_id = pas2pa.products_attributes_sets_id

AND pas.products_options_id = pa.options_id

AND pase.products_attributes_sets_id = pas.products_attributes_sets_id

AND pase.options_values_id = pa.options_values_id

AND pov.products_options_values_id = pa.options_values_id

AND pov.language_id = '" . $languages_id . "'

ORDER BY pase.sort_order, pa.options_values_id");

// >>>>> BOF Linkmatics attributes sets plus patch v1.01

if (tep_db_num_rows($products_options_query)== 0 ) {

$products_options_query = tep_db_query("

SELECT pov.products_options_values_id, pov.products_options_values_name,

pa.options_values_price, pa.price_prefix , pa.options_values_id

FROM " . TABLE_PRODUCTS_ATTRIBUTES . " pa, " .

TABLE_PRODUCTS_OPTIONS_VALUES . " pov

WHERE pa.products_id = '" . (int)$_GET['products_id'] . "'

AND pa.options_id = '" . $products_options_name['products_options_id'] . "'

AND pov.products_options_values_id = pa.options_values_id

AND pov.language_id = '" . $languages_id . "'

ORDER BY pa.options_values_id");

}

// <<<<< EOF Linkmatics attributes sets plus patch v1.01

// EOF Linkmatics attributes sets plus

$products_options_query = tep_db_query("select pov.products_options_values_id, pov.products_options_values_name, pa.options_values_price, pa.price_prefix, pa.options_id, pa.options_values_id from " . TABLE_PRODUCTS_ATTRIBUTES . " pa, " . TABLE_PRODUCTS_OPTIONS_VALUES . " pov where pa.products_id = '" . (int)$HTTP_GET_VARS['products_id'] . "' and pa.options_id = '" . (int)$products_options_name['products_options_id'] . "' and pa.options_values_id = pov.products_options_values_id and pov.language_id = '" . (int)$languages_id . "'");

while ($products_options = tep_db_fetch_array($products_options_query)) {

//START get attribute stock values/show out of stock

if (!$products_options_name['special']) {

$attribute_stock_query = tep_db_query("select products_stock_quantity from " . TABLE_PRODUCTS_STOCK . " where products_id = '" . (int)$HTTP_GET_VARS['products_id'] . "' AND products_stock_attributes REGEXP '(^|,)" . (int)$products_options['options_id'] . "-" . (int)$products_options['options_values_id'] . "(,|$)' AND products_stock_quantity > 0");

if (tep_db_num_rows($attribute_stock_query)==0) {

$products_options_array[] = array('id' => $products_options['products_options_values_id'], 'text' => 'Sin stock - ' . $products_options['products_options_values_name']);

} else {

$products_options_array[] = array('id' => $products_options['products_options_values_id'], 'text' => $products_options['products_options_values_name']);

}

}

else {

$products_options_array[] = array('id' => $products_options['products_options_values_id'], 'text' => $products_options['products_options_values_name']);

}

// END get attribute stock values/show out of stock

 

if ($products_options['options_values_price'] != '0') {

 

 

THANKS A LOT!!!

Share this post


Link to post
Share on other sites

I've installed this and I've gone to Configuration --> Product Information.

 

It says "Product Info Attribute Display Plugin" and "multiple_dropdowns".

 

Do I need to do anything to this?

 

I clicked on edit and I got this:

 

Fatal error: Call to undefined function: tep_cfg_pull_down_class_files() in pinup-parade/shop/admin/configuration.php(125) : eval()'d code on line 1

 

These are the first few lines:

 

<?php

/*

$Id: configuration.php,v 1.43 2003/06/29 22:50:51 hpdl Exp $

 

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2003 osCommerce

 

Released under the GNU General Public License

*/

 

require('includes/application_top.php');

 

$action = (isset($HTTP_GET_VARS['action']) ? $HTTP_GET_VARS['action'] : '');

 

if (tep_not_null($action)) {

switch ($action) {

case 'save':

$configuration_value = tep_db_prepare_input($HTTP_POST_VARS['configuration_value']);

$cID = tep_db_prepare_input($HTTP_GET_VARS['cID']);

 

 

 

What's happened? :blink:

 

Also, when I went to Catalog --> Products Attributes nothing's changed. What do I have to do to get it to work? (presumably that won't be easy with a "fatal error"!)

 

All I want to use this for is to add sizing info to each item as I'm selling clothing.

 

I have to admit that I'm not sure what I'm doing when using phpMySQL, so when I was following the "New Install" instructions, I followed them exactly, but I was wondering why I wasn't asked to use the "upgrade.sql" file. Could this be the answer to my fatal error?!

 

Any help gratefully received!

Edited by helvissa

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×