Jump to content
zonetown

[Contribution] QTpro - Quantity Tracking Professional

Recommended Posts

OOOOK.

 

I took away the error in the reports menu. (By removing the last link in reports.php).

 

BUT STILL, I CANNOT MODIFY QUANTITIES BY ATTRIBUTES.

 

Please, can anyboy help us?

Share this post


Link to post
Share on other sites

Hi

 

I have solved this problem. What you have to do is to go to product attribute page. On the top left there is product option table. Ist colum is ID, 2nd is option name, like colour and size. the 3rd colum is for Track stock? Check this colum infront of product option you want to track. If it says 'No' then click the edit button and check the box to change this to yes. Go back to admin catalog menu. Click stock button infront of the product you wanted to amend, it will show you all attributes in the next page, select the attribute by drop down window enter the quantity and press add. Thats it! You can go to Admin Report menu where you can see the stock as per attributes. I hope you will find this useful.

 

Cheers!

 

Sohail

 

 

OOOOK.

 

I took away the error in the reports menu. (By removing the last link in reports.php).

 

BUT STILL, I CANNOT MODIFY QUANTITIES BY ATTRIBUTES.

 

Please, can anyboy help us?

Share this post


Link to post
Share on other sites

Hi

 

Sorry for late response, I just saw this post. Here is the answer.

 

What you have to do is to go to product attribute page. On the top left there is product option table. Ist colum is ID, 2nd is option name, like colour and size. the 3rd colum is for Track stock? Check this colum infront of product option you want to track. If it says 'No' then click the edit button and check the box to change this to yes. Go back to admin catalog menu. Click stock button infront of the product you wanted to amend, it will show you all attributes in the next page, select the attribute by drop down window enter the quantity and press add. Thats it! You can go to Admin Report menu where you can see the stock as per attributes. I hope you will find this useful.

 

Cheers!

 

Sohail

 

 

 

Can i ask how? i am having the same problem. The stock report page or the products stock page just simply does not show the attributes stock level nor does it allow me to put the stock level for the attributes.

Share this post


Link to post
Share on other sites

I have installed QTPro 4 on a fresh install of OSC but it doesn't seem to be working.

 

When I go to stock it doesnt give me the option to add stock for different attributes.

 

Also on the product info page i get the errors

 

Warning: Invalid argument supplied for foreach() in /homepages/27/d171964990/htdocs/store/includes/classes/pad_base.php on line 383

 

Warning: Invalid argument supplied for foreach() in /homepages/27/d171964990/htdocs/store/includes/classes/pad_base.php on line 443

 

And even though I changed the display option to single radioset it still displays drop down boxes.

 

Any help on this is gretaley appreciated as I think this is a great contribution.

Share this post


Link to post
Share on other sites
I have installed QTPro 4 on a fresh install of OSC but it doesn't seem to be working.

 

When I go to stock it doesnt give me the option to add stock for different attributes.

 

Also on the product info page i get the errors

 

Warning: Invalid argument supplied for foreach() in /homepages/27/d171964990/htdocs/store/includes/classes/pad_base.php on line 383

 

Warning: Invalid argument supplied for foreach() in /homepages/27/d171964990/htdocs/store/includes/classes/pad_base.php on line 443

 

And even though I changed the display option to single radioset it still displays drop down boxes.

 

Any help on this is gretaley appreciated as I think this is a great contribution.

 

 

I see no one has replyed yet and I'm no expert but I have installed this contribution and I had my share of error & warning messages, but now it seems to work. 1st Some how you have to get rid of the Warning messages. Go through the install again making sure you didn't forget or put something in the wrong folder(s). After that, the admin panel Product Attributes is where you specify the attributes that will later be added to stock. but 1st go over your install again.

Share this post


Link to post
Share on other sites

Hi all! I am wondering if anyone is using this contribution with SPPC? If so, anything I should know- like which to install first? Thanks!- Lisa

Share this post


Link to post
Share on other sites
Hi all! I am wondering if anyone is using this contribution with SPPC? If so, anything I should know- like which to install first? Thanks!- Lisa

 

 

ps: Are there any snapshots available for this contribution? It would be great to see what it looks like on a website and on OSC admin panel... Thanks!

Share this post


Link to post
Share on other sites
I have installed QTPro 4 on a fresh install of OSC but it doesn't seem to be working.

 

When I go to stock it doesnt give me the option to add stock for different attributes.

 

Also on the product info page i get the errors

 

Warning: Invalid argument supplied for foreach() in /homepages/27/d171964990/htdocs/store/includes/classes/pad_base.php on line 383

 

Warning: Invalid argument supplied for foreach() in /homepages/27/d171964990/htdocs/store/includes/classes/pad_base.php on line 443

 

And even though I changed the display option to single radioset it still displays drop down boxes.

 

Any help on this is gretaley appreciated as I think this is a great contribution.

 

ok I have this fixed not in the way I expected it to work but it works now.

 

I did a complete re-install of OSC 2.2 and then added in QTPro V4. It still didn't work until I ran the test.sql file. Now everything seems to work fine.

Share this post


Link to post
Share on other sites

Thanks to Nicholas Rivera to getting me going real quick here with your code on sorting by price!

 

If you have installed "Product Attributes Sort Order":

http://www.oscommerce.com/community/contri...uct+Attrib+Sort

 

And would like to sort by your assigned sort order, a simple one line modification in pad_base.php will do the trick.

 

What it does...

First - sorts by attributes sort order

Second - sorts by price

Third - if price is same (or 0), it sorts based on the order that the option was entered.

 

includes/classes/pad_base.php

 

Line ~ 318

from:

$products_options_query = tep_db_query("select pov.products_options_values_id, pov.products_options_values_name, pa.options_values_price, pa.price_prefix from " . TABLE_PRODUCTS_ATTRIBUTES . " pa, " . TABLE_PRODUCTS_OPTIONS_VALUES . " pov where pa.products_id = '" . (int)$this->products_id . "' and pa.options_id = '" . (int)$products_options_name['products_options_id'] . "' and pa.options_values_id = pov.products_options_values_id and pov.language_id = '" . (int)$languages_id . "'");

 

to:

$products_options_query = tep_db_query("select pov.products_options_values_id, pov.products_options_values_name, pa.options_values_price, pa.price_prefix, pa.products_attributes_id, pa.attribute_sort from " . TABLE_PRODUCTS_ATTRIBUTES . " pa, " . TABLE_PRODUCTS_OPTIONS_VALUES . " pov where pa.products_id = '" . (int)$this->products_id . "' and pa.options_id = '" . (int)$products_options_name['products_options_id'] . "' and pa.options_values_id = pov.products_options_values_id and pov.language_id = '" . (int)$languages_id . "'" . " order by pa.attribute_sort, pa.options_values_price, pa.products_attributes_id");

Share this post


Link to post
Share on other sites

I've added 4.3 and noticed a couple of things:

 

1) Amending stock level

We have a few options being tracked e.g.

 

Black, size 10, qty 12

Black, size 8, qty 14

There doesn't seem to be a way to amend the quantities - or am I missing something?

I've tried switching stock tracking off and on, no change.

This is a big problem for us because the clients shop sells from a physical shop as well, and so needs to amend stock levels manually.

 

2) After deleting Products Attributes: qty update fails

We delete all options for a product. The "Stock" button against the product then has a Quantity field and "Update" button. But this fails to change the value.

Changing the value in Edit Product works though.

 

3) If we re-add any of the options we'd previously deleted, all re-appear and all stock levels are as before

So it seems that deleting Products Attributes doesn't actually delete their associated stock info

 

Any help much appreciated folks!

Share this post


Link to post
Share on other sites

** PLS IGNORE ABOVE POST No way of editing/removing, sorry. Current questions here:

 

I've added 4.3 and noticed a couple of things:

 

1) After deleting Products Attributes: qty update fails

We delete all options for a product (Catalog > Options Attributes). The "Stock" button against the product then shows a Quantity field and "Update" button.

But this only allows us to change the value once....? Further adjustments don't work...

Changing the value in the normal Edit Product screen works fine though.

 

2) If we re-add any of the options we'd previously deleted (Catalog > Options Attributes), *all* previous options re-appear also in the item, when you hit the Stock button. If they had Stock Quantities before, they re-appear too....

This is a bad one. It probably means having to dive into phpMyAdmin, which a client certainly won't and shouldn't do.

 

So it seems that deleting Products Attributes doesn't actually delete their associated stock info

 

Any help much appreciated folks!

Share this post


Link to post
Share on other sites

Hey all,

 

I have installed QT Pro Version 4.3 - and I have a strange problem.. The countdown of the stock only works sometimes.. I can't see when it works and when it not works.. Have some of you had that problem, that it only works sometimes?

 

/Olzen


/Olzen

Share this post


Link to post
Share on other sites

Hey all,

 

I have installed QT Pro Version 4.3 - and I have a strange problem.. The countdown of the stock only works sometimes.. I can't see when it works and when it not works.. Have some of you had that problem, that it only works sometimes?

 

/Olzen


/Olzen

Share this post


Link to post
Share on other sites

Hey all,

 

I have installed QT Pro Version 4.3 - and I have a strange problem.. The countdown of the stock only works sometimes.. I can't see when it works and when it not works.. Have some of you had that problem, that it only works sometimes?

 

/Olzen


/Olzen

Share this post


Link to post
Share on other sites

Hi,

 

I used every day this fantastic contribution and I wanted to thanks a lot all who worked hard on it.

I am looking for the possibility to add a model by color (it's mean to have a new model number for the color red for exemple).

I was looking everywhere and find nothink, can somebody help me.

 

thanks in advance

Share this post


Link to post
Share on other sites
hi - i think ive got qtpro working 95%. i just need a little help with the shopping cart display

 

for example:

 

- i have 1 x small, 1 x medium, 1 x large.

 

- i order 1 x small.

 

- in shopping_cart.php i update the quantity for small to 2 x small (alternatively, i can go back to the product and add 1 x small again). qty in cart shows as 2 x small. however, there is no sold out message or the message to alter the quantity in shopping_cart.php - should this be showing?

 

- qtpro is working because if i go to the shipping details page and press confirm, it sends me back to shopping_cart.php.

 

- the only time it shows the sold out message and the message to alter the quantity is if i update the quantity for small to greater than the total for all sizes for the product ie if i order 4 x small it will show as sold out.

 

is there something wrong with my qtpro install, or is that just normal and i need to do some additional coding myself?

 

thanks

 

 

I am having the exact same problem here. Everything works perfectly except for no warning in the checkout process like explained above.

Is there anyone yet having the solution for this problem? I'm kind of desperate by now, every time I think I'm almost done, there is an other problem that needs a solution.

Please help me!

Share this post


Link to post
Share on other sites

just a short question ... i have QTpro with Additional Images in use - maby i have a bug between ???

 

when i create options i can see that in Stock Report

 

Products ............ Model ............... Quantity and Price

myProductName...myModelNr. ........40

..Size....Color...................................

.. S......White.................................10

.. S......Black .................................10

.. M......White .................................10

.. M......Black .................................10

 

 

but when i go to catalog and by this Product with an option (white - s)

 

than i have this result

 

Products ............ Model ............... Quantity and Price

myProductName...myModelNr. ........39

..Size....Color...................................

.. S......White.................................10 ------> here must be 9

.. S......Black .................................10

.. M......White .................................10

.. M......Black .................................10

 

 

the quatity for options is still the same - just at total quantity is this abstract ???

 

in Catalog/Products Attributes/Product Options Track Stock? Action is YES

can you tell me where can i fix this ?

 

thnx.s

Edited by truelovestore_en

Share this post


Link to post
Share on other sites

I love this contribution, but I was wondering if anyone has been able to figure out a way to sort the attributes as desired. I would LOVE to see an extra column in the administration where you can set the order. Say I have three color attributes: red, blue and green. And maybe I want red 1st, blue 2nd and green 3rd. There should be a way to set that order by assigning 1 to red, 2 to blue etc.

 

If anyone can figure this out, I'd love the assistance. There is another contrib I've used before for adding a sort order to attributes but I haven't yet been able to apply it to this contribution.


Rachel M.

Share this post


Link to post
Share on other sites

Thanks for this great contribution. We are having only one issue related to the orders.php page in the admin section. The amount ordered infront of the item is 0 instead of the correct quantity. The math for the price is correct, the email sent to the user is correct (quantity and price).

 

We discovered this during testing and cant figure out if this is related to this contribution or something we have done.

Thanks for any input you can provide on this.

Share this post


Link to post
Share on other sites

I installed that contribution a while ago and it seems to work fine form me. But I do have one question:

 

Is it possible to display the actual stock value for each attribute in e.g. the dropdown list at the Product description page? - so that a customer does not have to find out how many are available of a attribute by try and error.

 

So what i mean is: i have sizes for clothes, but lots of them just exist in very small amounts - so i can do this with qtpro in a dropdown list:

 

Size

|_ XS

|_ S

|_ M

|_ L - out of stock

|_ XL - out of stock

 

 

but i would like to show this

 

Size

|_ XS (5)

|_ S (2)

|_ M (2)

|_ L - out of stock

|_ XL - out of stock

 

 

has anybody done that, or any idea how to do it?

 

thank you very much!

Share this post


Link to post
Share on other sites
qtpro in a dropdown list:

 

Size

|_ XS

|_ S

|_ M

|_ L - out of stock

|_ XL - out of stock

 

Conte:

 

I have installed QTPRO and it is working but I would like to have the sizes show "out of stock" next to them in the dropdown list just like you have done above. Right now all of the sizes are shown in the dropdown and if the size selected is out of stock the customer will not find out until the clothing is added to the shopping cart.

 

Did you install a contribution to get this to happen or any idea how to do it?

 

Thanks!

Share this post


Link to post
Share on other sites

Please ignore message above........after looking further I discovered it was a setting.

Share this post


Link to post
Share on other sites

Below is posting from STS thread...

 

STS v4.5.2 AND QT Pro v4.3

 

Already made posting on this subject but outside the STS v4 contribution pages so though some people have looked at that none has replied. I need to move on and need help asap!

 

I have had STS working well using single new design html template and very happy with results. Added QT Pro contribution carefully checking that no php file clashed in either contribution. QT Pro allows for multi-attribute stock tracking.

 

On returning to the catalogue(I have named it cart), I get the following error message:

 

Fatal error: Call to a member function on a non-object in /home/shapely/public_html/cart/includes/header.php on line 14

 

Lines 12-14 of header.php shows:

 

// START STS 4.1

$sts->restart_capture ('applicationtop2header'); // Capture header from the actual script, needed to take out javascript

// END STS 4.1

 

Can someone help me with this. Do you think this an STS problem or QT Pro? Many thanks in advance.

 

--------------------

 

Michael, have you posted this in the QT Pro thread? This appears to be a QT Pro installation issue. I just quickly browsed that thread and noticed others with the same issue even without having STS installed. Try reinstalling the QT Pro contribution as that seems to have corrected this problem for the others.

 

Bill Kellum

--------------------

 

Have carried out complete re-install and problem remains. Can't see if QT Pro is working ok or not. Any QTPro experts out there with any ideas?

Share this post


Link to post
Share on other sites
Have carried out complete re-install and problem remains. Can't see if QT Pro is working ok or not. Any QTPro experts out there with any ideas?

 

No idea re STS but do you have a local server or some hosting where you could do a vanilla osc + QTPro installation to make sure QTPro works before adding it to STS?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×