Jump to content
zonetown

[Contribution] QTpro - Quantity Tracking Professional

Recommended Posts

I wanted to ask you guys if there is an easy way to export the low stock report to excel?

I don't know of anyone who has done that before, certainly no-one has posted a contribution add-on for that in this thread.


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites
I hope someone can help me with this

 

I have QTPro installed and there are no errors. The only thing I am having problems with is tracking stock of the product attributes.

 

for example:- I have a t-shirt which comes in Small, Med & Large, I have 2 of each in stock but it will let me add 3 x Small to the shopping cart and doesn't say any is out of stock iyswim

 

has anyone else had this problem?

Make sure you have set Track Stock? to Yes in Product Options at admin/Catalog/Product Attributes

 

// Fredrik

Share this post


Link to post
Share on other sites
Make sure you have set Track Stock? to Yes in Product Options at admin/Catalog/Product Attributes

 

// Fredrik

 

I have checked this and they are set to track stock :blink:

 

I need to get this working and I don't know what else to try

Share this post


Link to post
Share on other sites
I need to get this working and I don't know what else to try

Have you fixed your issue?


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites
but it will let me add 3 x Small to the shopping cart and doesn't say any is out of stock iyswim

Can you checkout and fulfill the order?

 

The settings in admin/configuration/stock should be;

Check stock level = true

Subtract stock = true

Allow Checkout = false

 

// Fredrik

Share this post


Link to post
Share on other sites
Allow Checkout = false

that's the key one! you probably got it on the wrong setting


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites
Can you checkout and fulfill the order?

 

The settings in admin/configuration/stock should be;

Check stock level = true

Subtract stock = true

Allow Checkout = false

 

// Fredrik

 

I have it set to this already, I can still checkout and then when I go and check stock for that attribute it has a -negative figure

 

I must be missing something, this is a real mystery

Share this post


Link to post
Share on other sites
I have it set to this already, I can still checkout and then when I go and check stock for that attribute it has a -negative figure

 

I must be missing something, this is a real mystery

I guess you need to go thru the installation then. Perhaps you missed a part.

 

// Fredrik

Edited by redrum

Share this post


Link to post
Share on other sites
I guess you need to go thru the installation then. Perhaps you missed a part.

 

// Fredrik

 

I've got it working, I reinstalled the includes/functions/general.php file and it works now :D

 

I think I might have messed up this file when installing another contribution

Share this post


Link to post
Share on other sites
I am having a bit of trouble which I think is stemming from the use of QTPro and STS4.3 together. When STS is disabled, I'm able to add items to my cart just fine. But with STS ENabled, it can only remember one item at a time. Using the "Continue Shopping" button and adding a new item causes the original cart contents to be forgotten, and the new item to be the only one there.

 

I've already asked around in the STS forum topic. This is the response I got from one of the developers there:

Does anyone know what he is referring to? Has anyone dealt with this before? I'd hate to have to reinstall the site from scratch just to see if I screwed up somewhere (certainly a possibility). I'd greatly appreciate any experiences people have had using the two together.

 

The only other contribution on the system is the register_globals contribution, in case that makes a difference.

 

Thanks a bunch in advance,

Sam

 

Since I haven't heard any response, can I safely assume that installing QTPro alongside STS 4.3.3 should work without issue? Did I screw up the installation process anywhere? Can anyone with both installed comment?

 

Thanks in advance,

Sam

Share this post


Link to post
Share on other sites
Can anyone with both installed comment?

I have no knowledge whatsoever of STS, i've never used it.. sorry


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites

Has anyone had success integrating the current versions of QTPro (4.3) & PayPal IPN (2.0)?

 

I found a help file for integrating 4.25 w/ IPN v1.0 but so far, nothing on the current builds.

 

I am in dire need of running my site with both of these operational - please help!?

 

Ciao,

 

Anthony David Adams

 

P.S. I mis-posted this in a general forum - I'm new, my apologies. Delete if needed!

Share this post


Link to post
Share on other sites
I don't know of anyone who has done that before, certainly no-one has posted a contribution add-on for that in this thread.

 

 

If the table is formatted correctly, you can simply copy and paste into excel. To do so, you would have to copy the content of the report (including the headers if you'd like) and then right click on a cell and select "Paste Special" and then select paste as text. However, in this case, the low stock report contains a table within the table to address the stock levels of products with attributes and this creates a big mess when pasting into excel. If you select a number of rows that do not include attribute stock, and try the method I've outline above, you can see that this copy and paste method is pretty nifty.

 

It would be of great value if someone was willing to format the report to be more copy/paste friendly.

 

THanks,

V

Edited by valeeum

Share this post


Link to post
Share on other sites
I found a help file for integrating 4.25 w/ IPN v1.0 but so far, nothing on the current builds.

In fact what you refer to as paypal 2.0 is actually v1.5 and I have used v1.4 with QTpro and have no problems... download v1.4 and then upgarde to the v1.5 with text-diff if you need to.


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites
In fact what you refer to as paypal 2.0 is actually v1.5 and I have used v1.4 with QTpro and have no problems... download v1.4 and then upgarde to the v1.5 with text-diff if you need to.

 

Chooch,

 

Thanks for the tip. Is there anything special outside the install instructions with the two contributions that is needed to make them work together?

 

I will try it tonight and report back ;) In the meantime I disabled non-account holders from paying via paypal, and enabled the generic CC module. My girlfriend has a CC machine in her clothing store, so shouldn't be a problem while I get this up and running.

 

Ciao,

Anthony David Adams

Share this post


Link to post
Share on other sites
Chooch,

 

Thanks for the tip. Is there anything special outside the install instructions with the two contributions that is needed to make them work together?

 

I will try it tonight and report back ;) In the meantime I disabled non-account holders from paying via paypal, and enabled the generic CC module. My girlfriend has a CC machine in her clothing store, so shouldn't be a problem while I get this up and running.

 

Ciao,

Anthony David Adams

I haven't looked properly at the new download but lets face it, it can't be that hard it's only 2 files to text-diff.


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites

A few quick questions...

 

I this post still current? Does it need to be done for the Website Payments Pro contribution as well? Lastly, if my client has a Website Payments Pro account is the wpp contribution the only PayPal related contrib. I need to use?

 

Thanks in advance,

Sam

 

This is a code solution for shops wanting to use both QTPro Quantity Tracking Professional (version 4.25 from 27 Feb 2006) and the official osCom team PayPal IPN module inc. tax fix (version 1.0 Mark Evans plus navyhost January 2006).

 

The problem:

QTPro amends checkout_process.php. However, the PayPal IPN uses paypal_ipn.php to mirror the function of checkout_process.php so the QTPro code needs to be manually added to /includes/modules/payment/paypal_ipn.php.

...

Share this post


Link to post
Share on other sites

Is it possible to use qt pro and easypopulate to add new products to stock ?

 

I've tried to set $products_with_attributes = true; but i can't see any stock controll in the downloaded file.

 

Any idea what i should do to get it to work ?

Share this post


Link to post
Share on other sites
I've got it working, I reinstalled the includes/functions/general.php file and it works now :D

 

I think I might have messed up this file when installing another contribution

 

is that tanyajane?? if so, hiya! :)

 

while I'm here, anyone done anything with the stock page?

Share this post


Link to post
Share on other sites

Hello!

 

I am having issues with QT pro *ONLY* in IE. Both IE 6 and 7 refuse to work.

 

http://destroyed.chazbox.com/store/product...;products_id=47 there is the product page, in IE when you select size and color and hit 'add to cart' absolutly nothing happens.

 

I see there is a javascript error bubt I am completely retarded when it comes to javascript.

 

Here is the error:

 

Line: 217

Char: 5

Error: Object Required.

Code: 0

URL: http://destroyed.chazbox.com/store/product...;products_id=47

 

And here is the tid-bit of code it is referring to:

 

<script LANGUAGE="JavaScript"><!--
 function chkstk(frm) {
var stk={11:{1:1,2:1,3:1,4:1,5:1}};
var instk=false;
if (stk[frm['id[3]'].value]) if (stk[frm['id[3]'].value][frm['id[2]'].value]) instk=true;
 return instk;
 }
 function stkmsg(frm) {
var instk=chkstk(frm);
var span=document.getElementById("oosmsg");
while (span.childNodes[0])
  span.removeChild(span.childNodes[0]);
if (!instk)
  span.appendChild(document.createTextNode("The combination of options you have selected is currently out of stock.  Please select another combination."));
else
  span.appendChild(document.createTextNode(" "));
 }
 stkmsg(document.cart_quantity);
//--></SCRIPT>

 

 

where the line of code that is errorring out is:

 

 if (stk[frm['id[3]'].value]) if (stk[frm['id[3]'].value][frm['id[2]'].value]) instk=true;

 

I get this error with EVERY method possible. sequenced, multiple drop downs, radio buttons, single dropdowns, etc.

 

Thanks!

 

 

PS. I should note it works perfectly in mozilla/firefox.

Edited by cricex

Share this post


Link to post
Share on other sites

My QtPro seems to work great, however, it doesn't seem to update all the time. I have bracelets in my store with 26 colors and 5 sizes to choose from. The color lists first because its option id is 1.

 

So I get the color dropdown and then the size drop down, and the select statements seem to be right, but they don't always get updated via javascript. What could be going on?

Share this post


Link to post
Share on other sites
I get this error with EVERY method possible. sequenced, multiple drop downs, radio buttons, single dropdowns, etc.

I don't see any errors after visiting the above link


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites
What could be going on?

store URL?


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×