Jump to content
zonetown

[Contribution] QTpro - Quantity Tracking Professional

Recommended Posts

In addition to my problem above, I'm getting the following error when in the Admin>Catalog>Product Attributes page > when I try to add a new Product Attribute (bottom section of the page) - I fill in the info, click on insert - the following error appears:

 

1136 - Column count doesn't match value count at row 1

 

insert into products_attributes values ('', '367', '4', '47', '', '+')

 

[TEP STOP]

 

Anybody know what could be causing this and what I would need to do to fix it?

 

Thanks for any help!!

Share this post


Link to post
Share on other sites
I just installed the QTPro v4.2 contribution - I updated the product attributes with the stock info for one of my products - went to my site/store to see the results and now when I click on the "More Info" button, the product description no longer appears.

 

Here is the URL to the Product:

http://www.lilhouseofpaws.com/index2.php?cPath=65_80

When you click on "More Info" button you'll see how there is nothing about the product. Before I installed the contrib, the info was appearing ok. Am I missing something on the admin control panel or somewhere else?

 

Any help would be greatly appreciated!

 

Thanks!

Ok, you can all disregard this posting - I think I figured it out - I downloaded KDiff3 and compared my original files to the contrib updated ones and it appears that my original files were changed to make my site work the way it does, so some of the code in the contrib files were not matching up; therefore, making my product info not appear. So I basically just updated my files with the code that starts with

//++++ QT Pro: Begin Changed code

and ends with

//++++ QT Pro: End Changed Code

to signal where the code was modified and all seems to be working.

Edited by Lil Paws

Share this post


Link to post
Share on other sites
Great! Thanks for that - I hadn't realised that the contribution would take care of so much in the frontend that you can leave the allow checkout setting at "true". This really is a good contribution!

 

The drawback there is that it will allow checkout on out-of-stock attributes! I *think* there's a way round it but I can't remember off the top of my head. I'm working on something that should help though.

Share this post


Link to post
Share on other sites
In addition to my problem above, I'm getting the following error when in the Admin>Catalog>Product Attributes page > when I try to add a new Product Attribute (bottom section of the page) - I fill in the info, click on insert - the following error appears:

 

1136 - Column count doesn't match value count at row 1

 

insert into products_attributes values ('', '367', '4', '47', '', '+')

 

[TEP STOP]

 

Anybody know what could be causing this and what I would need to do to fix it?

 

Thanks for any help!!

I have now figured this one out myself - had to go into the sql database - product_attibutes table - found that there was an extra field in the table that was not supposed to be there (I think it was from another contib I tried to use before this one).

Share this post


Link to post
Share on other sites

Hi, I'm fairly new to OSC, and definitely need QTPro to do our biz the way we need it- we sell apparel and other items that require multiple attributes and separate inventory tracking-

 

but our other issue is that we need to update the inventory of those thousands of UPC's daily- and it looks like I'd have to do that by hand with QTPro (and of course that's not practical)

 

is there any import/export utility for excel (csv/tab-delim files) that works with this? I had installed another mod a few wks ago (before looking at other ecomm platforms) that does import/export but I don't think it was meant to work with the multi-attribute nature of QTPro - forgive me if this has been addressed elsewhere... the search utility on this board isn't helping me much and I've got one of those end of the day headaches ;-(

 

And of course, I don't have the PHP skill to create a utility that pulls everything from the multiple db's into a csv and then back into OSC from the import csv...

 

Thanks!

Brian Carter

Adventure 16

Edited by bbcarter

Share this post


Link to post
Share on other sites

Thanks for this support forum

Ive set up QTPro with the following ...

 

Product Info Attribute Display Plugin sequenced_dropdowns

Show Out of Stock Attributes True

Mark Out of Stock Attributes Right

Display Out of Stock Message Line True

Prevent Adding Out of Stock to Cart True

 

Check stock level true

Subtract stock true

Allow Checkout false

Mark product out of stock ***

Stock Re-order level 5

 

Ive entered all stock attribute combination levels above 5,

 

Problem...The options in the 1st dropdown are displayed but will not then display any sequenced options in the 2nd dropdown

 

Any assistance would be most appreciated

With many thanks

Nadege

Share this post


Link to post
Share on other sites

This is a wonderful contribution! After a few snags on my end, I got everything working great!

 

Question for anybody familiar with this or other contributions - similar to having a product with different options/attributes, which QTPro takes care of, is there anything that does the same thing with weight? I have a product with different options and for the most part those options all weigh a different amount; therefore, the customer upon checkout is being charged based on the weight of the main product (which could me more or less weight).

 

Anybody with any suggestions to other contributions that would work with QTPro or any php gurus out there that might want to take this on to add the capability to QTPro?

 

Thanks so much!

Share this post


Link to post
Share on other sites

Brian, easypopulate works with qtpro but I'm not sure if it works with multiple levels of attributes. If you're working on two levels of attributes only you could perhaps use master products for one type of option, say colours, and qtpro for the second level, say sizes. If you're uploading your stock listing the number of products wouldn't be a problem but there again I'm suspecting you'd have to rewrite your spreadsheet, probably not much of a time-saving? Worth poking around on the EP thread.

Share this post


Link to post
Share on other sites

Hi- Im still waiting anxiously to hear any advice regarding my prev post.

It may help to know that i only run one other contribution (All products- Display All) and that shouldnt be incompatible in any way...

With many Thanks

Nadege

 

QTPro Problem...The attribute options in the 1st dropdown are displayed but will not then display any sequenced options in the 2nd dropdown

 

 

Thanks for this support forum

Ive set up QTPro with the following ...

 

Product Info Attribute Display Plugin sequenced_dropdowns

Show Out of Stock Attributes True

Mark Out of Stock Attributes Right

Display Out of Stock Message Line True

Prevent Adding Out of Stock to Cart True

 

Check stock level true

Subtract stock true

Allow Checkout false

Mark product out of stock ***

Stock Re-order level 5

 

Ive entered all stock attribute combination levels above 5,

 

Problem...The attribute options in the 1st dropdown are displayed but will not then display any sequenced options in the 2nd dropdown

Share this post


Link to post
Share on other sites
Hi Northerndreamer,

 

If you haven't already done this:

This is the code change I made from line 94 of the admin/stats_low_stock_attrib.php file:

 

 
 $products_query_raw = "select p.products_id, p.products_model, pd.products_name, p.products_quantity,p.products_price, l.name from " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_DESCRIPTION . " pd, " . TABLE_LANGUAGES . " l where p.products_id = pd.products_id and p.products_id = pd.products_id and l.languages_id = pd.language_id and pd.language_id = '" . (int)$languages_id . "' order by p.products_model ASC";

 

I added p.products_model to the first line of the db query and changed the order by to p.product_model instead of the product name.

 

Then made changes from line 112 of the same file to include the model number - I also changed the text size on the product name:

 

<td class="formAreaTitle"><?php echo '<a href="' . tep_href_link(FILENAME_STOCK, 'product_id=' . $products['products_id']) . '"><strong style="font-size:14px;">' . $products['products_name'] . '</a> - ' . $products['products_model'] . '</strong>'; ?> </td>

 

Hope this helps someone.

 

Regards

 

Rhys

Share this post


Link to post
Share on other sites

Hi,

 

I have QT Pro installed and it works perfect so far.

 

I am looking to add a inventory display function so that instead of just offering an option or saying it is out of stock, it should always add the QTY available for a particular option combo.

 

A further addition would be to allow multiple adds of a particular option. say like you pick a shirt in White, Small and you pick add a text field that allows you to add more than 1 qty.

 

Right now, the drop downs just show the option name and pricing, how do you ADD the inventory count?

 

Anyone attempt this?

 

Gary

Share this post


Link to post
Share on other sites

I'm new to the whole MySQL thing. Could someone be kind enough to explain how I add the extra tables in the .sql file to my existing db? Either using the MySQL Administrator GUI or the command line client. Also, I seem to have two identical db showing in MySQL, one called mystore and one called localhost, which one needs updating?

Share this post


Link to post
Share on other sites

Shane, localhost is (probably!) the name for your server, not your database. I'm not familiar with MySQL Administrator, I've only used phpMyAdmin, but somewhere there will be a tab or box or link to a page where you can either import the file or copy and paste the file contents.

 

Gary I'll think on this one, it's too late right now for me to consider it! You could look at the coding for the out of stock messages and see if you can adapt that in the pad_ files?

Edited by trogette

Share this post


Link to post
Share on other sites

I believe I've found a significant bug in this contribution...

 

I recently set up qtpro and am having problems updating stock for products without attributes. Upon reveiwing the code in the checkout_process.php file, I noticed a possible bug that I would like reviewed by the qtpro master coders. Here it is...

 

Around line 256 (i'm using a heavily modified store so this is just an approximation)

 

// do not decrement quantities if products_attributes_filename exists
	if (!$download_selected) {
	  $stock_left = $stock_values['products_quantity'] - $actual_stock_bought;
	  tep_db_query("UPDATE " . TABLE_PRODUCTS . " 
					SET products_quantity = products_quantity - '" . $actual_stock_bought . "' 
					WHERE products_id = '" . tep_get_prid($order->products[$i]['id']) . "'");
//++++ QT Pro: End Changed Code

 

The text in red below taken from the code above seems to be wrong...

tep_db_query("UPDATE " . TABLE_PRODUCTS . "

SET products_quantity = products_quantity - '" . $actual_stock_bought . "'

WHERE products_id = '" . tep_get_prid($order->products[$i]['id']) . "'");

 

 

shouldn't this actually by $stock_values['product_quantity'] instead of product_quantity? Or, wouldn't it make more sense to use the variable $stock_left since it's already computed in the line above this query?

 

This seems wrong to me and would like to have this verified by those who have more experience with this contribution. The stock tracking bug is making invenotry management difficult for me and would like this solved asap.

 

Thanks,

V

Share this post


Link to post
Share on other sites
Thanks for this support forum

Ive set up QTPro with the following ...

 

Product Info Attribute Display Plugin sequenced_dropdowns

Show Out of Stock Attributes True

Mark Out of Stock Attributes Right

Display Out of Stock Message Line True

Prevent Adding Out of Stock to Cart True

 

Check stock level true

Subtract stock true

Allow Checkout false

Mark product out of stock ***

Stock Re-order level 5

 

Ive entered all stock attribute combination levels above 5,

 

Problem...The options in the 1st dropdown are displayed but will not then display any sequenced options in the 2nd dropdown

 

Any assistance would be most appreciated

With many thanks

Nadege

 

I'm having the same problem. I think it's a problem with the Javascript, but I don't know exactly which file to look into to fix the problem.

 

Anyone's help is GREATLY appreciated!

Share this post


Link to post
Share on other sites

Has anyone worked out yet how to get QTPro to work with sequenced drop-downs ?

Is it possible- or is there a bug that needs fixing in the javascript etc ?

Any asistance wuld be greatly apreciated

With many thanks

Nadege

Share this post


Link to post
Share on other sites

I am trying to get QT PRO (already installed) to work with Attributes Sets Plus...and I can't figure out how to merge them...specifically on product_info.php and I also believe categories.php... any insight or code would be greatly appreciated!!! Thanks!

Share this post


Link to post
Share on other sites

Cross-posted on Master Products...

 

I'm looking again at the issue of options in Master Products when using the QTPro contribution. Options on MP listings don't add to my cart at all, v frustrating! I'd like to see the pad_base file (particularly the tep_draw_pull_down_menu lines) of anyone who has got this working.

 

Thanks :)

Share this post


Link to post
Share on other sites

I am just trying to get this mod to work I have installed the sql file and made the mods to the files by adding the code but it is not working. I have other mods installed so my code is not orignal basic install. Not sure if this is the issue and just need to know what line the code needs to be on. Right now I get errors in my product_info.php file for catalog and the menu item is not showing up in the admin screen on the left.

Arghhh :( someone please help.

 

Thanks

Share this post


Link to post
Share on other sites

HI all

 

I have a (small?) problem.

I?m using QT Pro with the pad_sequenced_dropdowns.

My attributes are all shown in reverse order. eg

XL

L

M

S

XS

 

instead of

XS

S

M

L

XL

 

Is there a way to fix this?

 

Thanks in advance :)

Share this post


Link to post
Share on other sites

I also am getting an error after I installed it. On the catalog side I get this error when I click a product:

 

Parse error: syntax error, unexpected $end in /home/bl/public_html/lid/Store1/product_info.php on line 431

 

 

The last few lines for product_info.php are(line 431 is the last line of code below):

 

</td></tr>

 

</table>

</form></td>

<!-- body_text_eof //-->

<td width="<?php echo BOX_WIDTH; ?>" valign="top"><table border="0" width="<?php echo BOX_WIDTH; ?>" cellspacing="0" cellpadding="2">

<!-- right_navigation //-->

<?php require(DIR_WS_INCLUDES . 'column_right.php'); ?>

<!-- right_navigation_eof //-->

</table></td>

</tr>

</table>

<!-- body_eof //-->

 

<!-- footer //-->

<?php require(DIR_WS_INCLUDES . 'footer.php'); ?>

<!-- footer_eof //-->

</body>

</html>

<?php require(DIR_WS_INCLUDES . 'application_bottom.php'); ?>

Share this post


Link to post
Share on other sites

I looked back this seems to be the issue when I add this code in I get the error:

 

<?php

//++++ QT Pro: Begin Changed code

if (tep_not_null($product_info['products_image'])) {

?>

Share this post


Link to post
Share on other sites

Ok fixed above and tried to edit post but would not let me. Issue now is:

 

When I add this code:

 

//++++ QT Pro: Begin Changed code

$products_id=(preg_match("/^\d{1,10}(\{\d{1,10}\}\d{1,10})*$/",$HTTP_GET_VARS['products_id']) ? $HTTP_GET_VARS['products_id'] : (int)$HTTP_GET_VARS['products_id']);

require(DIR_WS_CLASSES . 'pad_' . PRODINFO_ATTRIBUTE_PLUGIN . '.php');

$class = 'pad_' . PRODINFO_ATTRIBUTE_PLUGIN;

$pad = new $class($products_id);

echo $pad->draw();

//++++ QT Pro: End Changed Code

 

 

It displays this on the product info pages under the description of the items:

 

//++++ QT Pro: Begin Changed code $products_id=(preg_match("/^\d{1,10}(\{\d{1,10}\}\d{1,10})*$/",$HTTP_GET_VARS['products_id']) ? $HTTP_GET_VARS['products_id'] : (int)$HTTP_GET_VARS['products_id']); require(DIR_WS_CLASSES . 'pad_' . PRODINFO_ATTRIBUTE_PLUGIN . '.php'); $class = 'pad_' . PRODINFO_ATTRIBUTE_PLUGIN; $pad = new $class($products_id); echo $pad->draw(); //++++ QT Pro: End Changed Code

Share this post


Link to post
Share on other sites
I looked back this seems to be the issue when I add this code in I get the error:

 

<?php

//++++ QT Pro: Begin Changed code

if (tep_not_null($product_info['products_image'])) {

?>

 

Most likely the "{" at the end of the if line has no corresponding "}". If you look at the base file, you'll see where it should be...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×