Latest News: (loading..)
zonetown

[Contribution] QTpro - Quantity Tracking Professional

2,160 posts in this topic

now i am really confused. some items stock work some dont.

 

SHopping Cart View

shoppingcart.jpg

 

Inventory Admin View

inventory.jpg

 

db view through php myadmin of products_stock

phpmyadmin.jpg

 

 

please help!

Share this post


Link to post
Share on other sites

This module is pretty complex and I am still working out some minor bugs. It has consume a bit of my time and will be a bit before I get everything corrected.

 

The QTpro project is in the mist of being handed down to Linda McGrath of http://www.thewebmakerscorner.com in hopes she will improve the contribution. Show your support to her for taking over QTpro project.

 

I will be updating the site with the last Patch and Version soon hopefully. It will fix the auto checked on the catalog product info page, that is causing it to show up as null on the shopping cart.

 

Right now, this module is not made to be supported with Buy it Now feature. If you want to use QTpro, disable that feature. Maybe in the future or someone will figure a solution for this.

 

Thanks,

Joe

Share this post


Link to post
Share on other sites

Thanks joe for working on this.. I sell clothes too and this was a must have.

 

Vtec: I am having the same problem and I think I know what is happening.. but because I am a newbie I have no idea how to fix it..

 

This is what I noticed. If I go into the product and just click add to cart I get the "product not in stock" error. Notice in the cart that the attribute is not listed below the item. The radio button was selected but it doen't register.

 

Now if I go into the product and click a different attribute and then click the top attribute again.. THEN add it to the cart.. all is good.

 

So the problem is with that top radio button..

 

If anyone has a fix I would love to hear from you.

 

Thanks!

 

Staci

Share this post


Link to post
Share on other sites

yeah, thats exactly what this is doing, but we never tried selecting one then the other to fix that. great find staci! hopefully this will be an ewasy fix.

Share this post


Link to post
Share on other sites
I will be updating the site with the last Patch and Version soon hopefully. It will fix the auto checked on the catalog product info page, that is causing it to show up as null on the shopping cart.

 

Sorry Joe I didn't read that part.. I am also having problems with items that don't have attributes.. I sell a lot of one of a kinds and have been getting this error when I go to the cart:

 

Warning: ksort() expects parameter 1 to be array, null given in /home/virtual/site30/fst/var/www/html/catalog/includes/functions/general.php on line 104

 

Warning: Variable passed to each() is not an array or object in /home/virtual/site30/fst/var/www/html/catalog/includes/functions/general.php on line 106

1064 - You have an error in your SQL syntax near ') and language_id=1' at line 1

 

select products_options_id as id,special from products_options where products_options_id in () and language_id=1

 

Any help is greatly appreciated!

 

Staci

Share this post


Link to post
Share on other sites

that was a simple fix about the adding products to cart. I just nulled out the auto checked.

 

You can download it on the following url.

 

http://vary.net/qtpro/download/product_info.zip

 

I actually had this fix for awhile, but I was having some personal problems and everything else. I'm sorry for the delay.

 

Joe

 

I am aware of other problems...

Share this post


Link to post
Share on other sites

MSWOOHEE, the directory stucture you gave me looks very similar to the ENSIM CP.

 

I made QTpro to function on cPanel and not on ENSIM and Plesk because of how difficult it is to work with them.

 

I am surprise you got osCommerce to even work on it. The problem I had was not being able to send emails to anyone. Several other small problems eventually popped up.

 

Joe

Share this post


Link to post
Share on other sites
MSWOOHEE, the directory stucture you gave me looks very similar to the ENSIM CP.

 

I made QTpro to function on cPanel and not on ENSIM and Plesk because of how difficult it is to work with them.

 

I am surprise you got osCommerce to even work on it. The problem I had was not being able to send emails to anyone. Several other small problems eventually popped up.

 

Joe

 

 

Joe, Absolutely NO IDEA what you just said lol. your mod is the only thing I have added. OSC sits on a new host withnothing else on it.. actually I don't know what caused the error but when I log off and start a new cart that product works fine. But I still have one cart locked up because of that error. So, I dunno.. if it happens again I will note everything.

 

Also the URL for the fix should be:

 

http://vary.net/qtpro/download/patch/product_info.zip

Share this post


Link to post
Share on other sites
that was a simple fix about the adding products to cart. I just nulled out the auto checked.

 

You can download it on the following url.

 

http://vary.net/qtpro/download/product_info.zip

 

I actually had this fix for awhile, but I was having some personal problems and everything else. I'm sorry for the delay.

 

Joe

 

I am aware of other problems...

 

Joe, That the correct file because I'm not seeing a difference. Its still auto selecting and its not going to the cart properly.

Share this post


Link to post
Share on other sites

I made QTpro to function on cPanel and not on ENSIM and Plesk because of how difficult it is to work with them.

 

really? i have this installed in ensim and its works great except for the error when adding that to the cart. thanks for the fix Joe, you rock!

Share this post


Link to post
Share on other sites

i have another question. when i add a new product and change its stock levels for the attributes for the first time, when i click the 'add' button it doesnt go to the proper url. eg instead of www.domain.com/catalog/admin/stock.php?blahblahblabh , it goes to just /catalog/admin/... so i get a page not found. it still works when i insert the full url, but is there a way to make it do that automatically.

 

also, i get an error when i try to zero out the last attribute. eg i have a blue and a black widget. i can zero out one, and it goes away just fine, but when i try to zero out the other with no more attributes, it gives this.

 

1064 - You have an error in your SQL syntax near 'where products_id=49' at line 1



update products set products_quantity= where products_id=49



[TEP STOP]

 

the first one isnt really a pressing issue b/c i can manually enter the url, but the second one is a little more important b/c i sell things in the retial store which shares the same inventory as the web store will. i understand that if i am zeroing out the last attributew for that item i can just turn the item off(same result no more item in the catalog on the client side) but i just wanted to give a heads up on a bug.

 

kevin

Share this post


Link to post
Share on other sites

I could use a little help. When doing a base install then putting qtpro 2.0 in, whenever i add an item to my cart I get this:

 

Warning: ksort() expects parameter 1 to be array, null given in /home/threadz/public_html/catalog/includes/functions/general.php on line 104  

 

Warning: Variable passed to each() is not an array or object in /home/threadz/public_html/catalog/includes/functions/general.php on line 106  

1064 - You have an error in your SQL syntax near ') and language_id=1' at line 1  

 

select products_options_id as id,special from products_options where products_options_id in () and language_id=1

 

 

Any ideas???

Share this post


Link to post
Share on other sites

:cry: I have 1 week trying to fix these error, appears on the catalog when i try to see some product

 

 

ossnap.jpg

im using oscommerce 2.2

 

tanks a lot for your help

Share this post


Link to post
Share on other sites
This is what I noticed. If I go into the product and just click add to cart I get the "product not in stock" error. Notice in the cart that the attribute is not listed below the item. The radio button was selected but it doen't register.

 

Now if I go into the product and click a different attribute and then click the top attribute again.. THEN add it to the cart.. all is good.

 

So the problem is with that top radio button..

 

If anyone has a fix I would love to hear from you.

 

The ksort() error was being generated by the radio button 'looking like' it was checked, but the script not seeing any buttons checked. Joe's fix just let the customer see that the radio button was not checked, but it still allows for null attributes if the customer forgets to select something.

This patch adds a javascript check to ensure that a radio button has been selected before moving on:

http://www.msu.edu/~sloughwi/product_info.php

You might have to right-click and choose "save file as"

Hope this helps!

:wink:

 

Also: Joe, I think you should update the order process so that the quantities under product_stock are updated and not just the quantities under products. Not vital, just a suggestion.

Another nice feature would be drop down boxes for each attribute instead of radio buttons. That would require a bit of work, but would make the order process look nicer.

Share this post


Link to post
Share on other sites

Correction: ksort() error was NOT being caused by the reason above. The above error was causing the script to show 'no attributes' when there shoudl always be some.

 

ksort() error is being caused by a NULL array getting sent to a stock level function.

 

Here's a fix:

Put this in catalogincludesmodules

 

http://www.msu.edu/~sloughwi/order_details.php

 

right click then save as...

 

hopefully that will do the trick! :)

Share this post


Link to post
Share on other sites
Correction: ksort() error was NOT being caused by the reason above. The above error was causing the script to show 'no attributes' when there shoudl always be some.

 

ksort() error is being caused by a NULL array getting sent to a stock level function.

 

Here's a fix:

Put this in catalogincludesmodules

 

http://www.msu.edu/~sloughwi/order_details.php

 

right click then save as...

 

hopefully that will do the trick! :)

 

Paul, sorry I'm new .. and slow :? hehe.. I just want to make sure I have this right... The first fix you posted is just to make sure that an atribute is selected..

 

Does the second fix mean that I wouldn't have to include an attribute on every item? What I have been doing to avoid the errors is adding each item with a product attribute and then adding the stock to that attribute. So for instance.. I have a blue widget.. thats all I have. I list it as a blue widget and then add the attribute "blue". Then I stock the item so it shows 12 "blue". When a customer places the item into the shopping cart and does not select "blue" they now get a out of stock message and are instructed to go back and choose a color or size.

 

If I just add the item "blue widget" and show stock in the "stock" box..and do not add the attribute "blue" and add stock to the "blue" attribute THEN I get that ksort error.

 

I hope that makes sense.. I don't want try and install something that I'm not sure how it works :)

 

Thanks!

Share this post


Link to post
Share on other sites

Yes you are right.

 

The first fix give a pop up box saying "you must select an option" when there are attributes to choose from and the customer has not choosen one.

The second fix stops the ksort() error that appear when someone puts an item with no attributes into a their cart. This second fix would do away with the need to have attributes on every item.

 

So lets say a customer is buying a 'thingy' and a 'widget'. There are no attributes for the 'thingy' but the customer can get a red or blue 'widget'. Before fix one, the customer could have added the widget to his cart w/o selecting an attribute, which would have given an out of stock error. Fix 1 stops that and forces the customer to select blue or red for the 'widget'.

Before fix 2 the customer could have selected the 'thingy' and put it in his cart, but as soon as he viewed his cart he would get a 'ksort()' error. Fix 2 fixes the ksort() bug. After applying fix 2, you no longer need to give every item attributes.

The customer adds a blue 'widget' and a 'thingy' to his cart and off he goes :)

 

Make sure you back-up your old files before trying these new ones. If they dont' work for some reason, you can just put the backups into action again.

 

Please let me know if there are any problems! :D

Share this post


Link to post
Share on other sites

The link on page 1 of this thread no longer works, and I am looking for this EXACT SOLUTION, and am desperate to find a complete answer. It seems as if everyone who has it says it works great.

 

I am selling paintings and want to have different sizes of the same painting available. So that when the 20x24's sell out, we can still have the option of the 8x10's there. And to have manage the quantity available with each option is exactly what I am needing.

 

Any help is much appriciated. If someone could even post the files that were once on the "http://www.vary.net/qtpro" site (it is not up anymore). Or if someone could email me the .zip file, or the extracted files, or ANYTHING!!!!!!!!

 

Thank You so much guys,

Danno~

Share this post


Link to post
Share on other sites
The link on page 1 of this thread no longer works, and I am looking for this EXACT SOLUTION, and am desperate to find a complete answer. It seems as if everyone who has it says it works great.

 

I am also curious about this contribution. I've experimented with QTPro 2.0 for some time now, but have yet not managed to make good use of it. Is someone developing new features to this addition or is there some other ongoing effort to enable separate quantities for separate product attributes, hereby referred to as "attribute quantities"? (An earlier post from Joe mentioned handing over to Linda McGrath...)

 

It appears to me that the "attribute quantities" are not automatically updated when a product is sold. Have I misunderstood anything here or isn't that a showstopper for an addition such as this one?

What is the use of separate "attribute quantities" if they don't get updated?

 

I may be able to contribute, but I need to know the status first.

 

Thank you for your feedback,

Claes

 

BTW: Danno, if you are still looking for the QTPro download, send me an email.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now