Jump to content
Sign in to follow this  
Popeye3165

cURL set up question

Recommended Posts

Hello,

 

I'm trying to set up my authorize.net payment mod and I'm getting an error message while processing the test cards. I have godaddy as my hosting and I'm on a Linux server. I have confirmed that the cURL is compiled. They are telling me that I need to install the following script to get the cURL to work correctly:

 

Using CURL to Connect Using HTTPS

 

Below is a PHP script that uses CURL to connect securely to a remote system (http://www.authorize.net), obtain data from that system and then creates a Web page based on that data.

 

Note: On our shared hosting, any CURL applications that make secure HTTP connections (HTTPS over port 443) need to pass through a proxy server. The address for this proxy server is proxy.shr.secureserver.net and connections must specify the use of port 3128. The code below already includes this information.

<?

 

$URL="https://www.authorize.net";

if (isset($_GET["site"])) { $URL = $_GET["site"]; }

$ch = curl_init();

echo "URL = $URL <br>n";

curl_setopt($ch, CURLOPT_VERBOSE, 1);

curl_setopt ($ch, CURLOPT_HTTPPROXYTUNNEL, TRUE);

curl_setopt ($ch, CURLOPT_PROXYTYPE, CURLPROXY_HTTP);

curl_setopt ($ch, CURLOPT_PROXY,"http://proxy.shr.secureserver.net:3128");

curl_setopt ($ch, CURLOPT_SSL_VERIFYPEER, FALSE);

curl_setopt ($ch, CURLOPT_URL, $URL);

curl_setopt ($ch, CURLOPT_TIMEOUT, 120);

$result = curl_exec ($ch);

echo "<hr><br>n";

echo 'Errors: ' . curl_errno($ch) . ' ' . curl_error($ch) . '<br><br>';

echo "<hr><br>n";

curl_close ($ch);

print "result - $result";

echo "<hr><br>n";

 

?>

 

Is this correct and if so, what file/s does this script need to be added too?

 

Thanks in advance!

Share this post


Link to post
Share on other sites

I still can't get connectivity to authorize.net, so I hope you do and this helps solve my problem. I'll be interested in knowing what happens, and if I use a different host, would it change anything. Sarasota guy

Share this post


Link to post
Share on other sites

I have exactly same problem after I moved to godaddy's hosting and I chatted with couple of their support, no one know what's going on, they said is script coding issue and they could not provide any help... Did you contact the person who provide you the script code to check where we should add it?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×