Jump to content
Sign in to follow this  
mikrokosmonaut

Order Confirmation Issues with PayPal IPN

Recommended Posts

Hi there.

 

I realise that there are some very similar questions to mine on this forum but I think mine needs some hand-crafted solutions from you osC legends.

 

Here are my vital statistics:

 

osC version 2.2 RC 2a with UK based modifications.

Server requirements all came up green during installation.

Only payment module installed is 'PayPal Website Payments Standard'.

 

Unfortunately due to starting off testing the PayPal on the live server on a previous installation, I can not use Sandbox because it doesn't support turning off Order ID checking to help void the 'Invoice already paid' problem of multiple Order IDs. I am therefore giving PayPal 2p every time I test! Doh.

 

Anyway the system works great so long as the user either manually returns to the merchant or is automatically redirected. Unfortunately if you close the payment confirmation window prematurely, the order is still registered as having being paid in the Admin but no order confirmations are sent to either the seller or the buyer (apart from the PayPal invoices).

 

I found out that this problem is supposedly solved by setting up PayPal IPN, so I did. I pointed the PayPal Return URL to catalog/ext/modules/payment/paypal/standard_ipn.php.

 

Unfortunately still no order confirmations emails after premature closure of the payment confirmation page.

 

I've tried entering the secure version of the Return URL i.e. https:// etc to no avail. Is this URL meant to be an https:// address?

 

In any case can anybody tell me why even after wrestling with IPN I am still having this issue? I realise that the UK modifications may have altered the Payment Modules somehow so that they perhaps no longer properly support IPN, even though this would be a bit silly because there still exists a file named 'standard_ipn.php'.

 

There is also a feature in Sandbox where you can send a 'test IPN' to your Return URL. Does anybody know whether this is an effective way of debugging IPN issues in the first place? I tried it anyway but still no luck.

 

Please help! Much love.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×