Jump to content
Sign in to follow this  
killerwhale65

photo gallery for oscommerce

Recommended Posts

new version 0.6

 

I have just uploaded the newest version of Photo Gallery for osCommerce.

In this version, the already announced admin module has been introduced. Currently you will be able to edit/remove comments (usefull to fight SPAM), delete pictures and clean up the thumbnails folder.

Also some smaller bugs were solved.

 

Direct download: http://addons.oscommerce.com/info/6181

 

Visit the project website for more information: http://oscommerce-photo-gallery.micrographx.be

 

 

Have fun!

Edited by killerwhale65

Matthias Thoen

my contribution: Photo Gallery for osCommerce

--check my homepage in my CARD--

Share this post


Link to post
Share on other sites

Hi,

Just installed 0.6 and wanted to say thanks for a great contribution.

I understand this is a new contrib in process so I wanted to give you feedback as well.

  • Installation was generally simple and straightforward. I did need to change permissions on my .../gallery/thumbnails folders to allow the Apache process to write files.
  • The new Admin functionality is welcomed but a bit confusing still. I get the following:

21 [
] [
]

101 [
] [
]

102 [
] [
]

Is this the interface or did I miss something in the install? If it's the interface I understand this is a new contrib and a work in process; otherwise what did I do wrong?
  • The contrib uses OTF Thumbnailer (I'm using 2.3.x) but where is the thumbnail size controlled? I'm getting thumbnails sized differently (150x112) than what I have set in the "Images" configuration.
  • Search Engine Optimization:
    • I use SEO-G and Header Tags SEO contributions.
    • Header Tags SEO seems to be able to work
    • I have not started integrating with SEO-G yet.
    • In general it's important for a contribution to populate any page or image it generates with meaningful Title, Desc, and Log tags. If the title and desc of the image could populate these tags that would be wonderful and the search engines might actually index your images!

    [*]I notice that the CSS is imbedded in the PHP files. Is it possible to pull that code out into a separate file?

Again thank you for a fine contribution.

Ralph

Share this post


Link to post
Share on other sites
  • Search Engine Optimization:
    • I use SEO-G and Header Tags SEO contributions.
    • Header Tags SEO seems to be able to work

 

 

PS - It works with Header Tags SEO if you add

 

// Photo Gallery

define('FILENAME_GALLERY', 'gallery.php');

 

to catalog/includes/filenames.php.

You would need to add the other file names if you wanted them included as well.

 

Ralph

Share this post


Link to post
Share on other sites
Hi,

Just installed 0.6 and wanted to say thanks for a great contribution.

I understand this is a new contrib in process so I wanted to give you feedback as well.

  • Installation was generally simple and straightforward. I did need to change permissions on my .../gallery/thumbnails folders to allow the Apache process to write files.
  • The new Admin functionality is welcomed but a bit confusing still. I get the following:

21 [
] [
]

101 [
] [
]

102 [
] [
]

Is this the interface or did I miss something in the install? If it's the interface I understand this is a new contrib and a work in process; otherwise what did I do wrong?
  • The contrib uses OTF Thumbnailer (I'm using 2.3.x) but where is the thumbnail size controlled? I'm getting thumbnails sized differently (150x112) than what I have set in the "Images" configuration.
  • Search Engine Optimization:
    • I use SEO-G and Header Tags SEO contributions.
    • Header Tags SEO seems to be able to work
    • I have not started integrating with SEO-G yet.
    • In general it's important for a contribution to populate any page or image it generates with meaningful Title, Desc, and Log tags. If the title and desc of the image could populate these tags that would be wonderful and the search engines might actually index your images!

    [*]I notice that the CSS is imbedded in the PHP files. Is it possible to pull that code out into a separate file?

Again thank you for a fine contribution.

Ralph

 

i also get this error in admin pages

 

21 [edit comment] [delete picture]

Clean up thumbnail folder

 

no pictures show up,

 

i am using sts template, any helpl please

Share this post


Link to post
Share on other sites
Hi,

Just installed 0.6 and wanted to say thanks for a great contribution.

I understand this is a new contrib in process so I wanted to give you feedback as well.

Again thank you for a fine contribution.

Ralph

Thanks for your valuable feedback, i will try and see how to incorporate your suggestions in future versions.

About the admin, that is correct the way you see it. I know this interface is basic, but it does what it needs to do: edit/remove comments, delete pictures and clean the thumbnails folder.

About the OTF contrib: picture sizes are hardcoded in the gallery.php and gallery_user.php files for now. You will be able to change them later in the admin.

 

i also get this error in admin pages

 

21 [edit comment] [delete picture]

Clean up thumbnail folder

 

no pictures show up,

 

i am using sts template, any helpl please

This is no error, this is correct, no pictures are supposed to show up, only the filenames/picture numbers


Matthias Thoen

my contribution: Photo Gallery for osCommerce

--check my homepage in my CARD--

Share this post


Link to post
Share on other sites

Have just uploaded your newest version and looking forward to using it.

Have returned this error when uploading picture

 

[Function copy] : failed to open stream : No such file or directory in home/******/public_html/gallery_user.php on line 80

 

I think line 80 reads //$target_path = $target_path . basename( $_FILES['uploadedfile']['name']);

 

Very new to html and would appreciate any help.

Edited by clarkie

Share this post


Link to post
Share on other sites
Have just uploaded your newest version and looking forward to using it.

Have returned this error when uploading picture

 

[Function copy] : failed to open stream : No such file or directory in home/******/public_html/gallery_user.php on line 80

 

I think line 80 reads if(copy($file[tmp_name'][$key], $target_path)) (

 

Very new to html and would appreciate any help.

Looks like something goes wrong during the copying of the file from a temporary folder on your server, to the /gallery folder.

Try to make your gallery folder writable (CHMOD 666).

 

Before the [function copy], is there anything else listed, such as:

Warning: copy(.....)?

Edited by killerwhale65

Matthias Thoen

my contribution: Photo Gallery for osCommerce

--check my homepage in my CARD--

Share this post


Link to post
Share on other sites
Looks like something goes wrong during the copying of the file from a temporary folder on your server, to the /gallery folder.

Try to make your gallery folder writable (CHMOD 666).

 

Before the [function copy], is there anything else listed, such as:

Warning: copy(.....)?

 

 

Yes

Warning : copy(gallery/3_1.jpg)

How do I go about making gallery folder writable?

and thanks for the quick response

Edited by clarkie

Share this post


Link to post
Share on other sites
Yes

Warning : copy(gallery/3_1.jpg)

How do I go about making gallery folder writable?

and thanks for the quick response

In your FTP program, right click on the gallery folder, and choose something like file attributes (depending on the program you use). Now make sure all read/write/execute options are ticked.


Matthias Thoen

my contribution: Photo Gallery for osCommerce

--check my homepage in my CARD--

Share this post


Link to post
Share on other sites
In your FTP program, right click on the gallery folder, and choose something like file attributes (depending on the program you use). Now make sure all read/write/execute options are ticked.

 

 

Have changed permissions to 666, but the same error is still showing.

Any other ideas, I really want to upload some photos to see how they look.

Share this post


Link to post
Share on other sites
Have changed permissions to 666, but the same error is still showing.

Not to mention when I do change these permissions it comes up with an Internal Server Error.

Any other ideas, I really want to use your contribution on my site.

Share this post


Link to post
Share on other sites
Have changed permissions to 666, but the same error is still showing.

Any other ideas, I really want to upload some photos to see how they look.

In the gallery_user.php file, before this line 80, add the following:

echo 'FOR TESTING ONLY'.$file['tmp_name'][$key]."<br>".$target_path;

 

Now upload a picture, and now you should see on top of your website the text 'FOR TESTING ONLY'. Let me know what is says next to that text, as well as directly below it.

 

If that text does NOT appear, do this:

 

change the following:

			if(copy($file['tmp_name'][$key], $target_path)) {
			//$messageStack->add('gallery_user','success');
			$messageStack->add('header',TEXT_FILE. ' '. basename($file['name'][$key]). ' '.TEXT_UPLOADED,'success');
			mysql_query("INSERT INTO gallery (cID,pID) VALUES (".$customer_id.",".$n.")");
		} else{
			//$messageStack->add('There was an error uploading the file '.  basename($file['name'][$key]). ', please try again!','error');
			$messageStack->add('header','There was an error uploading the file '.  basename($file['name'][$key]). ', please try again!','error');
		}

 

into this:

			/*if(copy($file['tmp_name'][$key], $target_path)) {
			//$messageStack->add('gallery_user','success');
			$messageStack->add('header',TEXT_FILE. ' '. basename($file['name'][$key]). ' '.TEXT_UPLOADED,'success');
			mysql_query("INSERT INTO gallery (cID,pID) VALUES (".$customer_id.",".$n.")");
		} else{
			//$messageStack->add('There was an error uploading the file '.  basename($file['name'][$key]). ', please try again!','error');
			$messageStack->add('header','There was an error uploading the file '.  basename($file['name'][$key]). ', please try again!','error');
		}
*/

 

That will deactivate the copy function so it will also not generate an error. Upload a picture. Now you should see the text 'FOR TESTING ONLY', let me know what it says next to it and below it.


Matthias Thoen

my contribution: Photo Gallery for osCommerce

--check my homepage in my CARD--

Share this post


Link to post
Share on other sites
In the gallery_user.php file, before this line 80, add the following:

echo 'FOR TESTING ONLY'.$file['tmp_name'][$key]."<br>".$target_path;

 

Now upload a picture, and now you should see on top of your website the text 'FOR TESTING ONLY'. Let me know what is says next to that text, as well as directly below it.

 

If that text does NOT appear, do this:

 

change the following:

			if(copy($file['tmp_name'][$key], $target_path)) {
			//$messageStack->add('gallery_user','success');
			$messageStack->add('header',TEXT_FILE. ' '. basename($file['name'][$key]). ' '.TEXT_UPLOADED,'success');
			mysql_query("INSERT INTO gallery (cID,pID) VALUES (".$customer_id.",".$n.")");
		} else{
			//$messageStack->add('There was an error uploading the file '.  basename($file['name'][$key]). ', please try again!','error');
			$messageStack->add('header','There was an error uploading the file '.  basename($file['name'][$key]). ', please try again!','error');
		}

 

into this:

			/*if(copy($file['tmp_name'][$key], $target_path)) {
			//$messageStack->add('gallery_user','success');
			$messageStack->add('header',TEXT_FILE. ' '. basename($file['name'][$key]). ' '.TEXT_UPLOADED,'success');
			mysql_query("INSERT INTO gallery (cID,pID) VALUES (".$customer_id.",".$n.")");
		} else{
			//$messageStack->add('There was an error uploading the file '.  basename($file['name'][$key]). ', please try again!','error');
			$messageStack->add('header','There was an error uploading the file '.  basename($file['name'][$key]). ', please try again!','error');
		}
*/

 

That will deactivate the copy function so it will also not generate an error. Upload a picture. Now you should see the text 'FOR TESTING ONLY', let me know what it says next to it and below it.

 

 

After using the first bit of code only it read

FOR TESTING ONLY/tmp/phpt9FfLN

gallery/

Warning: copy(gallery/3_1.jpg)[functioncopy]:failed to open stream: No such file or directory in /home/*****/public_html/gallery_user.php on line 80

 

A different photo gave me this

FOR TESTING ONLY/tmp/phpfwwmEp

gallery/

Edited by clarkie

Share this post


Link to post
Share on other sites
A different photo gave me this

FOR TESTING ONLY/tmp/phpfwwmEp

gallery/

No error? That means this different photo did upload? Can you confirm there are files in your gallery folder?


Matthias Thoen

my contribution: Photo Gallery for osCommerce

--check my homepage in my CARD--

Share this post


Link to post
Share on other sites
No error? That means this different photo did upload? Can you confirm there are files in your gallery folder?

 

 

No sorry this photo also showed the same

Warning : copy(gallery/3_1.jpg)[function copy] : failed to open stream:No such file or directory in /home/*****/public_html/gallery_user.php on line 80

 

I was just pointing out the different code that followed the loading of a different image.

 

Is it possible I have not loaded a file properly?

Edited by clarkie

Share this post


Link to post
Share on other sites
No sorry this photo also showed the same

Warning : copy(gallery/3_1.jpg)[function copy] : failed to open stream:No such file or directory in /home/*****/public_html/gallery_user.php on line 80

 

I was just pointing out the different code that followed the loading of a different image.

 

Is it possible I have not loaded a file properly?

I think you have misplaced the code i have given you earlier.

 

It should read:

$target_path = $target_path . $customer_id."_".$n.".jpg"; 
echo 'FOR TESTING ONLY'.$file['tmp_name'][$key]."<br>".$target_path;
if(copy($file['tmp_name'][$key], $target_path)) {

 

and not:

echo 'FOR TESTING ONLY'.$file['tmp_name'][$key]."<br>".$target_path;
$target_path = $target_path . $customer_id."_".$n.".jpg"; 
if(copy($file['tmp_name'][$key], $target_path)) {


Matthias Thoen

my contribution: Photo Gallery for osCommerce

--check my homepage in my CARD--

Share this post


Link to post
Share on other sites
I think you have misplaced the code i have given you earlier.

 

It should read:

$target_path = $target_path . $customer_id."_".$n.".jpg"; 
echo 'FOR TESTING ONLY'.$file['tmp_name'][$key]."<br>".$target_path;
if(copy($file['tmp_name'][$key], $target_path)) {

 

and not:

echo 'FOR TESTING ONLY'.$file['tmp_name'][$key]."<br>".$target_path;
$target_path = $target_path . $customer_id."_".$n.".jpg"; 
if(copy($file['tmp_name'][$key], $target_path)) {

 

 

Sorry, I have know enetred code on correct line it now reads

 

FOR TESTING ONLY/tmp/phpIjROcQ

gallery/3_1.jpg

 

Warning: copy(gallery/3_1.jpg)[function.copy] :failed to open stream: No such file or directory in/home/*****/public_html/gallery_user.php on line 81

Share this post


Link to post
Share on other sites
Sorry, I have know enetred code on correct line it now reads

 

FOR TESTING ONLY/tmp/phpIjROcQ

gallery/3_1.jpg

 

Warning: copy(gallery/3_1.jpg)[function.copy] :failed to open stream: No such file or directory in/home/*****/public_html/gallery_user.php on line 81

Honestly, i have no idea. It looks like the temporary file on your server does not exist, hence it cannot be copied to the gallery folder. Maybe you should contact your hosting provider to inquire about the use of the php copy function. Maybe it is disabled i don't know.


Matthias Thoen

my contribution: Photo Gallery for osCommerce

--check my homepage in my CARD--

Share this post


Link to post
Share on other sites

Hello again.

 

Just like the user who posted here earlier, I was wondering if there was an easy way to sort the pictures by upload date?

The newest ones are currently added to the end of the page.

 

Kenny


--------------------------------------------------------------------------------------------------

Share this post


Link to post
Share on other sites
Hello again.

 

Just like the user who posted here earlier, I was wondering if there was an easy way to sort the pictures by upload date?

The newest ones are currently added to the end of the page.

 

Kenny

You can always sort the query to your likings. Sorting will be added in the future.


Matthias Thoen

my contribution: Photo Gallery for osCommerce

--check my homepage in my CARD--

Share this post


Link to post
Share on other sites

future:

*admin interface where you can set

------>amount of rows displayed per page

------>subgalleries

------>allowed file formats, file size and dimensions

------>amount of pics allowed per customer

------>allow specified customers to have more pics

 

 

Hello,

 

How to allow specified customers to have more pics? I can not find it at admin. Thanks

Share this post


Link to post
Share on other sites
Hello,

 

How to allow specified customers to have more pics? I can not find it at admin. Thanks

Please read carefully: these are future plans ;)

Edited by killerwhale65

Matthias Thoen

my contribution: Photo Gallery for osCommerce

--check my homepage in my CARD--

Share this post


Link to post
Share on other sites
Sorry. That is my fault. I am waiting the "future plans", Thanks for great works!

You are most welcome.


Matthias Thoen

my contribution: Photo Gallery for osCommerce

--check my homepage in my CARD--

Share this post


Link to post
Share on other sites

:rolleyes: Hi, great great update with 0.6 , just in admin for see the images "if you want":

find:

			echo $fotos['cID'].$fotos['pID'].' [<a href="'.tep_href_link('gallery.php', 'gID=1&selected_box=configuration&editcomment&cID='.$fotos['cID'].'&pID='.$fotos['pID']).'">edit comment</a>] [<a href="'.tep_href_link('gallery.php', 'gID=1&selected_box=configuration&delpic&cID='.$fotos['cID'].'&pID='.$fotos['pID']).'">delete picture</a>]<br>';

and add after:

// img
  $dir = "../gallery/";
  $file = $fotos['cID']."_".$fotos['pID'].".jpg";
		echo "\n".'<a id="autoload'.$fotos['cID'].$fotos['pID'].'" href="' . tep_href_link($dir.$file) . ''.$fotos['title'].'\'})">'.tep_image($dir . $file, '', 50, 50, 'hspace="5" vspace="5"').'</a><br>';		
// end img

 

if that is not clean but that goes right ;)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×