Jump to content
Sign in to follow this  
rztv

Expiration Date error

Recommended Posts

Using Authorize.net AIM Module - seems clean until confirmation page SUBMIT - then, regarless of what expiration date is entered, returns to Payment page with "Credit Card Error" !

 

The expiry date entered for the credit card is invalid.<br>Please check the date and try again.

 

 

Happens in Test and Live modes.

 

Order Confirmation page looks fine - all info properly displayed - including "valid" expiration date.

 

Click SUBMIT and error show up.

 

Any ideas?

Share this post


Link to post
Share on other sites
Hello,

 

Have you tried capturing the information sent back from Authorize.net and looking at it?

 

RookuhShay

 

Never sends info to Authorize.net. Kicks out error "Credit Card Error!

 

The expiry date entered for the credit card is invalid.<br>Please check the date and try again. "

 

has to be bad file.... cc_validation.php would be my guess, but I can't find anything wrong with it.

 

Any other ideas?

Share this post


Link to post
Share on other sites
Never sends info to Authorize.net. Kicks out error "Credit Card Error!

 

The expiry date entered for the credit card is invalid.<br>Please check the date and try again. "

 

has to be bad file.... cc_validation.php would be my guess, but I can't find anything wrong with it.

 

Not posting to database either.

 

Any other ideas?

Share this post


Link to post
Share on other sites

Try uninstalling the module from Oscommerce. Download the original authorizenet_cc_aim.php when you first installed Oscommerce overwriting the authorizenet_cc_aim.php on the server and reinstalled it.

 

I ran into a simular situation, this cured it.

 

RookuhShay

Share this post


Link to post
Share on other sites
Try uninstalling the module from Oscommerce. Download the original authorizenet_cc_aim.php when you first installed Oscommerce overwriting the authorizenet_cc_aim.php on the server and reinstalled it.

 

I ran into a simular situation, this cured it.

 

RookuhShay

That didn't do it. removed that file and replaced all edited files with originals. Then re-installed and same issue. CC.php works - doesn't return error, but athorizenet_cc_aim.php does. Have compared files, can't see where issue is.

 

I think it has to be in checkout_process.php If I read this code right, that's where it validates cc_expires, and then passes along to next process.

 

If you have any other idea, please let me know.

 

All this stems from cc.php not storing expiration date in database. Used to work and encrypted date, but not in latest version of cc.php.

 

Thanks,

RZ

Share this post


Link to post
Share on other sites

I have been having the same problem with the Authorize.net AIM module only. Client needs this to capture CVV code. Did you find a fix?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×