Jump to content
Sign in to follow this  
gcupat

Really need help getting Autorize.net working

Recommended Posts

Hi all, I am totally at a loss here and I just do not know WHAT I am doing wrong -- ANY help would be SO appreciated.

 

I am trying to get Authorize dot net to work. In the administration area under payment modules:

 

--- I enabled Authorized dot net

--- put in the log in ID

--- transaction key inputted

--- MD5 Hash info

--- have the transaction server set to Test

--- Transaction mode to Test

--- Transaction Method to Authorize

--- Payment zone to --none--

--- Set order Status to 0

--- and the cURL to /usr/local/bin/curl (although I have to admit that I am really not sure if this is right, we are hosting on Lunarpages)

 

I am not sure if there is anything ELSE I have to do, but obviously I do because this is SO not working.

 

Please, if anyone has any suggestions. I would so be appreciative.

 

Thanks in advance!

Share this post


Link to post
Share on other sites
Hi all, I am totally at a loss here and I just do not know WHAT I am doing wrong -- ANY help would be SO appreciated.

 

I am trying to get Authorize dot net to work. In the administration area under payment modules:

 

--- I enabled Authorized dot net

--- put in the log in ID

--- transaction key inputted

--- MD5 Hash info

--- have the transaction server set to Test

--- Transaction mode to Test

--- Transaction Method to Authorize

--- Payment zone to --none--

--- Set order Status to 0

--- and the cURL to /usr/local/bin/curl (although I have to admit that I am really not sure if this is right, we are hosting on Lunarpages)

 

I am not sure if there is anything ELSE I have to do, but obviously I do because this is SO not working.

 

Please, if anyone has any suggestions. I would so be appreciative.

 

Thanks in advance!

Share this post


Link to post
Share on other sites

Hi gcupat,

 

I am also having the same problems as you are. The only difference is that I haven't been able to figure out where to get the MD5 info to put into os commerce; also, I have my zone set to the zone that authorize.net required, and I think my curl doesn't have local in it. Still, it doesn't work. I have it enabled, but it's just not seeing it, because I also take checks, and that's the only choice it comes up with. I also copied the authorize.net aim file from the includes area to the ext payment module, but that also isn't helping. There were about 4 others payment modules there, so I thought it just needed adding to activate it. Authorize . net is no help.

 

I would also appreciate any suggestions.......

sarasotaguy

Share this post


Link to post
Share on other sites
Remove it if you are using the one that came preloaded. download and install this one. http://addons.oscommerce.com/info/4091 Use the one dated 14 Aug. 2008

 

Hi Scott,

I deleted my older version of authorize.net's aim module, and was able to get both the money order/check and credit card modules to show on my site under test. The check module works and sends me an email when I test with it. The credit card module is not working, and doesn't send me any type of email. I've worked with authorize.net and they tried setting my site to live, changing the transaction number, etc, and even doing a transaction from there, but it didn't get through to them. In either test or live mode, when I input either the test cc acct numbers or my own real one, I get a message in a red bar stating:

"-your credit card could not be authorized for this reason (but it doesn't give me a reason anywhere). Please correct any information and try again or contact us for further assistance."

 

I went into the php code with authorize.net to see if the curl was set properly; it was for the live setting, but not for the test setting, which authorize.net said really should be set the same as the live setting, even while testing. I corrected it, but it still doesn't change anything. I have asked authorize.net developer support to respond back, but haven't heard from them yet.

 

Do you have any suggestions why my testing isn't working? Also, when I input the discover 6011 or the decline 4222 cc numbers, I get a message that the first 4 digits of these cards are not accepted for that type of credit card.

 

Thanks, Mike

sarasota guy

Share this post


Link to post
Share on other sites

Hello,

 

I am suggesting that you capture the payment string sent back from authorize.net.

 

How to do this:

 

Right after this lines:

 

$transaction_response = $this->sendTransactionToGateway($gateway_url, $post_string);

 

 

if (!empty($transaction_response)) {

$regs = preg_split("/,(?=(?:[^\"]*\"[^\"]*\")*(?![^\"]*\"))/", $transaction_response);

 

Add this script:

 

// begin logging of post variables, authorize.net request, and authorize.net response

 

$myFile = "/home/your-path/file.txt";

$fh = fopen($myFile, 'a') or die("can't open file");

$stringData = "\nSENT: ".$post_string;

fwrite($fh, $stringData);

$stringData = "\nRESPONSE: ".$transaction_response;

fwrite($fh, $stringData);

foreach($HTTP_POST_VARS as $key => $value) {

$stringData = "\nPOST: $key=$value";

fwrite($fh, $stringData);

}

fwrite($fh, "\nDone.\n");

fclose($fh);

 

// end logging

 

IMPORTANT!!!

 

In this line...

 

$myFile = "/home/your-path/file.txt";

 

make sure that you put the correct path. The WHOLE path...NOT JUST "www.mysite.com/catalog..." Its got to include the server path.

 

You can find this information pretty much all over your site, but a quick dirty way to find this path, would be on the admin side. Log into your oscommerce administration and on the left side click:

 

Tools > File Manager

 

Up at the top under the heading "File Manager" you will see your full path. While you are in the file manager, create a new file in the path in which you want to store your logs called "file.txt". Use this path to the file. I recommend adding a few folders to try and hide the info a bit.

 

Once you read the file, if you still need it, copy and past it to your local machine, but DO NOT under any circumstances, leave this info on your live server. That is a hackers paradise.

 

DO NOT LEAVE IT THERE! DELETE IT IMMEDIATELY!

 

Best,

 

RookuhShay

Share this post


Link to post
Share on other sites
Hi gcupat,

 

I am also having the same problems as you are. The only difference is that I haven't been able to figure out where to get the MD5 info to put into os commerce; also, I have my zone set to the zone that authorize.net required, and I think my curl doesn't have local in it. Still, it doesn't work. I have it enabled, but it's just not seeing it, because I also take checks, and that's the only choice it comes up with. I also copied the authorize.net aim file from the includes area to the ext payment module, but that also isn't helping. There were about 4 others payment modules there, so I thought it just needed adding to activate it. Authorize . net is no help.

 

I would also appreciate any suggestions.......

sarasotaguy

 

Mike,

 

You generate the MD5 hash number and it adds an extra layer of security with API and Transaction.

 

However, it is optional, though recommended, but WOULD NOT keep the payment gateway from functioning correctly.

 

I have just started with the default AIM module and am also repeating all the issues you guys are having.

 

Cordially,

Hank

Share this post


Link to post
Share on other sites
Hi all, I am totally at a loss here and I just do not know WHAT I am doing wrong -- ANY help would be SO appreciated.

 

I am trying to get Authorize dot net to work. In the administration area under payment modules:

 

--- I enabled Authorized dot net

--- put in the log in ID

--- transaction key inputted

--- MD5 Hash info

--- have the transaction server set to Test

--- Transaction mode to Test

--- Transaction Method to Authorize

--- Payment zone to --none--

--- Set order Status to 0

--- and the cURL to /usr/local/bin/curl (although I have to admit that I am really not sure if this is right, we are hosting on Lunarpages)

 

I am not sure if there is anything ELSE I have to do, but obviously I do because this is SO not working.

 

Please, if anyone has any suggestions. I would so be appreciative.

 

Thanks in advance!

 

 

My hosting is Lunarpages and they have given me three paths for the cURL

 

 

/usr/bin/curl

 

/usr/include/curl

 

/usr/share/curl

 

 

They say the one to use depends on A.net's requirement.

 

I cannot find anything on the A.net site about the path they require.

 

 

Anyone know?

 

Cordially,

hwkd

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×