Jump to content
Latest News: (loading..)
lildog

Manual Order Maker

Recommended Posts

BUMP

 

Any help still appreciated on this subject. When I create a new order all of the fields are populated correctly but when I click save, the fields are not filled in the edit order section. An existing order is filled correctly when editing it.

Regards Andy

ASE Awards

Share this post


Link to post
Share on other sites

Hi I am sorry if these are dumb questions but a) will manual order entry work on osCommerce Online Merchant v2.3.1 and B) can anyone spare the time to give me a brief guide to installing it along with Order Editor?

Thank you.

 

Howard

Share this post


Link to post
Share on other sites

I have been using this add on for quite a while now. I really do like it, but I have been having a minor issue since day one, that I did ask in here earlier, but still have not fixed the problem. It isn't a big issue just is time consuming. I installed everything step by step (or atleast I thought I did) but when I choose the customer from the drop down list in create_order.php and hit save, the customer information does not populate on the edit_orders.php page. Just blank fields, which I have to manually enter the customer info into the fields to continue. If anyone could help me, I would greatly appreciate it!

Share this post


Link to post
Share on other sites

Hello, on the create_order.php page, I select an existing customer from the pull down menu and it logs me out of admin. When I re-login, the information for the customer that I chose is filled in. Can you tell me how to fix whatever is logging me out. This is the section of code I am referring to in create_order.php

 

<?php if ($customer_count > 0){ ?>
                 <tr>
                   <td class="main" valign="top"><input name="handle_customer" id="existing_customer" value="existing" type="radio" checked="checked" onClick="selectExisting();" /></td>
                   <td class="main" valign="top"><label for="existing_customer" style="cursor:pointer;"><?php echo CREATE_ORDER_TEXT_EXISTING_CUST; ?></label></td>
                 </tr>
                 <tr>
                   <td class="main" valign="top"></td>
                   <td class="main" valign="top">
                   <?php
                   echo "<form action=\"$PHP_SELF\" method=\"GET\" name=\"cust_select\" id=\"cust_select\">\n";
                   echo tep_hide_session_id();
                   echo "<table border=\"0\" cellspacing=\"0\" cellpadding=\"0\">\n";
                   echo "<tr>\n";
                   echo "<td>$SelectCustomerBox</td>\n";
                   echo "<td> <input type=\"submit\" value=\"" . BUTTON_SUBMIT . "\" name=\"cust_select_button\" id=\"cust_select_button\"></td>\n";
                   echo "</tr>\n";
                   echo "</table>\n";
                   echo "</form>\n";
                   ?>	

Edited by steffanih

Share this post


Link to post
Share on other sites

Hi guys,

I was looking forward into using this contrib, however I´m stuck with this error upon opening the create_order.php:

 

Existing Customer Account

Fatal error: Call to undefined function tep_hide_session_id() in/hermes/webxxx/bxxx/pow.x/htdocs/store/admin/create_order.phpon line 171

 

 

I managed to sort out the error by removing all three instances of tep_hide_session_id(); but I´m sure that is not the correct workaround for this..

 

Thanks for any comments! I´m using OsC 2.2MS2

Edited by cszita

Share this post


Link to post
Share on other sites

can any one help

i can choose the customer then when i click save i get

 

Warning: require_once(includes/functions/password_funcs.php) [function.require-once]: failed to open stream: No such file or directory in /home/XXX/public_html/shopping/admin/create_order_process.php on line 14

 

Fatal error: require_once() [function.require]: Failed opening required 'includes/functions/password_funcs.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/XXX/public_html/shopping/admin/create_order_process.php on line 14

 

 

please any help would be appreciated

Hi mafiouso, have you been able to fix this? I'm having the same problem, and I couldn't find a solution in any replies

If anyone could help, that would be grand! :D

 

Cheers, Curt.

Edited by croth

Share this post


Link to post
Share on other sites

Fixed! the password_funcs.php wasn't in the admin/includes/functions/ only in includes/functions/ so I placed it also in admin/includes/functions/

Edited by croth

Share this post


Link to post
Share on other sites

Hello,

 

i installed order maker and it worked.

 

butt when i want to add a product an fill in the searchbox, it does not filter.

I get the whole list of products.

 

has anybody an idea how to solve this?

 

Thank you

 

regards

 

Twindaddy

Share this post


Link to post
Share on other sites

I installed this contribution after Order Editor and had a similar problem to a number of others. Upon creating a customer or selecting an existing customer and clicking on "Save" on the create_order.php page I would be taken to the create_order_process.php page which was blank.

 

The fix in my case was to copy the password_funcs.php page from includes/functions/ to admin/includes/functions/

 

All works!


You will never learn if you don't try. And boy am I trying....!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×