Latest News: (loading..)
lildog

Manual Order Maker

184 posts in this topic

This contribution is to create a new order in the admin section of osCommerce. You also need to have order editor installed.

Edited by lildog

Share this post


Link to post
Share on other sites

I uploaded a newer version that has collect res/commercial compatibility file and cleaned up a file. This is in prep to update this contrib.

 

lildog

Share this post


Link to post
Share on other sites

Hi lildog,

 

I wondered if it is possible/or if this contribution can already, choose from a number of addresses for a customer? For example store a shipping address and a billing address when creating a customers account and then have the possibility to choose from either when creating the order?

 

Thanks

 

Dave

Share this post


Link to post
Share on other sites

Morning lildog.

 

I've installed your wonderful contribution but, for some reason, the 'Select a client' drop down does not populate with my list of clients?

 

Any thought?

Regards, Edward

Share this post


Link to post
Share on other sites

I've got the same problem - no customers in the dropdown menu. Also, at the bottom of the page I get this:

 

Confirm client details:

 

Warning: require(includes/modules/create_order_details.php) [function.require]: failed to open stream: No such file or directory in /home/harvesto/public_html/cart/admin/create_order.php on line 131

 

Fatal error: require() [function.require]: Failed opening required 'includes/modules/create_order_details.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/harvesto/public_html/cart/admin/create_order.php on line 131

 

If I type in a client ID and hit "Confirm" the page returns to Step 1 and I still see nothing.

 

Please advise as soon as possible!

Thanks for a great contribution!

Edited by Quiet City

Share this post


Link to post
Share on other sites

you are missing a file: includes/modules/create_order_details.php

 

 

lildog

 

I've got the same problem - no customers in the dropdown menu. Also, at the bottom of the page I get this:

 

Confirm client details:

 

Warning: require(includes/modules/create_order_details.php) [function.require]: failed to open stream: No such file or directory in /home/harvesto/public_html/cart/admin/create_order.php on line 131

 

Fatal error: require() [function.require]: Failed opening required 'includes/modules/create_order_details.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/harvesto/public_html/cart/admin/create_order.php on line 131

 

If I type in a client ID and hit "Confirm" the page returns to Step 1 and I still see nothing.

 

Please advise as soon as possible!

Thanks for a great contribution!

Share this post


Link to post
Share on other sites

it does not now but is very possible. I think it is a viable idea and try to work it in.

 

 

lildog

 

Hi lildog,

 

I wondered if it is possible/or if this contribution can already, choose from a number of addresses for a customer? For example store a shipping address and a billing address when creating a customers account and then have the possibility to choose from either when creating the order?

 

Thanks

 

Dave

Share this post


Link to post
Share on other sites

I will check it out.

 

lildog

 

Morning lildog.

 

I've installed your wonderful contribution but, for some reason, the 'Select a client' drop down does not populate with my list of clients?

 

Any thought?

Regards, Edward

Share this post


Link to post
Share on other sites

It has been so long since I did this. I believe I used the code from step by step but updated it. So basically it is the same.

 

lildog

 

How does this compare with the Step-By-Step Manual Order Entry contribution? Have you any screen shots?

Share this post


Link to post
Share on other sites
you are missing a file: includes/modules/create_order_details.php

 

 

lildog

 

 

AH! The one in the /Admin/ directory... I missed it on the FTP upload. Thanks very much!

Share this post


Link to post
Share on other sites

Thanks for helping me get the Order Entry module going, but I have a little problem with completing the order information. When I've either created a customer ID or selected an existing one, and proceed to the "edit order" page, a portion of the Billing Address panel disappears when the page finishes loading. The portion of the panel is the Credit Card information under the Payment Method dropdown. I see it as the page loads, but then it becomes hidden, and I can't get it back to input the credit card information.

 

Also, a minor thing: When I click the button to "Add a product" and the smaller window opens, there's not activation button or link to proceed. The first step drop down menu shows "All Products..." but doesn't load the items I'm trying to select. However, I discovered by trial that I could type a search word and press "enter" to activate the search and proceed to the next step. Is there something missing on the page to make it either clearer or intuitive for my client who will be managing this system?

 

Thanks for any help you can offer!

Share this post


Link to post
Share on other sites
it does not now but is very possible. I think it is a viable idea and try to work it in.

 

Hi lildog,

 

great news I'm looking forward to it :)

Share this post


Link to post
Share on other sites

Hi Edward,

 

Try to change aroud line 29:

 

FIND:

 

$SelectCustomerBox .= "</select>\n";

 

 

CHANGE:

 

$SelectCustomerBox .= ">" . $db_Row["customers_lastname"] . ", " . $db_Row["customers_firstname"] . "</option>\n";

 

If you have some problems ... post again ;)

Share this post


Link to post
Share on other sites
Hi Edward,

 

Try to change aroud line 29:

 

FIND:

 

$SelectCustomerBox .= "</select>\n";

 

 

CHANGE:

 

$SelectCustomerBox .= ">" . $db_Row["customers_lastname"] . ", " . $db_Row["customers_firstname"] . "</option>\n";

 

If you have some problems ... post again ;)

 

This worked perfectly. Thank you!

Share this post


Link to post
Share on other sites

aureliosilva and floorjunkies,

Is this a coding error in the contrib? Does this need to be added in?

 

Thanks,

lildog

Share this post


Link to post
Share on other sites

Hello

 

Although order editor is required for this contribution I have installed AJAX order editor - will this contribution work with the AJAX install?

 

If no - can anyone please recommend an altrnative to Manual Order Maker?

 

Many Thanks

 

TMM

Edited by themilkman

Share this post


Link to post
Share on other sites
Hello

 

Although order editor is required for this contribution I have installed AJAX order editor - will this contribution work with the AJAX install?

 

If no - can anyone please recommend an altrnative to Manual Order Maker?

 

Many Thanks

 

TMM

Would have thought that the support forum for AJAX order editor would be the place to ask.

Share this post


Link to post
Share on other sites

Yes it will. All order maker does is create the order. Then order editor edits that order. These two contribs were all one sometime ago, at some point the order creation part was dropped and I picked it up and turned it into a contrib. That is why order editor is required also, although I don't remember exactly, they both share some code.

 

lildog

 

 

 

 

Would have thought that the support forum for AJAX order editor would be the place to ask.

Share this post


Link to post
Share on other sites
Yes it will. All order maker does is create the order. Then order editor edits that order. These two contribs were all one sometime ago, at some point the order creation part was dropped and I picked it up and turned it into a contrib. That is why order editor is required also, although I don't remember exactly, they both share some code.

 

lildog

 

Hi Lildog

 

Okay I have installed you contribution Manual Order Maker 1.4.4 and am using AJAX order editor

 

Just got a couple of issues.

 

 

 

1. I have noticed that when the customers details are shown the conutry is not automatically selected in the drop down, this is no good as I will have to ask the customer where they are from even though they have set up an account with the country of residence.

 

2. After selecting a client and then verifying the customer by click confirm I am shown a 404 error for the page admin/create_order_process.php - however if I navigate back to Order I see the order for the customer has been made. How do I get rid of this issue of being shown a 404 page to make the process more user friendly?

 

3. Lastly is the billing telephone and shipping telephone number suppose to be populated in the blank order form?

 

4. In the field below the drop down to select a clicnt, client ID, how would any one know what their client id is?

 

Thank You

 

TMM

Edited by themilkman

Share this post


Link to post
Share on other sites

Hey,

 

I have two issues:

 

1) Customers that have been added manually cannot be found when searching for customers' names in the Admin => Customers section

2) A standard value for creating customers seems to be gender=female. That way, when importing customers' data and orders with my warehouse software, it always says "Mrs" on the invoices.

 

Is there a way to fix that?

 

B. regards

Share this post


Link to post
Share on other sites

I am going to go through this contrib and try to sort out a couple of bugs and make it a little nicer to use. Be patient and keep putting your concerns up here, so they can be looked to.

 

lildog

Share this post


Link to post
Share on other sites

Ok here's the deal with this and Step-By-Step Manual Order Entry. I believe Manual order maker and order editor were both together as Step-By-Step Manual Order Entry. Somewhere along the line Order editor was started and I salvaged the 'other half' of the code and turned it into this contrib. That is why order editor is required also.

 

lildog

 

It has been so long since I did this. I believe I used the code from step by step but updated it. So basically it is the same.

 

lildog

Share this post


Link to post
Share on other sites

UPDATE: I stand to be corrected. Order Editor seems to work as it should when adding an item to an order. However when adding an item to an order just made with this contrib, the drop down doesn't work as advertised. I will fix it.

 

1.

Thanks for helping me get the Order Entry module going, but I have a little problem with completing the order information. When I've either created a customer ID or selected an existing one, and proceed to the "edit order" page, a portion of the Billing Address panel disappears when the page finishes loading. The portion of the panel is the Credit Card information under the Payment Method dropdown. I see it as the page loads, but then it becomes hidden, and I can't get it back to input the credit card information.

 

The edit page is not actually part of this contrib...that would be Order editor, I think. MOUSE OVER THE LITTLE i BUTTON after Payment method, there is some configuring that can be done. Looks like it is working like it is supposed to

 

 

2.

Also, a minor thing: When I click the button to "Add a product" and the smaller window opens, there's not activation button or link to proceed. The first step drop down menu shows "All Products..." but doesn't load the items I'm trying to select. However, I discovered by trial that I could type a search word and press "enter" to activate the search and proceed to the next step. Is there something missing on the page to make it either clearer or intuitive for my client who will be managing this system?

 

Also an order editor question. I am also having the same problem, though. when I figure it out I will let you know.

 

lildog

Edited by lildog

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now