Jump to content
Sign in to follow this  
rapetet

Help! I'm running Sppc v421 and was getting several differant errors!

Recommended Posts

First, the login pages didn't like my catalog being set up in any place other than //mysire,com/catalog/

 

I fixed that problem by doing a new install of oscommerce

 

now everything was working except when I logged in to test the group checkout now I get an error that reads

 

1146 - Table 'mydatabase.TABLE_CUSTOMERS_GROUPS' doesn't exist

 

select IF(c.customers_payment_allowed <> '', c.customers_payment_allowed, cg.group_payment_allowed) as payment_allowed from customers c, TABLE_CUSTOMERS_GROUPS cg where c.customers_id = '4' and cg.customers_group_id = '0'

 

[TEP STOP]

 

What the hell is wrong!!!

Share this post


Link to post
Share on other sites

Hi Rapetet !

 

 

1146 - Table 'mydatabase.TABLE_CUSTOMERS_GROUPS' doesn't exist

 

select IF(c.customers_payment_allowed <> '', c.customers_payment_allowed, cg.group_payment_allowed) as payment_allowed from customers c, TABLE_CUSTOMERS_GROUPS cg where c.customers_id = '4' and cg.customers_group_id = '0'

 

What the hell is wrong!!!

 

i suggest you to have a look in your filename.php files and database_table.php files on both side... you're probaly missing some lines to complete your

modifications: check !

 

hummmmm.... if you've got an idea, every thing seems to run well on my side (well ?) but my customers transfered to their "new" customer group can't be more than 2 in it !!!!! it doesn't match for more....

any reason ?

 

best regards,

Thierry. B)


Thanks to the whole osCommerce Community.

Prod Server: Percona Server via UNIX socket Percona Server version: 5.5.40-36.1-log - Percona Server (GPL), Release 36.1, Revision 707
 phpMyAdmin 3.5.8.2 Database version: libmysql - 5.0.96 PHP extension: mysqli
version Oscommerce-RC2A php 5.3 with many add-ons/up-dates ...... and liters of coffee !
Local dev: EasyPHP DevServer 14.1 VC9  "Minakami"  avec oscom 2.3.1 + Them switcher, Grid system et css 24 col 1280 px width, KissIT_image thumbnailer, lightbox,  Invoice editor, Superfish horizontal navbar, Quick inventory, margin report, PWA (purshase without account), Products field groups, Products Extra fields Footer boxes... modified to my personnal needs....

Share this post


Link to post
Share on other sites
Hi Rapetet !

 

 

 

 

i suggest you to have a look in your filename.php files and database_table.php files on both side... you're probaly missing some lines to complete your

modifications: check !

 

hummmmm.... if you've got an idea, every thing seems to run well on my side (well ?) but my customers transfered to their "new" customer group can't be more than 2 in it !!!!! it doesn't match for more....

any reason ?

 

best regards,

Thierry. B)

Thank you but I figured out how to make it work.

 

step1: I performed a fresh install of oscommerse

 

step2: I performed a fresh install of Seperate Pricing Per Customer version 4.21

 

that was it, now it runs perfectly. :lol:

Share this post


Link to post
Share on other sites

I found that if you are planning to use the SPPC contribution, that it is best to make it the FIRST installation before all other contributions. Adding it after the store has had other changes, is..........well, REALLY difficult. I am glad you have it workin as it is an exceptional modification.

 

 

Chris


:|: Was this post helpful ? Click the LIKE THIS button :|:

 

See my Profile to learn more about add ons, templates, support plans and custom coding (click here)

Share this post


Link to post
Share on other sites

good morn',

 

well, i agree with you chris but my site is on production since beg of this year and i did'nt plan till a few weeks ago to add such modification !!!

anyway, i've got to make it work (even if i started localy a new one throught a W3C last version...).

i'm gonna digg here in the forum and i'll find it : 2 customers per group , it's really a few.... don't you think ?! :lol:

 

Thierry.


Thanks to the whole osCommerce Community.

Prod Server: Percona Server via UNIX socket Percona Server version: 5.5.40-36.1-log - Percona Server (GPL), Release 36.1, Revision 707
 phpMyAdmin 3.5.8.2 Database version: libmysql - 5.0.96 PHP extension: mysqli
version Oscommerce-RC2A php 5.3 with many add-ons/up-dates ...... and liters of coffee !
Local dev: EasyPHP DevServer 14.1 VC9  "Minakami"  avec oscom 2.3.1 + Them switcher, Grid system et css 24 col 1280 px width, KissIT_image thumbnailer, lightbox,  Invoice editor, Superfish horizontal navbar, Quick inventory, margin report, PWA (purshase without account), Products field groups, Products Extra fields Footer boxes... modified to my personnal needs....

Share this post


Link to post
Share on other sites
i'm gonna digg here in the forum and i'll find it : 2 customers per group , it's really a few.... don't you think ?!

Ridiculous error. Never, ever heard someone getting that error (which particular error, where he gets it, exact error message etcetera is not communicated with us, so we are supposed to rely on our crystal balls...).

 

No point searching for it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×