Jump to content
Sign in to follow this  
ComArge

Cool Flash Carousel Menu

Recommended Posts

Hello,

 

I'm installing the Carousel to my life shop, and i get the following error:

"ssl_rx_record_too_long"

 

I get this error when i want to login to the shop, when you go from http to https.

 

How do i solf this problem? in my test shop where i have no SSL it is wordking pefect.

 

Maybe i have looked it over in the forum but i think i can't be the only one, or ....

 

regards,

Jan


Dreams can come true, if you help them a littlebit

Share this post


Link to post
Share on other sites
Hello,

 

I'm installing the Carousel to my life shop, and i get the following error:

"ssl_rx_record_too_long"

 

I get this error when i want to login to the shop, when you go from http to https.

 

How do i solf this problem? in my test shop where i have no SSL it is wordking pefect.

 

Maybe i have looked it over in the forum but i think i can't be the only one, or ....

 

regards,

Jan

The login page loaded OK for me using IE7 and the latest version of Firefox.

 

But you should look at the SSL side of your site with IE.

 

You've got almost a dozen things causing "nonsecure items" popup when viewing with IE.

:o


If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Share this post


Link to post
Share on other sites
The login page loaded OK for me using IE7 and the latest version of Firefox.

 

But you should look at the SSL side of your site with IE.

 

You've got almost a dozen things causing "nonsecure items" popup when viewing with IE.

:o

 

Hi Jim,

 

Thanks for your reaction.

 

I know, i have a lot of tools/advertisments and so on, that i use random.

But when you answer "no" they are not loading ofcourse. so thats not a real problem ant they are harmless.

 

It works correct now because i use the old config.php, and than there are no problems.

It is only when i put the new config.php online with the adjustments fron the flash carousel.

And then nothing works when you are transpoted to the SSL connection.

A blanc screen with the message is all

Edited by jan64

Dreams can come true, if you help them a littlebit

Share this post


Link to post
Share on other sites

Hi every body. I have a problem with FLASH CAROUSEL 3 . My problem is it " Warning: fopen(home/a5953042/public_html/kampanya/kampanya.xml) [function.fopen]: failed to open stream: No such file or directory in /home/a5953042/public_html/includes/functions/flash_carousel.php on line 36 "

PLS for HELP !

I check directory " KAMPANYA " , CHMOD 777

Share this post


Link to post
Share on other sites
Hi Jim,

 

Thanks for your reaction.

 

I know, i have a lot of tools/advertisments and so on, that i use random.

But when you answer "no" they are not loading ofcourse. so thats not a real problem ant they are harmless.

 

It works correct now because i use the old config.php, and than there are no problems.

It is only when i put the new config.php online with the adjustments fron the flash carousel.

And then nothing works when you are transpoted to the SSL connection.

A blanc screen with the message is all

 

Is it possible to edit the config.php like below?

 

Add to the top in config.php:

$dom_name = $_SERVER["SERVER_NAME"];

 

//define('HTTP_SERVER', 'http://www.my-current-domain-name.com');

define('HTTPS_SERVER', 'https://www.my-current-domain-name.com');

//define('HTTP_COOKIE_DOMAIN', 'www.my-current-domain-name.com');

define('HTTPS_COOKIE_DOMAIN', 'www.my-current-domain-name.com');

 

define('HTTP_SERVER', 'http://' . $dom_name);

//define('HTTPS_SERVER', 'https://' . $dom_name);

define('HTTP_COOKIE_DOMAIN', $dom_name);

//define('HTTPS_COOKIE_DOMAIN', $dom_name);

 

The // are mine adjustments.

 

Is there somebody who knows of SSL keeps on working correct?

 

Sorry but i don't know much about this important lines in a config file.


Dreams can come true, if you help them a littlebit

Share this post


Link to post
Share on other sites

Hi All!

 

I looked through the thread but didn't see - Does this work in 2.2ms2? Does it require some special changes?

 

Thanks so much! It looks GREAT!

 

:D

Share this post


Link to post
Share on other sites

Hello everyone,

 

Many thanks for this interesting looking contrib. I am getting it installed, thanks to the instructions. I did not complete step 16, don't think it's necessary in my case (am I wrong?).

 

My problem is now either:

 

Warning: fopen(/mnt/xxx/xxx/xxx/xxx/www/shop/catalogkampanya/kampanya.xml) [function.fopen]: failed to open stream: No such file or directory in /mnt/xxx/xx/xx/xx/www/shop/catalog/includes/functions/flash_carousel.php on line 36

 

Which I worked through by changing the "Flash Carousel xml/image Store Directory" in admin from "kampanya" to "/kampanya" (I know this is probably the wrong way, but am just experimenting).

..when I've done this I get the error:

 

Warning: main(/kampanya/style_2/medium/configuration.php) [function.main]: failed to open stream: No such file or directory in /mnt/xxx/xxx/xxx/xxx/www/shop/catalog/includes/modules/flash_carousel.php on line 15

 

Warning: main() [function.include]: Failed opening '/kampanya/style_2/medium/configuration.php' for inclusion (include_path='.:/usr/local/nf/lib/php') in /mnt/xxx/xxx/xxx/xxx/www/shop/catalog/includes/modules/flash_carousel.php on line 15

 

Can anyone suggest where to look for a solution or what's wrong exactly?

I have modified my configure.php files to include "www." before the domain names.

I corrected "lenght" typos.

I find the kampanya xml file generated, but contains no products.

Same problem if logged in as customer, or just visiting

 

Current problems visible here

 

Thanks for your help!!

Matt

Share this post


Link to post
Share on other sites
Hello everyone,

 

Many thanks for this interesting looking contrib. I am getting it installed, thanks to the instructions. I did not complete step 16, don't think it's necessary in my case (am I wrong?).

 

My problem is now either:

 

 

 

Which I worked through by changing the "Flash Carousel xml/image Store Directory" in admin from "kampanya" to "/kampanya" (I know this is probably the wrong way, but am just experimenting).

..when I've done this I get the error:

 

 

 

Can anyone suggest where to look for a solution or what's wrong exactly?

I have modified my configure.php files to include "www." before the domain names.

I corrected "lenght" typos.

I find the kampanya xml file generated, but contains no products.

Same problem if logged in as customer, or just visiting

 

Current problems visible here

 

Thanks for your help!!

Matt

 

 

Your path is not correct:

308/d35/s40/b01a9a05/www/shop/catalogkampanya/kampanya.xml)

The slash is missing in your path, between catalog and kampanya

see the error in your shop

Edited by jan64

Dreams can come true, if you help them a littlebit

Share this post


Link to post
Share on other sites
The slash is missing in your path, between catalog and kampanya

see the error in your shop

 

In which file can I change this? When I change it in the admin by adding / before kampanya...I get the other error I mentioned in my post...

Edited by whpash

Share this post


Link to post
Share on other sites

okay.. i installed it, made the SQL tables.. uploaded the files. replaced the codes.. activated it from the admin panel, choosed products.. everything, yet, i cant find it anywhere on the page :S

 

http://shop.icustomyze.com

Share this post


Link to post
Share on other sites
In which file can I change this? When I change it in the admin by adding / before kampanya...I get the other error I mentioned in my post...

 

So, assuming I am doing the right way...I added / before kampanya in Flash carousel image xml directory configuration in osc admin... so now the path is correct.

 

My error is now:

Warning: main(/kampanya/style_2/medium/configuration.php) [function.main]: failed to open stream: No such file or directory in /mnt/w0308/d35/s40/b01a9a05/www/shop/catalog/includes/modules/flash_carousel.php on line 15

 

Warning: main() [function.include]: Failed opening '/kampanya/style_2/medium/configuration.php' for inclusion (include_path='.:/usr/local/nf/lib/php') in /mnt/w0308/d35/s40/b01a9a05/www/shop/catalog/includes/modules/flash_carousel.php on line 15

 

I have kampanya folder set to 777

I have tried rerunning sql query..but I get an error saying table is already created

 

I see line 15 in shop/catalog/includes/modules/flash_carousel.php is:

include(FLASH_CAROUSEL_DIRECTORY.'/'.$flash_carousel_info['0'].'/'.$flash_carousel_info['1'].'/configuration.php');

 

Can someone guide me toward what is the problem...I'm using latest FC install 3.2

 

Many thanks for your help.

Edited by whpash

Share this post


Link to post
Share on other sites

hello, I'd like to thank the author for this great contribution and I'd also like your help about a couple of things.

 

I installed the latest version of Flash Carousel and it worked perfectly fine out of the box. However I have 2 problems.

 

Some products are in a different language than english (ie. greek, using utf-8 in the DB and everywhere else) and their name doesnt show on the flash carousel. Furthermore instead of the euro sign, I only see a "€" thing. Can you help me with this please? The site being tested is http://www.t-store.gr, you can see a pen on the flash carousel and this has a name in greek that doesnt show at all.

Edited by zeppos

Share this post


Link to post
Share on other sites

Just curious why there are no install files in the contribution? Why do we have to go to another site and rummage for the install files? I'd love to add this but I am too lazy to search all over for files that should be added to the contribution. Is it me or is it silly to not have an install file included?

Share this post


Link to post
Share on other sites
Just curious why there are no install files in the contribution? Why do we have to go to another site and rummage for the install files? I'd love to add this but I am too lazy to search all over for files that should be added to the contribution. Is it me or is it silly to not have an install file included?

 

I just updated some install intructions according to users feedbacks. That is the reason and also want to show you my development site. Maybe you can add some help to me.

Share this post


Link to post
Share on other sites

Ok, I have installed it and I dont see productsin the carousel. I have the next arrows and the "GO" button, just no images in the carousel. I noticed when I was uploading the "new files" that there wasnt any flash files present. I installed the 12 Apr 2009 version. I also had another little problem, I only have one instance of

 

<tr>
<td><?php include(DIR_WS_MODULES . FILENAME_NEW_PRODUCTS); ?></td>
</tr>

So i just am adding the

<tr>
<td><?php include(DIR_WS_MODULES . FILENAME_FLASH_CAROUSEL); ?></td>
</tr>

to the index.php to see if I can get it to show up.

 

as a result I am also getting this error:

Warning: Missing argument 1 for infoboxfooterbody() in /home/content/path/to/site/html/toybox/includes/classes/boxes.php on line 184

the boxes.php has this code on line 184

 

function infoBoxFooterBody($contents, $left_corner = true, $right_corner = true, $right_arrow = false) {

 

Do I need to do anything to configure the carousel's products? I thought it worked of the existing "New Products".

Thanks for any hyelp you may be able to provide

Edited by jester420247sl

Share this post


Link to post
Share on other sites

I appollogize, I get the carousel to show up now but my carousel doesnt spin on a mouse over instead I have the next arrows and the "GO" button. How do I modify it to be setup on a mouseover?

 

I am also getting this error:

Warning: Missing argument 1 for infoboxfooterbody() in /home/content/path/to/site/html/toybox/includes/classes/boxes.php on line 184

the boxes.php has this code on line 184

 

function infoBoxFooterBody($contents, $left_corner = true, $right_corner = true, $right_arrow = false) {

 

and when I click the "GO" button or the image it doesnt take me to the product page.

 

thanks in advance for any help you can provide.

Edited by jester420247sl

Share this post


Link to post
Share on other sites

OK, I got all the kinks worked out. I am curious if there is a way to add a background image behind the carousel? I have made an image that I added to its own table etc. I would much rather be able to hard code it into the carousel so that I can disable the image with the carousel in the admin console.

Thanks fo any advice you may have

Share this post


Link to post
Share on other sites

I can not install the New Style for osCommerce Flash Carousel.

How I do?

I doing download of New Style for osCommerce Flash Carousel.

I unziped Style_3 folder

I read Setup.txt.

 

Where are catalog folder on my OSCommerce?

where I save Style_3?

 

www.mydigital.com.br/shop

:blink:

Share this post


Link to post
Share on other sites
I can not install the New Style for osCommerce Flash Carousel.

How I do?

I doing download of New Style for osCommerce Flash Carousel.

I unziped Style_3 folder

I read Setup.txt.

 

Where are catalog folder on my OSCommerce?

where I save Style_3?

 

www.mydigital.com.br/shop

:blink:

Hi,

 

Copy style_3 to www.mydigital.com.br/shop/kampanya folder.

Share this post


Link to post
Share on other sites

I installed all the files for this on a new site and going by the step by step instruction from the maker. Wehn i get to install direction #15 i believe it says to edit the config file but there isn't any config file that was within the files, any help appreciated as i can get this to work yet.

 

my site was just installed as of toay so no changed were made yet except for a few categories and basic setup

Share this post


Link to post
Share on other sites

Hi,

 

I've installed the flash carousel, I get no errors, but I only get a white box?

I've been going at it for over 8 hours trying to figure out the problem on my side (it works perfectly on others sites) so the error is on my side.)

I've set the kampanya folder to 777 (folder only, not the contents).

I uploaded all files in Ascii mode.

I already configured the sql, I configured the admin/configuration/flash carousel and admin/catalog/flash carousel

 

Please help....

 

 

Regards,

 

Douglas

=========================================================

 

Below is a copy of my source code for the catalog/index.php

 

<td><!-- flash_carousel_products //-->
			  <style type="text/css" media="screen">
					body { margin:0; text-align:center; }
					div#flash_carousel_container { text-align:center; }
					object#flash_carousel { display:block; margin:0 auto; }

	</style>	
	<script type="text/javascript" src="kampanya/swfobject.js"></script>
	<script type="text/javascript">
		var flashvars = {};
		var params = {};
		params.menu = "false";
		params.wmode = "transparent";
		params.bgcolor = "#ffffff";
		params.devicefont = "true";
		var attributes = {};
		attributes.id = "flash_carousel";
		attributes.align = "middle";
		swfobject.embedSWF("http://financeportal.com/catalog/kampanya/style_3/small/kampanya.swf", "flash_carousel", "400", "180", "9.0.0", "expressInstall.swf", flashvars, params, attributes);
	</script>
<div id="flash_carousel_container">		
<div id="flash_carousel">
	<a href="http://www.adobe.com/go/getflashplayer">
		<img src="http://www.adobe.com/images/shared/download_buttons/get_flash_player.gif" alt="Get Adobe Flash player" />
	</a>
</div>
</div>
<!-- flash_carousel_products_eof //--></td>

 

And below is my catalog/kampanya/kampanya.xml source

 

<?xml version="1.0" encoding="iso-8859-1"?>
<products>
	<product image="kampanya_dvd_a_bugs_life.gif" Productname="A Bugs Life" Price="$35.99" url="http://financeportal.com/catalog/product_info.php?products_id=8" />
	<product image="kampanya_dvd_die_hard_3.gif" Productname="Die Hard With A Vengeance" Price="$39.99" url="http://financeportal.com/catalog/product_info.php?products_id=12" />
	<product image="kampanya_dvd_blade_runner.gif" Productname="Blade Runner   Directors Cut" Price="$30.00" url="http://financeportal.com/catalog/product_info.php?products_id=5" />
	<product image="kampanya_dvd_lethal_weapon.gif" Productname="Lethal Weapon" Price="$34.99" url="http://financeportal.com/catalog/product_info.php?products_id=13" />
	<product image="kampanya_dvd_beloved.gif" Productname="Beloved" Price="$54.99" url="http://financeportal.com/catalog/product_info.php?products_id=20" />
	<product image="kampanya_hewlett_packard_lj1100xi.gif" Productname="Hewlett Packard LaserJet 1100X.." Price="$499.99" url="http://financeportal.com/catalog/product_info.php?products_id=27" />
	<product image="kampanya_gt_interactive_disciples.gif" Productname="Disciples: Sacred Lands" Price="$90.00" url="http://financeportal.com/catalog/product_info.php?products_id=24" />
	<product image="kampanya_dvd_fire_down_below.gif" Productname="Fire Down Below" Price="$29.99" url="http://financeportal.com/catalog/product_info.php?products_id=11" />
</products>

Share this post


Link to post
Share on other sites

I tried this with step by step direction from maker and it doesn't work so it obviously needs other alterations which he doesn't clarify.

Share this post


Link to post
Share on other sites

Hi,

 

installed this contribution, have an issue with the resize class.

 

basically it doesn't work, when resize is switched on/off, get this error:- Notice: Undefined offset: -1 in /home/simplydr/public_html/w4/includes/classes/seo.class.php on line 1173

 

when I comment out the //require(DIR_WS_CLASSES . 'flash_carousel_image_resize.php'); in includes/modules/flash_carousel and resize is set to true I get error:-

Fatal error: Class 'imageTransform' not found in /home/simplydr/public_html/w4/inget this error includes/modules/flash_carousel.php on line 84

 

When I comment out and I have the resize set to true I get Notice: Undefined offset: -1 in /home/simplydr/public_html/w4/includes/classes/seo.class.php on line 1173

 

If I comment out the line and have the resize switched to false the carousel displays normally.

 

the error looks a lot worse though, as the sites info boxes dont work and pretty mucfh everything else doesnt either, same applies for STS mode.

 

The site is very heavily modified, but as the one file seems to destroy the entire site I suspect the problem may not be with all the other modules.

 

Hope someone can shed some light on this great module, I also saw a post earlier which was about more advanced features such as images in teh middle and as a background, example of it on the site was given as http://www.dees-fancydress.co.uk/catalog/ I tried to look at the zip file, but I suspect that the link was no longer active as the download was empty.

 

Would like to know where I can find the information to get those advanced features to work.

 

 

 

Thanks

Johnny


Getting better with mods but no programmer am I.

Share this post


Link to post
Share on other sites

hi there im a newbie.. just wandering if anybody could tell me how to locate the kampanya to load this coding for the flash carousel? im with just host.com but have choosen the oscommerce...will it be on my cpanel of just host?

 

 

thanking you in advance

 

sasha

Share this post


Link to post
Share on other sites

Somebody knows if this contribution is compatible with BTS and Ultimate SEO url . I installed the 3.2 , the carousel work fine but I got several warnings like:

-Notice: Undefined variable: _sid in /home/mhd-01/xxxxxx/htdocs/catalog/includes/classes/seo.class.php on line 761

-Notice: Undefined variable: new_products_category_id in /home/xxxx/htdocs/catalog/includes/modules/featured.php on line 20

-Notice: Use of undefined constant cfgvalue - assumed 'cfgvalue' in /home/mhd-01/xxxxx/htdocs/catalog/includes/column_right.php on line 81

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×