Jump to content
Sign in to follow this  
ComArge

Cool Flash Carousel Menu

Recommended Posts

Carousel v 3.2

OSC v2.2 rc2a

STS 4.5.8

 

Install was running good till I hit step 14.

 

"Create the database table for flash carousel products. Open database_sql folder and choose appropriate file.

For English run flash_carousel_english.sql file with sql program like phpMyAdmin."

 

The database_sql folder is empty and is also empty in the downloaded archive.

 

I am a newb, can anyone give any detail about how to run this file when I find it?

Share this post


Link to post
Share on other sites
Carousel v 3.2

OSC v2.2 rc2a

STS 4.5.8

 

Install was running good till I hit step 14.

 

"Create the database table for flash carousel products. Open database_sql folder and choose appropriate file.

For English run flash_carousel_english.sql file with sql program like phpMyAdmin."

 

The database_sql folder is empty and is also empty in the downloaded archive.

 

I am a newb, can anyone give any detail about how to run this file when I find it?

 

Hi,

I forgot the put sql files. But I publish a new version titled with osCommerce Flash Carousel 3.2 sql files.

Please use this version

Share this post


Link to post
Share on other sites
Carousel v 3.2

OSC v2.2 rc2a

STS 4.5.8

 

Install was running good till I hit step 14.

 

"Create the database table for flash carousel products. Open database_sql folder and choose appropriate file.

For English run flash_carousel_english.sql file with sql program like phpMyAdmin."

 

The database_sql folder is empty and is also empty in the downloaded archive.

 

I am a newb, can anyone give any detail about how to run this file when I find it?

Share this post


Link to post
Share on other sites
Carousel v 3.2

OSC v2.2 rc2a

STS 4.5.8

 

Install was running good till I hit step 14.

 

"Create the database table for flash carousel products. Open database_sql folder and choose appropriate file.

For English run flash_carousel_english.sql file with sql program like phpMyAdmin."

 

The database_sql folder is empty and is also empty in the downloaded archive.

 

I am a newb, can anyone give any detail about how to run this file when I find it?

 

Ok I have the sql file now, but do I import it to the store db or what? I don't see anything in phpmyadmin for running an sql file. Are there any special settings to pay attention too?

Share this post


Link to post
Share on other sites
Ok I have the sql file now, but do I import it to the store db or what? I don't see anything in phpmyadmin for running an sql file. Are there any special settings to pay attention too?

Yes, you should import sql file to your store database.

Share this post


Link to post
Share on other sites
Now demo site http://demo.oscommerce.com.tr/ has an error in Firefox only, IE looks OK

 

Fatal error: Call to a member function add_current_page() on a non-object in /home/content/g/f/t/gfthdg30sadh3f/html/demo/includes/application_top.php on line 317

I am reaaly new to this all so please bear with me. I very much would like to use the carousel. I down loaded it and copied it to my catolog folder and nothing happens. I have looked all over and really need someone to tell me what to do next Thank you

Share this post


Link to post
Share on other sites

Hi ComArge,

Thank you very much, it's wonderful that you have done so much improvements on the carousel.

It's now perfect. You are really great.

 

I have a little question about loading the carousel. I want it to be loaded after whole the page loads, so that it doesn't slow the page-load down. When I activate the carousel it takes so much time (a few seconds more) to load the page.

 

I mean, first I would like to have the page loaded, after then the carousel loads. Is that possible? I think with a few changes in index.php it's could be done. But I have no idea how to do it. I have read that it could be done with JavaScript window.onLoad function or some function like this. But I am not good at JavaScript, I don't know how to use this function to work with carousel so that it would be loaded after all the rest of the page is loaded.

 

Any idea?

Edited by deggial

Share this post


Link to post
Share on other sites
Hi ComArge,

Thank you very much, it's wonderful that you have done so much improvements on the carousel.

It's now perfect. You are really great.

 

I have a little question about loading the carousel. I want it to be loaded after whole the page loads, so that it doesn't slow the page-load down. When I activate the carousel it takes so much time (a few seconds more) to load the page.

 

I mean, first I would like to have the page loaded, after then the carousel loads. Is that possible? I think with a few changes in index.php it's could be done. But I have no idea how to do it. I have read that it could be done with JavaScript window.onLoad function or some function like this. But I am not good at JavaScript, I don't know how to use this function to work with carousel so that it would be loaded after all the rest of the page is loaded.

 

Any idea?

 

Hi,

 

Okey I will think about it. How we can manage to this. But really I want to take help from users. Maybe someone has a productive solution.

Share this post


Link to post
Share on other sites

Hi,

 

Thanks for the nice contribution, unfortunately i'm having some errors when I try to use it:

 

Notice: Undefined variable: connection in /home/xxxxx/public_html/includes/classes/seo.class.php on line 815

 

Notice: Undefined offset: -1 in /home/xxxxx/public_html/includes/classes/seo.class.php on line 1089

 

Notice: Undefined variable: _sid in /home/xxxxx/public_html/includes/classes/seo.class.php on line 785

 

Fatal error: Cannot redeclare class imageTransform in /home/xxxxx/public_html/includes/classes/flash_carousel_image_resize.php on line 30

 

 

I'm using the most recent version of the contribution, and afaik I followed all the steps provided.

 

 

Thanks in advance.

Share this post


Link to post
Share on other sites

I managed to solve my problem, i changed error_reporting in flash_carousel.php to error_reporting(0).

 

 

Thanks :)

Share this post


Link to post
Share on other sites
Hi,

 

Okey I will think about it. How we can manage to this. But really I want to take help from users. Maybe someone has a productive solution.

 

Hi ComArge,

There is a web site that explains how to do it. Have a look at that please:

 

http://answers.google.com/answers/threadview/id/27907.html

 

And I have found right now just another web page that explains much more simpler, look at the 6th post at this page:

http://www.swishtalk.com/showthread.php?t=31560

Edited by deggial

Share this post


Link to post
Share on other sites
Hi ComArge,

There is a web site that explains how to do it. Have a look at that please:

 

http://answers.google.com/answers/threadview/id/27907.html

 

And I have found right now just another web page that explains much more simpler, look at the 6th post at this page:

http://www.swishtalk.com/showthread.php?t=31560

I will work out this weekend. Maybe I can manage.

Share this post


Link to post
Share on other sites

Hi. ppl.

 

I got this coon contribution installed. but facing serious problems. its not showing anything at all. just as the page loads in FF there is a gab. but when page is done loading. the gab closes. and nothing at all is showing. no errors to work with. nothing.

 

anyone got any hints as to what could be wrong or how to display some errors ?.

Share this post


Link to post
Share on other sites

in my last post. i got a blank page. and some gab confusion.

 

the gab was due to the fact that the values in the configuration file was not transfered correctly. a

	$style = array();

was missing from somewhere in the code. i just placed at the top of the modules/flash_carousel.php file.

 

from the "view source" i could see the values 3 instead of default 600X300. well. that brought up a nicer size flash movie for me.

 

but my problem now is that customers HAS to be logged in to be able to see the movie with the products

Share this post


Link to post
Share on other sites
Hi. ppl.

 

I got this coon contribution installed. but facing serious problems. its not showing anything at all. just as the page loads in FF there is a gab. but when page is done loading. the gab closes. and nothing at all is showing. no errors to work with. nothing.

 

anyone got any hints as to what could be wrong or how to display some errors ?.

If you send me your web address, I can look what the problem is.

Share this post


Link to post
Share on other sites
If you send me your web address, I can look what the problem is.

 

 

Hi Com Arge

 

Thank you for the reply. well. actually i narrowed it down to the fact that the customer HAS to be logged in to be able to see the carousel. and i cannot seem to find any session registered argument in your code. så i find it unusual :)

 

you can try this domain http://coretest.demo-shop.dk/index.php

 

but as i said. you need to be logged in to see the movie

http://coretest.demo-shop.dk/create_account3.php?fromlogin=1

Share this post


Link to post
Share on other sites
Hi Com Arge

 

Thank you for the reply. well. actually i narrowed it down to the fact that the customer HAS to be logged in to be able to see the carousel. and i cannot seem to find any session registered argument in your code. så i find it unusual :)

 

you can try this domain http://coretest.demo-shop.dk/index.php

 

but as i said. you need to be logged in to see the movie

http://coretest.demo-shop.dk/create_account3.php?fromlogin=1

 

I have looked your website and checked your xml file. And there is a problem.

<?xml version="1.0" encoding="iso-8859-1"?>
<products>
	<product image="kampanya_prod_demo_color0_20051202180023.jpg" Productname="Doggy lotion" Price="<div class="show_price">25,00kr.</div>" url="http://coretest.demo-shop.dk/doggy-lotion-p-54.html?osCsid=efee96ccba708c133ac18e1958ca37c4" />
	<product image="kampanya_prod_demo_color0_20051213115126.jpg" Productname="Good dog tee" Price="<div class="show_price">25,00kr.</div>" url="http://coretest.demo-shop.dk/good-dog-tee-p-58.html?osCsid=efee96ccba708c133ac18e1958ca37c4" />
	<product image="kampanya_prod_demo_color0_20051122140636.jpg" Productname="Prikket trøje" Price="<div class="show_price">25,00kr.</div>" url="http://coretest.demo-shop.dk/prikket-troeje-p-59.html?osCsid=efee96ccba708c133ac18e1958ca37c4" />
	<product image="kampanya_prod_demo_color0_20051105194209.jpg" Productname="Skønne stof tyggeben" Price="<div class="show_price">25,00kr.</div>" url="http://coretest.demo-shop.dk/skoenne-stof-tyggeben-p-65.html?osCsid=efee96ccba708c133ac18e1958ca37c4" />
</products>

 

As you see Price="<div class="show_price">25,00kr.</div>" is problem. Flash can not read this syntax. Please remove <div class="show_price"> and </div> then test your site.

Share this post


Link to post
Share on other sites
As you see Price="<div class="show_price">25,00kr.</div>" is problem. Flash can not read this syntax. Please remove <div class="show_price"> and </div> then test your site.

 

Nice one. thank you very much. the tag is only present when not logged in. that explains the odd behaviure.

Share this post


Link to post
Share on other sites

Could someone please be so kind as to tell me exactly how to edit the flashfiles to be able to change the directory of wich it looks for the xml file ?

 

im a wrong or is it wierd that it is possible to change the dir from admin. but it needs to be edited in the flash source ?

 

please tell me exactly wich program i need and i will see if i can find the directory myself, and change it. (is it just adobe flash ? (not player))

Share this post


Link to post
Share on other sites

any one know what this is?

Fatal error: Call to a member function add_current_page() on a non-object in /home/thewin6/public_html/includes/application_top.php on line 312


thewinehaven.com

Share this post


Link to post
Share on other sites
any one know what this is?

Fatal error: Call to a member function add_current_page() on a non-object in /home/thewin6/public_html/includes/application_top.php on line 312

Have you faced this problem after osCommerce Flash Carousel install?

 

I searched over the forum and I found below address you can look it.

 

http://forums.oscommerce.com/index.php?sho...68369&st=20

Share this post


Link to post
Share on other sites

Hi,

 

I love the carousel, works great only onr problem, i can't select any style.

Where is it going wrong? somebody any idea?

 

And another question, is it possible that the carousel selects random the products instead of add them in the admin section.

 

regards,

Jan


Dreams can come true, if you help them a littlebit

Share this post


Link to post
Share on other sites
Could someone please be so kind as to tell me exactly how to edit the flashfiles to be able to change the directory of wich it looks for the xml file ?

 

im a wrong or is it wierd that it is possible to change the dir from admin. but it needs to be edited in the flash source ?

 

please tell me exactly wich program i need and i will see if i can find the directory myself, and change it. (is it just adobe flash ? (not player))

 

 

Hi. please help me out here someone. im not familiar with flash at all.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×