Jump to content
Latest News: (loading..)
Sign in to follow this  
ComArge

Cool Flash Carousel Menu

Recommended Posts

Thanks Emmetje!!

Is it possible delete the mirror image in the .php or only in the .fla?!??!! :blink:

I try to edit the .fla with Flash Professional 8 but said: Unexpected file format??!?!!!??

 

The same happened to me, also Flash Professional 8 maybe it's created with another version.

Share this post


Link to post
Share on other sites

Hi There,

 

i installed the latest version (2.0d) of this great contri but have some problems...

it seems to work, but just sometimes. i´ve added 7 products in the admin. status is 1. status in table products is also 1.

sometimes 1, sometimes 2, sometimes 3, somtimes 5 products are shown. never 7, but often no products are shown...

my 1st idea was about too long filenames of the images, but when i shorten them with substr() (in line 129 and 95-101) it doesn´t work.

 

has anyane a solution for this?

Edited by albossum

Share this post


Link to post
Share on other sites

Hi there again,

 

my problem is solved!!!

 

the reason was not the too long filenames of the images, the products names were the problem... seems the contri don´t like special characters like " or so...

 

perhaps it could help other people...

 

good night

 

albossum

Share this post


Link to post
Share on other sites

Hello. I just installed the latest version of this contrib, and get the following errors on my index page:

 

Warning: include(includes/modules/rotator) [function.include]: failed to open stream: No such file or directory in /home/utopiawe/public_html/index.php on line 308

 

Warning: include(includes/modules/rotator) [function.include]: failed to open stream: No such file or directory in /home/utopiawe/public_html/index.php on line 308

 

Warning: include() [function.include]: Failed opening 'includes/modules/rotator' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/utopiawe/public_html/index.php on line 308

 

After reading this whole thread, I'm still pretty well clueless as to why. The "rotator" file is there, in includes/modules. Any suggestions would be greatly appreciated.

 

Russ


One: people are not wearing enough hats. Two: matter is energy. In the universe, there are many energy fields which we cannot normally perceive. Some energies have a spiritual source which act upon a person's soul. However, this soul does not exist ab initio, as orthodox Christianity teaches. It has to be brought into existence by a process of guided self-observation. However, this is rarely achieved, owing to man's unique ability to be distracted from spiritual matters by everyday trivia.

Share this post


Link to post
Share on other sites

Forgot to mention, I also get the following error in the admin section when I click on "Flash Rotator" under Catalog:

 

1146 - Table 'utopiawe_osc1.TABLE_ROTATOR' doesn't exist

 

select count(*) as total from products p, TABLE_ROTATOR s, products_description pd where p.products_id = pd.products_id and pd.language_id = '1' and p.products_id = s.products_id

 

[TEP STOP]

 

 

However, that table exists, just as the "rotator" file does. I looked at both of them in file manager and via FTP. I followed the installation instructions to the letter, as far as I could tell. When I imported the sql, there was a warning message that the new table was empty or some such, other than that, everything went off without a hitch. And that wasn't a red error, just a yellow warning.

 

Russ


One: people are not wearing enough hats. Two: matter is energy. In the universe, there are many energy fields which we cannot normally perceive. Some energies have a spiritual source which act upon a person's soul. However, this soul does not exist ab initio, as orthodox Christianity teaches. It has to be brought into existence by a process of guided self-observation. However, this is rarely achieved, owing to man's unique ability to be distracted from spiritual matters by everyday trivia.

Share this post


Link to post
Share on other sites

Hello There,

I've recently tried to install this cool contribution(I've downloaded the 2.0 version)and did all the necessary file and sql uploads and only get the white screen box with no products(images) being shown on the welcome page.

 

I've read through most of this forum but i didn't see a solution for this problem.Has anyone got any suggestions and/or solutions for this?Thank you very much in advance.

 

Destron

Share this post


Link to post
Share on other sites
Hello. I just installed the latest version of this contrib, and get the following errors on my index page:

 

Make sure that you made the changes both in catalog en admin to includes/database_tables.php and includes/filenames.php and that they are correct, anywhere before the last ?>

Edited by emmetje

Share this post


Link to post
Share on other sites
Hello There,

I've recently tried to install this cool contribution(I've downloaded the 2.0 version)and did all the necessary file and sql uploads and only get the white screen box with no products(images) being shown on the welcome page.

 

Try version 2.0d there were some bugs in the previous versions.

Share this post


Link to post
Share on other sites

Mirror images don't respect original images sizes. Version 2.0 has been created but has still the same problem.

 

Anybody can give a solution? Is that in the inner code of Flash? Thanks.

Share this post


Link to post
Share on other sites

edit

 

I am experiencing some trouble with the € euro sign when I change i to € is shows an x in the caroussel and when i put & euro ; i get that and not a sign

Edited by diy

Share this post


Link to post
Share on other sites

Thanks a bunch, Emmetje! I checked the files you mentioned, and sure enough, I had a line or two that wasn't correct. Fixed it, got the flash running on my homepage, but the links didn't work. I applied the fix you posted a few days ago, and voila! Everything seems to be working great. Just wanted to say thanks, it's a great looking contribution, and thanks for your help in getting it working on my site. :)

 

Russ

 

PS - I noticed several posts here from folks who, like me, work with Flash 8, and can't open the source file for the .fla. I'm sure I'm not the only one who'd appreciate it if you could possibly add a backward-compatible version of that source file. It's still an awesome contribution, regardless!


One: people are not wearing enough hats. Two: matter is energy. In the universe, there are many energy fields which we cannot normally perceive. Some energies have a spiritual source which act upon a person's soul. However, this soul does not exist ab initio, as orthodox Christianity teaches. It has to be brought into existence by a process of guided self-observation. However, this is rarely achieved, owing to man's unique ability to be distracted from spiritual matters by everyday trivia.

Share this post


Link to post
Share on other sites

Hi, people, have you guys trying to using Firefox 3.0 with window vista on this contribution? it doesn't load the flash file from my screen with firefox

Have you guys find out this problem yet?

ken

Share this post


Link to post
Share on other sites

Hello,

I want to say thanks for a cool contrib. I just installed 2.0d today and everything went smooth. I set up two test products in a new store.

 

Here are the problems.

 

1. No Flash Movie. Just a White Box

2. XML File is not updating in the images directory (File and Directory are 777)

 

Here is what I know

 

1. Dont work in IE 6 or FF 3

2. Database tables have the correct product info

3. All required edits have been done

4. no strange error messages in the error logs

 

Help please

 

Thanks

Share this post


Link to post
Share on other sites
Hello,

I want to say thanks for a cool contrib. I just installed 2.0d today and everything went smooth. I set up two test products in a new store.

 

Here are the problems.

 

1. No Flash Movie. Just a White Box

2. XML File is not updating in the images directory (File and Directory are 777)

 

Here is what I know

 

1. Dont work in IE 6 or FF 3

2. Database tables have the correct product info

3. All required edits have been done

4. no strange error messages in the error logs

 

Help please

 

Thanks

 

Another piece of info - If I manually edit the XML it works fine.... (Linking is a bit off)

Share this post


Link to post
Share on other sites
Another piece of info - If I manually edit the XML it works fine.... (Linking is a bit off)

 

Problem solved, there was an error in includes/configure.php

Share this post


Link to post
Share on other sites
Very nice mod!

Can someone tell me how to remove the price and the name when the mouse is on the product?

thank you.

 

That has to be done in the flash source, can't help you there.

Share this post


Link to post
Share on other sites
Check this thread in the dutch forums about how to display the eurosign correctly http://forums.oscommerce.nl/index.php?showtopic=16664

 

 

I tried and tested a lot of things (when i put € in the databse all prices become the ? with the black background)

 

I THINK that it has to do with the flash version or fonts or something like that

 

The $ sign works fine and the english pound sign can work

Share this post


Link to post
Share on other sites
I THINK that it has to do with the flash version or fonts or something like that

 

It does not. I use the euro sign as well and it's working fine, follow the instructions in the forum I mentioned.

Share this post


Link to post
Share on other sites

Looks great. I have a couple issues. The resize is looking for GD/GD2 library of some sort. Is there a way around this? I assume I am going to have to re-compile my PHP with this function?

 

Issue 2: The reflection is not displaying properly i relation to the parent image. Where can this be modified?

Issue 3: I am using transparent on black background. Obviously the text isn't showing up. Where can I specify the text color?

Share this post


Link to post
Share on other sites
New features version 1.2

 

Download at http://addons.oscommerce.com/info/6123

Some configuration variables added to kampanya.php

You can resize images

You can define product number to show

If you want to resize images open kampanya.php and change these:

 

$image_need_resize = 1; // 1 on, 0 off

$width = 100; // image width

$height = 75; // image height

$limit_product_number = 12; // how many products want to show

 

At this version you can resize images by using thumb function. So that you need CHMOD images and under images direcories to 777. Because script produce thumb images of products.

 

By the way setup second step updated. You can see below.

 

There is no update copy all files to your existing store.

 

http://demo.oscommerce.com.tr

 

 

Hello,

 

Nice contribution, I have installed it on my site www.e-modelisme.com,

 

One question, where is kampanya.php file ? it is not in the contrib.

 

Thank you for your reply & support,

Yves

Share this post


Link to post
Share on other sites

Hi just installed the latest version think it was D, all files appear to be installed, permission mods made and sql file create.

 

On my homepage it simply reads 'This text is replaced by the Flash movie.'

 

Anyone got any ideas where I've gone wrong?

Share this post


Link to post
Share on other sites
Hi just installed the latest version think it was D, all files appear to be installed, permission mods made and sql file create.

 

On my homepage it simply reads 'This text is replaced by the Flash movie.'

 

Anyone got any ideas where I've gone wrong?

 

Make sure the swfobject.js is in the includes folder.

Share this post


Link to post
Share on other sites
Hi,

 

This seems to be nice and easy contrib but I'm facing some issues with the shadow and text.

 

Shadow of image is falling on the image itself in some cases and the text appears behind the image.

 

BTW - I have RTL (Right to Left) website and am using STS template system.

 

3b656159ec.jpg

 

Many thanks to the author and every one that improved the code.

 

Looks great. I have a couple issues. The resize is looking for GD/GD2 library of some sort. Is there a way around this? I assume I am going to have to re-compile my PHP with this function?

 

Issue 2: The reflection is not displaying properly i relation to the parent image. Where can this be modified?

Issue 3: I am using transparent on black background. Obviously the text isn't showing up. Where can I specify the text color?

 

Had same issue. got it fixed,

do u have macromedia flash 8.

here is the decompiled flash file (.fla) u can edit text color size, reflection and stuff u need,

http://digitechsystem.co.uk/flash/kampanya.swf.rar

after u finish editing just export back to swf

Edited by artur223

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×